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C H A P T E R  1  

 Installation 
Thank you for choosing Alibre Design!  We welcome you to the ever-growing community of 
designers who have discovered the high value of Alibre Design's feature-rich modeling capability 
and modest price. 

Alibre Design is easily installed on your computer.  Follow the directions in this chapter to get up and 
running in a matter of minutes. 

In This Chapter 

System Requirements ............................................................................................. 2 
On the CD................................................................................................................ 3 
Installing Alibre Design ............................................................................................ 4 
Installing Alibre Design Help.................................................................................... 6 
Upgrading ................................................................................................................ 7 
Uninstalling Alibre Design and Alibre Design Help.................................................. 7 
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1.1    System Requirements 

The following requirements must be met to install and run Alibre Design. 

Supported operating systems 

• Windows® XP Professional or Home Edition 

• Windows 2000 Professional SP2 or later 

• Windows Vista Home Basic, Home Premium, Business, or Ultimate  

Software requirements 

• Internet Explorer 4.01 SP2 + Active Desktop or later   
(6.0 or later recommended) 

• Microsoft Virtual Machine 

• Microsoft DirectX 9.0c 

Hardware requirements 

• Intel Pentium or equivalent processor;  2GHz or faster 

•       1 - 2 GB RAM 

• 1024 x 768 screen resolution minimum; 1280 x 1024 or greater recommended 

• Video card with DirectX 9.0c support (64 MB or higher) 

• 16-bit or 32-bit color 

• 200 MB available hard disk space 

• Virtual memory: 1 GB  

• CD-ROM drive (to install from CD) 

• Mouse or pointing device 

Note:  Please see the latest Alibre Design Readme file for information on hardware 
requirements for users running any edition of Windows Vista.   

Internet connection 

An internet connection is not required for design and data management functions of Alibre 
Design. 

An internet connection IS required to hold Team Design sessions, securely share data through 
the Repository, and use the Alibre Assistant for support. 

• 56.6 kb minimum 
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• Recommended: DSL, Cable Modem, T1 or faster 

Additional Recommendations for assemblies of 500 or more parts 

• Intel Pentium or equivalent processor; 3 GHz or faster 

•       2 GB RAM 

•       2 GB Virtual Memory 

 
 

1.2    On the CD 

The following items are on the installation CDs: 

Alibre Design Software & Multimedia CD (all versions of Alibre Design) 

• Alibre Design 10.0 application • Alibre Design Training Videos (2 
hours of training) 

• Alibre Design Help • Microsoft Virtual Machine 
software, build 3809 

• Alibre PhotoRender (specific license 
key required) 

• Internet Explorer 5.5 

• DirectX 9.0c  

  

Alibre Design Professional CD (Alibre Design Professional) 

• ALGOR DesignCheck 

•      Access information for part libraries

 

Alibre Design Expert CD (Alibre Design Expert) 

• ALGOR DesignCheck • Alibre Motion 

•       Access information for part libraries            • Machinist Toolbox 

• Alibre CAM • Engineers Toolbox 
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1.3    Installing Alibre Design 

The Alibre Design Installer is available on the installation CD as well as from the Alibre website.   

 To download the Alibre Design installer from the web site:  

1. Sign in with your user name and password and go to the Downloads page.   

2. Click Alibre Design Client to download the version of Alibre Design associated with your 
license. We recommend that you save the installer to your hard drive in case the installation 
process is interrupted. 

3. Once you have saved the installer to your hard drive, double click the file to begin the 
installation process.  

4. Continue the installation as described below, beginning with step 4. 

 

 To Install Alibre Design from the CD: 

1. Insert the CD-ROM into the CD drive.  Within a few seconds, a window appears.  If the window 
does not appear, open the Windows Explorer, and double-click your CD-ROM drive icon to 
open the window. 

2. Click Install Alibre Design on the CD menu. 

3. Click Install Alibre Design 10.0.  

4. Review the system requirements; then click Install Now.  InstallShield initializes and launches 
the Alibre Design installation wizard. 

5. Click Next.  The License Agreement page appears. 

6. Read the Product License Agreement and select I accept the terms in the license 
agreement, and then click Next. 

7. Specify a name and organization if desired. 

8. Choose whether this installation is for all users or only you. 

9. Click Next. 
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10. By default, Alibre Design is installed in the Program Files directory on the C: drive.  If desired, 
select a different destination folder. 

11. Choose where to place shortcuts. 

12. Select the language you prefer. 

13. Click Install. 

14. When the installation is complete, a message will appear prompting you to install PDFCreator.  
Click OK to continue. 

  

Note:  PDFCreator cannot be installed on the Vista operating system. In addition, if you do not 
install PDFCreator, you will be unable to fully publish BOMs or Drawings to PDF. If you choose 
to install a different PDF Printer application, you can print to PDF, but you will be unable to add 
a header or footer to the PDF. 

15. Select the language you wish to use, and then click OK.  

16. Click Next in the Welcome Dialog. 

17. Read the license agreement, then check I accept the agreement and click Next. 

18. Choose the Standard or Server Installation, then click Next. 

19. Enter a name for the PDF Printer (the default is PDFCreator), then click Next.   

20. Select the Location to install PDFCreator, then click Next. 

21. Read the information in the PDFCreator Toolbar dialog, and then click Next.  

22. Choose the components you want to install, then click Next. 
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23. Choose where to place the program's shortcuts, then click Next.  (If you do not want a shortcut, 
check the Don't create a Start Menu folder option.) 

24. In the Select Additional Tasks dialog, check the items that you want performed during the 
installation, and then click Next. 

25. Click Install in the Ready to Install dialog. 

26. Click Finish to exit the wizard.  The Alibre Design Install Wizard will indicate that the installation 
is complete.  

27. Click Finish.  

 
 

1.4    Installing Alibre Design Help 

Alibre Design has an integrated help system for you to access anytime you need assistance.  The 
help system is accessed by choosing the Help menu option from any workspace or the Home 
window.  The help system utilizes Microsoft Internet Explorer to run.   

The Alibre Design Help files are automatically installed during installation of the software.  They are 
installed as a separate program, and can be uninstalled (see "Uninstalling Alibre Design and Alibre 
Design Help" on page 7) if desired.   

If you have uninstalled the Help files, when you select the Help menu option, you may see the 
following message: 

 

You may re-install a local copy of Alibre Design Help that will be available when working offline. Help 
can be installed from the Alibre Design Installation CD, or you can download it from our website.  

 To manually install the version of Help included on the CD: 

1. Right-click your My Computer icon and select Explore. 
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2. Double-click the CD-ROM drive icon. Double-click start_here.exe. 

3. Click Install Alibre Design from the menu. 

4. Click Update an old Alibre Design Help Installation. 

5. Click Install Now.  InstallShield initializes and launches the Alibre Design Help installation 
wizard 

6. Follow the steps in the InstallShield Wizard to install Help locally. 

 
 

1.5    Upgrading 

Alibre, Inc. may periodically release service packs or minor software releases (such as version 10.x 
or 10.0 SPx) to implement new features or resolve software issues. Users who have a current 
maintenance agreement are eligible to receive upgrades and service packs.  These releases are 
distributed via the Alibre Design server automatically. When an update is available, you are 
prompted to upgrade upon launching Alibre Design. If you do not want Alibre Design to automatically 
check for updates, from the Home Window, go to the Tools menu, and select Options.  On the 
General tab, check the option Do not check for updates on Startup.  The process includes a small 
download and a brief installation. 

You may also download the updated Alibre Design client from our website at 
www.alibre.com/support/downloads.aspx.  In addition, you can order an upgrade CD, also available 
on our website.  If you choose to upgrade by downloading the new release from our website, or by 
installing from an upgrade CD, you will be reinstalling a full version.  You will need to uninstall your 
previous version before installing the upgraded version.   

 
 

1.6    Uninstalling Alibre Design and Alibre Design Help 

 To Uninstall Alibre Design: 

1. From the Start menu, select Control Panel or Settings - Control Panel depending on your 
operating system. 

2. Select Add or Remove Programs. 

3. From the Currently installed programs list, select Alibre Design. 
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4. Click Remove. 

5. At the prompt, click Yes to confirm that Alibre Design should be removed. 

6. The uninstall program removes program files, folders, and registry entries.  Repository files are 
NOT removed. 

7. When the files are removed, the uninstall program may indicate that the process is complete.  
Click OK. 

8. Alibre Design Help files are installed as a separate program.  If you wish to uninstall them, 
repeat the steps above and select Alibre Design Help from the Currently installed programs 
list.  
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C H A P T E R  2  

 Getting Started With Alibre Design 
Alibre Design is a powerful mechanical design software application.  You can use Alibre Design to 
create complex 3D designs and 2D drawings.  This chapter provides a high-level overview of the 
basic design capabilities in Alibre Design. 

 

In This Chapter 

Initial Launch of Alibre Design ................................................................................. 10 
Integrated Tutorials.................................................................................................. 11 
The Home Window.................................................................................................. 12 
Changing Your Password........................................................................................ 16 
The Repository ........................................................................................................ 18 
Workspaces............................................................................................................. 19 
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2.1    Initial Launch of Alibre Design 

 To launch Alibre Design: 

From the Start menu, select All Programs > Alibre Design.  An initial startup screen is displayed. 

 
Figure 1: Start-up screen during initial software launch 

 

If you have already registered with Alibre, Inc.… 

1. Enter the user name and password you obtained from Alibre, Inc..   

Note:  Shortly after purchasing Alibre Design, new customers receive an email from Alibre 
containing a user name and a temporary password.  If you register and/or purchase on the 
website, your user name and password are displayed at that time. 

2. Click Submit.  If an internet connection is detected, your license key will be automatically 
retrieved from the Alibre server.  Otherwise, you will see a message with a 5 character Site Key 
and instructions to follow to obtain a license key.   

Note:  If you call Alibre Support for help in obtaining your license key, you will have to provide 
this 5 character Site Key, as well as your computer's Machine Name.  
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3. After several seconds, the startup screen will be replaced by the Alibre Design Home Window.  
Also, the Set Default Workspace dialog will appear.  

4. Choose which default workspace you would like to see when starting Alibre Design from the 
drop-down menu.  You can select None if you do not want any default workspace to open. 

5. If you are a new user, you may want the appropriate tutorial to display when you open a new 
workspace.  If so, check Display tutorials when opening new workspaces. 

6. Click OK.  A new Part workspace is created and the corresponding introductory tutorial, 
Modeling a Simple Part, is automatically displayed (if you checked the option in step 5).  The 
Home window remains open behind the workspace. 

 

If you have not yet registered with Alibre, Inc.… 

Choose one of the available options: 

• Register Alibre Design Xpress - Register your free copy of Alibre Design Xpress to gain 
additional functions and the opportunity to participate in exclusive activities like the Xpress 
Design Contest.   You will be directed to a web form where you can register with Alibre, Inc.  
You will select a user name and be provided with a password to enter in the startup screen 
shown above. 

• Skip and run Alibre Design Xpress - Start using Alibre Design Xpress without the 
additional functions available to registered users. 

• Get a Trial Version of Alibre Design  - Sign up for a 30 day fully-functional trial of Alibre 
Design including real-time team design.  You will have access to the following features 
available in Alibre Design Professional:  sheet metal design, the Repository, and Alibre 
PhotoRender (which requires installation of a separate module). 

• Buy Alibre Design Products - Purchase Alibre Design software, training materials, and 
other optional components. 

 
 

2.2    Integrated Tutorials 

Alibre Design tutorials are fully integrated with the application.  When the application is launched for 
the first time, a part modeling tutorial opens in conjunction with a part workspace (if you have part 
workspace set as the default workspace). 

Each workspace type (part, assembly, sheet metal, drawing) has a corresponding introductory 
tutorial.  By default, whenever you create a new workspace, the corresponding introductory tutorial is 
also displayed.  This behavior can be changed (see "System Options" on page 15). 
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In addition, all of the tutorials are accessible from the Tutorials tab in the Home Window. 

We strongly recommend that you work through these included tutorials.  Working through them will 
give you a good understanding of the basic modeling terms and concepts used in Alibre Design.  
You will also become familiar with 3D viewing techniques in Alibre Design.   

 
Figure 2: Alibre Design Home Window - Tutorials Tab 

Alibre, Inc. will periodically release new tutorials and make these available in the Tutorials tab.  
When working online you can check for newly posted material by clicking the Check for updates 
button.  When new tutorials are available, they can be downloaded to your computer and 
subsequently accessed while offline. 

Note: To download new material when you see [New] or [Outdated] next to the title of a tutorial, 
right-click on the title and choose Download.  

 
 

2.3    The Home Window 

Alibre Design is comprised of five main components: the Home window, the Repository, the 
Message Center, the Team Manager, and design and drawing areas referred to as workspaces.  
Each component opens in a separate window that you can independently resize, position or tile. 
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When you launch Alibre Design, the Home window appears first and is always open while Alibre 
Design is running.  The Home window serves as the starting point for all other areas of Alibre 
Design.  Whenever you have another Alibre Design window open, you can quickly access the Home 
window by clicking the Alibre Design icon in the lower right corner of any other Alibre Design 
window. 

 
Figure 3: Alibre Design Home Window 

 
 

2.3.1    The Welcome Tab 

The Welcome tab offers several links get you get started using Alibre Design. You can use these 
links to start each type of workspace, as well as to open or import files. You can choose from the 
following options:  

 

 

Start a new part workspace 

 

Start a new sheet metal part workspace 

 



 Chapter 2 - Getting Started With Alibre Design 

14 

 

Start a new assembly workspace 

 

Start a new 2D drawing workspace 

 

Start a new Bill of Materials workspace 

 

Open an existing Alibre Design file 

 

Import a file into Alibre Design 

 
 

2.3.2    The Tutorials Tab 

The Tutorials tab provides access to integrated tutorials within the software.  Introductory tutorials 
are available for each type of Alibre Design workspace.  You can download and open the tutorials 
directly from this tab.   

Alibre, Inc. will periodically release new tutorials and make these available in the Tutorials tab.  
When working online you can check for newly posted material by clicking the Check for updates 
button.  When new tutorials are available, they can be downloaded to your computer and 
subsequently accessed while offline. 

Note: To download new material when you see [New] or [Outdated] next to the title of a tutorial, 
right-click on the title and choose Download.  

 
 

2.3.3    The Sessions Tab 

The Sessions tab lists all active and scheduled team design sessions that you are involved in.  You 
can view details about each session as well as join active sessions or schedule new sessions from 
this tab. 
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2.3.4    The Community Tab 

The Community tab provides access to a set of resources to help you get the most out of Alibre 
Design, including authorized consultants, solution partners, international resellers, support, and 
training. 

 
 

2.3.5    System Options 

A number of system options can be set and modified from the Home window.  From the Tools menu 
select Options.  The Options dialog appears. 

 
Figure 4: Alibre Design Options Dialog 

 

General tab: 

The General tab allows you to specify the language you are using, which type of workspace opens 
by default on startup (Note: You can select None so that no workspaces automatically open upon 
launching the software), whether or not a tutorial opens by default with the applicable workspace 
type, and whether or not updated tutorials will be automatically downloaded. 

Also, you can change the startup options for checking for software updates and you can choose to 
have Alibre Design remember your password. 
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User Information tab: 

Under the User Information tab, you may enter personal information such as name, company, 
email address, phone number, etc.  Check the Public box next to any item to make that information 
available to other users.  If you want to make your user name visible to the entire Alibre Design 
community, select the Display my user name in the public list option. 

Sign In tab: 

The Sign In tab allows you to change your Alibre Design password anytime, and you can add an 
additional username and password for accessing the Alibre Design server. 

Team Design tab: 

The Team Design tab provides access to options associated with Team Design sessions. 

Display tab: 

Under the Display tab you can check your graphics settings by selecting the Settings button.  

 
 

2.4    Changing Your Password 

All user accounts are assigned a password when the account is opened.  You will use your 
password to use Alibre Design, as well as to access your account on the Alibre, Inc. website.  You 
can change your password at any time.  

 To change your password from the Alibre, Inc. website: 

1. In your Internet Explorer browser, go to www.alibre.com.  

2. Click the link Sign In at the top of the page.   
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3. Enter your username and current password, then click Submit.  

 

4. You will be directed back to the home page, and the Sign In link will now read Sign Out.  Scroll 
to the bottom of the page, and click the Account Info link.  

 

5. You will be directed to a page containing your account information.  On the left side of the 
page, click the Change Password link.  

 

6. In Password, enter the new password you would like to use, then enter it again in the Confirm 
box.  Click Submit to accept the new password.  
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7. You will see a note that the password has been changed.  

 

Note:  You will also notice on the Account Information list there is an option to Update Profile.  You 
can use this form to update your contact information with Alibre, Inc.   

 
 

2.5    The Repository 

Some versions of Alibre Design include a personal data vaulting and versioning system known as 
the Repository.  More information is provided in the section dedicated to the Repository. 

To open the Repository from the Home window, from the Window menu, select Repository.  Or, 
click the Repository tool on the toolbar. 

 
Figure 5: Alibre Design Repository Workspace 
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One local repository is available upon installation.  The initial repository name matches your user 
name; however, the repository name can be changed - just right-click the repository and select 
Rename.  To create additional local repositories, from the File menu, select New Repository.  All 
repositories are displayed in the Repository Explorer.  Data can be moved and/or copied between 
repositories. 

A version history is automatically maintained for all files.  Each time a file is saved, a new version is 
created in the Repository.  To view the version history, select a file; then check Show Selected 
Item's Version History.  The version history shows which user created the version, the day and 
time the version was created, and any comments. 

Note:  Versioning can be disabled.  From the Tools menu, select Options and unselect the Always 
make new versions on save option. 

The Item Properties area displays summary information for each design as well as a preview 
image.  The image displays the model in its orientation when it was last saved. 

An important and versatile feature of the Repository is the ability to share data directly with other 
users anywhere in the world, easily and securely.  The modern peer-to-peer architecture of Alibre 
Design makes this possible without having to store data on a central server.  However, for users who 
desire a centralized location to store data, server-based repositories are also available from Alibre, 
Inc.  Depending on your version of Alibre Design, the server-based repositories may require an 
additional charge.    

For detailed information about sharing data, you can reference the chapter dedicated to the 
Repository (see "The Repository" on page 479).    

 
 

2.6    Workspaces 

Before proceeding further in this User Guide, we strongly recommend that you work through 
two of the basic Part Design tutorials, Introduction to Sketching and Constraints, and Modeling a 
Simple Part. 

Working through these tutorials will give you a good understanding of the basic modeling terms and 
concepts used in Alibre Design.  You will also learn how to manipulate your 3D models in Alibre 
Design. 

By completing these tutorials now you will be better prepared for the material in the subsequent 
sections. 

All design related tasks, as well as all Team Design sessions, are carried out in windows referred to 
as workspaces.  New workspaces can be opened from the Home window, the Repository, or other 
open workspaces.  From the File menu, select New to open a new workspace.  Five workspace 
types are available: part, sheet metal part, assembly, drawing, and bill of materials. 
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Note:  Sheet metal part, drawing, and bill of materials workspaces are not available in all versions of 
Alibre Design.  

The Design Explorer, displayed on the left side of a part or assembly workspace, lists all reference 
geometry, such as planes and axes, and feature geometry associated with the design.  Toolbars are 
located on top and to the right of the main work area. 

For detailed information about creating new designs, please see Chapters 3-11. 

The workspace can be customized in a number of ways.  From the Tools menu, select Options.  
Use the Color Scheme tab to change the background color of the main work area.  Default colors 
can be selected and custom colors can be added.  Additionally, the toolbars can be positioned and 
toggled on and off - from the View menu, select Toolbars. 

To set workspace properties, from the File menu, select Properties.  The Design Properties dialog 
includes six tabs.  

 
Figure 6: Design Properties Dialog 

The General Tab is used for notes and comments related to the design. 

The Units tab is employed to set all design units and associated display format and precision.  
Several other unit display settings are also available.  
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The Dimension tab is used to control dimension properties such as size, dimension orientation and 
spacing, and arrowhead style. 

The Material tab is used to set the density of the part material.  This information is used when 
calculating physical properties of the part. 

The Display tab is used to control the graphics display. 

In the Display Acceleration field, you can set the options you wish to use when in Display 
Acceleration mode in parts and assemblies.  Please see the Display Acceleration (on page 
280) section for more detail. 

The Curve Smoothness setting is applied on this tab to set the precision of the graphic 
display.  Selecting the Automatic option provides the cleanest display of the model, with all 
edges appearing smooth and precise.  Selecting the Manual option yields an approximate 
facetted display of the model.  The Manual option also requires a Minimal Circular Facets 
number, which represents how many line segments make up a circle.  When the facet setting is 
higher, the display appears smoother.  The Automatic and Manual options are a tradeoff 
between performance and graphic display.  Applying the Automatic option improves the graphic 
display but performance decreases slightly.  Applying the Manual option improves performance 
but the graphic display degrades somewhat.  (However, setting the Manual option too high can 
degrade performance.) 

The Apply Options tab is used to apply Design Properties settings on a system-wide basis, or only 
to the current workspace. 
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C H A P T E R  3  

 Introduction to the Design Interface 
Alibre Design is a parametric solid modeling system.  Parametric solid modeling involves applying 
dimensions and other parameters (such as angle values and offset distances) to define a 2D profile, 
and ultimately the 3D shape, of an object.  These dimensions and parameters can be changed at 
anytime to easily modify designs and alter the shape of a model. 

To begin creating your model, you first create a sketch, which is a 2D profile.  From this profile, a 3D 
feature is created. Examples of features include holes, fillets, cuts, and revolutions. You can add as 
many features as necessary to fully define the part.  From there, multiple parts can be put together 
to create an assembly.  Using a solid modeling tool to create assemblies shortens the length of the 
design process by giving you an early look at how your parts will fit together.  You can correct small 
errors in the fit between parts without having to spend time and money on a prototype early in the 
process.   

Using Alibre Design, you can also create 2D drawings and Bills of Material from either parts or 
assemblies.  Alibre Design is fully associative, which means that the parametric capabilities 
propagate through the parts, assemblies, 2D drawings, and Bills of Material.  This means that if you 
modify a parameter in one location, the models are updated everywhere that parameter is used. 

You can also import parts, assemblies, and drawings from other CAD systems into Alibre Design.  
You can modify these imported parts and assemblies by adding new features to them, or by using 
the Direct Editing (on page 206) tools.  
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3.1    Workspaces 

All design work in Alibre Design is done in windows called workspaces.  You can open a part, sheet 
metal part (in Alibre Design Professional and Expert), assembly, drawing, or bill of materials 
workspace.  Each workspace is displayed in a separate window; however, a drawing workspace can 
contain multiple drawing sheets.  You can have as many workspaces open as needed. 

 
 

3.1.1    Opening a New Workspace 

 To open a new part, sheet metal part, assembly, drawing, or bill of materials workspace: 

Select the appropriate tool from the Welcome tab in the Home Window. 

Or, 

Click the new Part, Sheet Metal Part, Assembly, Drawing, or Bill of Materials workspace tool on 
the Home window main toolbar. 

 

Or, 

In the Home window, from the File menu, select New, and then select either Part, Sheet Metal Part, 
Assembly, Drawing, or Bill of Materials. 

Note that sheet metal, BOMs, and drawings are not available in all versions of Alibre Design. 
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3.1.2    Workspace Terms 

Alibre Design workspaces are divided into two distinct areas.  

• The Design Explorer is located on the left side of the workspace and lists all information 
related to a design, including reference geometry and feature geometry. 

• The work area is the section of the workspace in which you create all parts, assemblies 
and drawings.  Toolbars may be located above and to the right of the work area.  

 
Figure 7: Part Workspace 
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3.1.3    Model Terms 

The following terms are consistently used throughout the documentation and refer to geometric 
elements in a model (faces, edges, and vertices) as well as reference geometry (reference planes, 
axes, and the origin). 

 
Figure 8: Common Model Terms 

 
 

3.1.4    Work Area Color Scheme 

You can change the color of the work area background and all other display components in a part, 
sheet metal part, or assembly workspace. 

 To change the color scheme: 

1. In a part or assembly workspace, from the Tools menu, select Options. 
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2. Choose one of the four pre-defined color schemes, e.g. Dark Background Scheme, from the 
Scheme drop-down list, then click OK to apply the setting. 

Or, 

Customize your display by creating a new color scheme. 

 

 To create a new color scheme: 

1. Click New.  The New Color Scheme dialog appears.  

2. Enter a name for the new custom color scheme, then click OK.  

Note:  You cannot modify the default color schemes.  If you attempt to change a color without 
creating a new color scheme, you will automatically be prompted to create a new scheme.  

3. Select a category to modify from the Category drop down list.  Next, select a Field in that 
Category.  The diagram will show the current color scheme. 

4. Click in the Color field to set a new color.  Select the desired color, then select OK to apply the 
setting.  
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Note:  A gradient background can be achieved by setting different colors for the 'General - 
Background Top' and 'General - Background Bottom' fields.  A solid background can be 
achieved by setting these to be the same color. 

5. Click OK to finish creating the new color scheme. 

 
 

3.1.5    Multiple Views 

You can split the work area into as many as four different views.  You can zoom, rotate, and set the 
view mode in each view independently. 

 To split the work area into multiple views: 

1. In a workspace, from the Window menu, select Split View. 

2. Select Horizontal, Vertical, or Both.  The Horizontal and Vertical options split the work area 
into two views.  The Both option splits the work area into four views. 

 

 To select a view and make it active: 

1. Click anywhere in the view border.  A red arrow appears in the upper right corner of the active 
view. 

 
Figure 9: Workspace with Split Views 
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3.1.6    Named Views 

In part, sheet metal part, and assembly workspaces, you can use named views to control view 
display and manipulation.  You can quickly change the display to a default view and add custom 
views using the Orientations command under the View menu or by selecting the View 

Orientations  tool on the View toolbar.       

 

To apply a named view to the work area, double-click a named view, or select a named view and 
then click Set. 

You can also add a custom view orientation by clicking Add and subsequently entering a view 
name.   

 
 

3.1.7    Design Explorer 

As previously described, each workspace consists of the work area and the Design Explorer.  The 
Design Explorer's primary purpose is to track and list the structure of a part, assembly, or drawing.  
However, the Design Explorer can be used to accomplish numerous tasks. 
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Use the Design Explorer to:   
   

• Select items in the design by name. 

• Suppress or hide selected features and parts. 

• Suppress or hide planes and axes. 

• Temporarily roll the model or assembly back to an 
earlier state in time: double-click a feature or part 
in the Design Explorer or use the rollback bar. 

• Identify and change the order in which features 
are regenerated. 

• Rename features: right-click a feature and select 
Rename. 

• Delete features and parts. 

• Toggle the display of section views on and off. 

• Edit sketches: right-click a sketch and select Edit. 

• Edit features:  right-click a feature and select Edit. 

• Track and control the display of redline markups.  

• Check the status of a feature or part to resolve 
errors.  

 
 

3.1.8    Document Browser 

Alibre Design provides two different mechanisms to save and retain your design documents.  All 
versions of Alibre Design support storing design documents as files in the Windows file system.  In 
addition, some versions of Alibre Design include the Repository, a personal data vaulting and 
versioning system. 
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Whenever you save or open a design document in Alibre Design, you are presented with the 
Document Browser, shown below.  Through the two tabs, Repository and File System, the 
Document Browser gives you access to both the Repository and the Windows File System. 

 
Figure 10: Document Browser Repository Tab 

 
Figure 11: Document Browser File System Tab 
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On the File System tab, you can browse through any of the drives on your computer, or you can click 
the Browse button to browse to other areas such as Desktop, My Documents, and My Network 
Places. 

 
 

3.2    Selection Methods 

The majority of design tasks require that an item be selected.  For example, a reference plane or 
planar face must be selected before you can begin sketching.  

• Selecting Individual Items - To select faces, edges, vertices, etc., first click the Selection 

tool  or choose Select from the View menu.  Move the mouse pointer over an item, 
and then click once to select the item.  An item will highlight as you move the mouse 
pointer over it and will change color after you select it. 

Note: Selection highlight colors will vary depending on the work area background color scheme 
used.   

• Selecting Multiple Items - To select multiple items in the work area, hold the Shift key 
while you select the items.  In cases where a multiple selection is required, you do not need 
to hold down the Shift key (except when using Advanced Selector).  In the Design 
Explorer, holding the Shift key will select everything in between the items you selected.  
Hold the Control Key while selecting to choose only the items you click. 

• Selecting by Dragging - In a sketch or a 2D drawing, select multiple items by dragging a 
selection rectangle around a group of items. 

• Using a Selection Filter - Apply a filter to make selecting a specific item type easier.  Filter 
on Solid > Features, Faces, Edges, and/or Vertices, in addition to Surface > Surfaces, 
Faces, Edges, and/or Vertices.  To apply a selection filter, from the Tools menu, expand 
Selection Filters and choose the appropriate filter.  You can also activate the Selection 
Filters toolbar and control filters easily with icons. 

• Face, Edge, and Vertex Cursors - As you move the mouse pointer over faces, edges, and 
vertices, the mouse pointer will change to provide a visual indication of the item type.   

 

Vertex Selection 

  

Edge Selection 

 

Face Selection 

• Modifying a Selection - Many dialogs require a selection or multiple selections in order to 
complete the command.  The selected item name will often populate an area in a dialog.  
To change the selection, either make another selection, which will override the previous 
selection, or right-click the item name in the dialog, and choose Clear Selections or 
Remove Selected Item(s). 
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• Advanced Selector - On occasion, other items may obscure the item you want to select.  
Use the Advanced Selector to accurately select an item.  To use the Advanced Selector, 
move the mouse pointer over the item, right-click it, and choose Advanced Selector from 
the pop-up menu.  The Select dialog appears containing all the items in the vicinity of the 
click location, including items hidden behind other faces.  Select the item you want from the 
list. 

Note: You can also Ctrl-click with the middle mouse button (if you have one) to access the 
Advanced Selector.  

 
Figure 12: Advanced Selector Options 

• Selecting from the Design Explorer - Select any item in the Design Explorer by clicking 
the item name.  The associated item will change color in the work area.  Select non-
consecutive items in the Design Explorer by holding down the Ctrl key as you click.  Select 
consecutive items in the Design Explorer by holding down the Shift key as you click.  

 
 

3.3    Toolbars 

You can control toolbar visibility as well as toolbar position in a workspace.  
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 To turn toolbars on and off: 

1. In any open workspace, from the View menu, select Toolbars; or, right-click in the toolbar area 
at the top of the workspace and select Toolbars.  The Toolbars dialog appears. 

 
Figure 13: Toolbars Dialog 

2. To hide a toolbar that is currently displayed, click the checked box next to the toolbar name. 

3. To display a toolbar, click the empty check box next to the toolbar name. 

4. Click Close to apply changes and exit the dialog. 

Note:  You can also turn individual toolbars on and off by right clicking in the toolbar area at the top 
of the workspace.  A list of toolbars appears.  Toolbars with checkmarks are currently on, and those 
without checkmarks are currently off.  Toggle a toolbar on and off by clicking on it.     

       

 To move a toolbar between the top and right of the workspace: 

1. In any open workspace, from the View menu, select Toolbars.  The Toolbars dialog appears. 

2. To move a toolbar from the top of the workspace to the right of the workspace, select the 
toolbar name and then click Right. 

3. To move a toolbar from the right of the workspace to the top of the workspace, click the toolbar 
name and then click Top. 

4. Click Close to apply changes and exit the dialog. 
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 To drag a toolbar to a different position in an area: 

1. Move the cursor near the vertical bar on the left side of the toolbar. 

2. Click and hold the left mouse button and drag the toolbar to a new position within its respective 
area. 

 
 

3.4    View Manipulation 

You can change the way the model appears in the work area by modifying the orientation and 
display of the model. The tools available from the View toolbar, the Orient View toolbar, the Visibility 
toolbar, and the View menu allow you to manipulate the model in many different ways (rotating it, 
changing the zoom level, reorienting it, and viewing the model as a wireframe or shaded model, for 
example).     

View Toolbar: 

  

Orient View Toolbar: 

 

Visibility Toolbar: 

 

 

•  The Pan tool moves the current view around the work area.  Click the icon and then 
click and drag the cursor around the work area.  

Note: You can also pan by holding the Shift key and the left and right mouse buttons down 
simultaneously while moving the cursor around the work area.  You can also pan by holding 
down the middle mouse button if you have one. 

•  The Rotate tool rotates a part or assembly around a given point.  Click the icon and 
then click and drag the cursor around the work area. 
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Note: You can also rotate by holding the left and right mouse buttons down simultaneously 
while moving the cursor around the work area. 

•  The Zoom Mode tool changes the scale of the work area view.  Click the icon, hold 
the left mouse button down, and move the cursor up to zoom in, or down to zoom out. 

Note: If available, you can use the mouse wheel to dynamically zoom in and out. 

•  The Zoom to Window tool changes the zoom level of the view so that a specified 
region fills the work area.  Select the tool, click and drag a rectangle around the desired 
area.  Release the mouse button when the rectangle borders the correct area. 

•  The Zoom to Fit tool restores the view so that the entire design is displayed in the 
work area. 

•   The Previous View  tool reorients the work area to views that preceded the current 
view.   

•    The Next View tool becomes available after the Previous View tool has been used. 

•  The Orthographic tool changes the display of the work area so that parallel edges, 
faces, etc. appear as infinitely parallel. 

•  The Perspective tool changes the display so that all parallel edges, faces, etc. 
appear to converge into one point.   

•  The Display Acceleration tool optimizes your display by simplifying the designs 
according to user-defined preferences. Refer to the section on Display Acceleration (on 
page 280) for more information. 

•  The Orient tools store default views of front, back, left, 
right, top, bottom, and isometric. 

•  The Orient to Sketch Plane tool changes the display so the sketch plane is 
displayed.  This is only available in sketch mode.  This is a toggle between the front and 
back view of the sketch plane. 

•  The Isometric to Sketch Plane tool  changes the display so that it is an isometric 
view of the sketch plane. 

•  The Orient to Plane tool allows you to reorient the view to a plane of your choosing. 
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•  The View Orientations tool stores default views (e.g. front, back, left, etc.) as well as 
custom views. 

•  The Rotation Points tool stores default rotation points (the origin, model's center of 
mass and center of volume) as well as custom rotation points.  

• The Model Shading tools change the display to wireframe (so that only the edges of the 
model are shown, or shaded (so that the faces of the model are shaded). 

        

•    The Toggle 
tools allow you to toggle on and off the following options:  Design Explorer, Silhouette 
Edges, All Reference Geometry, Coordinate System, Planes, Axes, Points, Surfaces, 
Annotations, Redlines, Sketches, Grid, Sketch Dimensions, and Constraint Symbols.  

 
 

3.5    Data Recovery Options 

Alibre Design has the ability to backup your designs periodically, or to notify you when you haven't 
saved your design. You can set your preferences for each workspace type. 

 To set your data recovery options: 

1. In any workspace, from the Tools menu, select Options. The Options dialog appears.   



 Chapter 3 - Introduction to the Design Interface 

38 

2. Select the Recovery tab.  

 

3. For each workspace type, select one of the following options: 

a. Select Disable Recovery Options if you do not want to use either the save notification or 

data recovery features. 

b. The Notify option will alert you with a dialog when you have made changes to your design 

since it was last saved, and you have not re-saved your design in the number of minutes 

you specified.  You can then choose to Ignore the message, or choose Bring to Front to 

bring the workspace up so you can manually save the file.  
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c. The Save Recovery Data option will save your design data for all changed files in the 

background while you work. If you open an item and do not make changes, nothing will be 

saved. If Alibre Design closes unexpectedly (during a power outage, for example), when 

you start Alibre Design again you will be presented with a recovery dialog that allows you 

to select which files you would like to recover. 

4. Click OK to accept the changes and exit the dialog.  

 
 

3.6    Getting Help 

Help can be accessed numerous ways while you are using Alibre Design. 

Integrated Help 

• The integrated Help is automatically installed during installation of Alibre Design, as a 
separate program.  

• You can manually install Help from the Alibre Design Installation CD or the Alibre support 
web site, www.alibre.com/support.  Choose the Downloads link, then under the 
Documentation section, select Alibre Design Local Help Installer. 

• To access Help related to a specific dialog, click the Help button  in the dialog. 

• When you mouse over an icon on a toolbar, a Tooltip will popup that identifies the function 
of the tool. 

• The status bar in the lower left corner of a workspace displays hints related to completing a 
command and provides a brief description of a tool or function. 

• While working online with the Alibre Server, you can access the Help system from any 
window with the Help menu or the F1 key. 

Tutorials 

• Design tutorials are available by default in the Alibre Design Home Window on the Tutorials 
tab.  Periodically, Alibre, Inc. will release new tutorials and distribute them for download via 
the Tutorials tab.  You can check for new materials in the Tutorials tab when you are signed 
into the Alibre Design server. 

Alibre Support website 

• You can obtain help from many areas on the Alibre, Inc. website.   Go to 
www.alibre.com/support, and you will find links to:  
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• Frequently Asked Questions - a list that contains helpful information on a variety of 
topics.  On the left side of the page, click the FAQ link.  

• Knowledge Base - contains tips and instructions for performing specific tasks. 

• Downloads - a page containing all of the downloads available to you.  You must be 
signed in to the website to view all of the downloads you have a license for.  

Interactive Support (for users with active maintenance agreements) 

• While working in online mode, you can contact the Alibre Assistant from the Contacts list 
in the Home window.  You can send messages, start a chat conversation, and work in a 
Team Design session in real-time to ask technical questions and resolve issues. 

• You can contact the Alibre Application Engineers by phone or email during regular support 
hours.  

• You can sign in to the Alibre Support web page and enter a support incident for the Alibre 
Application Engineers  

Note:  Interactive support requests are handled in the order they are received.  You should receive a 
response from an application engineer within approximately 24 hours.  

 
 

3.7    Keyboard Hot-Key Descriptions 

The following is a list of keyboard hot-keys for some of the most commonly used functions of Alibre 
Design.   

General (for Part, Assembly, and Drawing Workspaces) 

Open CTRL + O 

Select All CTRL + A 

Copy CTRL + C 

Cut CTRL + X 

Paste CTRL + V 

Save CTRL + S 

Save As CTRL + SHIFT + S 

Undo CTRL + Z 
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Redo CTRL + Y 

Delete DEL 

Help F1 

 

Part Workspace 

Design Properties ALT + RETURN 

Options CTRL + SHIFT + O 

Sketch Mode Toggle CTRL + K 

Orientation Dialog CTRL + U 

Measurement Tool Dialog CTRL + M 

Equation Editor Dialog CTRL + E 

Toggle Workspace CTRL + TAB 

Previous View F3 

Next View F4 

Regenerate F5 

Zoom to Fit HOME 

Toggle Sketches on/off CTRL + SHIFT + K 

Toggle All Reference Geometry on/off CTRL + SHIFT + P 

 

Assembly Workspace 

Assembly Properties ALT + RETURN 

Options CTRL + SHIFT + O 

Insert Part/SubAssembly CTRL + SHIFT + I 
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Insert New Part CTRL + SHIFT + N 

Orientation Dialog CTRL + U 

Measurement Tool Dialog CTRL + M 

Equation Editor Dialog CTRL + E 

Toggle Workspace  CTRL + TAB 

Regenerate F5 

Previous View F3 

Next View F4 

 

Drawing Workspace 

Drawing Properties ALT + RETURN 

Options CTRL + SHIFT + O 

Sketch Mode Toggle CTRL + K 

Bill of Materials CTRL + B 

Print CTRL + P 

Toggle Workspace  CTRL + TAB 

 

Repository Workspace 

Open CTRL +  O 

Open Read-Only CTRL + R 

Deposit CTRL + D 

Deposit & Check-in CTRL + SHIFT + D 

Withdraw CTRL + W 
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Check-out & Withdraw CTRL + SHIFT + W 

Check-in CTRL + U 

Check-out CTRL + K 

Redo CTRL + Y 

Undo CTRL + Z 

Version History F6 

Properties F7 

Refresh F5 
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C H A P T E R  4  

 Sketching 
Sketching is fundamentally the most critical aspect of parametric solid modeling.  The majority of 
features in Alibre Design begin with a sketch.  A sketch is made up of one or more figures (such as 
lines, circles, and arcs, etc.) and provides the basic profile for a feature.  Mastering sketching 
techniques is important and leads to considerable time savings during modeling work.  

 

In This Chapter 

The Sketching Interface........................................................................................... 46 
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4.1    The Sketching Interface 

The Sketching toolbar is shown by default on the right side of the workspace.   

 
Activate Sketch (with options fly-out) ... activates sketch mode 

 
Select ... select sketch figures and entities 

 
Constraints (with options fly-out)... place manual constraints on a sketch 

 
Dimension ... place dimensions on sketch figures 

 
Line (with options fly-out)... create a line figure  (fly-out includes Reference Line ... 
create a reference line figure) 

 
Circle (with options fly-out)... create a circle figure (fly-out includes Ellipse ... 
create an Elliptical figure) 

 
Arc ... create an arc figure (options for circular and elliptical) 

 
Rectangle (with options fly-out)... create a rectangle figure (fly-out includes 
Polygon . . . create an n-sided polygon figure) 

 
B-Spline (with options fly-out)... create a spline figure 

 
Sketch Node ... create a sketch node 

 
Direct Coordinate Entry ... Creates sketch figures by entering point-to-point 
Cartesian or Polar coordinates 

 
Trim (with options fly-out)... delete part of a figure that extends beyond another one  
(fly-out includes Extend ... extend a figure up to another figure) 

 
Fillet (with options fly-out)... place a fillet on two existing figures  (fly-out includes 
Chamfer ... place a chamfer on two existing figures) 

 
Linear Sketch Repeat (with options fly-out) ... pattern a sketch figure in one or 
more linear directions  (fly-out includes Circular Sketch Repeat ... pattern a sketch 
in a radial direction) 
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Sketch Shapes (with options fly-out)... create an individual or a pattern of a 
common shape 

 
Offset ... offset an existing figure by a precise distance 

 
Mirror ... create a symmetric copy of a figure about a reference 

 
Project to Sketch ... use existing feature edges to create new sketch figures 

 

Note:  The Extend, Trim, Fillet, Chamfer, Offset, Mirror, and tools on the Sketching toolbar are 
only active when applicable sketch figures are in the sketch.  For example, the Extend tool will not 
become active until at least two figures have been sketched. 

The tools that are accessible on the Sketching toolbar are also accessible from the Sketch menu.  
The Sketch menu also contains tools that do not have a corresponding toolbar icon. 

Ordinate Dimension . . . Creates ordinate dimensions in 2D drawings. 

Auto Dimension . . . Automatically place dimension to place sketch 

Reference Figures . . . Create reference figures of various shapes. 

Move . . . Move sketch figures from one location to another 

Rotate . . . Rotate sketch figures about a center axis 

Analyze . . . Determines if open ends, overlaps, or self-intersections exist in a sketch (also 
available on the Sketch Overlay) 

Insert > Axis  . . . Inserts a 3D axis; sketch figures can be used as references. 

Insert > Point . . . Inserts a 3D point; sketch figures can be used as references. 

Create Custom Symbol . . . Creates a custom symbol using sketch figures. 

Text > Field . . . Inserts a text field into sketches. 

Text > Label . . . Inserts a text label into sketches. 

 
 

4.2    Sketch Mode 

Before creating a 3D feature, you must first create a 2D sketch, which serves as the profile (cross-
section) for the feature. All 2D sketching is done in Sketch Mode.  You must sketch on a reference 
plane or planar face.  You will enter Sketch Mode to create new sketches or modify existing 
sketches.    
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4.2.1    Entering Sketch Mode 

You must enter sketch mode before you can begin sketching.  

 To enter sketch mode: 

Select the Activate 2D Sketch  tool from the Sketching toolbar. 

Or, 

From the Sketch menu, select Activate 2D Sketch. 

Or, 

Right-click in the work area and select Activate 2D Sketch from the pop-up menu. 

Or, 

Press Ctrl + K on the keyboard. 

You must sketch on an existing reference plane or face.  You can select your sketch plane before or 
after entering sketch mode.  If you did not select a sketch plane before you entered sketch mode, 
you will need to select a sketch plane after entering sketch mode, before you can begin sketching.  If 
you have your cursor hints turned on (Tools > Options > General tab), you will be prompted by the 
cursor hint to select a sketch plane.  You can select the sketch plane from the Design Explorer or in 
the work area. Once you select the sketch plane, all of the available sketching tools will become 
active.  The Activate Sketch tool on the Sketching toolbar will always appear in the active state 

 while in sketch mode. 

 
 

4.2.2    Exiting Sketch Mode 

 To exit sketch mode: 

You can use any of the methods listed for entering sketch mode by unselecting the chosen option, or 
use one of the following methods as well:  

• Select the Exit button  from the sketch mode overlay (refer to Sketch Mode 
Overlay (on page 49) for details) 

• Choose the Select  tool from the View toolbar 

• Create a feature from the sketched profile.  For example, select a feature tool such as the 

Extrude Boss  tool from the Part Modeling toolbar 
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• Select the Regenerate  tool from the Part Modeling toolbar, or from the Feature 
menu, select Regenerate All or press the F5 key on the keyboard 

 
 

4.2.3    Sketch Mode Overlay 

When you enter sketch mode, an overlay will appear at the top of the work area.  This overlay gives 
you quick access to grid options, the analyze sketch function, and the ability to create multiple 
sketches without leaving sketch mode.   

 

You can turn the display of this overlay on and off by going to the Tools menu, and selecting 
Options.  On the Overlays tab, you will see the following options:  

• Show Full Overlay - Only applies to Direct Editing Functions (see "Direct Editing" on page 
206)  

• Show overlay in 2D Sketch mode 

To turn off the overlay in sketch mode, uncheck the option Show overlay in 2D Sketch mode.  
Check it to turn it back on. 

 

When the overlay is turned on, you have the following capabilities:  

• Check Show Grid? to display the sketch grid, and uncheck it to turn the display off 

• Set the grid X Spacing and Y Spacing as desired 

• Check Snap to Grid? to snap to the X & Y gridline intersections (you can snap to grid even 
if you have the grid display off) 

• Select the Analyze Sketch tool  to open the Analyze Sketch dialog 

• Select the Refresh tool  to refresh the work area. 

• Click Apply to accept the sketch you have created and begin a new sketch (you will be 
prompted to select a sketch plane to begin sketching again; you can choose the same 
sketch plane or a new one) 

• Click Exit to accept the sketch you have created and exit sketch mode 
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4.3    Sketch Figures 

You can create sketch figures while you are in Sketch Mode. 
 

4.3.1    Line 

 To sketch a line: 

1. Select the Line  tool from the Sketching toolbar; or from the Sketch menu select Figures 
> Line; or right-click and select Line from the pop-up menu. 

Position the cursor at the location you want to start the line.  

2. Click in the Work Area to start the line and drag the cursor to sketch the line. 

3. Click again to complete the line segment.  You can continue to sketch additional line segments 
by clicking.  Double-click or press ESC on the keyboard to end the line. 

Note:  During sketching, hints that provide step-by-step instructions are displayed in the lower left 
corner of the workspace. 

 

 To resize a line: 

1. Select the Select  tool from the Sketching toolbar. 

2. Move the cursor over a node at the end of the line. 

3. Click, hold the mouse button, and drag the node to resize the line. 

4. Release the mouse button. 
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 Note:  You can also edit the dimension of the figure, if you have placed one. 

 

 To move a line: 

1. Select the Select  tool from the Sketching toolbar. 

2. Move the cursor over the line. 

3. Click, hold the mouse button, and drag the line to a new location. 

4. Release the mouse button. 

 

 

 To change the angle of a diagonal line: 

1. Select the Select  tool from the Sketching toolbar. 

2. Move the cursor over a node at the end of the line. 

3. Click, hold the mouse button, and drag the node to change the angle. 

4. Release the mouse button. 

 
 

4.3.2    Circle 

 To sketch a circle: 

1. Select the Circle  tool from the Sketching toolbar; or from the Sketch menu select 
Figures > Circle; or right-click and select Circle from the pop-up menu. 
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2. Position the mouse pointer at the center point location.  

3. Click in the Work Area to place the center of the circle and release.  Then drag the mouse to 
sketch the circle. 

4. Click again to complete the circle. 

 
 

     

 To resize a circle: 

1. Click the Select  tool from the Sketching toolbar. 

2. Move the mouse pointer over the circle.  

3. Click, hold the mouse button, and drag the figure to resize the circle. 

4. Release the mouse button. 

Note:  You can also edit the dimension of the figure, if you have placed one. 

 To move a circle: 

1. Click the Select  tool from the Sketching toolbar. 

2. Move the mouse pointer over the center node of the circle.  

3. Click, hold the mouse button, and drag the circle. 

4. Release the mouse button. 
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4.3.3    Circular Arcs 

You can sketch three different circular arc types:  1) Center, Start, End; 2) Start, End, Radius; 3) 
Tangent-Start, End.    

 To sketch a circular arc using Center, Start, End: 

1. Select the Circular Arc - Center, Start, End  tool from the Sketching toolbar; or from the 
Sketch menu select Figures > Circular Arc > Center, Start, End; or right-click and select 
Circular Arc from the pop-up menu. 

2. Position the mouse pointer at the center of the arc.  

3. Click to place the center of the arc. 

4. Click a second time to start the arc. 

5. Move the mouse to sketch the arc. 

6. Click a third time to complete the arc. 

    

 

   To sketch a circular arc using Start, End, Radius: 

1. Select the Circular Arc - Start, End, Radius  tool from the Sketching toolbar; or from the 
Sketch menu select Figures > Circular Arc > Start, End, Radius. 

2. Position the mouse pointer at the arc starting location.  

3. Click to start the arc. 

4. Click a second time to place the arc endpoint. 
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5. Move the mouse pointer to size the arc. 

6. Click a third time to complete the arc. 

 

 To sketch a circular arc using Tangent-Start, End: 

1. Select the Circular Arc - Tangent-Start, End  tool from the Sketching toolbar; or from the 
Sketch menu select Figures > Circular Arc > Tangent-Start, End. 

2. Click the line or circular arc that will be tangent to the new arc.  Click close to the side that you 
want the new arc to originate from. 

3. Move the mouse pointer to size the arc. 

4. Click a second time to complete the arc. 

 

 To increase or decrease a circular arc's diameter: 

1. Click the Select  tool from the Sketching toolbar. 

2. Move the mouse pointer over the circular arc.  

3. Click, hold the mouse button, and drag the figure to resize the circular arc. 

4. Release the mouse button. 

Note:  You can also edit the dimension of the figure, if you have placed one. 

 

 To reshape a circular arc: 

1. Click the Select  tool from the Sketching toolbar. 

2. Move the mouse pointer over the circular arc center node.  

3. Click, hold the mouse button, and drag the center node to reshape the circular arc. 
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4. Release the mouse button. 

 

 To move a circular arc: 

1. Click the Select  tool from the Sketching toolbar. 

2. Select the arc AND center node by dragging a selection rectangle around the entities.  

3. Hold the Shift key, click and hold the mouse button, and drag the circular arc. 

4. Release the mouse button. 

 
 

4.3.4    Rectangles 

You can sketch two different rectangle types:  1) Rectangle by Two Corners; 2) Rectangle by 
Three Corners.  

 To sketch a rectangle using Two Corners: 

1. Select the Rectangle by Two Corners  tool from the Sketching toolbar; or from the 
Sketch menu select Figures > Rectangle > Two Corners. 

2. Click to place one corner of the rectangle. 

3. Move the mouse pointer to sketch the rectangle. 

4. Click a second time to locate the opposite corner of the rectangle. 

       

 To sketch a rectangle using Three Corners: 

1. Select the Rectangle by Three Corners  tool from the Sketching toolbar; or from the 
Sketch menu select Figures > Rectangle > Three Corners. 

2. Click to place one corner of the rectangle. 
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3. Move the mouse pointer and click a second time to locate the other corner on the same end of 
the rectangle. 

4. Move the mouse pointer to adjust the rectangle length. 

5. Click a third time to place the end of the rectangle. 

 

 To resize a rectangle: 

1. Choose the Select  tool from the Sketching toolbar. 

2. Move the mouse pointer over an edge or a node.  

3. Click, hold the mouse button, and drag the sketch entity to resize the rectangle. 

4. Release the mouse button. 

 

 To move a rectangle: 

1. Choose the Select  tool from the Sketching toolbar. 

2. Select the entire rectangle by dragging a selection rectangle around it.  

3. Hold the Shift key, click and hold the mouse button, and drag the rectangle. 

4. Release the mouse button. 

 
 

4.3.5    Spline Curves 

Alibre Design provides NURBS (B-spline) curve functionality in sketches.  The main distinguishing 
feature of the B-spline compared to "simple" splines is that it retains its shape at all times. That is, it 
can only translate and rotate rigidly in order to satisfy the constraints imposed on it.  In addition to 
the B-spline curve, you can also create a spline curve by reference points.  This spline curve does 
not retain its shape as a B-spline does.   
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Creation of spline curves by reference points 

Splines created using this method are not B-splines.  You specify a set of reference points in the 
work area to define the spline.  You can use the Offset Figures tool on this spline, as described in 
the 'Using Offset on a Spline Curve' segment below.   

1. From the Sketch menu, select Figures > Spline > Create > Spline by reference points. 

2. Left-click to start the spline curve. 

3. Move the mouse pointer and click a second time to place a reference point. 

4. Move the mouse pointer to shape the curve. 

5. Continue clicking to place additional reference points. 

Note: You may choose to specify one or more reference points by invoking the direct 
coordinate entry tool and keying in the X, Y coordinates. 

6. Double-click or hit escape to complete the spline curve. 

Note: By making the last reference point to be the same as the first reference point, a closed 
spline curve can be created.  

 

 To modify a reference point spline curve: 

1. You can change the shape of a reference point spline curve by clicking on and dragging any of 
the reference points along the curve.   

2. You can move the entire spline curve in the same way you move other sketch figures, by 
selecting the Move tool from the Sketch menu.  You must select the entire curve by dragging a 
selection rectangle around it.  

 

Creation of NURBS curves by control points 

Using this method, you specify a set of control points in the work area to define the B-spline. Existing 
points can be identified. A preview is shown as you move the mouse. 
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1. Select the B-spline by control points    tool from the 
Sketching toolbar; or from the Sketch menu select Figures > Spline > Create > B-spline by 
control points. 

2. Left-click to start the spline curve. 

3. Move the mouse pointer and click a second time to place a control point. 

4. Move the mouse pointer to shape the curve. 

5. Continue clicking to place additional control points. 

Note: You may choose to specify one or more control points by invoking the direct coordinate 
entry tool and keying in the X, Y coordinates. 

6. Double-click or hit escape to complete the spline curve. 

Note: By making the last control point to be the same as the first control point, a closed B-
spline curve can be created.  

 

Creation of NURBS curves by interpolation 

Using this method, you first specify a set of interpolation points in the Work Area that define the B-
spline.  A curve is then interpolated through the interpolation points. 

1. Select the B-spline by interpolation points     tool from 
the Sketching toolbar; or from the Sketch menu select Figures > Spline > Create > B-spline 
by interpolation points. 

2. Click to start the spline curve. 

3. Move the mouse pointer and click a second time to place an interpolation point. 

4. Move the mouse pointer to shape the curve. 

5. Continue clicking to place additional interpolation points. 
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Note: One or more interpolation points may be specified via the direct coordinate entry tool. 

6. Double-click or hit escape to complete the spline curve.  

 

Constraining B-spline curves 

The following constraints are supported on the B-spline curve: 

• Coincident constraint: An existing reference point can be made coincident with a location 
on the B-spline by either dragging it onto the B-spline OR by using the sketch Coincident 
constraint tool. 

Note:  A point coincident to a B-spline is kept “floating”, meaning that the constraint system can 
move the point of coincidence to any other location along the curve.  However any coincidence 
established at either endpoint of the B-spline remains fixed. 

• Tangent constraint: can be placed between a B-spline curve and any other figure in the 
sketch that can participate in the constraint system. 

Note: The note above on “floating” and “fixed” constraint applies to this constraint also. 

• Perpendicular constraint can be placed between a B-spline curve and any other figure in 
the sketch that can participate in the constraint system. 

Note:  The note above on “floating” and “fixed” constraint applies to this constraint also. 

• Intersection point constraint can be placed between a B-spline curve and any other 
figure in the sketch that can participate in the constraint system. 

• Fixed constraint allows the B-spline curve to be locked in place. 

 

Moving a B-spline curve 

The main distinguishing feature of the B-spline is that it retains its shape at all times. That is, it can 
only translate and rotate rigidly in order to satisfy the constraints imposed on it. Other items to note 
include: 

• Dragging a B-spline by its endpoint to existing sketch geometry introduces a “fixed” 
coincident constraint between the B-spline and that figure. 

• Otherwise, dragging a B-spline to an existing reference point introduces a “floating” 
coincident constraint between the B-spline and that figure. 
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• Dragging an existing reference point to a B-spline introduces a coincident constraint 
between the point and the B-spline. It is “fixed” or “floating” depending on whether the point 
was dragged to the B-spline's endpoint or an internal location respectively. 

 

 To move a B-spline curve rigidly: 

1. Choose the Select  tool from the Sketching toolbar. 

2. Click and hold the mouse button on the curve, and drag the spline curve. 

3. Release the mouse button to place the curve. 

 

Trimming and extending B-spline curves 

The B-spline curve can be trimmed using other figures (lines, arcs, circles, ellipses and B-splines). 

Open figures like lines and arcs can be extended to the intersection point with a B-spline curve.  
However, the B-spline curve itself cannot be extended. 

 

B-spline curve shape modification 

An assortment of methods is available to modify or tweak the B-spline curve's shape while still 
honoring all the constraints placed on the curve. These tools take advantage of the excellent 
local shape modification properties of B-splines. 

 To modify a B-spline curve's shape: 

From the Sketch menu, select Figures > Spline > Edit > Desired Action 

Possible Actions: 

Move Control Points - Modify shape by moving a control point 

Move Curve Points - Modify shape by moving a point on the B-spline curve to a new position. 

Insert Knots - Insert new knots on the curve knot vector without changing curve shape. 

Remove Redundant Knots - Remove existing knots that can be removed without changing 
the curve shape.  Alibre Design will automatically remove any possible knots; then a dialog will 
appear summarizing the results. 
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DXF/DWG import/export of NURBS curves 

NURBS geometry defined by control points present in DXF/DWG files can be read and precisely 
represented by the same mathematical representation in Alibre Design.  
 
DWG files can also contain splines that are defined by interpolation points. Alibre Design will read 
these and convert them into B-spline curves. While for most parts these curves will appear very 
similar to what they look like in AutoCAD, their shapes may not exactly match. Also, AutoCAD allows 
users to specify “tolerance” while defining splines by interpolation. Alibre Design will assume this 
value is always zero. 

 

Using Offset on a spline curve 

The offset tool (see "Offsetting Figures" on page 80) can be used to select either B-spline curves or 
reference point spline curves for creating an offset curve. As with other offset figures, this offset will 
not be associative to the original curve.  This means that if the original curve is modified, the offset 
figures will not update as a result.  In addition, the offset curve will not contain any reference, 
control, or interpolation points.   

 
 

4.3.6    Ellipses 

 To sketch an ellipse: 

1. Select the Ellipse tool  from the Circle fly-out on the Sketching toolbar; or, from the 
Sketch menu, select Figures > Ellipse. 

2. Click to select the ellipse center. 

3. Move the mouse pointer and click a second time to place the major axis of the ellipse. 

4. Move the mouse pointer and click a third time to place the minor axis of the ellipse. 

    

 To resize an ellipse: 

1. Choose the Select  tool from the Sketching toolbar. 

2. Move the mouse pointer over the ellipse.  

3. Click, hold the mouse button, and drag to reshape the ellipse. 
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4. Release the mouse button. 

Note:  You can also edit the dimension of the figure, if you have placed one. 

 

 To move an ellipse: 

1. Choose the Select  tool from the Sketching toolbar.  

2. Select the entire ellipse by dragging a selection rectangle around it.  

3. Hold the Shift key, click and hold the mouse button, and drag the ellipse. 

4. Release the mouse button. 

 
 

4.3.7    Elliptical Arcs 

 To sketch an elliptical arc: 

1. Select the Elliptical Arc tool  from the Arc fly-out on the Sketching toolbar; or, from the 
Sketch menu, select Figures > Elliptical Arc. 

2. Click to select the elliptical arc center. 

3. Move the mouse pointer and click a second time to place the major axis of the elliptical arc. 

4. Move the mouse pointer and click a third time to place the minor axis of the elliptical arc. 

5. Click a fourth time to start the elliptical arc. 

6. Click a fifth time to complete the elliptical arc. 

 

 To resize an elliptical arc: 

1. Choose the Select  tool from the Sketching toolbar. 

2. Move the mouse pointer over the elliptical arc or one of the associated nodes.  



Chapter 4 - Sketching 

 63 
 

3. Click, hold the mouse button, and drag to resize the elliptical arc. 

4. Release the mouse button. 

Note:  You can also edit the dimension of the figure, if you have placed one. 

 

 To move an elliptical arc: 

1. Choose the Select  tool from the Sketching toolbar. 

2. Select the entire spline curve by dragging a selection window around it.  

3. Hold the Shift key, click and hold the mouse button, and drag the elliptical arc. 

4. Release the mouse button. 

 
 

4.3.8    Polygons 

 To sketch an n-sided polygon: 

1. From the Sketch menu, select Figures > Polygon; or select the Regular Polygon 

 tool from the Sketching toolbar.  The Regular Polygon dialog appears. 

2. Enter the number of sides for the polygon. 

3. Choose to measure the internal or external diameter. 

4. Left click once in the sketch window to locate the center of the polygon.  Move the mouse to 
size the polygon.  Left click again to place the polygon. 

5. Choose Apply; then Close. 
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 To resize an n-sided polygon: 

1. Choose the Select  tool from the Sketching toolbar. 

2. Move the mouse pointer over the circle that defines either the internal or external diameter of 
the polygon.  

3. Click, hold the mouse button, and drag to resize the polygon. 

4. Release the mouse button. 

Note:  You can also edit the dimension of the figure, if you have placed one.   

 

 To move an n-sided polygon: 

1. Click on the center node of the polygon and drag the polygon to a new location.   

Or, 

1. Choose the Select  tool from the Sketching toolbar. 

2. Select the entire polygon by dragging a selection rectangle around it.  

3. Hold the Shift key, click and hold the mouse button, and drag the polygon. 

4. Release the mouse button. 

 
 

4.3.9    Sketch Shapes 

You can create a variety of standard shapes in Alibre Design.  Each of these shapes can be placed 
alone or in a standard pattern. 

Sketch Shapes are particularly useful for creating hole patterns with a large number of instances. 
 Using the Sketch Shapes tool to create a pattern and then creating one extruded cut requires less 
regeneration time than creating a cut and then patterning the cut figure, for example. 
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Each Sketch Shape or Sketch Shape pattern is treated as a single entity.  Sketch Shapes can not be 
trimmed or extended, and other sketch entities can not be trimmed or extended to them.  Sketch 
shapes can not be filleted or chamfered.  Dimensions can only be applied to the nodes that are 
automatically placed with each sketch shape.  (These nodes are typically placed in the center of 
each instance as well as the First Shape Anchor, if it is not in the center.) 

 
 

Standard Shapes Available 

Round 

 

Square 

 

Obround 

 

Rectangle 

 

Rectangle with R Corner 

 

Single D 
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Double D 

 

 

 

These shapes are available from the Sketch menu, as well as on the Sketching Toolbar. 

• From the fly-out menu on the Sketching Toolbar:  
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• From the Sketch menu, select Shape: 

 

 

 
 

Standard Sketch Shape Pattern Types 

The Pattern type field offers 5 different patterns to choose from. 

 

No Pattern -creates a single instance of the selected shape 
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Linear Pattern -creates a linear pattern of the selected shape 

 

When Linear Pattern is selected, the dialog options will look like this: 

 

You will set the values for: 

• Pitch - The distance between two successive shapes in the pattern 

• Pattern Angle - The angle of inclination with respect to the positive X-axis 

• Number - The number of shapes in the pattern (must be a value of 1 or greater) 

 

Arc Pattern - creates an arc pattern of the selected shape 
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When Arc Pattern is selected, the dialog options will look like this: 

 

You will set the values for: 

• Pattern Radius - The radius of the arc pattern 

• Start Angle - The angle of the first shape of the pattern with respect to the positive X-axis 

• Pitch Angle - The angle between two successive shapes in the pattern 

• Number - The number of shapes in the pattern (must be a value of 1 or greater) 

 

Check the box for Shape Angle Vector if you want the shapes in the pattern aligned along the radius 
of the arc pattern.  (This option is not available for the round shape) 
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Figure 14: Shape Angle Vector Unchecked 

 
Figure 15: Shape Angle Vector Checked 

      

Circular Pattern - creates a circular pattern of the selected shape 

 

When Circular Pattern is selected, the dialog options will look like this: 

 

You will set the values for: 

• Pattern Radius - The radius of the circular pattern 
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• Start Angle - The angle of the first shape of the pattern with respect to the positive X-axis 

• Number - The number of shapes in the pattern (must be a value of 1 or greater) 

 

Check the box for Shape Angle Vector if you want the shapes in the pattern aligned along the radius 
of the circular pattern.  See Arc Pattern above for an example of how the Shape Angle Vector option 
works.  (This option is not available for the round shape) 

                     

Grid Pattern - creates a grid pattern of the selected shape 

 

When Grid Pattern is selected, the dialog options will look like this: 

 

You will set the values for: 

• Pitch along X - The distance between two successive shapes in the x-direction (noted in 
the diagram as PX) 

• Pitch along Y - The distance between two successive shapes in the y-direction (noted in 
the diagram as PY) 

• Number along X - The number of shapes in the pattern in the x-direction (noted in the 
diagram as NX; must be a value of 1 or greater) 



 Chapter 4 - Sketching 

72 

• Number along Y - The number of shapes in the pattern in the y-direction (noted in the 
diagram as NY; must be a value of 1 or greater) 

• Pattern Angle - The angle of inclination with respect to the positive X-axis 

 
 

First Shape Anchor Location 

The first shape anchor location is where the mouse pointer is in relation to the first shape of the 
pattern when you are placing the shapes in the work area. 

Examples of two of the available options are shown below. From these examples, you can see how 
the First Shape Anchor Location option works.   This example pattern is a grid pattern of 2 shapes in 
the x-direction and 2 shapes in the y-direction, using the square shape.  

If you choose the center position... 

 

When placing the sketch shapes in the work area, the mouse pointer will be located in the center of 
the first shape.  In the image below and all of the following images, the first shape is the square on 
the bottom left of the pattern.  
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If you choose the top left position... 

 

When placing the sketch shapes in the work area, the mouse pointer will be located at the top left of 
the first shape.    

 

 
 

 To create a shape: 

1. Select the desired Shape tool from the Shapes fly-out .   
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The Shape dialog for the chosen shape appears, and a preview of the figure is shown in 
the work area.  This example shows the Round Shape Dialog.  

 

 

2. Fill in the appropriate values for the chosen shape:  

 

Round  

In the Diameter [D] field, enter the desired value for the diameter. 

Square 

In the Side length along X field, enter the desired value for the side length of the square. 

In the Angle field, enter the desired angle, measured from the x-axis. 

Obround 

In the Side length along X field, enter the desired value for the length of the shape. 

In the Side length along Y field, enter the desired value for the width of the shape.   

In the Angle field, enter the desired angle from the x-axis, if any. 
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Rectangle 

In the Side length along X field, enter the desired value for the side length of the rectangle. 

In the Side length along Y field, enter the desired value for the width of the rectangle. 

In the Angle field, enter the desired angle, measured from the x-axis. 

Rectangle with R corner 

In the Side length along X field, enter the desired value for the side length of the rectangle. 

In the Side length along Y field, enter the desired value for the width of the rectangle. 

In the Radius field, enter the value for the radius of the corners. 

In the Angle field, enter the desired angle, measured from the x-axis. 

Single D 

In the Side length along X field, enter the desired value for the side length of the single D. 

In the Side length along Y field, enter the desired value for the width of the single D. 

In the Angle field, enter the desired angle, if any, measured from the x-axis. 

Double D 

In the Side length along X field, enter the desired value for the side length of the double D. 

In the Side length along Y field, enter the desired value for the width of the double D. 

In the Angle field, enter the desired angle, if any, measured from the x-axis.  

In the Pattern Type field, select the pattern type you desire. 

   

3. In the Pattern Parameter field, enter the values that apply for the pattern type you selected. 

4. Set the First Shape Anchor location (this option is not in Arc or Circular pattern types).  This 
determines where the first shape in the pattern will be placed with respect to your mouse 
pointer when you click to place the shape.   

5. Move your mouse pointer in the work area and click to place the figure. The Round Shape 
dialog remains open. You can continue to modify the values in the Round Shape dialog as 
needed.   

6. Select Apply to accept the sketch figure.  The sketch figure is placed, and centerpoints are 
shown for each shape.  In addition, a preview for a new sketch figure appears with the mouse 
pointer.  You can place another sketch shape pattern (you can modify any of the parameters 
when placing the next sketch pattern), or choose Close to exit the Round Shape dialog. 

Note: Once a sketch shape pattern has been placed, all of the shapes in the pattern are grouped as 
one sketch figure.  You cannot separate them.  However, you can edit the shape pattern. 
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 To edit a shape or shape pattern: 

1. Right-click the shape in the work area and select Edit; or double-click the shape in the work 
area.  The Round Shape dialog appears. 

2. Make any changes necessary to the shape, then select OK.  The figure updates to reflect the 
changes. 

Note: The only way to edit sketch shapes is via the Shape dialog. 

 
 

4.4    Reference Figures and Sketch Nodes 

Reference figures and sketch nodes are used as construction geometry.  Construction geometry is 
any entity that helps you model a part, but does not contribute to the physical properties of the 
model.  For example, a reference line can be sketched and subsequently used in a sketch mirror 
operation.  You can also place dimensions and constraints in relation to reference figures and sketch 
nodes.  Reference figures and sketch nodes are contained within a sketch but are only visible in 
sketch mode.  Reference figures are displayed as green dashed lines in sketch mode.  Reference 
figures can be created in the exact same shapes as normal sketch figures. 

 To sketch a reference figure: 

1. From the Sketch menu select Reference Figures > and then select a figure type. 

2. To sketch the reference figure, follow the same steps you would use to create a normal sketch 
figure. 

You can move and resize a reference figure just as you would a normal sketch figure. 

 

 To place a sketch node: 

1. Select the Sketch Node  tool from the Sketching toolbar; or from the Sketch menu select 
Figures > Node. 

2. Click once to place a sketch node. 
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 To convert a sketch figure to a reference figure: 

1. Right-click on a sketch figure.  

2. Choose Convert To Reference Figure.       

 
 

4.5    Working with Existing Sketch Figures 

4.5.1    Extending  Figures 

You can use the Extend tool to extend a line or arc to meet another line, arc, circle, spline, or 
reference line. 

 To extend a sketch figure: 

1. Select the Extend  tool from the Trim/Extend fly-out on the Sketching toolbar; or from the 
Sketch menu select Extend; or right-click and select Extend from the pop-up menu. 

2. Move the mouse pointer over the line or arc that you want to extend. 

A dashed preview will appear showing the direction of the extended entity.  If the direction is 
incorrect, move the mouse pointer to the opposite end of the entity.  

3. To generate the extension, click once on the entity. 

   

         
 

4.5.2    Trimming  Figures 

You can use the Trim tool to delete portions of sketch entities based on intersections with other 
entities.  You can trim a line, arc, ellipse, circle, and spline that intersect with other lines, arcs, 
ellipses, circles, splines, and reference lines. 
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 To trim a sketch figure: 

1. Select the Trim Figure  tool from the Sketching toolbar; or from the Sketch menu select 
Trim; or right-click and select Trim from the pop-up menu. 

2. Move the cursor over the portion of the sketch figure that you want to trim.  The portion 
becomes highlighted. 

3. Click the highlighted portion to delete it up to its intersection with another sketch figure.  The 
entire figure will be deleted if it does not intersect with another figure. 

   

 
 

4.5.3    Adding 2D Fillets to Sketch Figures 

You can use the 2D Fillet tool to place a tangent arc at the intersection of two sketch figures and 
subsequently delete the corner.  You can also place a fillet on non-intersecting figures; the figures 
will be extended and a fillet will be placed accordingly at the resultant intersection. 

 To add a 2D fillet to a sketch figure: 

1. Select the 2D Fillet  tool from the Sketching toolbar; or, from the Sketch menu select 
Fillet.  The Fillet Figures dialog appears. 

2. Select the first figure by clicking it.  The figure name appears in the Figures to Fillet section of 
the dialog. 

3. Select the second figure by clicking it.  The figure name appears in the Figures to Fillet 
section of the dialog. 

4. Enter the fillet radius value in the Radius box. 

5. Click Apply to create the fillet.  (The Apply button will be inactive if the radius value is not 
possible.)  The Fillet Figures dialog remains open so you can continue to place fillets on other 
figures.  
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Note:  Consecutive fillets with a diameter equal to the first fillet will not be dimensioned; instead 
an equal constraint will automatically be placed. 

6. Click Close to close the Fillet Figures dialog.  

  

 
 

4.5.4    Adding Chamfers to Sketch Figures 

You can use the 2D Chamfer tool to place a beveled edge at the intersection of two sketch figures 
and subsequently delete the corner.  You can also place a chamfer on non-intersecting figures; the 
figures will be extended and a chamfer will be placed accordingly at the resultant intersection. 

 To add a 2D chamfer to a sketch figure: 

1. Select the 2D Chamfer  tool from the Sketching toolbar; or from the Sketch menu select 
Chamfer.  The Chamfer dialog appears. 

2. Select the first figure by clicking it.  The figure name appears in the Figures to Chamfer 
section of the dialog. 

3. Select the second figure by clicking it.  The figure name appears in the Figures to Fillet 
section of the dialog. 

4. Enter the chamfer distance value in the Distance box. 

5. Click Apply to create the chamfer.  (The Apply button will be inactive if the distance value is too 
large.)  The Chamfer dialog remains open so you can continue to place chamfers on other 
figures.  

6. Click Close to close the Chamfer dialog.  
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4.5.5    Offsetting Figures 

You can use the Offset tool to automatically create sketch figures offset from another selected figure 
or sketch by a specified distance. 

 To offset sketch figures: 

1. Select the Offset  tool from the Sketching toolbar.  The Offset dialog appears. 

2. Select the figure(s) to offset either one at a time or drag a selection rectangle around all figures.   
The figure name(s) appears in the Figures to Offset section of the dialog. 

3. Enter the offset distance value in the Distance box. 

4. If necessary, select the Flip Direction option to create the offset in the opposite direction. 

5. Select a Gap Type (the default is Natural). 

 
Figure 16: Original Sketch Example 
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Natural:  Extends the edges of the wall along their natural curves until they intersect. 

 
Figure 17: Result Using Natural Gap Type 

Round:  Creates fillets on any corners of the wall profile. 

 
Figure 18: Result Using Round Gap Type 

Extend: Extends the edges of the wall beyond their endpoints in straight lines until they 
intersect. 

 
Figure 19: Result Using Extend Gap Type 
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6. Click OK to create the offset figure(s).  The new figures are created and become part of the 
sketch. 

 

 

 
 

4.5.6    Mirroring Figures 

You can use the Mirror tool to create copies of figures mirrored about another reference line or 
figure.  A Symmetric constraint is automatically applied between the original figure and the mirror 
figure.  If you change the original figure, the mirrored figure will also change. 

 To mirror a sketch figure: 

1. Select the Mirror  tool from the Sketching toolbar.  The Mirror Figure dialog appears. 

2. Select the figure(s) to mirror either one at a time or drag a selection rectangle around all 
figures.  The figure name(s) appears in the Figures to mirror section of the dialog. 

3. Select the Mirror Axis to mirror the figure about.  The mirror axis can be either a reference line 
or another sketch figure.  You can NOT choose a reference geometry axis (such as the X-axis).   

4. Click OK to create the mirrored figure. 
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4.5.7    Creating Patterns of Sketch Figures 

You can create linear and radial patterns of an existing sketch figure or figures.  Linear patterns can 
be created in one or two directions. 

 To create a linear pattern in one direction: 

1. Select the Linear Sketch Repeat  tool from the Sketching toolbar; or, from the Sketch 
menu, select Repeat > Linear.  The Linear Repeat dialog appears. 

2. Select the figure to be patterned. 

3. Select the linear path for the first pattern direction.  Lines, reference lines, axes, and edges can 
be used as the linear path. 

4. Enter the appropriate value in the Copies field; this value includes the original figure. 

5. Enter the appropriate Spacing value that controls the distance between each figure in the 
pattern. 

6. If necessary, select the Change Direction option. 

7. Click OK to create the pattern. 
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 To create a linear pattern in two directions: 

1. Select the Linear Sketch Repeat  tool from the Sketching toolbar; or, from the Sketch 
menu, select Repeat > Linear.  The Linear Repeat dialog appears. 

2. Select the figure to be patterned. 

3. Select the linear path for the first pattern direction.  Lines, reference lines, axes, and edges can 
be used as the linear path. 

4. Enter the appropriate value in the Copies field; this value includes the original figure. 

5. Enter the appropriate Spacing value that controls the distance between each figure in the 
pattern. 

6. If necessary, select the Change Direction option. 

7. Select the linear path for the second pattern direction.  The second linear path should not be 
parallel to the first. 

8. Enter the appropriate value in the Copies field; this value includes the original figure. 

9. Enter the appropriate Spacing value that controls the distance between each figure in the 
pattern. 

10. If necessary, select the Change Direction option. 

11. Click OK to create the pattern. 

                  

 To create a radial pattern: 

1. Select the Circular Sketch Repeat  tool from the sketch repeat fly-out on the Sketching 
toolbar; or, from the Sketch menu, select Repeat > Circular.  The Circular Pattern dialog 
appears. 
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2. Select the figure to be patterned. 

3. Select the Circular path center.  Axes, points, and existing edges on other features can be 
used as the circular path center. 

4. Enter the appropriate value in the Copies field; this value includes the original figure. 

5. Enter the angle that will separate each copy in the radial direction. 

6. If necessary, select the Change Direction option. 

7. Click OK to create the pattern. 

 

 
 

4.5.8    Moving and Rotating Sketch Figures 

You can move existing sketch figures from one location to another, or rotate them about an axis.  

 To move sketch figures: 

1. From the Sketch menu, select Move.  The Move Figures dialog appears. 
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2. Click the Figures selection button.  Select the figures you want to move in the work area. 

3. Click the From button.  Click a location in the work area that you want to move the figures from. 

4. Click the To button.  Click the location in the work area that you want to move the figures to.  

5. Check Copy if you wan the original figures to be copied to the new location. 

6. Click Apply; then Close. 

Note:  If you want to move the figures using coordinates, click the Direct Coordinate Entry 

 button. 

OR, 

1. Choose the sketch Select  tool from the Sketching toolbar. 

2. Select the figures to be moved.    If you are moving an entire sketch, from the Edit menu, 
choose Select All, or press Ctrl + A on the keyboard.  The figures become highlighted. 

3. Hold the Shift key on the keyboard, and click and drag the sketch figure(s) to the new location. 

 To rotate sketch figures: 

1. From the Sketch menu, select Rotate.  The Rotate Figures dialog appears. 

 

2. Click the Figures selection button.  Select the figures you want to rotate in the work area. 
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3. Click the Center button.  Click the location in the work area around which you want to rotate the 
figures. 

Note:  If you want to move the figures using precise coordinates, click the Direct  Coordinate 

Entry  button. 

4. In Angle, set the angle of rotation. 

5. Check Copy if you want the original figures to be copied to the new location. 

6. Click Apply; then Close. 

 
 

4.6    Sketch Constraints 

Figures in a sketch may be constrained to a size, orientation, and relationship to another 2D figure or 
3D edge.  Some constraints are used to apply relationships between figures (for example, 
perpendicular, tangent, parallel, equal size) or between figures and reference lines, planes, axes, 
vertices, and edges.  Other constraints are applied to individual figures, including those that control a 
figure's orientation (for example, horizontal or vertical) and dimension.  

Some sketch constraints are applied automatically as figures are sketched.  Horizontal, vertical, 
coincident, midpoint, tangent, intersection, and perpendicular constraint types are automatically 
placed depending on the type, size and orientation of the figure(s).  

Sketch constraints are shown in proximity to the applicable sketch figure.  In this example, the 
sketch constraints are shown enlarged.  

    

Note:  When you sketch a new figure on an existing figure or on a node on an existing figure (e.g. 
start a new line on the node at the end of an existing line), a coincident constraint is automatically 
applied.  The coincident constraint is not displayed in this case.  To break this coincident constraint, 
move the cursor over the coincident nodes, hold the Ctrl key, click and drag. 
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Constraints can also be applied manually to figures after they have been sketched with tools from 
the Constraints toolbar.  The Constraints fly-out toolbar is available from the Sketching toolbar in part 
and drawing workspaces. 

          

  
 

4.6.1    Constraint Types 

Fourteen different constraints can be applied to sketch figures. 

  
Fixed - Figures may be constrained to a fixed position in the sketch.  After the 
constraint is applied, the node or figure may not be moved without first deleting the 
constraint. 

Can be applied to: a node or any sketch figure 

 
Vertical - One or more lines may be constrained to be vertical.  Sketch nodes may also 
be constrained to be vertically aligned.  Lines may be vertically constrained 
automatically as they are sketched or after placement. 

Can be applied to: any line or any two nodes 

 
Horizontal - One or more lines may be constrained to be horizontal. Sketch nodes may 
also be constrained to be horizontally aligned.  Lines may be horizontally constrained 
automatically as they are sketched or after placement. 

Can be applied to: any line or any two nodes 

 
Intersection - Two figures may be constrained to intersect at a point. 

Can be applied to: a point and any combination of arcs or lines 

 
Symmetric - An axi-symmetric relationship may be defined between figures.  After a 
symmetric constraint is applied, the figures are arranged axi-symmetrically and 
equidistant from a reference line or sketch line.  The figures will become equal in size 
after the constraint has been placed.  

Can be applied to: any two figures of like nature, e.g. two lines or two circles 

 
Coradial - Figures may be constrained to share the same center point and same 
radius.  Circles/arcs can be coradially constrained automatically during sketching or 
after placement. 

Can be applied to: two or more arcs or circles 

 
Concentric - Figures may be constrained to share the same center point.  Circles/arcs 
can be concentrically constrained automatically during sketching or after placement. 

Can be applied to: two or more arcs or circles 
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Collinear - Figures may be constrained so that they lie on the same line.  Lines may be 
collinearly constrained automatically as they are sketched or after placement. 

Can be applied to: a combination of two or more lines, axes, reference lines, edges 

 
Coincident - A point can be constrained so that it lies on a figure.  

Can be applied to: a point and any sketch figure 

 
Midline - A node can be constrained so that it is fixed at the middle of a line.  Midpoint 
constraints can be placed automatically as a figure is sketched or after a figure has 
been sketched. 

Can be applied to: a node and a line or arc 

 
Equal - Figures can be constrained to be equal in size.  Equal constraints can be 
applied automatically during sketching or placed manually after a figure has been 
sketched. 

Can be applied to: any two or more sketch figures 

 
Tangent - Figures can be constrained to be tangent to a curve.  Tangent constraints 
can be applied automatically during sketching or placed manually after a figure has 
been sketched. 

Can be applied to: a curve and a line or two curves 

 
Perpendicular - Lines can be constrained to be perpendicular to other linear entities.  
Perpendicular constraints can be applied automatically during sketching or placed 
manually after a figure has been sketched. 

Can be applied to: two lines or a line and a circle or circular arc 

 
Parallel - Lines can be constrained to be parallel to each other.  Lines can be 
constrained parallel automatically during sketching or can be manually constrained 
after placement. 

Can be applied to: at least two lines 

 
 

4.6.2    Manually Applying Sketch Constraints 

 To manually apply a sketch constraint: 

1. Click the small black options arrow  on the Sketching toolbar to access the Constraint fly-
out, or from the Sketch menu, select Constraints. 

2. Select the applicable constraint tool.  The mouse pointer changes to show the corresponding 
constraint symbol.  For example, after selecting the Coincident constraint tool, the mouse 

pointer changes to . 
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3. In the sketch, select the figures to constrain.   Many of the constraint types require multiple 
selections.  For example, applying a symmetric constraint first requires selecting a reference 
line or sketch line and then selecting two other sketch figures.  Simply click all the required 
entities one-by-one to apply the constraint.  

Note:  When manually applying constraints, hints are displayed in the status bar in the lower 
left corner of the workspace.  The hints provide step-by-step instructions to apply a constraint.  
You can turn these hints on and off by going to the Tools menu and selecting Options.  Make 
sure Status Hints is checked on.  

 

 
 

4.6.3    Deleting Constraints 

Sketch constraints can be deleted at anytime regardless of whether they were placed automatically 
or manually. 

 To delete a sketch constraint: 

1. Select the sketch Select  tool from the Sketching toolbar. 

2. Position the mouse pointer over the sketch constraint you want to delete.  The figure 
associated with the constraint is highlighted and the mouse pointer displays the selected 
constraint symbol. 

 

3. When the constraint symbol appears on the mouse pointer, right-click the constraint and select 
Delete from the pop-up menu.  The constraint is deleted. 

Note:  For constraints applied to multiple figures, deleting the constraint from one deletes that 
constraint from all the other figures in that constraint group. 
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4.6.4    Controlling the Display of Sketch Constraint Symbols 

Sketch constraints symbol visibility can be turned on and off.  In addition, you can control the size of 
the sketch constraint symbols. 

 To turn off sketch constraint visibility: 

From the View menu, select Constraint Symbols, or press Ctrl+Shift+C on the keyboard.  Figures 
will remain constrained when constraint symbols are hidden.  This is a toggle on/off, so they visibility 
can be turned back on using the same command. 

 

 To change the size of the constraint symbols: 

From the Tools menu, select Options.  On the General tab, in the Design Viewing field, check 
Large Constraint Symbols.  This will increase the size of the constraint symbols.  Un-checking the 
option will return the symbols to their original size. 

 

 
 

4.6.5    Checking the Status of a Sketch 

Constraint status of an individual figure 

There are several possible states that indicate whether a figure is constrained completely or not.  A 
figure is constrained completely when zero degrees of freedom (the number of ways in which the 
sketch can still move within the sketch plane) remain.  These states are displayed in the workspace 
status bar when a sketch constraint tool is selected and the cursor is positioned over a figure. 
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Well-defined: A figure is fully constrained and dimensioned; there are no remaining degrees of 
freedom.  

Under-defined: A figure is not fully constrained or dimensioned; figures can move unexpectedly as 
a result. 

Over-defined: A figure has conflicting constraints and/or dimensions that may or may not cause an 
additional constraint to fail.  If a constraint fails, delete one or more constraints or dimensions. 

Fixed: A figure is fully constrained and the figure cannot be modified.  Other figures can be 
constrained to it. 

Not-changed:  The indicated constraint was not applied to this geometry.  The figure is dependent 
on another figure with conflicting constraints. 

Not-consistent:  The assigned dimension value(s) and constraints are in conflict and cannot be 
applied to the geometry. 

Unknown: Occurs when a component of a constraint has been removed.  

It is not necessary for figures in a sketch to be well-defined before you use the sketch to create a 
feature.  However, it is good design practice in general to ensure that sketches are well-defined. 
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Status of entire sketch 

By default, the number of remaining degrees of freedom (DOF) in the entire sketch is displayed in 
the status area in the lower right corner of a workspace.  The DOF value will increase or decrease 
automatically as you sketch or delete figures, and add or delete dimensions and constraints. A fully 
defined sketch will have zero degrees of freedom.  It is not required to fully define a sketch before it 
can be used in a feature operation.  

 

 

 To hide the DOF hints: 

1. From the Tools menu, select Options.  The Options dialog appears. 

2. Select the General tab if it is not already selected. 

3. In the Hints area, unselect DOF hints. 

4. Click OK. 

 
 

4.7    Dimensioning Sketch Figures 

Normally, to fully define and capture design intent in a sketch, you must place dimensions on sketch 
figures.  However, it is not required to dimension sketches before they are used to create features.  
Most importantly, sketch dimensions can easily be changed and modified at any time.  Additionally, 
any dimensions you place in a sketch will in turn be displayed in the 2D drawing that is based on the 
part when you choose to Project Design Dimensions when creating the drawing. 
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Two types of dimension states exist: driving and driven.  Driving dimensions are used to define and 
constrain a figure.  After driving dimensions have been placed on a figure, driven dimensions can 
also be added that are dependent upon the values of the driving dimensions.  By default, driven 
dimensions are displayed in parentheses.  Driven dimensions cannot be edited since they are 
dependent on driving dimensions. Subsequent changes to driving dimensions automatically update 
the driven dimensions.  

In the figure below, the 2.000 and .750 dimensions are driving dimensions, and the 1.250 dimension 
is a driven dimension (noted by parentheses).  If the 2.000 or .750 dimension was changed, then the 
1.250 dimension would automatically update as well. 

 
Figure 20: Sketch Figure Dimensions 

 
 

4.7.1    Dimensioning Sketch Figures 

Linear, radial, diametrical and angular dimensions may be created.  Linear dimensions may be 
placed on a line, between two parallel lines, or between nodes.  Diameter and radius dimensions 
may be created for circles and arcs.  Angular dimensions may be created between two non-parallel 
lines. 

 To dimension individual figures: 

Follow the steps below to place length dimensions on lines, and diameter dimensions on arcs and 
circles. 

1. Select the Dimension  tool from the Sketching toolbar; or from the Sketch menu, select 
Dimension; or right-click in the work area and select Dimension from the pop-up menu. 

2. Move the cursor over the figure you want to dimension.  The figure is highlighted. 

3. Click the figure to show a preview of the dimension.  Move the cursor to move the dimension 
preview. 
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Note: You can press the Esc key on the keyboard to cancel the current dimension operation. 

Depending on the type of figure you are dimensioning as well as where you move the preview 
dimension, a new dimension may be inferred.  For example, depending on where the cursor is 
moved, three different dimensions could be placed on an angled line. 

 

     Actual Length 

 

      Horizontal Distance    
 

     Vertical Distance 

4. After the dimension has been positioned properly, click again.  A dimension control box 
appears. 

 

5. Enter the appropriate dimension value in the box and press Enter on the keyboard.  The 
dimension is defined. 

Note: You can enter fractions (e.g. 3/8) and simple equations (e.g. 1.5 * 3) into the dimension 
control box.  You can also enter a value with units other than the current display units (e.g. 5 
mm).  The value will be converted to the display units automatically.  Supported unit 
abbreviations are “, ', mm, cm, and m. 

 

 To dimension distances or angles between figures: 

Follow the steps below to place distance dimensions or angular dimensions between figures, e.g. 
between lines, between nodes, between arc or circle center nodes, etc. 

1. Select the Dimension  tool from the Sketching toolbar, or from the Sketch menu, select 
Dimension, or right-click in the work area and select Dimension from the pop-up menu. 

2. Move the cursor over the first figure you want to dimension from. 

3. Click the figure, a preview may appear but do not place the dimension at this time. 
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4. Move the cursor over the second figure you want to dimension to and click again.  A new 
dimension preview appears. 

5. Move the cursor to position the dimension and click a third time.  A dimension control box 
appears. 

6. Enter the appropriate dimension value in the box and press Enter on the keyboard.  The 
dimension is defined. 

 
 

 
 

4.7.2    Auto Dimensioning a Sketch 

You can automatically place driving dimensions on an entire sketch or on a selected subset of 
sketch figures.  The number of dimensions placed automatically will vary depending on the number 
of sketch constraints that exist in the sketch.  If you want to automatically place as many dimensions 
as possible initially, it is recommended you minimize the use of sketch constraints. 

 To auto dimension the entire sketch: 

1. From the Sketch, select Auto Dimension.  The Auto Dimension dialog appears. 

 

2. Choose the option All figures and click the Apply button.   
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Note: The Remaining DOF: field shows you how many degrees of freedom you currently have 
remaining.  You can not modify this value in the Auto Dimension dialog.  To decrease the 
number of DOF remaining, continue adding dimensions and constraints to your sketch.  

3. Dimensions appear on the sketch.  You can Close the dialog and modify any of the dimensions 
as required. 

 
Figure 21: Before Applying Auto Dimension 

 

 
Figure 22: After Applying Auto Dimension 
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 To auto dimension a subset of the sketch figures: 

1. From the Sketch, select Auto Dimension.  The Auto Dimension dialog appears. 

2. Choose the option Selected figures. 

3. Select one or more figures to dimension and click the Apply button. 

4. Dimensions appear for the selected figures.  You can either select and dimension additional 
figures or Close the dialog and modify the created dimensions. 

 
 

4.7.3    Using Spinner Controls 

When you place dimensions on sketch figures, you can enter the dimension value manually by 
typing a value.  You can also use the spinner arrows to incrementally change a dimension value 
based on a pre-determined increment value. 

 To set the spinner increment: 

1. From the File menu, select Properties.  The Design Properties dialog appears. 

2. Select the Units tab if it is not already selected. 

3. In the Spinner Increment area, enter a Length increment value, i.e. .125”, .250”, .375”, etc. 

4. Also enter an Angle increment value based on degrees. 

5. Click Apply and then click Close. 

 

 To use the spinner arrows: 

1. Select the Dimension  tool from the Sketching toolbar and dimension a figure. 
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2. When the dimension control box appears, click one of the two black arrow buttons to increase 
or decrease the dimension by the spinner increment value. 

 

 
 

4.7.4    Using Equations in Dimensions 

You can create dimensions using mathematical relations between dimensions or parameters, using 
dimension names as variables in the equations. 

 To use equations in dimensions: 

1. You can type in an equation in any text box where you would enter a dimension, or in the 
Equation Editor.   

 

 To show equations in sketches and models: 

1. From the File menu, select Properties.  The Design Properties dialog appears. 

2. Select the Dimension tab. 

3. Select the Show Equations option. 

4. Click Apply and then click Close. 

5. Place a dimension on a figure.  The parameter name associated with the dimension is now 
displayed. If you included an equation, the equation will be displayed, but not the value.   
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You can reference existing parameters as you create new dimensions.  You can then manage the 
equations using the Equation Editor. 

 To use the Equation Editor: 

1. You can access the Equation Editor directly when placing dimensions.  Press the Edit 

Equation  button on the dimension control box. 

 

The Equation Editor dialog appears in which you can add new equations and constants, 
use an existing equation to set the value of the dimension, or set the value equal to 
another dimension.  The dimension parameters are listed under the Name column, the 
current values of the parameters are listed under the Result column, and the dimension 
type is listed under the Type column. 

 

You can access the Equation Editor at anytime.  From the Tools menu, select Equation 
Editor, or press Ctrl + E on the keyboard.   

2. To modify an equation, select the equation from the list, and click Modify, or double-click in the 
field that you want to modify, i.e. name or equation. 



Chapter 4 - Sketching 

 101 
 

3. If necessary, you can click Add to create new parameters.  In the Add Equation dialog, specify 
the name of the new parameter; the type of parameter you want to create (Distance, Angle, 
Count, or Scalar); and the equation that will define its value.  You can also add a comment if 
you desire.  When you are finished, Close the Add Equation dialog. Type in the new variable 
name, new equation, or variable value and press Enter on the keyboard. 

4. Click OK in the Equation Editor dialog to apply the changes.   

 

Functions available for use 

The following functions are available for use in equations in Alibre Design.  

Function Name Description 

abs(x) absolute value Returns the absolute value of the argument. 

acos(x) arc cosine acos (a/c) = a in radians |x| < 1 

asin(x) inverse sine asin (b/c) = a in radians |x| < 1 

atan(x) arc tangent atan(b/a) = α in radians |x| < 1 

sin(x) sine Returns the sine of an angle. The argument can be any valid 
numeric expression in radians. The sin(x) function takes an 
angle and returns the ratio of two sides of a right triangle. The 
ratio is the length of the side opposite the angle divided by the 
length of the hypotenuse. To convert degrees to radians, 
multiply degrees by pi/180. To convert radians to degrees, 
multiply radians by 180/pi. 

sin(a) = b/c 

cos(x) cosine Returns the cosine of an angle. The argument can be any valid 
numeric expression in radians. 

cos(a)=a/c 

tan(x) tangent The argument can be any valid numeric expression that 
expresses an angle in radians. 

tan(a)=b/a 
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Function Name Description 

int(x) integer Returns the integer portion of the argument. The argument can 
be any valid numeric expression. If the argument is negative, 
int(x) returns the first negative integer less than or equal to the 
number. If the argument is a positive decimal number less than 
1, such as 0.885, zero is returned. 

frac(x) fraction Returns just the decimal portion of the argument. 

sign(x) sign Returns the sign of the argument. The argument can be any 
valid numeric expression. If the number is greater than zero, 
sign(x) returns 1, if the number returns 0, and if negative, the 
sign(x) returns -1. 

sqrt(x) square root Returns the square root of the argument:  

x > 0 

X^n Xn x > 0 

 

In the preceding table, “x” is a real number; “n” is an integer; and “a,” “b,” “c” and “α” have the 
following relationship: 

 

 

Dimensionality of equations 

Each parameter has a specified dimensionality (that is, length, angle, scalar, count).  When you write 
an equation for a parameter, the equation's dimensionality must match that of the parameter.  If the 
equation's dimensionality is different, the equation will be displayed in red and a popup error 
message will appear when you rollover the equation. 

For example: 

• If D1 and D2 are the lengths of two line figures, you can write the equation, D2 = D1 * 0.50, 
which has the correct dimensionality (length), but you cannot write D2 = D1 * D1, because 
this equation has dimensionality “length squared”. 

• If A1 is the angle between two line figures, you cannot write A1 = D1, because D1 is a 
length that will carry a unit, such as inches.  The angle will be in degrees.  These two do 
not have the same dimensionality.   



Chapter 4 - Sketching 

 103 
 

 

4.7.5    Changing Sketch Figure Dimensions 

 To change the value of an existing dimension: 

1. Select the sketch Select  tool from the Sketching toolbar. 

2. Move the cursor over the dimension.  The dimension is highlighted. 

3. Double-click the dimension.  The dimension control box appears displaying the current 
dimension value. 

4. Enter a new dimension value in the dimension and press Enter on the keyboard.  The 
dimension is updated and the figure reflects the new dimension. 

 
 

4.7.6    Deleting Sketch Figure Dimensions 

 To delete an existing dimension: 

1. Select the sketch Select  tool from the Sketching toolbar. 

2. Move the cursor over the dimension.  The dimension is highlighted. 

3. Select the dimension by clicking it.  

4. Press the Delete key on the keyboard 

Or, right-click and select Delete from the pop-up menu 

Or, from the Edit menu, select Delete 

 
 

4.7.7    Modifying Sketch Dimension Properties 

You can change individual dimension properties such as dimension line size and style, dimension 
value format and precision, dimension text size and orientation, dual dimension display, and 
tolerance information. 
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 To modify sketch dimension properties: 

1. Select either the sketch Select  tool or the Dimension  tool from the Sketching 
toolbar. 

2. Move the cursor over the dimension, right-click, and select Properties from the pop-up menu.  
The Dimension Properties dialog appears. 

                      

 

3. Select one of the four tabs:  Units and Tolerance, Lines and Arrows, Text, and Alternate 
Units and Text. 

4. Make desired changes to the dimension settings. 

5. Click OK to apply the changes. 
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4.8    Working in a Sketch 

By default, a new part workspace contains three reference planes: XY, YZ, and ZX (Refer to 
Reference Geometry (on page 137) for details related to inserting additional reference planes).  Any 
reference plane can be used as a sketch plane.  To select a reference plane to be used as the 
sketch plane, simply select it either in the work area or the Design Explorer before entering sketch 
mode, or enter sketch mode and then select the desired sketch plane.  You can refer to Entering 
Sketch Mode (on page 48) for more information.  

 
 

4.8.1    The Sketch Grid 

Upon entering a sketch, by default a sketch grid will be displayed that can be used as reference 
during sketching.  

                

The grid acts as an additional reference during sketching.  You can customize the grid spacing as 
well as choose to automatically snap to grid during sketching (snap to grid is not on by default).  
Both grid display and snap to grid are optional and can be turned on or off at any time. 
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 To turn the grid off: 

1. Uncheck the option Show Grid? on the Grid Overlay (this is a toggle - check the box to turn it 
on). 

OR, 

1. From the Tools menu, select Options.  The Options dialog appears. 

2. Select the Grid tab. 

3. Uncheck the Display grid check box to turn the grid off (this is a toggle - check the box to turn 
it on). 

4. Click OK in the Options dialog. 

 

 To turn snap to grid on: 

1. Check the option Snap to Grid? on the Grid Overlay (this is a toggle - uncheck the box to turn 
it off).  If you can not see the Snap to Grid? checkbox, you need to maximize your workspace. 

OR, 

1. From the Tools menu, select Options.  The Options dialog appears. 

2. Select the Grid tab. 

3. Check the Snap to grid check box to turn the snap to grid on (this is a toggle - uncheck the box 
to turn it off). 

4. Click OK in the Options dialog.  

Note:  You can snap to grid even if you do not have the grid displayed. 

 
 

4.8.2    Snapping to the Working Plane 

In sketch mode, you can have the work area view automatically reorient (once you have selected a 
sketch plane) so that you are looking directly at the sketch plane (the working plane). 
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 To turn Snap to the Working Plane on and off: 

1. From the Tools menu, select Options. 

2. Select the General tab if it is not already selected. 

3. In the Design Viewing area, check the Snap to working plane option to turn it on (uncheck it 
to turn it off). 

4. Click OK to accept the changes and exit the Options dialog. 

When this option is checked ON, the view will reorient once you have selected a sketch plane in 
sketch mode.  When this option is checked OFF, the work area view will remain in its current 
orientation once you have selected a sketch plane. 

 

 To reorient the view back to the sketch plane: 

While you are in sketch mode, you can reorient the view back to the sketch plane at any time. 

From the View menu, select Orient > To Sketch Plane; or select the Orient To Sketch Plane tool 

from the Orient View Toolbar . 

 

 To reorient the view to the isometric of the sketch plane: 

While you are in sketch mode, you can reorient the view to the isometric of the sketch plane at any 
time. 

From the View menu, select Orient > Isometric To Sketch Plane; or select the Isometric to 

Sketch Plane tool from the Orient View Toolbar . 

 
 

4.8.3    Cursor Dimension Hints 

As you sketch new figures, dimensional properties are by default displayed near the mouse pointer.  
For example, as you sketch a line, the line length and angle are displayed and updated automatically 
as you move the mouse pointer.  You can hide the cursor dimension hints if desired. 
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 To hide the cursor dimension hints: 

1. From the Tools menu, select Options. 

2. Select the General tab if not already selected. 

3. In the Hints area, unselect the Cursor hints option.  (This turns off ALL cursor hints.) 

4. Click OK.  

 
 

4.8.4    Mouse Pointer Display 

For the most part during sketching, the mouse pointer's appearance will change depending on which 
sketch tool is selected as well as the position of the mouse pointer. 

• The default symbol appears as  when the sketch Select  tool is selected. 

• When another sketch tool is selected, the symbol will change to indicate the tool's function.  

For example, when the circle tool is selected, the symbol appears as . 

• The mouse pointer also changes automatically depending on its position over an existing 
figure.  

 

 

Node on Figure 

 

On the Figure 

 

Midpoint of Figure 
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4.8.5    Inference Lines 

During sketching, inference lines are displayed to provide a visual aid for aligning nodes. Inference 
lines appear as dashed lines and are automatically generated when your cursor is vertically or 
horizontally aligned with existing nodes or points, including the origin. 

                     

 
 

4.8.6    Direct Coordinate Entry 

You can enter Cartesian and/or Polar coordinates while sketching to define start/endpoints, center 
points, and angular and radial values. 

 To use direct coordinate entry: 

1. Select any sketch figure tool. 

2. Right-click in the work area and select Direct Coordinate Entry from the pop-up menu, 

OR from the Sketch menu, select Direct Coordinate Entry. 

OR click the Direct Coordinate Entry tool    from the toolbar.  The Direct Coordinate 
Entry dialog appears. 

3. Select either the Cartesian or Polar tabs. 

4. Select either the Absolute or Relative options.  The Absolute option will define all nodes with 
respect to the origin at (0,0,0).  The Relative option will define all new nodes with respect to the 
last node entered.  

5. Enter the Cartesian or Polar coordinates depending on which system is being used. 

6. Click Set to define a node. 

7. Click Close when finished. 
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4.8.7    Right-click Menu 

During sketching, a number of sketch tools are available from a menu that is quickly accessed by a 
right-click in the work area.  Utilizing the right-click menu often provides the most efficient method in 
selecting a tool.  

 
 

4.8.8    Open and Closed Sketches 

Sketches define the profile of a 3D feature.  Most sketches will be closed, because the majority of 
3D features require closed sketches.  You can reference Feature Creation (on page 155) for more 
information related to features.  A closed sketch contains no open-ended figures.  The sketches 
below are examples of closed sketches. 

 

 

 

An open sketch contains open-ended figures.  Open sketches can only be used in Thin Wall Boss 
and Thin Wall Cut features.  You can reference Feature Creation (on page 155) for more 
information related to features.  The sketches illustrated below are examples of open sketches.  
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4.8.9    Checking Sketches for Errors 

For complicated sketches involving many figures and nodes, it may be helpful to check for errors in 
the sketch such as open ends, intersections, and overlaps before creating a feature.  If any of these 
errors exist, it may prevent you from successfully creating a 3D feature.  Checking for these is also a 
valuable troubleshooting tool to resolve sketch problems.   

Auto-Analyze Functionality 

Alibre Design has an auto-analyze function that will analyze a sketch by default when you exit the 
sketch.  You can turn the auto-analyze function off if desired.  

When the auto-analyze function is turned on, Alibre Design will automatically run the Analyze Sketch 
tool each time you exit sketch mode, or when you choose a feature tool while inside a sketch.  If the 
sketch has no errors, the process you have started will continue.  If the sketch contains errors, you 
will receive a dialog alerting you to the error.  

 

Choose one of the following options:  

Show me - this option brings up the Analyze Sketch dialog with the analysis results.  Select any of 
the results and continue on with Steps 6-10 in the check for errors manually instructions that follow.  

Ignore - this option allows you to continue the process you started.  Be aware that if you have 
started the process to create a 3D feature, the feature may fail as a result of the errors in the sketch.   

Note: Check the Do not show me this screen option first, if you want to turn off the auto-analyze 
function.  Alibre Design will not automatically analyze any future sketches unless you turn the option 
back on as described below.  

 



 Chapter 4 - Sketching 

112 

 To turn on and off auto-analyze functionality: 

1. From the Tools menu, select Options.  

2. On the General tab, in the Design Interaction section, uncheck the option for Automatically 
Analyze Sketches to turn it off (check the option to turn it back on). 

 

 To check a sketch for errors manually: 

1. Select the sketch Select  tool from the Sketching toolbar. 

2. Select either the entire sketch by dragging a selection rectangle over the desired sketch figures 
or select the appropriate sketch figures one at a time.  The figures are highlighted after 
selection. 

3. From the Sketch menu, select Analyze; or, from the Sketch Overlay, select the Analyze tool 

.  The Analyze Sketch dialog appears.    

 
Figure 23: Analyze Sketch Dialog 

4. In the Analyze section, check the items you would like to search for:  Disjoint Ends, Open 
Loops, Overlaps, Self-Intersections, and/or Degenerate Figures. 

5. Click the Analyze button. The sketch errors will appear in the Results area of the dialog. 

6. Click the result you want to view, and the area will highlight in the part work area.  In some 
instances, you can use the Heal option to resolve the sketch.  The Heal option is typically 
available for Disjoint Ends, Open Loops, and Degenerate Figures. 
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7. Select the Tolerance option in the Heal area of the dialog. 

8. Enter a Tolerance value that is larger than the existing gap distance between the open nodes.  

9. Once the Tolerance value is set, the Heal button will become active.  Click the Heal button to 
resolve the figure. 

10. Click Close to exit the dialog. 

 

 
 

4.8.10    Enclosed Figures 

A simple way to reduce steps when modeling a part is to create a sketch with enclosed figures.  
Enclosed figures are figures that are sketched within the profile of another figure.  Material will be 
removed from the enclosed figure profile when a feature is created.  The sketches illustrated below 
contain enclosed figures. 

  

 

  
 

4.8.11    Copying  and Pasting Sketch Figures 

You can cut, copy, and paste entire sketches or individual sketch figures within the same sketch or 
into new sketches altogether. 

 To copy and paste sketch figures within the same sketch: 

1. Select the sketch Select  tool from the Sketching toolbar. 

2. Select the figures to be copied.  The figures become highlighted. 
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3. From the Edit menu, select Copy, or press Ctrl + C on the keyboard. 

4. From the Edit menu, select Paste, or press Ctrl + V on the keyboard, or right-click and select 
Paste from the pop-up menu. 

5. The copied figure(s) are placed slightly offset from the originating figures. 

 

 To copy and paste sketch figures into a new sketch: 

1. Select the sketch Select  tool from the Sketching toolbar. 

2. Select the figures to be copied.    If you are copying an entire sketch, from the Edit menu, 
choose Select All, or press Ctrl + A on the keyboard.  The figures become highlighted. 

3. From the Edit menu, select Copy, or press Ctrl + C on the keyboard. 

4. Exit sketch mode, select the new sketch plane, and enter sketch mode. 

5. From the Edit menu, select Paste, or press Ctrl + V on the keyboard, or right-click and select 
Paste from the pop-up menu.  The figures are pasted into the new sketch in the same 
orientation with respect to the origin as the originating sketch. 

 
 

4.9    Sketches and the Design Explorer 

After creating a sketch, and subsequently exiting sketch mode, the sketch will be listed in the Design 
Explorer under the Features node in the order it was created. 



Chapter 4 - Sketching 

 115 
 

                     

 
 

4.9.1    Editing Sketches 

Sketches can be edited at anytime.  

 To edit a sketch: 

1. You can get into edit mode for a sketch in one of the following ways:  

• In the Design Explorer, right-click the sketch name and select Edit from the pop-up menu  

• In the Design Explorer, double-click the sketch name 

• Double-click a sketch in the work area if it has not been used to create a feature 

• If the sketch has been used to create a 3D feature, double-click the feature in the work area 
to edit the sketch used for that feature 

2. The sketch appears in sketch mode and you can make the appropriate modifications to the 
sketch, and then exit sketch mode to apply the changes. 
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4.9.2    Renaming Sketches 

Sketches are listed in the Design Explorer by default as Sketch<1>¸ Sketch<2>, etc.  You can 
rename the sketches to provide relevant information. 

 To rename a sketch: 

1. In the Design Explorer, right-click the sketch name and select Rename from the pop-up menu, 
or click the sketch name twice with a slight pause between the first and second click.  The 
sketch name is highlighted and can be changed. 

2. Type in the new sketch name. 

3. Press Enter on the keyboard. 

 
 

4.9.3    Deleting Sketches 

You can delete a sketch as long as it has not been used to create a 3D feature.  To delete a sketch 
that has an associated feature, you must first delete the feature. 

 To delete a sketch: 

1. In the Design Explorer, right-click the sketch name and select Delete from the pop-up menu, or 
select the sketch and press Delete on the keyboard. 
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C H A P T E R  5  

 3D Sketching 
3D Sketching allows you to create guide curves for better control of lofts.  In addition, using 3D 
sketches allows you to create sweeps that are ideal for modeling piping and cabling systems. 

In This Chapter 

The 3D Sketching Interface ..................................................................................... 118 
Entering and Exiting 3D Sketch Mode..................................................................... 124 
3D Sketch Figures ................................................................................................... 125 
3D Sketch Nodes..................................................................................................... 128 
Working with Existing 3D Sketch Figures................................................................ 129 
Dimensioning 3D Sketch Figures ............................................................................ 130 
3D Sketch Constraints............................................................................................. 133 
Other 3D Sketch Functions ..................................................................................... 135 
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5.1    The 3D Sketching Interface 

The 3D Sketching toolbar is shown by default on the right side of the workspace.  Commonly used 
sketch tools are accessible on the Sketching toolbar.  

 
Activate 3D Sketch (with options fly-out) ... activate 3D sketch mode 

 
Select ... select sketch figures and entities 

 
Constraints (with options fly-out) ... place manual constraints on a sketch 

 
Dimension  ... place dimensions on sketch figures 

 
Line  (with options fly-out)... create a line figure 

 
Arc (with options fly-out)... create an arc figure 

 
Spline (with options fly-out)... create a spline figure 

 
Sketch Node ... create a sketch node 

 
Direct Coordinate Entry ... create sketch figures by entering Cartesian or Polar 
coordinates 

 
Define Coordinate System ... define the current coordinate system 

 
Cycle Sketch Plane ... change the sketch plane 

 
Elevate ... change the elevation by dragging the cursor 

 
Elevation ... change the elevation by entering coordinates 

 
Fillet ... place a fillet on two existing figures 
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All of the tools accessible on the 3D Sketching toolbar are also accessible from the 3D Sketch 
menu. 

 
 

5.1.1    3D Sketching Context 

Just as 2D sketching is done in 2D Sketch Mode, 3D sketching takes place 3D Sketch Mode.  The 
3D sketching environment has a dedicated toolbar and right-click menu, which allow you to access 
the 3D sketch functions. 

You can modify the display of various 3D sketch items from the view menu.   

 To modify the display of sketch items: 

1. From the View menu, select Sketch Display.   The following items can be turned on or off in 
the display: 

• Grid 

• Sketch Dimensions 

• Constraint Symbols 

• Guide Lines 

• Current Coordinate System Indicator 

2. Select an item to turn it on or off.  A checkmark next to an item means it is visible (on).   This is 
a toggle on/off. 

 

 To modify the view orientation: 

From any orientation back to the sketch plane: 

From the View menu, select Orient > To Sketch Plane; or select the Orient to Sketch Plane tool  

 from the Orient View Toolbar. 

 

From any orientation to the isometric view of the sketch plane: 

From the View menu, select Orient > Isometric To Sketch Plane; or select the Isometric To 

Sketch Plane tool   from the Orient View Toolbar. 
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5.1.2    Current Coordinate System 

In the 3D sketching environment, all position-related data is entered with respect to the Current 
Coordinate System (CCS).  The CCS is depicted graphically by a 3D coordinate system in the work 
area.  This graphical coordinate system is called the CCS indicator.  Upon entering 3D sketch mode, 
the CCS is automatically created using the active plane, which becomes the XY-Plane of the CCS.  
The direction of the axes is determined automatically by the system.  

 

 To Define A New 3D Coordinate System: 

The CCS can be changed using the Define 3D-Coordinate System command.  

1. Select the Define Coordinate System   tool from the Sketching toolbar; or from the 3D 
Sketch menu, select Define Coordinate System.  The Define Coordinate System dialog 
appears. 

 

2. Enter the following information: 

3. Plane: Required - Enter the desired reference plane, planar face, or 2D sketch to be used as 
the plane.  Checking Reverse will toggle which Z-axis direction is positive. 

4. X-Vector: Optional - Enter the reference axis, linear edge, 2D sketch line, or 3D sketch line to 
be used for the X-Vector.  Checking Reverse will toggle which X-axis direction is positive. 

5. Origin: Optional - Enter a reference point, vertex, 2D node, or 3D node to be used as the 
origin.  If Project is checked, the point is projected to the plane to become the origin; otherwise 
the plane is moved to intersect the point that becomes the origin. 

6. Click OK to apply the changes. 
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 To turn off the CCS indicator: 

From the View menu, select Sketch Display > Current Coordinate System Indicator. This is an 
on/off toggle.  

 
 

5.1.3    Sketch Plane, Guide Lines, and Elevation 

The sketch plane is defined by any of the planes of the CCS and an elevation.   The sketch plane 
can be offset along its normal by an elevation distance.  

By default, the sketch plane is the XY-Plane of the CCS.  The sketch plane can be altered by using 
the Cycle Sketch Plane Command.  

Coordinate guides are displayed while in 3D sketch to indicate the current location of the cursor with 
respect to the CCS.  Guides for the sketch plane are displayed on the sketch plane.  A guide 
extending from the base plane to the current cursor position indicates the current elevation.  

 
Figure 24: Coordinate Guides Shown with the Sketch Plane Grid 

 To change the sketch plane: 

1. Select the Cycle Sketch Plane tool  from the Sketching toolbar; or from the 3D Sketch 
menu, select Cycle Sketch Plane.  
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2. The sketch plane cycles to the next primary plane each time the tool is clicked.  If the grid is 
turned on, it is displayed on the current base plane. 

 Notes:    

This command can be issued during other commands. 

You can also cycle the sketch plane by pressing the Tab or “F” key on the keyboard.  If you 
press one of these keys while in a figure creation command, the cursor will remain in the same 
position in space, rather than moving to an elevation of zero on the new sketch plane. 

 

Elevation 

Elevation is controlled in two ways.  The first method is to drag the mouse while in elevate mode.  
The second method is to use the Elevation Dialog.  

 To control elevation in Elevate mode: 

1. Select the Elevate    tool from the sketching toolbar; or from the 3D Sketch menu, select 
Elevate. This puts you into Elevate mode.  

2. While in Elevate mode, the coordinates on the base plane remain constant.  

3. Click and drag the cursor to the desired height from the base plane.  

4. To exit Elevate mode, select the Elevate tool again from the sketching toolbar, or from the 3D 
Sketch menu, select Elevate. 

Notes:  

To change the elevation of an existing figure, click and drag the figure while in Elevate mode. 

Elevate can be issued during other commands. 

While in a figure creation command, Elevate can be accessed at anytime by pressing the “E” 
key on the keyboard and holding it down while placing the figure. 
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Figure 25: Elevation Height at base plane  

 
Figure 26: Elevation Height Changed by Dragging Mouse Pointer 
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 To control elevation using Elevation Dialog: 

1. Select the Elevation    tool from the sketching toolbar; or from the 3D Sketch menu, 
select Elevation.  The Elevation dialog appears. 

2. Enter the desired elevation in the dialog.  This dialog can remain open and in use during other 
commands. 

3. Click the X in the upper corner of the dialog to close when finished. 

 
 

5.2    Entering and Exiting 3D Sketch Mode 

5.2.1    Entering 3D Sketch Mode 

You must enter 3D sketch mode before you can begin sketching. 

 To enter 3D sketch mode: 

Select the Activate 3D Sketch   tool from the Sketching toolbar. 

Or, 

From the 3D Sketch menu, select Activate 3D Sketch. 

The activate 3D Sketch tool will appear in the active state  while in 3D sketch mode. 

 
 

5.2.2    Exiting 3D Sketch Mode 

The same methods used to enter 3D sketch mode can be used to exit 3D sketch mode. 

 To exit 3D sketch mode, use any one of the following options: 

• Click the Select   tool from the View toolbar. 

• Create a feature from the sketched profile.  For example, select a feature tool such as the 
Sweep tool from the Part Modeling toolbar.  
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• Select the Regenerate   tool from the Part Modeling toolbar. 

• From the Feature menu, select Regenerate All. 

 
 

5.3    3D Sketch Figures 

5.3.1    Line 

 To sketch a line: 

1. Select the Line tool from the Sketching toolbar; or from the 3D Sketch menu, select Figures > 
Line; or right-click and select Line from the pop-up menu. 

2. Position the cursor at the location you want to start the line. 

3. Click to start the line and drag the cursor to sketch the line. 

4. Click again to complete the line segment.  You can continue to sketch additional line segments 
by clicking.  Double-click or press ESC on the keyboard to complete the line. 

 
 

5.3.2    Arc 

You can sketch three different circular arc types:  1) Center, Start, End; 2) Start, End, Radius; 3) 
Tangent-Start, End.    

 To sketch a circular arc using Center, Start, End: 

1. Select the Circular Arc - Center, Start, End  tool from the Sketching toolbar; or from the 
3D Sketch menu select Figures > Circular Arc > Center, Start, End; or right-click and select 
Circular Arc from the pop-up menu. 

2. Click in the Work Area to place the center of the arc. 

3. Click a second time to start the arc. 

4. Move the cursor to sketch the arc. 

5. Click a third time to complete the arc. 
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6. Note: The plane of the arc is defined by the three nodes.  If the three nodes are collinear, the 
current sketch plane is used. 

   

        

 To sketch a circular arc using Start, End, Radius: 

1. Select the Circular Arc - Start, End, Radius  tool from the Sketching toolbar; or from the 
3D Sketch menu select Figures > Circular Arc > Start, End, Radius. 

2. Position the cursor at the arc starting location.  

3. Click to start the arc. 

4. Click a second time to locate the end of the arc. 

5. Move the cursor to size the arc. 

6. Click a third time to complete the arc. 

Note: The plane of the arc is defined by the three nodes. 

 

 To sketch a circular arc using Tangent-Start, End: 

1. Select the Circular Arc - Tangent-Start, End  tool from the Sketching toolbar; or from the 
3D Sketch menu select Figures > Circular Arc > Tangent-Start, End. 

2. Click a line or circular arc. 

3. Move the cursor to size the arc. 

4. Click a second time to complete the arc. 
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5. Note:  The plane of the arc is defined by the tangent line passing through the nodes at the start 
and end of the arc.  

 

You can also modify a 3D sketch circular arc in the same way as a 2D sketch circular arc (see 
"Circular Arcs" on page 53).  

 
 

5.3.3    Spline 

Creation of NURBS curves by interpolation 

Using this method, specify a set of nodes in the Work Area to define the spline. A curve is then 
interpolated based on the placement of the nodes. 

1. Select the Spline     tool from the Sketching toolbar; or from the 3D Sketch menu select 
Figures > Spline. 

2. Click in the Work Area to start the spline curve. 

3. Move the cursor and click a second time to place an interpolation node. 

4. Move the cursor to shape the curve. 

5. Continue clicking to place additional nodes and curve segments. 

Note: One or more interpolation nodes may be specified via the direct coordinate entry tool. 

6. Double-click or hit escape to complete the spline curve.  

Note: If you place the final node at the same location as the first, the spline will be completed 
as a closed spline. 

 

 To edit a Spline Curve: 

In 3D Sketch, you can edit spline curves by selecting and dragging any of the nodes in the curve. 
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 Inserting a Node Into a Spline Curve 

1. From the 3D Sketch menu, select Insert Node into Spline; or select the Insert Node into 

Spline    tool from the sketching toolbar.  

2. Click the spline to place a node. 

3. Continue clicking the spline to place as many nodes as desired. 

4. Choose the Select   tool to exit the Insert Node command. 

 
 

5.4    3D Sketch Nodes 

5.4.1    Placing a Sketch Node 

 To place a sketch node: 

1. Select the Sketch Node  tool from the Sketching toolbar; or from the 3D Sketch menu 
select Figures > Node. 

2. Click in the work area to place a sketch node.  You can continue clicking to place as many 
sketch nodes as you need. 

 
 

5.4.2    Inserting Sketch Nodes From A File 

You can insert sketch nodes from a comma delimited text file.  These nodes can then be used to 
create features such as Sweeps.   
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 To insert sketch nodes from a file: 

1. From the 3D Sketch menu, select Figures > Insert from File.  The Insert Nodes from File 
dialog appears. 

 

2. Enter the required information: 

File Name:  Type in the file name or use the Browse button to designate the file containing 
the nodes. 

Choose one of the following:  

Fit a Spline Through the Nodes - the system will interpolate a spline through the nodes.  

Connect Consecutive Nodes with Lines - each node will be connected by a straight 
line.  

Do Nothing - the nodes will be placed in the sketch without connecting figures.  

3. Click OK to insert the nodes. 

 
 

5.5    Working with Existing 3D Sketch Figures 

5.5.1    Adding Fillets 

 To add a fillet to a sketch figure: 

1. Select the Fillet  tool from the Sketching toolbar; or from the 3D Sketch menu select 
Fillet.  The Fillet Figures dialog appears. 
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2. Select the first figure by clicking it.  The figure name appears in the Figures to Fillet field in the 
dialog. 

3. Select the second figure by clicking it.  The figure name appears in the Figures to Fillet field in 
the dialog. 

4. Enter the fillet radius value in the Radius field. 

5. Click Apply to create the fillet.  The Fillet Figures dialog remains open so you can continue to 
place fillets on additional figures.  

Note:  Consecutive fillets with a diameter equal to the first fillet will not be dimensioned; instead 
an equal constraint will automatically be placed. 

6. Click Close to close the Fillet Figures dialog.  

 
 

5.6    Dimensioning 3D Sketch Figures 

To fully define the 3D sketch you must place dimensions on sketch figures.  3D sketch dimensions 
function similar to 2D sketch dimensions.  It is not required to dimension sketches before they are 
used to create features.  In addition, sketch dimensions can easily be changed and modified at any 
time.  
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Linear, radial, and angular dimensions can be created.  Linear dimensions are placed on a plane 
running through an axis created by the endpoints and parallel with the screen at the time of creation.  
The dimension will always lie on this plane from that time forward.  The dimension can be dragged 
along this plane from place to place.  Radial dimensions may be created for circular arcs.  Angular 
dimensions may be created between two non-parallel lines. 

 
Figure 27: Examples of 3D Linear Dimensions 

   

 
Figure 28: Examples of 3D Radius Dimensions 
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 To dimension individual figures: 

Follow the steps below to place length dimensions on lines, and diameter dimensions on arcs and 
circles. 

1. Select the Dimension  tool from the Sketching toolbar; or from the Sketch menu, select 
Dimension; or right-click in the work area and select Dimension from the pop-up menu. 

2. Move the cursor over the figure you want to dimension.  The figure is highlighted. 

3. Click the figure to show a preview of the dimension.  Move the cursor to move the dimension 
preview. 

Note: You can press the Esc key on the keyboard to cancel the current dimension operation. 

Depending on the type of figure you are dimensioning as well as where you move the preview 
dimension, a new dimension may be inferred.  For example, depending on where the cursor is 
moved, three different dimensions could be placed on an angled line. 

 

     Actual Length 

 

      Horizontal Distance    
 

     Vertical Distance 

4. After the dimension has been positioned properly, click again.  A dimension control box 
appears. 

 

5. Enter the appropriate dimension value in the box and press Enter on the keyboard.  The 
dimension is defined. 

Note: You can enter fractions (e.g. 3/8) and simple equations (e.g. 1.5 * 3) into the dimension 
control box.  You can also enter a value with units other than the current display units (e.g. 5 
mm).  The value will be converted to the display units automatically.  Supported unit 
abbreviations are “, ', mm, cm, and m. 
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 To dimension distances or angles between figures: 

Follow the steps below to place distance dimensions or angular dimensions between figures, e.g. 
between lines, between nodes, between arc or circle center nodes, etc. 

1. Select the Dimension  tool from the Sketching toolbar, or from the Sketch menu, select 
Dimension, or right-click in the work area and select Dimension from the pop-up menu. 

2. Move the cursor over the first figure you want to dimension from. 

3. Click the figure, a preview may appear but do not place the dimension at this time. 

4. Move the cursor over the second figure you want to dimension to and click again.  A new 
dimension preview appears. 

5. Move the cursor to position the dimension and click a third time.  A dimension control box 
appears. 

6. Enter the appropriate dimension value in the box and press Enter on the keyboard.  The 
dimension is defined. 

 
 

 
 

5.7    3D Sketch Constraints 

Figures in a 3D sketch may be constrained to a size, orientation, and relationship to another figure or 
model edge.  These constraints are similar to their 2D sketch constraint counterparts. 

Tip:  When you are active in 3D sketch mode, you can constrain sketch figures to other existing 
sketches.  This is particularly helpful when you are sketching guide curves for lofts, to ensure that 
your guide curves touch each profile used in the loft. 
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5.7.1    Inferred Constraints 

Location 

During the creation of a figure a Location constraint will be applied automatically when a 3D node is 
created while hovering over the following objects: 

• Reference Points 

• Vertices 

• An Existing 3D Node  

• An Edge 

• 2D Nodes (in visible 2D sketches that have not been used to create 3D geometry) 

• 2D Figures (in visible 2D Sketch that have not been used to create 3D geometry) 

This constraint is associative. If the object associated with the constraint moves, the corresponding 
3D node moves with it.  Inferred constraints can be broken by holding the CTRL key; then clicking 
and dragging the node away. 

Fixed Direction 

During the creation of lines that are horizontal or vertical with respect to the sketch plane, an implied 
fixed direction constraint will be placed on them. 

 
 

5.7.2    Explicit Constraints 

Explicit constraints are applied in a fashion analogous to their 2D equivalents through the use of a 
toolbar button or menu selection. The Constraints fly-out toolbar is available from the Sketching 
toolbar. 

 

 

    Coincident - A node can be constrained so that it lies on a figure, model edge, or planar 
face. 

     Fixed - Figures may be constrained to a fixed position in the sketch.   After the constraint 
is applied, the node or figure may not be moved without first deleting the constraint. 
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    Direction - The direction of a 3D line can be constrained so that it is held constant. 

      Parallel - Lines can be constrained to be parallel to each other.  In addition, a line can be 
constrained to be parallel to a linear edge, a reference plane, or a planar face. For planes and faces, 
the constraint indicates that the line is perpendicular to the normal of the plane or face. 

     Perpendicular - Lines can be constrained to be perpendicular to other lines, reference 
planes, reference axes or planar faces.  Splines can be constrained to reference planes and planar 
faces. 

Note:  With the Perpendicular constraint, the behavior of lines and splines differs:  Lines will be 
parallel to the normal of a plane or face.  Splines will be set tangent at the start or end of the spline 
parallel to the normal of a plane or face.   

 Tangent - Figures can be constrained to be tangent to a curve.  Tangent constraints can 
be applied automatically during sketching or placed manually after a figure has been sketched. 

  Tangent Continuous - An open 3D figure can be constrained to be continuous at its 
endpoint to another open 3D figure or an open edge.  

  Collinear - Figures may be constrained so that they lie in the same line.  
 

5.8    Other 3D Sketch Functions 

Other sketch options are similar to 2D sketch options: 

The sketch grid (on page 105) 

Snapping to the working plane (on page 106) 

Cursor display (see "Mouse Pointer Display" on page 108) 

Editing sketches (on page 115) 

Renaming sketches (on page 116) 
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C H A P T E R  6  

 Reference Geometry 
Reference geometry consists of planes, axes, points, and surfaces, which are primarily used for 
feature construction aids.  Reference planes serve as the default sketch planes.  Axes are 
fundamental to creating features such as revolutions and patterns.  The primary reference point in a 
work area is the origin and is used extensively as a guide.  Additional reference geometry can be 
added as necessary. 

 

In This Chapter 

Reference Planes .................................................................................................... 138 
Axes......................................................................................................................... 142 
Points....................................................................................................................... 145 
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6.1    Reference Planes 

By default, three reference planes are visible in a part and assembly workspace, the XY-plane, YZ-
plane, and ZX-plane; any can be used as the sketch plane.  Additional reference planes can be 
inserted in any orientation and also used as the sketch plane.  You can modify the display options of 
the reference planes. 

 To modify plane display options: 

1. From the Tools menu, select Options, General Tab 

2. Check Shade reference planes to see the reference planes slightly shaded in the work area.  
Uncheck the box if you do not wish to see the shading. 

3. Check Show reference plane normals to see a 3D arrow designating the direction of a 
reference plane's normal when you place the cursor over it.  Uncheck the box if you do not wish 
to see the designating arrows. 

 
 

6.1.1    Offset Plane 

You can create a new reference plane parallel to an existing reference plane or planar face offset by 
a specified distance. 

 To create an offset plane: 

1. Select the Insert Plane  tool from the Inspection toolbar; or from the Insert menu, select 
Plane; or right-click in the work area and select Insert Plane from the pop-up menu.  The 
Insert Plane dialog appears. 

2. Select the existing reference plane or planar face to offset. 

Enter the offset Distance value.  (Use a value of 0.00 if you want the new plane to be on 
the existing plane or face.)  A preview of the new plane is displayed.  

3. If necessary, select Reverse to create the plane in the opposite direction. 
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4. Click OK to create the plane. 

 
Figure 29: Offset Reference Plane 

 
 

6.1.2    Tangent Plane 

You can create a new reference plane parallel to an existing reference plane or planar face and 
tangent to an existing cylindrical face. 

 To create a tangent plane: 

1. Select the Insert Plane  tool from the Inspection toolbar; or from the Insert menu, select 
Plane; or right-click in the work area and select Insert Plane from the pop-up menu.  The 
Insert Plane dialog appears. 

2. Select the existing reference plane or planar face to offset. 

Select the cylindrical face that the new plane will be tangent to.  A preview of the new 
plane is displayed. 

3. Check the Reverse option to choose the alternative tangent point. 

4. If desired, you can select the Symmetry Axis option to create the plane parallel to the original 
plane or face and through the axis of the cylindrical face. 
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5. Click OK to create the plane. 

 
Figure 30: Tangent Reference Plane 

 
 

6.1.3    Angled Plane 

You can create a new plane through an edge or axis at an angle to an existing reference plane or 
planar face. 

 To create an angled plane: 

1. Select the Insert Plane  tool from the Inspection toolbar; or from the Insert menu, select 
Plane; or right-click in the work area and select Insert Plane from the pop-up menu.  The 
Insert Plane dialog appears. 

2. Select an existing edge or axis. 

Select an existing reference plane or planar face.  A preview of the new plane is 
displayed. 

3. Enter the Angle value. 

4. If necessary, select Reverse to create the plane in the opposite direction. 

5. Click OK to create the plane. 
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6.1.4    Parallel Plane Through a Point 

You can create a plane parallel to an existing reference plane or planar face through an existing 
point. 

 To create a parallel plane through a point: 

1. Select the Insert Plane  tool from the Inspection toolbar; or from the Insert menu, select 
Plane; or right-click in the work area and select Insert Plane from the pop-up menu.  The 
Insert Plane dialog appears. 

2. Select an existing reference plane or planar face. 

Select an existing reference point.  A preview of the new plane is displayed. 

3. Click OK to create the plane. 

 
 

6.1.5    Plane at Line and Point 

You can create a plane through an edge or axis and a point or vertex. 

 To create a plane through a line and point: 

1. Select the Insert Plane  tool from the Inspection toolbar; or from the Insert menu, select 
Plane; or right-click in the work area and select Insert Plane from the pop-up menu.  The 
Insert Plane dialog appears. 

2. Select an existing axis or edge. 

Select an existing reference point or vertex.  A preview of the new plane is displayed. 

3. Select the Containing Edge/Axis option to create the plane through both the point and the 
axis/edge. 

Select the Normal to Edge/Axis option to create the plane through the point and normal 
to the axis/edge. 

4. Click OK to create the plane. 
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6.1.6    Three Point Plane 

You can create a plane through three points or vertices. 

 To create a plane through three points: 

1. Select the Insert Plane  tool from the Inspection toolbar; or from the Insert menu, select 
Plane; or right-click in the work area and select Insert Plane from the pop-up menu.  The 
Insert Plane dialog appears. 

2. Select an existing point or vertex. 

Select a second point or vertex. 

3. Select the third point or vertex.  A preview of the new plane is displayed. 

4. Click OK to create the plane. 

 
 

6.1.7    Plane Normal to 3D Sketch or 3D Edge 

You can create a plane normal to an open 3D sketch or normal to an edge of a solid model.  

 To create a plane normal to a 3D sketch or edge: 

1. Select the Insert Plane  tool from the Inspection toolbar; or from the Insert menu, select 
Plane; or right-click in the work area and select Insert Plane from the pop-up menu.  The 
Insert Plane dialog appears. 

2. Select an existing open 3D sketch or model edge.  A preview of the new plane is displayed.  

3. Check the Other End box to move the plane to the other end of the sketch or edge.  

4. Click OK to create the plane. 

 
 

6.2    Axes 

Three axes are visible by default in part and assembly workspaces, the X-axis, Y-axis, and Z-axis.  
Additional axes can be inserted as needed. 
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6.2.1    Axis Through Axis or Edge 

You can create an axis through an existing axis or linear edge. 

 To create an axis through an edge: 

1. Select the Insert Axis  tool from the Inspection toolbar; or from the Insert menu, select 
Axis; or right-click in the work area and select Insert Axis from the pop-up menu.  The Insert 
Axis dialog appears. 

2. Select an existing axis or edge.  A preview of the new axis is displayed. 

3. Click OK to create the axis. 

 
 

6.2.2    Axis Through Two Points 

You can create an axis through two points or vertices.  This method can be used to create an axis at 
an angle. 

 To create an axis through two points: 

1. Select the Insert Axis  tool from the Inspection toolbar; or from the Insert menu, select 
Axis; or right-click in the work area and select Insert Axis from the pop-up menu.  The Insert 
Axis dialog appears. 

2. Select an existing point or vertex. 

3. Select the second point or vertex.  A preview of the new axis is displayed. 

4. Click OK to create the axis. 

 
 

6.2.3    Axis Using Cylindrical Face 

You can create an axis using a cylindrical face as reference. 
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 To create an axis using a cylindrical face:  

1. Select the Insert Axis  tool from the Inspection toolbar; or from the Insert menu, select 
Axis; or right-click in the work area and select Insert Axis from the pop-up menu.  The Insert 
Axis dialog appears. 

2. Select an existing cylindrical face.  A preview of the new axis is displayed. 

3. Click OK to create the axis. 

 
 

6.2.4    Axis Through Two Planes 

You can create an axis at the intersection of two existing reference planes or planar faces. 

 To create an axis through two planes: 

1. Select the Insert Axis  tool from the Inspection toolbar; or from the Insert menu, select 
Axis; or right-click in the work area and select Insert Axis from the pop-up menu.  The Insert 
Axis dialog appears. 

2. Select an existing reference plane or planar face. 

3. Select a reference plane or planar face that intersects the first plane or face.  A preview of the 
new axis is displayed. 

4. Click OK to create the axis. 

 
 

6.2.5    Axis Offset and Parallel to Axis or Edge 

You can create an axis that is parallel to an existing axis or edge and offset by a specified distance. 

 To create an axis offset and parallel to an edge: 

1. Select the Insert Axis  tool from the Inspection toolbar; or from the Insert menu, select 
Axis; or right-click in the work area and select Insert Axis from the pop-up menu.  The Insert 
Axis dialog appears. 

2. Select an existing edge or axis. 
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3. Select a reference plane or planar face that passes through the edge or axis selected in step 1.  
A preview of the new axis is displayed. 

4. Enter an offset distance. 

5. If necessary select Reverse to create the axis in the opposite direction. 

6. Click OK to create the axis. 

 
 

6.3    Points 

In part and assembly workspaces, the origin is the only 3D point displayed by default.  Additional 3D 
points can be inserted as necessary. 

 To insert a new point: 

1. Select the Insert Point  tool from the Inspection toolbar; or from the Insert menu, select 
Point; or right-click in the work area and select Insert Point from the pop-up menu.  The Insert 
Point dialog appears. 

2. Select the appropriate point type below and follow the steps accordingly. 

 
 

6.3.1    Point at Specified Coordinates 

You can create a point using direct coordinate entry. 

 To create a point using direct coordinate entry: 

1. Enter the 3D coordinates of the new point.  The coordinates are based on the absolute 
coordinate system with the origin located at (0,0,0). 

2. Click OK to create the point. 

 
 

6.3.2    Point at Plane and Axis/Edge 

You can create a point at the intersection of plane or planar face and an axis or edge. 
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 To create a point at a plane and edge: 

1. Select a reference plane or planar face. 

2. Select an axis or edge.  A preview of the new point is displayed. 

3. Click OK to create the point. 

 
 

6.3.3    Point at Axis/Edge and Axis/Edge 

You can create a point at the intersection of two axes or edges. 

 To create a point at the intersection of two edges: 

1. Select an axis or edge. 

2. Select a second axis or edge.  A preview of the new point is displayed. 

3. Click OK to create the point. 

 
 

6.3.4    Point at the Center of Circular Edge 

You can create a point at the center of a circular edge. 

 To create a point at the center of a circular edge: 

1. Select a circular edge.  A preview of the new point is displayed. 

2. Click OK to create the point. 

 
 

6.3.5    Point at Vertex 

You can create a point at a vertex. 

 To create a point at a vertex: 

1. Select the vertex.  A preview of the new point is displayed. 
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2. Click OK to create the point. 

 
 

6.3.6    Point Along Edge 

You can create a point along an edge at a specified location. 

 To create a point along an edge: 

1. Select the edge.  A preview of the new point is displayed. 

Enter a Ratio value.  A ratio of .5 will place the point at the midpoint of the edge, 1.0 will 
place the point at the end of the edge.  

2. Click OK to create the point. 

 
 

6.3.7    Point Between Two Points 

You can create a point between two points at a specified location. 

 To create a point between two points: 

1. Select a point or vertex. 

2. Select a second point or vertex. 

3. Enter a Ratio value.  A ratio of .5 will place the point at the midpoint between the two existing 
points or vertices. 

4. Click OK. 

 
 

6.4    Reference Surfaces 

You can insert surfaces as reference geometry, similar to application planes, in order to trim or 
extend solids to the surfaces. In addition, you can thicken a reference surface into a solid. 
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6.4.1    Inserting Reference Surfaces 

Surfaces can be inserted from IGES or SAT files only. 

 To insert a surface: 

1. Open the part workspace that you want the surface inserted into. 

2. From the Insert menu, select Surfaces; or select the Insert Surfaces tool  from the 
Inspection toolbar.  The Insert Surface dialog appears. 

3. Select the file that you wish to insert; then click Open. The Insert Surface Options dialog 
appears, if you have that option turned on. 

Note:  To turn on the option to see the Insert Surface dialog, From the Tools menu, select 
Options> Interoperability Tab.  In the Insert Options section, check the box beside Show 
Options When Inserting.  

4. Select the desired options; then click OK.  

• Stitch Adjoining Faces takes faces that meet at a common edge and places them 
in the same surface body.  Each resulting lump becomes a surface. 

• None inserts the surfaces, as they exist in the file.  Each lump is a surface.  The 
body is unchanged. 

• Unstitch to Standalone Surfaces converts each face into a separate surface. 

• Heal is same as healing for import of solid.  It will recalculate inaccurate geometry in 
order to make the part more accurate upon import.  It cleans up the body by making 
sure edges lie on faces, eliminates duplicate vertices, etc.  Healing attempts to fix 
problems detected with the model by changing it.  Most IGES files require healing to 
import properly.  

• Make Tolerant will tag inaccurate geometry to enable more intelligent subsequent 
operations after import.  Because the geometry of a tolerant model is allowed to be 
less precise, inaccurate or leaky data can often be imported using the Make Tolerant 
option.  Making a model tolerant leaves its underlying geometry unchanged.   

The surface is inserted into the work area, and is listed in the Design Explorer under both Surfaces 
and Features. 
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6.4.2    Positioning Reference Surfaces 

The default location of the inserted surface is such that its coordinate system matches the current 
part workspace coordinate system with the same origin, orientation, and scale.  You can modify the 
location of the surface by positioning it. 

 To position a surface: 

1. In the Design Explorer, right-click the surface you wish to position. 

2. Select Edit.  The Position Surface dialog appears. 

 

3. In Method, select the method you wish to use to position the surface. 

• Axis and Offset:  The surface will be moved the offset distance in the direction of 
the specified axis or edge 

• Planar: Choose points or vertices to use for the start of the move and the end of the 
move.  These points will be projected onto the chosen plane, and the surface will 
move parallel to the plane 

• Coordinates:  Change the location of the surface by designating X, Y, and Z 
distances 

• Axis and Angle:  Rotate the surface about the specified axis by the given angle 

4. Fill in the appropriate data for the chosen method. 

5. Click OK to apply the change. 
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6.4.3    Thickening Reference Surfaces 

Once a reference surface has been inserted, you can thicken the surface to transform it into a solid.  
This will allow geometry such as holes and extruded cuts to be applied to the resulting solid.  Only 
one surface can be thickened at a time. 

 To thicken a surface: 

1. From the Feature menu, select Thicken Surface; or select the Thicken Surface tool   
from the Part Modeling toolbar.  The Thicken Surface dialog appears. 

 

2. In Surface, select the surface you wish to thicken. 

3. In Thickness, enter the desired thickness value. 

4. In Direction, choose forward, reverse, or both sides.  Arrows in the workspace will display the 
direction the thickness will be applied. 

5. Click OK to apply the Thicken feature. 

 
 

6.4.4    Trimming a Solid 

You can trim a solid model with respect to a surface.  
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 To trim a model: 

1. From the Feature menu, select Trim Model; or select the Trim Model tool    from the Part 
Modeling toolbar.  The Trim Model dialog appears. 

 

2. Select the Surface you wish to use to trim the model.  Arrows in the workspace will show the 
direction the surface will trim.  Check the Reverse box if necessary. 

3. Click OK to apply the Trim Model feature.  All features contained in the model will be trimmed. 

 
 

6.4.5    Extruding to Geometry 

You can use a reference surface in the “To Geometry” option of an extrusion or sweep.  See Feature 
Creation (on page 155) for information on extruding “To Geometry”.  

The sketch you are extruding must lie completely within the outline of the surface or the extrusion 
will fail. 

 
 

6.5    Reference Geometry Visibility 

You can hide reference geometry on an individual basis, by group, or altogether. 
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6.5.1    Hiding Individual Reference Geometry Items 

 To hide reference geometry items: 

1. Select the reference geometry item in the Design Explorer or work area.  You can also select 
multiple items.  The selected items become highlighted in the Design Explorer as well as the 
work area. 

2. Right-click in the work area and select Hide from the pop-up menu; or press Ctrl + H on the 
keyboard; or from the Edit menu select Hide Selection. 

The selected reference geometry items are hidden.  The text in the Design Explorer associated with 
the items will also become light gray. 

 
 

6.5.2    Hiding Reference Geometry by Groups 

You can hide groups of planes, axes, points, surfaces, the 3D view indicator, or the world coordinate 
system independently. 

From the View menu, select References > Coordinate System, References > 3D View Indicator, 
References > Planes, or References > Axes, or References > Points, or References > Surfaces, 
or , depending on which group you want to hide.  The group becomes hidden, and the text in the 
Design Explorer associated with the items will also become light gray.   

You can also press Ctrl + Shift + P on the keyboard to hide planes.  

Note:  Upon hiding planes as a group, all planes are hidden except for the plane that is currently 
selected.  To hide all the planes at once including the selected plane, select the Planes node in the 
Design Explorer, right-click in the work area and select Hide from the pop-up menu. 

 
 

6.5.3    Hiding All Reference Geometry Groups 

You can hide all reference geometry groups at one time. 

 To hide all reference geometry groups: 

From the View menu, select References > All.  All reference geometry groups become hidden 
except the plane that is currently selected.  The text in the Design Explorer associated with the items 
will also become light gray.  
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6.6    Renaming Reference Geometry 

New reference geometry items are by default sequentially named beginning with 4, e.g. Plane <4>, 
Axis <4>, Point <4>, etc.  You can rename default reference geometry as well as inserted reference 
geometry items. 

 To rename reference geometry items: 

1. Right-click the reference geometry item in the Design Explorer and select Rename from the 
pop-up menu.  Or, click the reference geometry in the Design Explorer twice with a short pause 
between clicks.  The name is highlighted and the cursor appears next to the name. 

2. Type a new name. 

3. Press Enter on the keyboard. 
 

6.7    Deleting Reference Geometry 

You can delete inserted reference geometry items.  You cannot delete default reference geometry. 

 To delete an inserted reference geometry item: 

Right-click the reference geometry item in the Design Explorer and select Delete from the pop-up 
menu; or select the reference geometry item in the Design Explorer or work area and press Delete 
on the keyboard. 

 

6.8    Editing Reference Geometry Properties 

You can modify the properties associated with an inserted reference geometry item. 

 To edit an inserted reference geometry item: 

1. Right-click the reference geometry item in the Design Explorer and select Edit from the pop-up 
menu; or right-click the reference geometry item in the work area and select Edit from the pop-
up menu.  The dialog associated with the item appears displaying the original properties. 

2. Modify the properties as necessary. 

3. Click OK to apply the change. 
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C H A P T E R  7  

 Feature Creation 
Parts are modeled by creating features.  Features are individual 3D shapes representing common 
mechanical design elements, like bosses and holes, which either create material or remove material 
in a part.  Many features, such as extrude boss and revolve boss, require an associated sketch to 
define the 2D profile of the 3D shape.  Other features, such as fillet and edge chamfer, can be 
created without a sketch and are applied to existing edges and faces. 
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7.1    The Part Modeling Interface 

The Part Modeling toolbar is shown by default on the right side of the workspace.  Commonly used 
modeling tools are accessible on the Part Modeling toolbar. 

 
Extrude Boss ... create an extrude boss feature, which adds material to the model in a 
linear fashion 

 
Extrude Cut ... create an extrude cut feature, which removes material in a linear 
fashion 

 
Revolve Boss ... create a revolve boss feature, which adds material in a circular 
fashion 

 
Revolve Cut ... create a revolve cut feature, which removes material in a circular 
fashion 

 
Loft Boss ... create a loft boss feature, which adds material between 2 or more cross 
sections 

 
Loft Cut ... create a loft cut feature, which removes material between 2 or more cross 
sections 

 
Sweep Boss ... create a sweep boss feature, which adds material as a profile is swept 
along a path 

 
Sweep Cut ... create a sweep cut feature, which removes material as a profile is swept 
along a path 

 
Helical Boss ... create a helical boss feature, which adds material in a helical fashion 

 
Helical Cut ... create a helical cut feature, which removes material in a helical fashion 

 
Fillet (with options fly-out)... create a fillet feature  (fly-out includes Edge Chamfer ... 
create an edge chamfer feature) 

 
Push/Pull Face/Sketch (with options fly-out) ... modify features by dragging faces 
and/or edges of a sketch  (fly-out includes additional Push/Pull tools as well as 
Remove Tool ...modify features by removing faces; and Draft Surface ... add a draft 
to a face on the model) 

 
Hole ... create a hole feature 
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Shell  ... create a shell feature 

 
Linear Feature Pattern (with options fly-out) ... create a pattern of a feature in one or 
two linear directions  (fly-out includes Circular Pattern, as well as Linear and Circular 
Topology Patterns ... create a pattern of a portion of the model) 

 
Feature Mirror ... mirror a feature about an edge or axis 

 
Scale ... scale a part model in any direction 

 
Design Boolean (with options fly-out)... create Boolean feature 

 
Trim Model (with options fly-out)... trim a model with respect to a reference surface  
(fly-out includes Thicken Surface ... thicken a reference surface) 

 
Insert Catalog Feature ... insert a feature that you previously saved  

 
Equation Editor ... open the Equation Editor  

 
Regenerate ... regenerate the part to update changes 

 

The tools that are accessible on the Part Modeling toolbar are accessible from the Feature menu as 
well.  The Feature menu also contains tools that do not have a corresponding toolbar icon. 

 

Thin Wall Boss > Extrude . . . create a thin wall extrude boss feature, which adds material to the 
model in a linear fashion 

Thin Wall Boss > Revolve . . . create a thin wall revolve boss feature,  which adds material in a 
circular fashion 

Thin Wall Boss > Sweep . . . create a thin wall sweep boss feature,  which adds material as a 
profile is swept along a path 

Thin Wall Cut > Extrude . . . create a thin wall extrude cut feature, which removes material in a 
linear fashion 

Thin Wall Cut > Revolve . . . create a thin wall revolve cut feature,  which removes material in a 
circular fashion 
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Thin Wall Cut > Sweep . . . create a thin wall sweep cut feature,  which removes material as a 
profile is swept along a path 

Chamfer > Vertex . . . create a vertex chamfer feature 

Offset Face . . . offset a face by a specified distance  

Move Face . . . move a face by a specified distance  

Save Catalog Feature ...  save a feature for use in other models 

 
 

7.2    Feature Terminology 

7.2.1    Feature Types 

Boss 

Boss features are used to create or add material in a part.  Generally, the first feature you create in a 
part will be a boss feature.   

Cut 

Cut features are used to remove material from a part.  You cannot create a successful cut feature 
until at least one boss feature has been created.  

Note:  Most 3D features will be created from a sketch.  You can only use an individual sketch to 
create one feature.  Once a sketch is used to create a feature, it will appear under that feature in the 
Design Explorer.  You can not use it again, unless you delete the 3D feature that is using it.  In the 
figure below, Sketch<1> is used by Revolution<1>, Sketch<2> is used by Extrusion<2>, and 
Sketch<8> is unused.  Therefore, only Sketch<8> is currently available for use in a new feature.   
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7.3    Extrude Boss and Extrude Cut 

Although the extrude boss and extrude cut features are different in end result, the steps used to 
create them are identical. 

Extrude features, also referred to as extrusions, either create or remove material by extending a 
sketch in a linear direction by a specified distance.  

 
 

7.3.1    Creating Extrude Boss and Extrude Cut Features 

Extrude features require a closed sketch (see "Open and Closed Sketches" on page 110). 

 To create an extrude boss or extrude cut: 

1. Select the Extrude Boss  tool or the Extrude Cut  tool from the Part Modeling 
toolbar; or from the Feature menu, select Boss > Extrude or Cut > Extrude.  The Extrude 
Boss or the Extrude Cut dialog appears. 

 

2. Click in the Sketch field to activate it, then select the sketch you want to extrude. 

3. Select a Type from the pull down menu.  Follow the steps below depending on the Type. 
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 To Depth, Mid Plane, Through All extrusions 

To Depth - Creates an extrusion of a specified depth on one side of the sketch plane. 

Mid Plane - Creates an extrusion of a specified depth on both sides of the sketch plane.  
Half the extrusion length is proportional to each side of the sketch plane. 

Through All - Applies only to extrude cut.  Creates the cut through the entire solid in the 
specified direction. 

a. Specify the extrusion Depth value.  If using To Depth, you can select the Reverse option 

if necessary to create the extrusion on the opposite side of the sketch plane. 

b. Note:  When using the To Depth or Mid Plane options, you can dynamically resize the 

extrusion in the work area by dragging the node associated with the sketch profile.  As you 

drag the node, the extrusion length will automatically increase or decrease increments 

based on the Spinner Increment value (File > Properties  > Units tab). 

  

c. To create the extrusion in a different direction other than normal to the sketch plane, 

unselect the Along Normal option.  Then select a linear edge or axis to define the 

extrusion direction. 

d. Specify a Draft Angle if required and click the Outward option to change the direction of 

the draft if necessary. 

e. You can enter a custom Label if you would like to customize the feature name as it is 

displayed in the Design Explorer. 

f. Click OK to create the extrusion. 
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Figure 31: Extruded boss result 

        

 To Geometry extrusions 

To Geometry - Creates an extrusion up to another reference plane or face. 

a. Select a Target by selecting a reference plane, surface, or face.  

b. You can also specify an Offset value to create the extrusion up to a specified distance 

from the Target. 

c. To create the extrusion in a different direction other than normal to the sketch plane, 

unselect the Along Normal option.  Then select a linear edge or axis to define the new 

extrusion direction. 

d. Specify a Draft Angle if required and click the Outward option to change the direction of 

the draft if necessary. 

e. You can enter a custom Label if you would like to customize the feature name as it is 

displayed in the Design Explorer. 

f. Click OK to create the extrusion. 

 

 To Next extrusions 

To Next - Creates an extrusion up to the nearest face(s) of the part.  For a To Next 
Extrusion to be successful, the sketch must lie within the boundaries of the Next Face.  If it 
is not, an error message will be displayed and the feature will fail.  
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Figure 32: Part of sketch lies outside boundaries of Next 

Face - extrusion will fail. 

 
Figure 33: Sketch lies inside boundaries of Next Face - 
extrusion will succeed 

a. Select the Reverse option if necessary to create the extrusion on the opposite side of the 

sketch plane. 

b. To create the extrusion in a different direction other than normal to the sketch plane, 

unselect the Along Normal option.  Then select a linear edge or axis to define the new 

extrusion direction. 

c. Specify a Draft Angle if required and click the Outward option to change the direction of 

the draft if necessary. 

d. You can enter a custom Label if you would like to customize the feature name as it is 

displayed in the Design Explorer. 

e. Click OK to create the extrusion. 

 
 

7.3.2    Creating Thin Wall Extrude Boss And Cut Features 

Thin wall extrude features either create thin walled bosses or cuts by extending a sketch in a linear 
direction by a specified distance.  As opposed to normal extrude boss and cut features discussed 
previously, thin wall extrusions can be created with open or closed sketches (see "Open and Closed 
Sketches" on page 110). 
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 To create a thin wall extrude boss or cut:  

1. From the Feature menu, select Thin Wall Boss > Extrude or Thin Wall Cut > Extrude.  The 
Extrude Thin Boss or the Extrude Thin Cut dialog appears. 

 

2. If the Sketch field is not already populated with the correct sketch, click in the Sketch field to 
activate it, then select the sketch you wish to use to create the feature.  

3. Select a Type.  (Refer to Creating Extrude Boss and Cut (see "Creating Extrude Boss and 
Extrude Cut Features" on page 159) for information related to the Type condition.) 

4. Specify a Length/Depth value or select a Target. 
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5. Select a Gap Type: 

 
Figure 34: Original Sketch Example 

Natural:  Extends the edges of the wall along their natural curves until they intersect. 

 
Figure 35: Result Using Natural Gap Type 

Round:  Creates fillets on any corners of the wall profile. 

 
Figure 36: Result Using Round Gap Type 
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Extend: Extends the edges of the wall beyond their endpoints in straight lines until they 
intersect. 

 
Figure 37: Result Using Extend Gap Type 

6. Specify an extrusion direction.  Select the Along Normal option to create the extrusion normal 
to the sketch plane.  Unselect the Along Normal option and select an edge or axis to create 
the extrusion in a direction other than normal to the sketch plane. 

7. To taper the extrusion, specify a Draft Angle.  To change the draft orientation, select the 
Outward option. 

8. Specify the Wall Thickness by entering values for the Side 1 and Side 2 wall thicknesses.  
Specifying a Side 1 value will create or remove material inward from the sketch, and a Side 2 
value will create or remove material outward from the sketch. 

9. Click OK to create the thin wall extrusion. 

 

  

 
Figure 38: Resulting thin wall boss extrusion 
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7.4    Revolve Boss and Revolve Cut 

Although the revolve boss and revolve cut features are different in end result, the steps used to 
create them are identical.  

Revolve features, also referred to as revolutions, either create or remove material by revolving a 
sketch by a specified angle around a centerline. 

  
 

7.4.1    Revolve Boss and Revolve Cut Features 

Revolve boss and cut features require a closed sketch (see "Open and Closed Sketches" on page 
110). 

 To create a revolve boss or cut: 

1. Select the Revolve Boss  or the Revolve Cut  tool from the Part Modeling toolbar; 
or from the Feature menu, select Boss > Revolve or Cut > Revolve.  The Revolve Boss or 
the Revolve Cut dialog appears. 

  

2. If the Sketch to revolve field is not populated with the sketch you want to revolve, click in it to 
activate it, then select the sketch you want to revolve. 

3. Select an edge, axis, or sketch line as the Axis centerline. 

4. Specify the rotation Angle. 

5. You can enter a custom Label to modify how the feature name is displayed in the Design 
Explorer. 

6. Click OK to create the revolution. 
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Figure 39: Resulting revolve boss feature 

  
 

7.4.2    Thin Wall Revolve Boss and Cut Features 

Thin wall revolve features either create or remove a thin wall of material by revolving an open or 
closed sketch around a centerline. 

 To create a thin wall revolve boss or cut: 

1. With a sketch still active, from the Feature menu, select Thin Wall Boss > Revolve or Thin 
Wall Cut > Revolve.  The Revolve Thin Boss or the Revolve Thin Cut dialog appears. 
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2. Specify the rotation Angle. 

3. Select an edge, axis, or sketch line as the Axis centerline. 

4. Choose a Gap Type: 

Natural:  Extends the edges of the wall along their natural curves until they intersect. 

Round:  Creates fillets on any corners of the wall profile. 

Extend: Extends the edges of the wall beyond their endpoints in straight lines until they 
intersect. 

5. Specify the Wall Thickness.  Side 1 creates or removes material on the inward side of the 
sketch; Side 2 creates or removes material on the outward side of the sketch. 

6. Click OK to create the thin wall revolution. 

  

 
Figure 40: Resulting revolved thin wall boss 

 
 

7.5    Loft Boss and Loft Cut 

Although the loft boss and loft cut features are different in end result, the steps used to create them 
are identical. 

Loft features, simply referred to as lofts, either create or remove material by forming a feature that 
transitions from one cross section (such as a sketch or existing face) to another along a path.  The 
two sketches reside on different planes, but do not have to be parallel to each other.   
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You can use two or more sketches or existing faces to create lofts. 

 To create a loft boss or cut: 

1. Sketch at least two profiles on two different planes.  The sketches must be closed.  The planes 
do not have to be parallel.  You may loft to a point by creating a sketch with exactly one node in 
it. 

2. Select the Loft Boss  tool or Loft Cut  tool from the Part Modeling toolbar; or from 
the Feature menu, select Boss > Loft or Cut > Loft.  The Loft Boss or the Loft Cut dialog 
appears. 

 

3. In the work area, select the sketches or faces to use in the loft.  If you select inside the design 
explorer, you must press Shift to select multiple sketches or faces. As you make the selections, 
the corresponding labels appear in the Cross Sections box. 

The sketches/faces must be listed in the order in which the loft will be created. To remove a 
sketch or face from the box, select it from the list and press Delete on the keyboard. 

4. If desired, check the Specify Tangent box next to a sketch or face. When “Specify Tangent” is 
selected, local control of surface directions in the vicinity of the lofted sketches/faces is 
possible. If “Tangency Angle” is 0 ˚, surface normals remain perpendicular to the sketch plane 
normal, or parallel to the adjoining face normals. 

5. If Specify Tangent is checked, Tangent Angles can be specified for sketches (but not faces). 
Specify the desired angle in the Tangent Angle field. In this case, the lofted surface tangent 
would be at the angle specified with the sketch plane normal. 
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6. If Specify Tangent is checked, additional control is obtained using the Tangent Magnitude for 
each Cross Section. Tangent Magnitudes control the rate at which surfaces diverge from the 
cross section sketch planes or faces. As Tangent Magnitudes increase, surfaces diverge more 
slowly from surface tangents at the sketch cross sections. Specify the desired value in the 
Tangent Magnitude field.  A value of 0 is equivalent to not using “Specify Tangent”.  

7. If desired, guide curves can be specified to constrain the location or direction of the lofted 
surface that is generated. To specify guide curves, check the Guide Curves checkbox, and 
select the sketches in the work area. 2D and 3D sketches may be used (but you can not use 
guide curves if you are using a face as one of your cross sections). 

Tip:  When you are active in 3D sketch mode, you can constrain sketch figures to other existing 
sketches.  This is particularly helpful when you are sketching guide curves for lofts, to ensure 
that your guide curves touch each profile used in the loft. 

Guide curves are each exactly one open or closed loop, each touching all the profiles. 
Multiple guide curves can be used for Global and Local types, however, for the Tangent 
type, only one guide curve should be specified.  As each curve is selected, the 
corresponding labels appear in the Guide Curves list box. To remove a guide curve from 
the box, select it from the list and press delete key on the keyboard, or choose an option 
from the right-click menu. 

Guide curve types: 

Global: Creates “virtual” guide curves, providing the ability to make one guide curve 
globally affect the lofted surfaces. 

Local:  These guide curves provide the ability to make one guide curve locally affect the 
lofted surfaces. 

Tangent: Forces the loft surface to follow the tangent vector of the guide cure at the point 
where the curve intersects the profile's plane. 

8. If necessary, select a loft creation option: 

• Simplify Surface:  Converts the resultant loft face from a spline type to an analytic 
type when possible.  A simplified surface contains less data, is of higher quality, and 
is faster to process in subsequent modeling operations.    

• Minimize twist:  Aligns the profiles so that the start of the second sketch is aligned 
to the start of the first sketch. 

• Connect ends:  The first cross-section is treated as if it is also the last cross-
section.  This is not available when using guide curves, as the guide curves can be 
used to connect the first and last cross sections.  You must have at least three cross-
sections to use this option. 

• Minimize Curvature: This determines the Tangent Magnitudes based on 
maximizing the minimum radius of curvature of the lofted body as a whole. This not 
only helps to create more pleasing surfaces but ensures greater ability to shell and 
blend lofted models. This option is applicable only when a single guide curve is 
present and the Guide Curve Type is "tangent". 

9. Click OK to create the loft. 
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Figure 41: Cross sections for loft 

 
Figure 42: Resulting Loft Boss Feature 

 

The following pictures illustrate the results of a loft creating using the same sketches, but 
with different types of guide curves. 

   
Figure 43: Sketches with no guide curve 

  
Figure 44: Sketches with guide curve 
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Figure 45: Loft with no guide curve 

 
Figure 46: Loft with global guide curve 

     
Figure 47: Loft with tangent guide curve 

 
Figure 48: Loft with local guide curve 

             
 

7.6    Sweep Boss and Sweep Cut 

Although the sweep boss and sweep cut features are different in end result, the steps used to create 
them are identical. 

Sweep features, simply referred to as sweeps, either create or remove material by moving a sketch 
along a path defined by a second sketch.   

The following guidelines should be followed when creating swept features: 

• The sketch that defines the profile must be closed (see "Open and Closed Sketches" on 
page 110).  

• The sketch(es) that define the path can be open or closed but cannot be self-intersecting.  
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• The sketch path cannot lie on the same sketch plane as the profile.  

• The sketch path must either start on the profile plane or pass through the profile plane.  

• The sketch path can be multiple 2D or 3D sketches, as well as Edges of Parts or Surfaces. 

• The sketch path must be continuous. 

 
 

7.6.1    Sweep Boss and Sweep Cut Features 

 To create a sweep boss or cut: 

1. Sketch the closed profile. 

2. Sketch the path(s).  The path must either start on or pass through the plane of the profile, but is 
not required to pass through the profile itself.  The path cannot intersect itself. 

3. Select the Sweep Boss  tool or the Sweep Cut  tool from the Part Modeling toolbar; 
or from the Feature menu, select Boss > Sweep or Cut > Sweep.  The Sweep Boss or the 
Sweep Cut dialog appears. 

 

4. In the Sketch to Sweep field, select the profile sketch. 

5. In the Path Objects field, select the path sketch(es).  One or more sketches or edges may be 
selected. 

6. Select a Sweep Type.  You can create the sweep along the Entire Path or To Geometry. 



 Chapter 7 - Feature Creation 

174 

7. If To Geometry was selected, click in the Geometry Target box, and select an existing plane, 
surface, or face in the work area.  You can also specify a Geometry Offset value to create a 
gap between the target and the end of the feature. 

8. If Entire Path was selected, click the Rigid check box if desired to force the profile to remain 
parallel to the profile's sketch plane through the sweep. 

9. To place a draft on the sweep, specify a Draft Angle.  Select the Outward option if necessary.  
You cannot create a draft if the Rigid option is applied. 

10. Click OK to create the sweep.   

 
Figure 49: Sweep Profile and Path Sketches 

 
Figure 50: Resulting Sweep 

 
 

7.6.2    Thin Wall Boss Sweep and Cut Sweep Features 

Thin wall sweep features either create or remove a thin wall of material by moving a closed or open 
sketch along a path defined by a second sketch. 
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 To create a thin wall boss or cut sweep: 

1. Sketch a closed or open profile to define the sweep cross-section. 

2. On a different plane, create a new sketch and sketch the path. 

3. From the Feature menu, select Thin Wall Boss > Sweep or Thin Wall Cut > Sweep.  The 
Sweep Thin Boss or the Sweep Thin Cut dialog appears. 

 

4. Select the Sketch to Sweep and the Path Objects (the sketch or sketches you wish to use as 
the path). 

5. Select a Sweep Type.  You can create the sweep along the Entire Path or To Geometry. 

6. If To Geometry was selected, click in the Geometry Target box, and select an existing plane, 
surface, or face in the work area.  You can also specify a Geometry Offset value to create a 
gap between the target and the end of the feature. 

7. If Entire Path was selected, click the Rigid check box if desired to force the profile to remain 
parallel to the profile's sketch plane through the sweep. 

8. Select a Gap Type: 
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Natural:  Extends the edges of the sweep wall along their natural curves until they 
intersect. 

Round:  Creates fillets on any corners of the wall profile. 

Extend: Extends the edges of the wall beyond their endpoints in straight lines until they 
intersect. 

9. Specify the Wall Thickness.  Side 1 creates or removes material on the inward side of the 
sketch, Side 2 creates or removes material on the outward side of the sketch. 

10. To taper the extrusion, specify a Draft Angle.  To change the draft orientation, select the 
Outward option. 

11. Click OK to create the thin wall sweep. 

 
Figure 51: Thin Wall Boss Sweep Profile and Path Sketches 

 
Figure 52: Resulting Thin Wall Sweep Boss 
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7.7    Helical Boss and Helical Cut 

Although the helical boss and helical cut features are different in end result, the steps used to create 
them are identical. 

Helical features, often referred to as helixes, either create or remove material by automatically 
sweeping a cross section, represented by a sketch, along a helical path.  The helical path is 
automatically created by the software and is driven by user specified parameters.  Helical features 
are beneficial when modeling springs, internal and external threads, ball screws, worm gears, etc. 

The following guidelines should be followed when creating helical features: 

• The sketch that defines the cross-section of the helix must be closed (see "Open and 
Closed Sketches" on page 110). 

• The sketch that defines the cross-section of the helix must also contain a reference line 
that represents the helical axis. 

 To create a helical boss or cut: 

1. Sketch the cross-section of the helix.  The cross-section is not limited to a certain profile but 
must be a closed sketch. 

2. From the Sketching toolbar, select the Reference Line tool. 

3. Sketch a reference line of any length in the axial direction that the helix will be created in.  This 
reference line will represent the axis of the helix.  

4. If necessary, place a dimension between the reference line and sketch figure(s) created in step 
1. 
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5. Select the Helical Boss  or the Helical Cut  tool from the Part Modeling toolbar; or 
from the Feature menu, select Boss > Helix or Cut > Helix.  The Helical Boss or the Helical 
Cut dialog appears, and the Main tab is initially displayed by default. 

 

6. In the Sketch to Revolve field, select the sketch representing the helical cross-section.  The 
Reference Line as Axis field is automatically populated with the reference line located within 
the sketch.  If more than one reference line exists, you can choose which one you wish to use. 

7. Select the direction of the helix, Clockwise or Counter Clockwise. 

8. If necessary, click the Reverse check box to change the axial direction the helix is created in. 

9. From the Type pull-down menu, select the appropriate helix type: 

• Height and Revolution:  a helix is generated by specifying the overall feature height 
as well as the number of helical revolutions within the specified height. 

• Height and Pitch:  a helix is generated by specifying the overall feature height as 
well as pitch.  The pitch is defined as the distance from one point on the helix to a 
corresponding point on the next revolution measured parallel to the axis. 

• Revolution and Pitch:  a helix is generated by specifying the number of revolutions 
as well the pitch. 
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• Spiral:  a flat helix is generated by specifying the number of revolutions as well as 
pitch. 

10. Specify the appropriate helix parameters (height, pitch, revolutions) depending on which type 
was selected.  Note that if Pitch is specified you can also specify Constant, Variable Ratio, 
and Variable End pitch conditions. 

• Constant: Lets you maintain a constant distance. The "ratio" control is disabled. 

• Variable End: Specifies the pitch at the end of the helix. 

• Variable Ratio: Allows you to change the pitch from start to finish in a ratio such that 
pitch at the end will be: ratio x start pitch. 

11. If applicable, specify a Taper angle to create a tapered helix. 

12. If applicable, click the Advanced tab to specify start and end conditions other than the Natural 
default condition. 

• Natural or Flat Conditions: for each of the two ends of the coil. The ends can have different 
end conditions.  If Flat is chosen, then you will also need to specify the Transition Angle 
and the Flat Angle. 

• Transition Angle: The distance (in degrees) over which the coil achieves the transition 
(normally less than one revolution). The example shows the top with a natural end and the 
bottom end with a one-quarter turn transition (90 degrees) and no flat angle. 

 

• Flat Angle: The distance (in degrees) the coil extends after transition with no pitch (flat). 
Provides transition from the end of the revolved coil to a flattened end. The example shows 
the same coil as the Transition angle shown above, but with a half-turn (180 degree) flat 
angle specified. 

 

13. Specify a Parallel or Normal Profile Orientation condition. 

14. Click OK to create the helical feature. 
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Figure 53: Helical Cut Feature 

  
Figure 54: Helical Boss Feature 

        

           
 

7.8    Fillet 

Fillet features create a rounded face on a part.  You can place a fillet on individual edges, and all 
edges of a face.  You can create a constant radius fillet or a variable radius fillet. 

 
 

7.8.1    Constant Radius Fillets 

Constant radius fillets create a rounded face of constant radius on an edge. 
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 To create a constant radius fillet: 

1. Select the Fillet  tool from the Part Modeling toolbar; or from the Feature menu select 
Fillet; or right-click and select Add Fillet from the pop-up menu.  The Fillet Edges dialog 
appears. 

 

2. Select Constant Radius as the Fillet Type. 

3. Select the edge(s) or face(s) to be rounded.  Selecting a face will subsequently select all the 
edges associated with that face. 

4. Unselect the Tangent Propagate option if necessary.  The Tangent Propagate option creates 
a fillet on the selected edge as well as any other edges that form a path in which a tangent 
condition can be resolved. 

 
Figure 55: Tangent Propagate On   Figure 56: Tangent Propagate Off 

                                  

5. Specify the Radius. 

6. Click OK to create the fillet. 
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7.8.2    Variable Radius Fillets 

Variable radius fillets create a rounded face of variable radius on an edge.  You specify a start radius 
and end radius and a smooth transition is made between the two along the selected edge(s).  

 To create a variable radius fillet: 

1. Select the Fillet  tool from the Part Modeling toolbar; or from the Feature menu select 
Fillet; or right-click and select Add Fillet from the pop-up menu.  The Fillet Edges dialog 
appears. 

2. Select Variable Radius as the Fillet Type. 

   

3. Select the edge(s) or face(s) to be rounded.  Selecting a face will subsequently select all the 
edges associated with that face. 

4. Unselect the Tangent Propagate option if necessary.  The Tangent Propagate option creates 
a fillet on the selected edge as well as any other edges that form a path in which a tangent 
condition can be resolved. 

5. Specify the start Radius in the first radius field. 

6. Specify the end Radius in the second radius field. 

7. Click OK to create the fillet. 
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7.9    Chamfers 

Chamfer features create a beveled face on a selected edge, face, or vertex. 

 
 

7.9.1    Edge Chamfers 

 To create an edge chamfer: 

1. Select the Chamfer  tool from the Part Modeling toolbar; or from the Feature menu, select 
Chamfer > Edge; or right-click and select Add Edge Chamfer from the pop-up menu.  The 
Chamfer Edge dialog appears. 

 

2. Select the edges or faces to chamfer. 

3. Select the Chamfer Type from the list: 
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Distance - Distance:  specify two distances, one for either side of the chamfer edge. 

Angle - Distance:  specify a distance and angle for the chamfer. 

Equal Distance: specify an equal distance for either side of the chamfer edge. 

4. Specify the chamfer Distance(s) and/or Angle values accordingly. 

5. Unselect the Tangent Propagate option if necessary.  The Tangent Propagate option creates 
a chamfer on the selected edge as well as any other edges that form a path in which a tangent 
condition can be resolved. 

6. Click OK to create the chamfer. 

 

 
 

7.9.2    Vertex Chamfers 

 To create a vertex chamfer: 

1. From the Feature menu, select Chamfer > Vertex.  The Chamfer Vertex dialog appears. 

  

2. Select the vertex or vertices to chamfer. 
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3. Specify the three Distance values for the three chamfer edges. 

4. Click OK to create the chamfer. 

 

 
 

7.10    Shells 

Shell features hollow out a part, removing the face(s) you select and leaving thin walls on the 
remaining faces.  The shell can be simple (a single, uniform wall thickness) or complex (multiple, 
non-uniform wall thicknesses). 

 To create a shell: 

1. Select the Shell  tool from the Part Modeling toolbar; or from the Feature menu select 
Shell.  The Shell dialog appears. 
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2. Select the Faces to remove.  You can select multiple faces if necessary. 

3. Specify the Standard thickness value, which defines the wall thickness after the part is 
shelled. 

4. If required, you can also select faces to override, in which case you can specify a custom wall 
Thickness.  To do so, click in the Overrides area, and select the face or faces to override in 
the Design Explorer or work area.  You can then set a custom override Thickness for each 
applicable face. 

5. Select the Shell outward option if you want to add external wall thickness. 

6. Click OK to create the shell. 

 

 
 

7.11    Draft Faces 

Draft surface features create a tapered face at a specified angle to another face in the model.  You 
can create drafts as individual features or you can specify drafts while creating other features such 
as extrude bosses. 
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 To create a draft: 

1. Select the Draft Surface  tool from the Part Modeling toolbar; or from the Feature menu 
select Draft; or right-click and select Add Draft from the pop-up menu.  The Draft dialog 
appears. 

 

2. Select the Faces to Draft.  

3. Select the Neutral Plane.  A reference plane or an existing face can be used as the Neutral 
Plane. 

4. Specify the draft Angle. 

5. If necessary, check the Outward option to create the draft in the opposite direction.  

6. Click OK to create the draft.  

 
 

7.12    Holes 

Hole features create standard holes, e.g. counter bored or counter sunk holes, in a part.  You place 
hole features on planes or planar faces and then place dimensions or constraints on the hole center 
to position the hole as required.  In addition, you can add thread information, which can be shown on 
drawings. 
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 To create a hole: 

1. Select the Hole  tool from the Part Modeling toolbar; or from the Feature menu select 
Hole; or right-click and select Add Hole from the pop-up menu.  The Hole dialog appears. 

 

2. Select the Start surface.  A reference plane or planar face can be used as the start surface. 

Note:  You can place multiple holes simultaneously.  With the Hole dialog open, just click again 
on the start surface to place another hole. 

3. Select the hole Type from the list.  A number of standard hole types are available. 

4. In the Specification field, enter the parameters associated with the hole type. 

5. Select a Depth condition from the list: 

Blind: creates the hole to a specified depth. 

To Limit Geometry: creates a hole up to a specified face or plane.  An offset can also be 
specified. 

Through All: creates a hole through the entire part. 

6. Specify the depth parameters depending on which depth condition is being used. 

7. If needed, choose the Thread type as described below. 

8. Click OK to create the hole(s). 
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 To add threads to a hole:  

1. In the Insert Hole dialog, choose the desired thread Series.  Alibre Design supports UNC, 
UNF, UNEF, UNS, Metric Course, Metric Fine, Metric Special, and NPT series threads. 
 
Note:  Alibre Design does not include pre-defined thread definitions for all of these thread 
types, although they are supported.  You can create your own thread definitions by editing the 
Alibre Design thread definition file, alibre_unicode.thd.  You can use Notepad to edit this file.  A 
definition of the file format is embedded within the file.  This file is located in the folder 
C:\Documents and Settings\All Users\Application Data\Alibre Design\System Files. 

2. Choose the Type thread desired. 

3. Specify the Length of the thread.  By default, the thread will extend the entire length of the 
hole. 

4. Choose the Source to specify the diameter to use for modeling the hole.  You may choose 
from the minor, pitch, major, and drill tap diameters. 

5. Click OK to create the hole and define the thread. 

Note:  The thread information is now included with the hole data.  While a graphical 
representation of the threads is not displayed on the model, when the 2D detailed drawing is 
created from the 3D design, the threaded hole information can be automatically be called out 
(see "Displaying Hole Callouts and Threads in Views" on page 423) in the applicable 
orthographic view.   

 
 

7.13    Catalog Features 

Extrude boss and cut features, hole features, sheet metal cut and dimple features, and sketches can 
be cataloged and reused in the same and other designs. 
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7.13.1    Saving Catalog Features 

 To save a catalog feature: 

1. From the Feature menu, select Save Catalog Feature.  The Save Catalog Feature dialog 
appears. 

 

2. Select the feature or sketch to save from the Design Explorer. 

3. Click Save As. The Save As Dialog appears. 

4. Use the Document Browser embedded in the Save As dialog to navigate to the desired 
location in either the repository or file system.  When you click Save, the feature will be saved 
to this location. 

5. In Name, enter a name to give this feature. 

6. Click Save to complete the save. 

Once you have a saved feature or sketch in the repository, you can create several instances of this 
feature in any model by using Insert Catalog Feature. 

 



Chapter 7 - Feature Creation 

 191 
 

 

7.13.2    Inserting Catalog Features 

 To insert a catalog feature after it has been saved: 

1. From the Feature menu, select Insert Catalog Feature. The Insert Catalog Feature dialog 
appears.  

 

2. Type in the saved name of the feature or sketch you want to use, or click the '…' button to bring 
up the 'Insert Design' dialog. 

3. In the Insert Design dialog, select the feature or sketch to use and click OK. 

4. In Placement, select the 'Base Plane' field in the dialog. Select the face that you want to insert 
the feature or sketch on. 

5. In Alignment Reference, select a linear edge to orient the catalog feature.  How this feature is 
placed will depend on how it was created.  When exported, the alignment reference is the 
bottom of the window of the sketch.  Therefore, the "bottom" of the feature as it was originally 
sketched will be aligned with the edge selected here. 

6. Enter a value for rotation if you need to rotate the imported operation. You can also use the 
'Rotate' and 'Move' handles in the work area to locate the feature - two dots appear on the 
preview.  Move your cursor over them to get the move or rotate arrows.  When you get the 
arrows, click and hold to drag the feature around 

7. Click Apply and Close.  You will see in the new feature or sketch in the Feature Tree.  The 
new operation and the sketch created by the catalog feature is a first class operation that can 
be edited/deleted. 
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7.14    Copying Existing Features 

After features have been created, they can be mirrored or patterned to easily create copies. 

 
 

7.14.1    Mirroring Features 

Mirroring a feature creates a copy of the feature mirrored about a reference plane or planar face.  If 
the original feature changes, the mirrored copy will automatically change as well. 

 To mirror a feature: 

1. From the Feature menu select Mirror; or, select the Feature Mirror tool  from the Part 
Modeling toolbar.  The Feature Mirror dialog appears. 

 

2. Select the Features to mirror from the work area or the Design Explorer. 

3. Select the Mirror plane.  You can use a reference plane or planar face. 

4. Check the Mirror Geometry box if you want to mirror the geometry exactly.  You will normally 
be concerned with this option when you are mirroring a feature that has been created using 
references to existing geometry such as “extrude to geometry”. Below are two models.  The 
first shows a mirror created with the Mirror Geometry box unchecked, and the second with the 
box checked. 
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Figure 57: Feature Mirror Dialog Showing Mirror Geometry 
Unchecked 

 
Figure 58: Example of Feature Mirrorred Without 
Mirror Geometry Option 

 
Figure 59: Feature Mirror Dialog Showing Mirror Geometry Checked 

 
Figure 60: Example of Feature Mirrorred Using 
Mirror Geometry Option 

 

5. Click OK to create the mirror. 

 
 

7.14.2    Feature Patterns 

Feature patterns create copies of a feature by repeating it in a linear or circular array. 

Linear Patterns 
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You can use a linear pattern to repeat a feature in one or two linear directions. 

 To create a linear pattern: 

1. From the Feature menu, select Feature Pattern > Linear; or, select the Linear Feature 

Pattern tool  from the Part Modeling Toolbar.  The Linear Pattern dialog appears. 

  

2. Select the features to be patterned. 

3. Check the Pattern Geometry box if you want to pattern the geometry exactly.  You will 
normally be concerned with this option when you are patterning a feature that has been created 
using references to existing geometry such as “extrude to geometry”.  Below are two models.  
The first shows a pattern created with the Pattern Geometry box unchecked, and the second 
with the box checked.  The cylinder was sketched on the ZX Plane, and extruded to the sloped 
face.  

  

 
Figure 61: Example of Feature Patterned Without Pattern 
Geometry Option 
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Figure 62: Example of Feature Patterned Using Pattern 
Geometry Option 

 

4. Select Linear path for the First Direction.  An axis or linear edge can be used for the path. 

5. Specify the number of Copies including the original feature. 

6. Specify the Spacing between each copy. 

7. Click the Change direction option to create the pattern in the opposite direction on the path. 

8. If required, repeat steps 4-7 to create the pattern in a second direction as well. 

9. Click OK to create the pattern. 

 

Circular Patterns 

You can use a circular pattern to repeat a feature in a radial direction around a centerline. 
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 To create a circular pattern: 

1. From the Feature menu, select Feature Pattern > Circular; or, select the Circular Feature 

Pattern tool  from the Feature Patterns fly-out on the Part Modeling toolbar.  The Circular 
Feature Pattern dialog appears. 

 

2. Select the features to be patterned. 

3. Check the Pattern Geometry box if you want to pattern the geometry exactly.  See the 
previous section on Linear Patterns for more information on Pattern Geometry. 

4. Select the Circular path center.  An axis or linear edge can be used as the center. 

5. Specify the number of Copies including the original feature. 

6. Specify the Angle in degrees to control the spacing between the copied features. 

7. If necessary, select Change direction to create the pattern in the opposite radial direction. 

8. Click OK to create the pattern. 

 
 

7.14.3    Topology Patterns 

Topology patterns are similar to Feature Patterns, except that you do not have to have a feature to 
use them.  Topology Patterns can be used to make copies of existing geometry, such as faces and 
edges. They are particularly useful when you are working with an imported model that does not have 
a feature history. 
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Note:  You can pattern entire features using the Topology Pattern functionality, but it is better design 
practice to use Feature Patterns for that purpose. Also, it is important to remember that the entire 
created pattern must be on the same face as the original geometry, or an invalid body will result.  

 

Topology Patterns vs. Feature Patterns 

Feature Patterns and Topology Patterns will often provide similar results.  However, the inputs for 
each type of pattern are different, as are the outcomes they can provide.  Feature Patterns are used 
to pattern complete features, which means there must be a feature history in the Design Explorer.  
Models that are imported into Alibre Design do not have a feature history.  Topology Patterns can be 
used to pattern actual geometry and do not require a feature, so they can be used on imported parts 
more easily.   

Most of the time, you will use Feature Patterns.  If you find that you can not accomplish your design 
goals with a Feature Pattern, try using a Topology Pattern.  

Pattern Inputs 

• Feature Patterns require you to tell Alibre Design which features you want to pattern.  You 
must pattern complete features.   

• Topology Patterns require you to tell Alibre Design which faces you want to pattern.  You 
can pattern any set of faces - either a set that would make a complete feature, or a set that 
represents only part of a feature.   

Pattern Outcomes 

• Feature Patterns will result in a pattern of complete features.  

• Topology Patterns will result in a pattern of sets of faces.  These may represent a complete 
feature but may not.  You should use a Feature Pattern if your design intent is to pattern 
the complete feature.  

The following segments for creating Linear Topology Patterns and Circular Topology Patterns will 
demonstrate using this functionality to pattern a portion of existing geometry on this part that was 
imported into Alibre Design as a .sat file. 
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Linear Patterns 

 To create a linear topology pattern: 

1. From the Feature menu, select Topology Pattern > Linear; or, select the Linear Topology 

Pattern tool  from the Part Modeling Toolbar (available in the Feature Pattern fly-out).  The 
Linear Topology Pattern dialog appears. 
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2. Select the Seed Face.  Using the Seed Face, Alibre Design will infer a group of related faces 
(adjacent to each other) that will be included in the pattern.  Selecting a different face as the 
Seed Face may or may not change the group of inferred related faces, depending on your 
model.  The inferred faces will be highlighted in the work area, and the number of selected 
faces will be displayed in the dialog next to the Seed Face.   

 
Figure 63: Model With Seed Face Selected 

3. Complete all of the requirements for the First Direction.  In Linear Path, select an edge or axis 
to determine the direction for the pattern creation.  A preview will be displayed in the work area.  

 
Figure 64: Linear Topology Pattern Preview 
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4. Check the Change Direction box to reverse the direction if necessary.      

5. Enter the desired Spacing between each copy.  

The resulting pattern can not overlap itself.  Setting the spacing too low can make the bodies 
overlap, resulting in an invalid body.  

6. Enter the number of Copies, including the original.   

7. If you would like to create the pattern in two directions, fill in the information for the Second 
Direction section as well.  

8. Check the Check Results box to have Alibre Design detect whether or not the resulting bodies 
from the pattern are valid.   It is good design practice to leave this box checked on.  If this box 
is unchecked, you may inadvertently create a pattern that appears to be valid, but in reality is 
not.   

If you do not use the Check Results option, you should go to the Tools menu and select Check 
Part after creating the pattern to verify that your model is a valid body.  

9. In Label, change the name of the pattern if desired.  

10.  Click OK to create the pattern.  

 
Figure 65: Linear Topology Pattern Completed 
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Circular Patterns 

 To create a circular pattern: 

1. From the Feature menu, select Topology Pattern > Circular; or, select the Circular 

Topology Pattern tool  from the Part Modeling Toolbar (available in the Feature Pattern 
fly-out).  The Circular Topology Pattern dialog appears. 

 

2. Select the Seed Face.  Using the Seed Face, Alibre Design will infer a group of related faces 
(adjacent to each other) that will be included in the pattern.  Selecting a different face as the 
Seed Face may or may not change the group of inferred related faces, depending on your 
model.  The inferred faces will be highlighted in the work area, and the number of selected 
faces will be displayed in the dialog next to the Seed Face.   

 
Figure 66: Circular Topology Pattern Model with Seed Face Selected 
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3. In Center, select an edge, axis, point, or cylindrical face for the axis the pattern will be created 
about.  A preview will be displayed in the work area.  

 
Figure 67: Circular Topology Pattern Preview 

4. Enter the number of Copies, including the original. 

5. Enter the desired Angle between each copy.  

The resulting pattern can not overlap itself.  Setting the Angle too low can make the bodies 
overlap, resulting in an invalid body.  

6. Check the Change Direction box to reverse the direction if necessary.       

7. Check the Check Results box to have Alibre Design detect whether or not the resulting bodies 
from the pattern are valid.   It is good design practice to leave this box checked on.  If this box 
is unchecked, you may inadvertently create a pattern that appears to be valid, but in reality is 
not.   

If you do not use the Check Results option, you should go to the Tools menu and select Check 
Part after creating the pattern to verify that your model is a valid body.  

8. In Label, change the name of the pattern if desired.  
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9.  Click OK to create the pattern.  

 
Figure 68: Circular Topology Pattern Completed 

 

 
 

7.15    Design Boolean Features 

You can use the Design Boolean Features to model parts for special applications such as packaging 
and mold design.  This is accomplished by using a “tool” or “tools” (a collection of other parts or 
assemblies) to modify a “blank” (the current part).  The creation of a Design Boolean is done in a 
special workspace called the Design Boolean Editor Environment.  The Boolean feature is 
parametrically related to the tool part.  Therefore, if the tool is modified and saved, the Boolean 
feature will update upon reopening.  You can also modify the dedicated assembly that contains the 
blank and the tool. 
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7.15.1    Design Boolean Editor Environment 

Upon selecting a Design Boolean Feature, the Blank part workspace transforms into the Design 
Boolean Editor Environment.  This special workspace exists within a part workspace, but resembles 
an assembly workspace regarding toolbars and options.  Inside the editor environment you will 
create a dedicated assembly that contains the blank part and the tool(s), constrained as required for 
modifying the design.   The editor environment workspace is shown below. 

 

There are two ways to exit the editor environment.  You can commit or discard the Boolean feature.    
Once you choose one of those options, the workspace is transformed back into the blank part 
workspace.  From the Edit menu, select Commit or Discard, or click the appropriate icon: 

 

 

Commit 

Discard 
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7.15.2    Creating Design Boolean Features 

Although the Boolean Unite, Subtract, and Intersect features are different in end result, the steps 
used to create them are identical.   The operations are the same as in set theory:  

• Boolean Unite  will add tool material to the blank part material.   

• Boolean Subtract  will remove tool material from the blank part material.    

• Boolean Intersect  will show the overlap of the tool material and the blank part 
material.    

Before you begin: 

You will need to have a part that you wish to modify.  This will be your “blank”.  In addition, you will 
need to have an existing part or assembly to use as a “tool”.  The tool must be saved to the 
repository or file system. 

 To create a Boolean design feature: 

1. Open the blank part. 

2. From the Feature menu, select Feature > Boolean > Subtract (or Unite, or Intersect).  The 
Insert Part/Subassembly dialog appears.  

OR 

Select the appropriate tool from the Design Boolean Feature fly-out on the Part Modeling 

toolbar.      

3. Highlight the part or assembly you wish to use for the tool; then click OK.  The part workspace 
window transforms into the Design Boolean Editor window.  Click in the Editor workspace to 
place the tool. Click Finish when you have the number of copies desired. 

NOTE: You can repeat steps 2 and 3 to add as many parts or assemblies as required. 

4. Constrain the tool(s) to the blank using the assembly constraints available in the Boolean editor 
workspace.  

5. Click the Commit icon, or from the Edit menu, select Commit to complete the Boolean feature.  
The window transforms back into the blank part workspace, and the Boolean feature will be 
listed as a feature in the design explorer. 
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NOTE: If a part or assembly in the tool is hidden in the dedicated assembly, it will not 
participate in the Design Boolean feature until it is unhidden. 

 
 

7.15.3    Editing Design Boolean Features 

The Boolean feature is parametrically related to the tool part or assembly.  Therefore, if the tool is 
modified and saved, the Boolean feature will update upon reopening (if you make changes to the 
tool inside the assembly context (see "Editing a Part in an Assembly" on page 352), the changes will 
automatically update without saving and reopening).  You can also modify the dedicated assembly 
that contains the blank and the tool by repositioning parts as well as adding or removing parts.  

 To edit a Boolean design feature: 

1. In the Design Explorer, right-click the Design Boolean feature you wish to modify. 

2. Select Edit.  The Design Boolean Editor Environment workspace appears. 

3. Make the necessary modifications to the dedicated assembly (remembering that hidden parts 
and assemblies will not participate in the Design Boolean feature); then from the File menu, 
select Commit to apply the changes.  The workspace will transform back into the part 
workspace. 

 
 

7.16    Direct Editing 

Direct Editing is the ability to manipulate a model without explicitly editing a feature or a sketch.  
Using the Direct Editing tools, you can move, remove, or resize existing geometry.  Direct Editing 
tools are available in a part workspace, or when you are editing a part in the context of an assembly.   

Direct Editing has several useful applications.  You can use it to modify models that have been 
imported into Alibre Design, and therefore contain no design history (which means there are no 
features or sketches available to modify).  You can use Direct Editing when you are designing a part 
in Alibre Design - there are instances when this would be easier than editing a feature or sketch 
explicitly.  You can also use Direct Editing for conceptual design.  You can move and resize parts of 
the model until it looks approximately like you want it, which gives you an idea of how the design will 
fit together.  Then you can go back to the sketches and features and add precise dimensions to 
finalize the design.  

Using the Direct Editing tools does not edit or delete any existing feature or sketch in the Design 
Explorer.  It creates a new feature in the tree.  Depending on which tool you use, the new feature 
may be an Offset Face, Move Face, or Remove Face feature.  
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7.16.1    Implications of Using Direct Editing 

Direct Editing tools are not intended to replace feature creation tools, or the editing of features and 
sketches to achieve your desired results. They are intended to supplement the design process by 
enabling you to quickly modify the size of sketches and features on your model.  You should use the 
traditional methods (such as editing a sketch or deleting a feature) for simple design changes.   

Using Direct Editing can leave created dimensions as inaccurate representations of the new model.  
As an example, reference the images below.  If you created an extrusion with a height of 2", you will 
have a model as shown in image A.  You can perform a Push Pull Face operation to the top face 
(image B), and the resulting body will be as shown in image C.  The new height of the extrusion is 
most likely what you are now interested in.  The dimension of 2" is no longer an accurate 
representation of the height of the extrusion.  The new total height is 2" plus the Push Pull Face 
dimension.  

Figure 69: A : Original Extrusion 

 
Figure 70: B:  Performing Push Pull Face 
Operation 

 
Figure 71: C:  Final Model 
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Direct Editing and 2D Drawings 

Because of this, 2D drawings will also be affected when you create drawings of models that have 
included Direct Edit functions.  When you create a 2D drawing, in the Standard View Creation dialog, 
you have the option to include Design Dimensions.  This option captures the dimensions you placed 
in the model and projects them into the drawing view.  If you create a drawing of the block in the 
previous example, you will get a view similar to the one below.  You can see the 2" dimension is 
located at the original height of the block.  The 2" dimension is still the design dimension for that 
feature.  In this case, if you want to represent the new height of the block, you would have to 
manually place a dimension - in this example it is the 3.185" dimension.   

 
Figure 72: Drawing View of Block After Using Direct Editing 

It is important to realize that you will need to manually add dimensions for most of the features that 
you modify using the Direct Editing tools.  However, the Direct Editing tools can speed up the design 
process, particularly on imported models.  The following sections describe each of the Direct Editing 
tools.  

 
 

7.16.2    Push Pull Face/Sketch 

You can use the Push Pull Face/Sketch tool in two ways.  First, you can use it to offset planar faces 
by a distance.  Second, you can use it on a sketch that has not yet been used to create a feature, 
which will create an Extrude Boss feature (based on the selected sketch).   
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 To use the Push Pull Face tool: 

1. Select the Push Pull Face/Sketch tool from the  Direct Editing fly-out on the Part 
Modeling toolbar; or, from the Feature menu, select Direct Edit > Push Pull Face or Sketch.  

2. The Push Pull Face overlay appears.  You may need to maximize your workspace in order to 
view the entire overlay. 

The Push Pull Face overlay has two sections.  If you have the "Show Full Overlay" option 
checked on, you will see both sections displayed.  If you have this option checked off, you will 
see the top section.  You can then display the bottom section by moving your mouse pointer 
over the overlay.  To turn this option on and off, from the Tools menu, select Options.  On the 

Overlays tab, check or uncheck Show Full Overlay.  Or, you can click the Pin button  to 
pin or unpin the bottom section.  

3. Click in the Selection field to activate it.  Left click to select a planar face or an unconsumed 
sketch.   

4. Check the Snap Every option if you would like the value of the Depth to snap at a defined 
increment.  

5. Set the Depth to push or pull the face or sketch to.  You can do this in two ways: 

a. Enter a value in the Depth field and select the Refresh tool  (or press the Tab key) to 

see a preview.   

b. Left click on the "hot spot" shown on the face and drag it until you have it placed 

approximately where you want it.  The Depth field will be populated with the new value.  

 

6. Click Reset to erase the current item from the Selection field and set the Depth value back to 0.  
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7. Check the Auto Apply option on if you want Alibre Design to automatically apply the current 
option when you select a new face to perform an operation on.  (If this option is unchecked, 
selecting a new face will begin a new operation without applying the current one.)   

The Auto Apply function only applies if you select a subsequent face or sketch to perform an 
operation on.  If you use the tool on only one face or sketch, and then click Exit, the operation 
will not automatically be applied.  So you can use Auto Apply when you are making multiple 
changes to multiple faces.   

8. Click Apply to accept the new position.  The model is updated, and a new feature is listed in 
the Design Explorer.  The Push Pull tool remains active. 

9. Left click another face or sketch to perform another Push Pull Face operation, or click Exit to 
leave the Push Pull mode. 

 

Common Errors When Using Push Pull Face 

1. Selecting a face that has fillets on it will cause the operation to fail.  To fix this error, delete the 
fillet, then apply the Push Pull Face operation, and then place the fillet.  In some cases you can 
suppress the fillet, apply the Push Pull operation, and then unsuppress it rather than deleting it. 

2. Selecting a chamfer as the face or selecting any face that has other faces meeting it at angles 
other than 90 degrees can cause unexpected results.  Depending on the results you want, it 
may be more beneficial to create an Extrude Boss feature instead of using Push Pull Face.   

 
 

7.16.3    Push Pull Pocket or Boss 

You can use the Push Pull Pocket or Boss tool to move a Pocket or a Boss by a distance in a linear 
direction.  This tool allows you to do this without editing a feature or a sketch.  It is useful for 
manipulating files that have been imported into Alibre Design and do not have features or sketches 
available to edit.  

A Pocket is an area of the model where material has been removed from the solid body.  This could 
be a Cut feature, but it does not have to be.  The following example contains one large pocket, with 
2 smaller pockets within it, for a total of 3 pockets.   
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A Boss is a solid portion of the model - it can be a feature or a part of a feature. It could be one of 
the Boss features such as Extrude Boss or Sweep Boss, but it does not have to be.  In the following 
example, there are 4 separate Bosses.  You can choose to move any combination of them with a 
Push Pull function.  

 
Figure 73: Model showing example of 4 separate bosses 

 To use the Push Pull Pocket or Boss tool: 

1. Select the Push Pull Pocket or Boss tool from the  Direct Editing fly-out on the Part 
Modeling toolbar; or, from the Feature menu, select Direct Edit > Push Pull Pocket or Boss.  
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2. The Push Pull Pocket or Boss overlay appears.  You may need to maximize your workspace in 
order to view the entire overlay. 

The Push Pull Pocket or Boss overlay has two sections.  If you have the "Show Full Overlay" 
option checked on, you will see both sections displayed.  If you have this option checked off, 
you will see only the top section.  You can then display the bottom section by moving your 
mouse pointer over the overlay.  To turn this option on and off, from the Tools menu, select 
Options.  On the Overlays tab, check or uncheck Show Full Overlay.  Or, you can click the 

Pin button  to pin or unpin the bottom section.  

3. Check the Infer Pockets option on if you want Alibre Design to infer additional faces to include 
based on the selection you make.  Uncheck it if you want to select all of the faces manually. 

4. Click in the Selection field to activate it.  Left click to select a face or combination of faces.  
You can select as many as necessary, but you must select a complete pocket or boss.  For 
example, in the previous image, boss 3 has two faces that must be selected, while boss 2 has 
5 faces that must be selected.   

5. Click in the Direction field to activate it, then select a linear edge, axis, plane, or planar face.   

Choosing an edge or axis allows you to move in one direction, while choosing a plane or planar 
face allows you to move in two directions.   

6. Check the Snap Every option if you would like the value of the Depth to snap at a defined 
increment.  

7. Set the Depth to move the pocket or boss.  You can do this in two ways: 

a. Enter a value in the Depth field and select the Refresh tool  (or press the Tab key) to 

see a preview.   
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b. Left click on the "hot spot" shown on the face and drag it until you have it placed 

approximately where you want it.  The Depth field will be populated with the new value.  

 

8. Click Reset to erase the current item from the Selection field and set the Depth value back to 0.   

9. Click Apply to accept the new position.  The model is updated, and the Push Pull tool remains 
active. 

The Auto Apply option only applies if you are using the Push Pull Face/Sketch tool. 

10. Left click another face or sketch to perform another Push Pull Pocket or Boss operation, or click 
Exit to leave the Push Pull mode. 

 

Common Errors When Using Push Pull Pocket or Boss 

1. Selecting a face that has fillets on it can cause the operation to fail, if all of the affected faces 
are not selected.  Even if you check the Infer Pockets option, some applicable faces may not be 
selected.  To fix this error, visually inspect the area around the highlighted faces to determine if 
any faces have been excluded.  If you find additional faces, select them.  

2. If you move a pocket into free space (off of the solid body) it will disappear.  This is because 
you are essentially moving a hole into empty space, where it can not exist.   
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7.16.4    Push Pull Radius 

You can use the Push Pull Radius tool to offset cylindrical faces by a distance, thereby changing the 
radius.  Using this tool creates an Offset Face feature in the Design Explorer.  This tool is especially 
useful for manipulating imported files that do not have a Design Tree and consequently do not have 
features or sketches for you to edit.   

 To use the Push Pull Radius tool: 

1. Select the Push Pull Radius tool from the  Direct Editing fly-out on the Part Modeling 
toolbar; or, from the Feature menu, select Direct Edit > Push Pull Radius.  

2. The Push Pull Radius overlay appears.  You may need to maximize your workspace in order to 
view the entire overlay. 

The Push Pull Radius overlay has two sections.  If you have the "Show Full Overlay" option 
checked on, you will see both sections displayed.  If you have this option checked off, you will 
see the top section.  You can then display the bottom section by moving your mouse pointer 
over the overlay.  To turn this option on and off, from the Tools menu, select Options.  On the 

Overlays tab, check or uncheck Show Full Overlay.  Or, you can click the Pin button  to 
pin or unpin the bottom section.  

3. Click in the Selection field to activate it.  Left click to select one or more cylindrical faces.   

4. Check the Snap Every option if you would like the value of the Radius Offset to snap at a 
defined increment.  

5. Choose the type of operation you want to apply by selecting Radius Offset or Final Radius from 
the drop down list.  Radius Offset applies the designated offset value to each cylindrical face 
you selected.  Final Radius is only available if you choose only one face, or if all of the faces 
you choose have an equal radius to start with.  This option will change the value of the radius 
(or radii) to the designated value. 

6. Set the new radius for the cylindrical face(s).  You can do this in two ways: 

a. Enter a value in the Final Radius To: or Offset Radius To: field and select the Refresh 

tool  (or press the Tab key) to see a preview.   
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b. Left click on the "hot spot" shown on the face and drag it until you have it placed where 

you want it.  The To: field will be populated with the new value.  

 

7. Click Reset to erase the current item from the Selection field and set the Radius To: value back 
to 0.     

8. Click Apply to accept the new position.  The model is updated, and the Push Pull tool remains 
active. 

The Auto Apply option only applies if you are using the Push Pull Face/Sketch tool. 

9. Left click another face to perform another Push Pull Radius operation, or click Exit to leave the 
Push Pull mode. 

 

Common Errors When Using Push Pull Radius 

1. Some file types import cylindrical items as 2 separate faces, rather than one face.  IGES is a 
common format that this occurs with.  In these cases, you will notice that when you choose the 
cylindrical face, only half of it will highlight.  If you click Apply, only half of the cylinder will 
resize.  To correct this, you simply need to select the other half of the cylinder as well.  

2. Using this tool on items that are not cylinders or cylindrical holes can cause unexpected results.  
Fillets are the most common example of this.  You can use this tool on a fillet, but you may not 
get the result you were expecting.  Below are examples of results you will see.  
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Figure 74: Model showing fillet 
selected for Push Pull Radius 

 
Figure 75: Model showing result of 
increasing radius on a fillet 

 
Figure 76: Model showing result of 
decreasing radius of fillet 

  
 

7.16.5    Remove Faces 

You can use the Remove Faces tool to remove design items from a model such as features, fillets, 
and portions of features.  This operation does not delete any previously created feature or sketch - it 
creates a new Remove Face feature in the Design Explorer. This tool is especially useful for 
manipulating imported files that do not have a Design Tree and consequently do not have features 
or sketches for you to edit.   

 To use the Remove Faces tool: 

1. Select the Remove Faces tool from the  Direct Editing fly-out on the Part Modeling 
toolbar; or, from the Feature menu, select Direct Edit > Remove Faces.  

2. The Remove Faces overlay appears.  You may need to maximize your workspace in order to 
view the entire overlay.  

3. Check the Use inferencing for: option if you want Alibre Design to infer additional faces based 
on the selections you make.  Then select either: 

a. Pocket or Boss - used for most selections except fillets; attempts to identify faces 

comprising a complete pocket or boss 

b. Fillet Chain - attempts to identify a chain of fillets that are tangent to each other and have 

the same radius 

4. Select faces in the model.  You can select as many faces as necessary.  You can change the 
Inferencing options at any time (or uncheck it to turn it off) if necessary. 
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5. Click Reset to erase the current item from the Selection field.     

6. Click Apply to accept the selection.  The model is updated, and the Remove Faces tool 
remains active. 

7. Left click another face to perform another Remove Faces operation, or click Exit to leave the 
tool. 

 

Common Errors When Using Remove Faces 

1. The most common error that will occur with this tool is not selecting everything necessary for 
the operation to succeed.  If you select only a portion of a boss or pocket, you may get the 
error: "REM_NO_SOLUTION: gap cannot be filled".  This typically means that Alibre Design 
does not know how the model should go together when the selected items are removed.  To 
correct this, you need to visually inspect the selected items and determine which faces have 
been excluded.   For example, complex fillets can sometimes leave a small face unselected.  If 
this error occurs, pay close attention to the filleted areas of the model. 

  
 

7.16.6    Tips for Successful Direct Editing 

The best way to be successful with the Direct Editing tools is to practice using them so you will learn 
to identify situations where they will be useful while minimizing potential issues.  These tools can 
help you accomplish many design goals easily, but there are situations where you should avoid 
using them.  

• If you can easily edit the model using traditional methods, you should use them (such as by 
editing sketches or features). 

Direct Editing is not meant to be a replacement for making easy modifications. There are 
some modifications that are difficult or time consuming to make that can be accomplished 
easily with Direct Editing tools. In general, if you can edit a base sketch or feature quickly 
to get your desired result, you should. 

• If you can delete a feature, do not use the Remove Tool. 

Using the Remove tool can be a quick way to remove features or portions of features. It is 
not intended to replace deleting a feature from the Design Explorer when doing that would 
accomplish your goal. For example, if you create a fillet that you later do not want, delete 
the Fillet Feature. Do not use the Remove Tool to remove the fillet. 

In general, these tips do not apply to the modification of imported geometry or conceptual design 
because the same potential issues will not typically arise. 
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7.17    Scaling Parts 

You can increase or decrease the size of a part by using the Scale feature.  Note that sheet metal 
parts cannot be scaled - only non-sheet metal solid parts.  You can also use the Scale feature to 
mirror an entire part. 

 To scale a part: 

1. From the Feature menu, select Scale.  The Scale dialog appears. 

 

 

2. In Scale Type, choose About Origin or About Centroid. 

3. Check Uniform if you want to uniformly scale the part in all 3 directions.  If you want a different 
factor for each direction, leave uniform unchecked and type in the desired values in Scale 
Factor X, Y, and Z boxes.  A scale factor of 1.0 leaves the model unchanged. 

A feature is created in the design explorer when the scale operation is performed. 

When modifying features before the scale operation, the model will roll back to the original 
dimensions. 
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 To mirror a part: 

1. From the Feature menu, select Scale.  The Scale dialog appears. 

 

2. In Scale Type, choose About Origin or About Centroid. 

3. Uncheck the Uniform option.    

4. To mirror the part, the values must be negative.  Enter a negative value in one or two directions 
(you can not enter a negative value in all 3 directions).  To mirror the part without changing the 
scale, enter a value of -1.0. 

A feature is created in the design explorer when the scale operation is performed. 

When modifying features before the scale operation, the model will roll back to the original 
orientation and dimensions. 

 
 

7.18    Managing Features in the Design Explorer 

After creating a feature it will be listed in the Design Explorer under the Features node.  Additional 
features will be listed in the order in which they were created.  This feature order defines the part's 
construction history. 
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By right-clicking a feature in the Design Explorer you can: 

• Edit the features properties 

• Suppress the feature  

• Rename the feature 

• Delete the feature 

• Check the Status of the feature 
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C H A P T E R  8  

 Sheet Metal Feature Creation 
Sheet Metal Part creation is not available in all versions of Alibre Design. Users of versions other 
than Alibre Design Professional and Expert can contact Alibre sales for information on adding Sheet 
Metal to your package.  Like other solid parts, sheet metal parts are modeled by creating features.  
Features are individual 3D shapes representing common mechanical design elements, like tabs and 
cuts, which either create material or remove material in a part.  Some features, such as tab, require 
an associated sketch to define the 2D profile of the 3D shape.  Other features, such as corner round 
and corner chamfer, can be created without a sketch and are applied to existing edges and faces. 
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8.1    The Sheet Metal Part Modeling Interface 

The Sheet Metal Part Modeling toolbar is shown by default on the right side of the workspace.  
Commonly used modeling tools are accessible on the Part Modeling toolbar. 

 
Flat Tab ... create a flat tab feature 

 
Flange ... create a flange feature 

 
Closed Corner ... close a corner between two flanges 

 
Formed Dimple ... create a dimple or drawn cutout 

 
Cut ... create cut feature 

 
Round Corner ... round a corner 

 
Chamfer Corner ... chamfer a corner 

 
Hole ... create a hole feature 

 
Insert Catalog Feature ... insert a saved feature or sketch 

 
Unbend ... unbend one or more flanges 

 
Rebend ... rebend one or more unbent flanges 

 
Flat Pattern ... view the model in a flattened state 

 
Equation Editor ... open the Equation Editor  

 
Generate to Last ... regenerate the part to the last feature to update changes 
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The tools that are accessible on the Sheet Metal Part Modeling toolbar are accessible from the 
Feature menu as well.  The Feature menu also contains tools that do not have a corresponding 
toolbar icon.  

Note: These features are all solid modeling features - using them in a sheet metal part may create a 
model that is incapable of unfolding to a flat pattern.  Use with caution.  Refer to the chapter on 
Feature Creation (on page 155) for information on creating each of these features. 

Features > Boss . . . create extruded, revolved, sweep, or loft boss features 

Features > Cut . . . create extruded, revolved, sweep, or loft cut features 

Features > Thin Wall Boss  . . . create a thin wall extruded, revolved, or sweep boss feature 

Features > Thin Wall Cut  . . . create a thin wall extruded, revolved, or sweep cut feature 

Features > Fillet . . . create a fillet feature 

Features > Draft . . . create a draft feature 

Mirror . . . mirror a feature about an edge or axis 

Pattern > Linear . . . create copies of a feature in a linear pattern 

Pattern > Circular . . . create copies of a feature in a circular pattern 

Save Catalog Feature ...  save a feature to the repository for use in other models 

 
 

8.2    Sheet Metal Part Parameters 

Sheet metal parts have parameters that govern the way the part can be designed.  The parameters 
are used as defaults in many sheet metal features.  This allows a flat pattern to be resolved. 

1. From the File Menu, select Properties.  The Design Properties dialog appears. 
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2. Click the Parameters Tab. 

 

 Set your sheet metal material parameters of: 

• Stock Thickness - The thickness of the sheet of metal used to manufacture the part. 

• Minimum Bend Radius - The minimum Bend Radius to be allowed in the model.  If you 
attempt to enter a radius smaller, it will automatically go to this minimum.  Default Value = 
thickness / 2. 

• Global Bend Radius - The default bend radius used in all instances unless otherwise 
specified during feature creation.  Default Value = thickness / 2. 

• K-Factor - During a forming process, "elongation" of the material occurs - a changing of 
shape due to the radius pushing material into another location.  The "elongation" is called 
the K-Factor, or bend deduction.  K-factors can be determined by using material charts. 

• Global Bend Relief - A small cut made in the material to prevent the bend radius from 
causing a distortion in the metal.  Type can be Rectangular (produces a rectangle shape 
cut) or Round (produces a rectangular cut with a round on the short edge).   

Default values:  

Type - rectangular  

Width - thickness  

Depth - thickness*2 

3. Choose Apply; then Close. 

The parameters set here are accessible in the Equation Editor (see "Using Equations in Dimensions" 
on page 99). 
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8.3    Tab 

A Tab is the first feature created in a sheet metal part, and inserts flat stock based upon a sketch. 
This is the only allowed initial feature. Tab thickness is obtained from the parameters set in the sheet 
metal part parameters.  The name of the thickness parameter is “AD_thickness”.  The 
AD_thickness value corresponds to the stock thickness parameter specified in the Design Properties 
Parameters tab.   

 To create a tab: 

1. Create a sketch and draw the profile you want to extrude. 

2. From the Feature Menu, select Tab. Or, select the Tab tool  from the Sheet Metal 
Modeling Toolbar.  The Tab dialog appears. 

 

3. Select the sketch you want to extrude. 

4. Check Reverse if you want the Tab to project off the other side of the sketch plane from what 
the preview shows. 

5. In Label, enter a unique name for this feature if desired. 

6. Click OK to create the feature. 
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8.4    Flange 

A flange is a section of the sheet metal that is bent from the original flat shape.   You can add a 
flange to any straight layer edge of flat stock material.  The flange places a bend and a rectangular 
(or trapezoidal for taper conditions) tab of flat stock material on the selected edge. 

Please note that Flange features can not be mirrored.  

 To create a flange: 

1. From the Feature menu, select Flange, or select the Flange tool  from the Sheet Metal 
Modeling toolbar.  The Flange dialog appears. 

On the Main Tab: 

2. In Edge, click the edge on the existing tab the flange will be attached to.  

3. In Alignment, choose the inside the tab wall, outside the tab wall, or adjacent to the tab wall 
condition.  Check the Trim Side Bends option if needed. 

The following figures illustrate the difference in each of the alignment options.  The solid 
line represents the sketch plane that the flange is created from, and the angle of the 
sketch plane (represented by the solid line here) is determined by the Bend Angle option 
described in step 7.    

 
Figure 77: Flange Adjacent Alignment 
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Figure 78: Flange Inside Alignment 

 
Figure 79: Flange Outside Alignment 

  

Note:  Trim Side Bends can be checked only when the Bend Alignment Type is INSIDE or 
OUTSIDE.  This option is applicable when the layer edge(s) adjacent to the selected edge have 
flanges.  If this is true, then there will be setback part on the flat stock side, which would 
interfere with the bend on the adjacent edge.  The distance by which the side bend is trimmed 
is equal to the setback of the current flange being made.  If there are bends on both sides of 
the current flange being made then both the bends are trimmed if this option is selected. Note 
that the side bend may be in the opposite direction also. 

4. In Leg, type the length of your flange, and choose if you want the length measured on the 
inside of the curve, the outside of the curve, or from the point where the bend ends.   The 
length will be calculated as illustrated in the figures below.  
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Figure 80: Flange Length Inside Option 

  
Figure 81: Flange Length Ouside Option 

Figure 82: Flange Length Tab Option 

 

   

5. Choose Bend Only if you do not want the flange wall, but just the bend that would be created 
for it.  This option can be used for creating jogs.  

6. Choose Match Taper if you want to specify that the taper of adjacent faces is continued 
through the flange.  

7. In Bend Angle, type in the angle you want your flange with respect to the face you are adding 
it to.  The bend angle is the "excluded" angle of the bend, measured as shown in the following: 

Using a bend angle equal to or greater than 180° will disable inside/outside alignment 
options.  

In Bend Radius, type in the radius for your bend.  This will be the inside radius of the 
bend. The default value here is the global bend radius specified in the parameters.  Check 
Reverse Bend if you want the flange to go the opposite direction from what is showing in 
the preview.  

On the Advanced Tab: 

8. In Bend Relief Type, specify if you want No Bend relief, Rectangular Relief, or Rounded Relief.  
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9. If you choose to have a relief, enter the Width and Depth.  (Default values are taken from the 
parameters set in the properties dialog) 

10. Bend Allowance – Choose Use K factor: use the specified K-Factor to calculate allowance 
for the bend OR choose Use unfold length: set the unfold length used when unfolding this 
bend.  

11. In Label, type in a unique name if desired.  

12. Click OK to create the feature.  

 
 

8.4.1    Sheet Metal Changes for Version 9.1 and Later 

In version 9.1 of Alibre Design, modifications were made to the way flanges are created in sheet 
metal parts.  These modifications ensure that the final dimensions of the sheet metal part are 
correct.  They will affect the dimensions of the part and the dimensions of the flat pattern.  

Your models will be affected in the following way:  

• Flanges that were created in a previous version of Alibre Design will continue to be 
generated using the old method, and the final dimensions of your model will remain the 
same.   

• New flanges created in the model after opening the part in v9.1 or later will follow the 
updated process for creation.  The final dimensions of your model will be correct, but may 
not behave as you expect, based on your past experience with the software. 

It is possible to have flanges in your model that are calculated differently.  This is because you can 
have flanges in your model that were created in a previous version, as well as new flanges created 
in version 9.1 or later.  

 

How model dimensions are calculated 

The tab length and flange length determine the overall dimensions of the final sheet metal part. The 
flange alignment type and length type that are selected during flange creation determines how the 
tab and flange length are measured in the part.  

The new method of calculation will produce different dimension values then the old method when the 
following options are chosen:  

• If the Bend Angle is anything other than 90 deg, and the alignment type is Inside, the length 
of the tab feature will be different.  
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• If the Bend Angle is anything other than 90 deg, and the length type is Inside or Outside, 
the length of the flange will be different.  

 

Updating a model created in a previous version 

You can update a part that was originally created in a previous version so that all flanges in the 
model are calculated using the updated method.   

To do this,  

1. From the File menu, select Properties.   

2. Choose the Parameters tab.  Check the box that says Update all flanges in this part created 
in a version of Alibre Design prior to V9.1.    

3. Click Apply.  You will be notified that the dimensions of the part will be permanently changed.    

Once you have converted a model, it can not be undone. 

  

Here is an example of how the dimensions of the part will change:  

Consider a 1”x 1” tab, on one edge of which we are adding a flange of length 1”. The options chosen 
are: 

Alignment type: Inside 

Length Type: Outside 
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The following figure shows the dimensions of the part before and after these changes have been 
implemented.  The updated method shows the correct dimensions of 1.0" for both the tab length and 
the flange length.  

 

 
 

8.5    Closed Corner 

You can close corners where two bends meet in sheet metal bodies with appropriate extensions and 
square corner bend reliefs. 

 To close a corner: 

1. From the Feature Menu, select Closed Corner.  Or, select the Closed Corner tool  from 
the Sheet Metal Modeling Toolbar.  The closed corner dialog appears. 

2. In Edge, click an edge that is part of the corner you want to close. 

3. In Join, choose the method that you want to use to join the two flanges. 

4. In Label, enter a unique name for this feature if desired. 

5. Click OK. 
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8.6    Dimple 

 To create a dimple: 

1. From the Feature menu, select Dimple.  Or, select the Dimple tool  from the Sheet Metal 
Modeling Toolbar. The dimple dialog appears. 

2. In Sketch, select the sketch you would like to use to create the dimple. 

Note:  Sketches used to create dimples can contain only 1 closed figure. 

3. In Depth, Enter the depth of the dimple from the start face.  The default is 2 times the thickness 
of the stock material. 

4. In Draft Angle, enter the angle if needed.  Only positive angle values are allowed.  If a negative 
angle is entered, the OK button will not activate. 

5. In Sketch Alignment, specify if the tool profile sketch is to be applied to the outside of the 
dimple or the inside, which impacts the offset and draft angles used to create the feature.  

6. Select Cut Out Material if you want to cut out the bottom of the dimple, resulting in a drawn 
cutout operation. 

7. In Include Rounding, you can include automatic fillets for the dimple operation.  Die Radius is 
the user specified radius for external fillets created by the dimple operation.  Punch Radius is 
the user specified radius for internal fillets created by the dimple operation. 

8. In Round Profile Corners, you can optionally round hard corners in the tool profile sketch.  

9. In Label, enter a unique name for the dimple feature if desired. 

10. Click OK. 

 
 

8.7    Cut 

Cutting removes material from a model based on the profile of a sketch.  The cut will be punched 
through a single stock thickness of the sheet metal. 
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 To Create a Cut: 

1. From the Feature menu, select Cut.  Or, select the Cut tool  from the Sheet Metal 
Modeling Toolbar.  The Cut dialog appears. 

2. In Sketch, select the sketch you wish to use for the cut. 

Note:  The sketch used in a cut must be placed on a sheet metal face. 

3. In Label, enter a unique name for the cut feature if desired. 

4. Click OK. 

 
 

8.8    Corner Rounds and Chamfers 

You can create a round or chamfer on any corner of a sheet metal part. 

 
 

8.8.1    Rounding a Corner 

1. From the Feature Menu, select Corner Round.  Or, select the Corner Round tool  from 
the Sheet Metal Modeling Toolbar.  The Corner Round dialog appears. 

2. In Items to Round, select the edges you want to round.  You may also select faces, which will 
round all corners adjacent to that face.  Any combination of faces and edges may be selected. 

3. In Radius, type in the desired radius for the round.  A preview will be shown. 

4. Enter the desired values in the distance fields.  A preview will be shown of the chamfer. 

5. Click OK. 
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8.8.2    Chamfering a corner 

1. From the Feature Menu, select Corner Chamfer.  Or, select the Chamfer Corner tool   
from the Sheet Metal Modeling Toolbar.  The Corner Chamfer dialog appears. 

2. In Edges/Faces to Chamfer, select the edges you want to chamfer.  You may also select 
faces, which will chamfer all corners adjacent to that face.  Any combination of faces and edges 
may be selected. 

3. In Chamfer Type, select Distance-Distance, Angle-Distance or Equal-Distance. 

4. Enter the desired values in the distance fields.  A preview will be shown of the chamfer. 

5. Click OK. 

 
 

8.9    Holes 

Alibre Design provides several standard holes. You can insert these standard holes on any planar 
face. The holes can be inserted to a specific depth ("blind"), through an entire model, or up to an 
intersection of a face. Holes are always inserted perpendicular to a face.  

Refer to the Holes section in the solid Features Creation chapter for comprehensive information on 
creating holes (see "Holes" on page 187). 

 
 

8.10    Unbend and Rebend 

You can unbend then rebend one or more flanges at a time.  A feature is added to the feature tree in 
the Design Explorer, allowing you to insert other features, such as a cut, between an unbend and 
rebend pair. 

 To unbend a flange: 

1. From the Feature menu, select Unbend.  Or, select the Unbend tool  from the Sheet Metal 
Modeling Toolbar. 

2. In Fixed Face/Edge, choose a face or an edge to remain fixed throughout the operation. 
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3. In Bends, select the bends of the flanges to unbend, or choose Select All Bends to unbend all 
flanges. 

4. Click OK. 

 

 To rebend a flange: 

1. From the Feature menu, select Rebend.  Or, select the Rebend tool  from the Sheet Metal 
Modeling Toolbar. 

2. In Unbent Bends, select the bends to rebend or choose Select All Unbent Bends to rebend 
all the unbent flanges. 

 
 

8.11    Flat Pattern 

This feature creates a flat pattern view of the entire model.   No modifications can be made while in 
flattened mode, and there is no editing access.   If the model is saved while in flattened mode, the 
model will revert to normal mode before saving. 

Note:  When entering a Team Design Session on a sheet metal part, all participants will enter 
flattened mode. 

 To create a flat pattern: 

From the Feature menu, select Flat Pattern, or, select the Flat Pattern  tool. The flattened 
state will be displayed. 

 

 To leave the flat pattern state: 

Select the Flat Pattern  tool, or, from the Feature menu, choose Flat Pattern (all other features 
will be grayed out, since no modifications can be made to the part while in the flattened state). 
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8.12    Catalog Feature 

After features or sketches have been created, they can be cataloged (see "Saving Catalog Features" 
on page 190) and saved to the repository for use in other part models. 

 
 

8.13    Copying Existing Features 

After sheet metal features have been created, many of them can be mirrored or patterned to easily 
create copies.  

Please note that you cannot mirror Flange features.  Flange features are dependent on the edge 
chosen during creation. 

Refer to the Feature Creation chapter for comprehensive information on creating patterns and 
mirrors (see "Copying Existing Features" on page 192). 

 
 

8.14    Managing Features in the Design Explorer 

After creating a feature it will be listed in the Design Explorer under the Features node.  Additional 
features will be listed in the order in which they were created.  This feature order defines the part's 
construction history. 
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By right-clicking a feature in the Design Explorer you can: 

• Edit the features properties 

• Suppress the feature  

• Rename the feature 

• Delete the feature 

• Check the Status of the feature 
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C H A P T E R  9  

 Working with Parts 
Parts are the fundamental component of a 3D design.  Detail drawings are created from parts and 
assemblies are built by integrating multiple parts. 
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9.1    Saving and Opening Parts 

You save and open parts using the file system or the Repository. 

 
 

9.1.1    Saving a New Part 

 To save the part to the file system: 

1. Select the Save  tool from the Standard toolbar; or from the File menu select Save.  The 

Save dialog appears and a blue part icon  is displayed next to the new part 
(that has not been previously saved). 

2. Click the File System tab. 

3. Navigate to the file system folder in which you want to save the part. 

4. To create a new folder at the currently selected location, click New Folder. 

5. If desired, click Advanced to enter detailed comments about the part. 

6. In the Name field, type the part name. 

7. Click Save to save the part. 

Note: When saving part files to the Windows file system, it is important to not move them around if 
that can be avoided.  Alibre Design files look at the full path name for parametric capability, so if a 
file is moved, the link to a parent object (such as an assembly) could be broken.  If this occurs, you 
will be prompted when opening the parent object that a file is missing, and you can browse to point 
to the new location if necessary.  

 

 To save the part to the repository: 

1. Select the Save  tool from the Standard toolbar; or from the File menu select Save.  The 

Save dialog appears and a blue part icon  is displayed next to the new part 
(that has not been previously saved). 
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2. Click the Repository tab. 

3. Navigate to the location in which you want to save the part. You can click the plus sign  next 
to a repository to expand it and display its folders.  You can save the part directly under the 
selected repository or into any of the repository's folders. 

4. To create a new folder at the currently selected location, click New Folder. 

5. If desired, click Advanced to enter detailed comments about the part. 

6. In the Name field, type the part name. 

7. Select the Save as type from the list.  The default type is the native Alibre format. 

8. By default, the Make new version for all option is on.  This option creates a new version of the 
design each time a save is completed.  This option is ignored if the item is being saved for the 
first time.  If you prefer to maintain one version of a design, deselect the Make new version for 
all option. 

9. Click Save to save the part. 

 
 

9.1.2    Opening a Part 

You can open a previously saved part from the Home window, from the Repository or from an open 
workspace. 

 To open a part from the Home window or any workspace: 

1. Select the Open  tool from the Standard toolbar; or from the File menu select Open.  The 
Open dialog appears. 

2. Using the Document Browser embedded in the Open dialog, navigate through the repository 
or the file system to the location of the desired part. 

3. Select the part from the item list and click OK; or double-click the part in the item list. 

4. In the Home Window, select the Open Alibre Design Files button  on the Welcome tab. 
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 To open a part from the repository: 

1. In the Repository Explorer, browse to the location the part is stored in.  If necessary, click the 
plus sign  next to a repository to expand it and display the folders within. 

2. To open the part, double-click the part in the item list; or right-click the part in the item list and 

select Open from the pop-up menu; or select the part in the item list and select the Open  
tool from the Standard toolbar. 

 
 

9.2    Using the Design Explorer 

The Design Explorer on the left side of a workspace provides an outline of the part's design history 
and structure.  The Design Explorer lists all features, sketches, faces, edges, vertices, planes, axes, 
points, section views, and redline views associated with a design. 

The Design Explorer is displayed by default.  You can hide the Design Explorer although it is 
recommended that you keep it displayed when working.  To hide the Design Explorer, from the View 
menu select Design Explorer.  A check mark next to a menu item indicates the item is currently 
displayed. 

Numerous tasks can be accomplished from the Design Explorer: 

• Moving the cursor over an item or selecting an item in the Design Explorer will 
subsequently highlight or select the corresponding item in the work area. 

• Right-click a feature to edit its properties, rename the feature, delete a feature, suppress a 
feature, and check the status of a feature. 

• Drag and drop features in the Design Explorer to reorder them.  Changing the feature 
generation order changes the construction of the part. 

• Click the plus  or minus  signs next to an item to expand or contract an item or item 
group.  For example, click the plus  sign next to a feature to see its associated sketch.  

  
 

9.3    Modifying a Part 

You can easily alter a part by editing sketches and features, suppressing features, reordering feature 
construction, and rolling back features. 
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9.3.1    Editing Sketches and Features 

After the initial creation of a feature, you can always edit the original feature sketch or the defining 
properties of the feature. 

 To edit a feature sketch:  

1. In the Design Explorer, click the plus  sign next to the feature to expand it and display its 
associated sketch. 

2. Right-click the sketch and select Edit from the pop-up menu; or double-click the sketch. 

Or, 

1. Select the feature in the work area. 

2. Right-click and select Edit Feature Sketch from the pop-up menu. 

Or, 

1. Double-click the feature in the work area to edit the sketch associated with that feature.   

 

The feature sketch appears in sketch mode and you can edit the sketch. 

 

  To edit a feature:  

1. In the Design Explorer, right-click feature and select Edit from the pop-up menu. 

Or, 

1. Select the feature in the work area. 

2. Right-click and select Edit Feature from the pop-up menu.  

 

The dialog associated with the feature type appears displaying the original feature properties.  You 
can change the properties as required.  
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9.3.2    Suppressing Features in Parts 

You can suppress features to temporarily remove them from a part.  Suppressing features hides 
them in the display and prevents the feature from being used in any other modeling operations.  
Suppressed features are not calculated during regeneration.   

 To suppress a feature: 

Right-click the feature in the Design Explorer and select Suppress from the pop-up menu. 

The feature becomes hidden in the work area.  The feature is listed in gray in the Design Explorer 
and the feature icon is shown in gray.  Note that if you suppress a feature, features listed below it in 
the Design Explorer may fail, if they depended on the suppressed feature for successful 
regeneration.  

 

To remove the suppress state, right-click the suppressed feature and select Suppress from the pop-
up menu. 

 
 

9.3.3    Reordering Features 

You can reorder features in the Design Explorer to alter the sequence in which features are created.  
Reordering features will change a part's construction. 

 To reorder features: 

1. In the Design Explorer, click and drag a feature up or down in the feature list.  When you drag a 
feature in the Design Explorer the cursor will change. 
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2. Release the mouse button when the feature has been dragged to the appropriate location in 
the feature list. 

The part will regenerate to reflect the new construction order. 

 

Original feature list: 

 

 

After reordering features: 

 

 

 
 

9.3.4    Rolling Back Features 

You can roll back a part to an earlier state in the design.  When you roll back to an earlier state, 
features below the rollback point become inactive.  When a part is rolled- back, new features are 
inserted at the rollback point, not at the end of the feature list. 

 To roll back features in the Design Explorer: 

1. In the Design Explorer, move the cursor over the blue Feature History  line. 

2. Click and drag the Feature History line above the features you temporarily want to disable.  

3. Release the mouse button. 

Or 
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1. Double-click the feature listed immediately above the features you want to disable. 

 

The Feature History line moves to the rollback point, the features below the line become gray, and 
the part is rebuilt to only reflect the features above the Feature History line. 

 

 

 To roll features forward: 

Drag the Feature History line below the feature or features you want to reactivate. 

Or 

Double-click the feature that you want to reactivate.  All inactive features above the feature you 
double-click will also become active again. 

Note:  To simultaneously reactivate all disabled features, select the Regenerate  tool from the 
Part Modeling toolbar; or from the Feature menu select Regenerate; or press F5 on the keyboard. 

 
 

9.4    Using the Measurement Tool 

You can use the measurement tool to measure items as well as distances and angles between 
edges, faces, vertices, planes, axes, and points in a design. 
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 To take a measurement: 

1. Select the Measurement  tool from the Inspection toolbar; or from the Tools menu select 
Measurement Tool; or press Ctrl + M on the keyboard.  The Measurement Tool dialog 
appears. 

 

2. Select a measurement Type, either Linear or Angular. 

3. Select a Mode: 

Pairs:  measurement is taken between two entities, e.g. distance from edge to edge 

Chain: cumulative measurement is taken between sequential selections, e.g. distance 
along multiple edges 

From First: measurement is taken between two entities, with first selection always 
remaining constant 

4. Select an entity to measure or an entity to measure from. 

Note:  You can also pre-select entities and then open the Measurement Tool dialog.  When 
pre-selecting, you must hold the Shift key down to select multiple items. 

5. If applicable, select an entity to measure to.  
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Note:  To measure to or from the center of cylindrical shapes, select the associated cylindrical 
face. 

 

6. Select the Projected on Plane option to project the measurement to another plane.  Select the 
Projection plane. 

A measurement preview line is displayed in the work area and measurement information 
is displayed in the Measurements area in the dialog. 

7. New measurements can be taken without closing the dialog.  Simply adjust the Type and Mode 
as necessary and select the new entities. 

8. Click Close when finished. 

 
 

9.5    Part Display Options 

You can select from four different display modes to control how parts are displayed. 

The default display type is Shaded.  Other display options include Wireframe, Shaded & Visible 
Edges, and Shaded & All Edges. 

 To change the display: 

From the View menu, select Display and one of the four options: 

• Shaded:  displays parts in shaded mode, edges are not outlined. 

• Wireframe: displays parts in wireframe mode, only edges are outlined and displayed.  

Note:  When viewing the display in wireframe, you can turn the silhouette edges of the model 
on or off.  To do this, from the View menu, select Display.  Check the Silhouette Edges option 

to turn them on.  You can also use the   tool to toggle them on and off. 
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• Shaded & Visible Edges: displays parts in shaded mode, only visible edges are outlined. 

• Shaded & All Edges: displays parts in shaded mode, visible as well as hidden edges are 
outlined. 

The display is updated. 

Note: You can quickly change between shaded and wireframe display modes by selecting the 

Shaded  and Wireframe  tools from the Options drop down list on the Visibility toolbar. 

 
 

9.6    3D Section Views 

You can insert 3D section views into a part and subsequently take measurements on the sectioned 
face or use the sectioned face in modeling operations. 

 To insert a 3D section view: 

1. Select the Insert 3D Section View  tool from the Inspection toolbar; or from the Insert 
menu select 3D Section View; or right-click and select Insert 3D Section View from the pop-
up menu.  The 3D Section View dialog appears. 

2. Click in the Parts to Section field.  Select the part to be affected by the section.   

3. Select a Slicing Plane.  A reference plane or planar face can be used.  A plane with arrows 
appears representing the cut.   

4. If necessary, select Reverse to change the direction of the section view.  The slicing plane 
points to the section side that will remain visible. 

5. Enter a value in the Offset field to shift the cutting plane and create the section view the 
specified distance from the slicing plane. 
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6. Click OK to create the section view.  The section view is also listed in the Design Explorer 
under the Section Views node. 

 

 

 Managing 3D section views: 

You can turn section view visibility on and off as well as delete section views from the Design 
Explorer.  To hide or display a section view, right-click the section view in the Design Explorer and 
select View from the pop-up menu.  A check mark next to View indicates the view is currently 
displayed.  

To delete a section view, right-click the section view in the Design Explorer and select Delete from 
the pop-up menu. 

You can insert multiple section views into a part.  However, you can only display one section view at 
a time. 

 
 

9.7    Part Physical Properties 

You can calculate and display the volume, mass, surface area, center of mass, inertial tensor, and 
principal axes of inertia of a part or assembly. 

 To set a density value: 

1. From the File menu, select Properties.  The Design Properties dialog appears. 

2. Select the Material tab. 
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3. In the Material field, select the desired material from the drop down menu, or select Custom to 
enter your own density value.  (The density is only valid for a part, not an assembly.) 

4. Click Apply and then Close. 

 

 To calculate physical properties: 

1. Select the Physical Properties  tool from the Inspection toolbar; or from the Tools menu 
select Physical Properties.  The Physical Properties dialog appears. 

2. Select an Accuracy setting. 

3. Click Calculate.  The physical properties are displayed.  If necessary, you can copy the 
physical properties information from the dialog and paste it into another document.  The units 
displayed for these calculations can be set from the File menu by selecting Properties, and 
choosing the Units tab. 

4. Click Close to close the dialog. 

 
 

9.8    Color Properties 

You can add color to a part as well as control a part's reflectivity and opacity. 

 To apply color properties: 

1. Right-click in the work area and select Color Properties from the pop-up menu; or from the 
Edit menu select Color Properties.  The Color Properties dialog appears. 

2. Select the Color button to apply a color to the part, or the Edge Color button to apply a color to 
the part edges.  The Color dialog appears.  

3. Select a color from the Basic colors area or create a Custom color.  Click OK and the preview 
will update to reflect your selection. 

4. Click OK to close the Color dialog. 

5. To add Opacity or Reflectivity¸ slide the controls appropriately.  (Less opacity will make the 
part appear transparent, as glass or clear plastic.  More reflectivity will make the part appear 
shiny, as metal or plastic.) 
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6. Click OK to apply the settings. 

 
 

9.9    Using the Project to Sketch Tool 

You can create new sketch or reference figures automatically by projecting existing edges onto a 
sketch plane.  This function is useful when you are creating a new part (or modifying an existing 
part) in an assembly workspace.  You can project edges from other parts in the assembly to the 
sketch in order to reference them in the new part. 

 To use Project to Sketch: 

1. Select a sketch plane. 

2. Enter sketch mode. 

3. Select the Project to Sketch  tool from the Sketching toolbar; or from the Sketch menu 
select Project to Sketch.  The Project to Sketch dialog appears. 

 

4. Select the existing feature edges that you want to project to the sketch plane. 

Note: You can select all the edges on a face at once by selecting a face. 

5. To create a new sketch figure, select the Create sketch figure option. 

6. To create a new reference figure, select the Create reference figure option. 

7. Select the Maintain association to source entity option if you want the new sketch or 
reference figure to reflect any changes made to the originating profile. 
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8. Click OK to create the new sketch or reference figure. 

 

 

If you selected the Maintain association to source entity option, project-to-sketch constraint 
symbols are displayed on the new figures to indicate that they are constrained to the originating 
profile. 

 

You will not be able to place dimensions on figures that were created with the Project to Sketch 
Maintain association to source entity option.  You can, however, delete the constraints and 
subsequently add driving dimensions to the figure. 

 

The following images demonstrate using Project to Sketch to create a new part in an assembly 
workspace.   

The assembly is shown slightly transparent in the background, and the reference planes for the new 
part are visible.  The assembly is currently in Edit Part mode on the new part.  
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The Project to Sketch dialog is open, and the face of an existing part is selected.  This will allow 
creation of a new part that will fit directly onto the existing face, with mounting holes in the correct 
location.   Maintain association to source entity is selected, so if the existing face is modified, the 
new part will update as well.  

 

 



Chapter 9 - Working with Parts 

 
 
 

 255 
 

Upon clicking the OK button, all of the edges of the selected face are projected onto the new sketch 
plane.  

 

An Extrude Boss feature is created from the sketch.  

 

The assembly is put back in Edit Assembly mode, and the new part can be constrained as 
necessary.  
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9.10    Spreadsheet Driven Designs 

You can create variations of a design by using a spreadsheet of parameters.  Additionally, a single 
spreadsheet of parameters can be shared by multiple designs.  The spreadsheet must be created in 
Microsoft Excel; Excel 2000, Excel 2007 and Excel XP are supported. 

Before you can drive a design with a spreadsheet of parameters, you must first set up Excel by 
installing the Alibre Design Add-In in Microsoft Excel.  Next, you may either create a design with a 
desired set of dimensions, or create a spreadsheet first with a set of varying parameters for those 
dimensions.  Then you are ready to drive the design with the spreadsheet. 

Note:  When using Excel 2007, you must be running Excel as Administrator.  If you are not, you will 
receive an error message. 

 
 

9.10.1    Setting Up Excel to Drive Designs 

Before you can drive a design with a spreadsheet of parameters, you must first install the Alibre 
Design Add-In to Microsoft Excel. 

 To set up Excel 2000 or XP: 

1. Launch Alibre Design. 

2. Launch Microsoft Excel. 

3. From the Tools menu in Excel, select Add-Ins.  The Add-Ins dialog appears.  

4. Click Browse.  The Browse dialog appears. 

5. Browse to Program Files > Alibre Design on your PC's local C:/ drive and locate the file 
named “Alibre Design Add-In.xla.” (This is the default location for Alibre Design files at 
installation.) 

6. Click the file name. 

7. Click OK.  The Alibre Design Add-In appears in the Add-Ins dialog with a checkmark next to it. 

8. Click OK.  In Excel, a new item appears in the Tools menu: Alibre Design Add-In > Control 
Parameters. 
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 To set up Excel 2007: 

1. Launch Microsoft Excel.   

2. Click the Microsoft Office logo in the top left corner of the spreadsheet.  

 

3. In the dialog, click the Excel Options button. 

4. In the Excel Options dialog, choose Add-ins. 

5. In the Add-ins section, in the Manage field, select Excel Add-ins from the drop down list, then 
click the Go button. 

  

6. Click the Browse button and Browse to Program Files > Alibre Design on your PC's local C:/ 
drive and open the file named “Alibre Design Add-In.xla.” (This is the default location for Alibre 
Design files at installation.)  

7. Make sure Alibre Design Add-In is checked, then click OK.  

8. Click the Microsoft Office logo again. 

9. In the dialog, click the Excel Options button. 
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10. Click Customize and expand the Popular Command drop down list. 

 

11. Select  Add-ins Tab.  

12. Click OK.  

13. The Add-ins tab is added. 

 

 
 

9.10.2    Driving Designs by Spreadsheet 

You can use Microsoft Excel spreadsheets to store and manage design information for use in driving 
one or more designs in Alibre Design.  You may either set up the spreadsheet first, or design the 
part first. 

TIP: You must go through the steps to set up Excel (see "Setting Up Excel to Drive Designs" on 
page 256) before you can drive a design. 

 To drive a design by spreadsheet: 

1. Launch Alibre Design. 

2. Open the desired part. 

3. Launch Microsoft Excel. 
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4. Save the workbook (spreadsheet). 

5. Enter the desired settings for the parameters.  For each parameter, enter a value, type, and 
units.  You may also enter a name and comments. 

6. From the Tools menu in Excel, select Alibre Design Add-In > Control Parameters.  The 
Control Parameters dialog appears.  The part name is displayed in the Design field and its 
dimensions appear in the parameters table.    

OR,  

for Excel 2007, select the Add-Ins tab.  Choose Alibre Design Add-In > Control Parameters. 

Note:  When using Excel 2007, you must be running Excel as Administrator.  If you are not, you 
will receive an error message.  

 

 

7. In Parameters, click one of the parameters.  Its name appears in the Name field. 

8. For Cell Reference, click the field then click the cell on the Excel spreadsheet that the 
parameter should reference. 
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- OR - 

Click the  button.  The cell reference box appears.  Click the desired spreadsheet cell; then 

click the  button to return to the Control Parameters dialog. 

9. In Type, select the parameter type: distance, angle or count. 

10. In Units, set the desired units of measurement (for distance and angle parameters). 

11. Click Modify. 

12. To add a new parameter, click Reset.  The entry fields are cleared.  In Name, type a name for 
the new parameter then follow steps 7-11 above. 

13. Click Close.  The open part in Alibre Design is modified to the new parameters. 

 

 To set more than one parameter at a time 

You can select more than one parameter at a time in the Control Parameters dialog. 

1. Select the first parameter you wish to set, then hold the Ctrl key down and select any other 
parameters to modify.  Each of the parameters will highlight. 

 

In the Name field, it will say Multi-Select and in the Cell Reference field, each of the cells will be 
listed in the order they appear in the Parameters section.  (It will say NULL in the place of a cell 
name if no cell is currently linked.) 

2. Click the  button to move to the linked Excel spreadsheet, and select - in the correct order - 
the new fields that you wish to link.  You must click the same number of cells as parameters 
you highlighted.  
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3. Return to the Control Parameters dialog by clicking the  button.  

4. Click the Modify button to update the parameter values. 

 
 

9.10.3    Modifying Spreadsheet Driven Parameters 

Modify the parameters for spreadsheet driven designs directly in Microsoft Excel. 

 To modify spreadsheet driven parameters: 

1. Launch Alibre Design. 

2. Open the part that is linked to the spreadsheet. 

3. Launch Microsoft Excel. 

4. Open the spreadsheet of prepared parameters. 

5. From the Tools menu in Excel, select Alibre Design Add-In > Control Parameters.  (For 
Excel 2007, select the Add-Ins tab.  Choose Alibre Design Add-In > Control Parameters.) 
The Control Parameters dialog appears.  (You may be prompted to save the workbook - the 
Excel file - before using it to control parameters.)  The name of the open part is displayed in the 
Design field and its dimensions appear in the Parameters table. 
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TIP: IF several parts are open in Alibre Design, click Active Sessions in the Control 
Parameters dialog.  The Active Sessions dialog appears.  Select the desired part and click 
OK.  Alternatively, you can click Repository or File System to find the desired design. 
 

 

6. In Parameters, click of the parameters.  Its name appears in the Name field.  

7. For Cell Reference, click the field then click the cell on the Excel spreadsheet that the 
parameter should reference. 

 - OR - 

Click the  button.  The cell reference box appears.  Click the desired spreadsheet cell; then 

click the  button to return to the Control Parameters dialog. 

Note:  If the spreadsheet is moved, or any folders are renamed, the link from the cell to the part 
dimension will be broken.  To reestablish the link, use the Equation Editor dialog to re-link the 
spreadsheet (see "Re-linking a Spreadsheet to a Part" on page 263) to the part.   

8. In Type, select the parameter type: distance, angle, or count. 

9. In Units, set the desired units of measurement (for distance and angle parameters). 
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10. Click Modify. 

11. To add a new parameter, click Reset.  The entry fields are cleared.  In Name, type a name for 
the new parameter; then follow steps 6-10 above. 

12. Click Close.  The open part in Alibre Design is modified to the new parameters. 

 
 

9.10.4    Re-linking a Spreadsheet to a Part 

If a spreadsheet file used in driving a design is moved or folders are renamed in the path to their 
locations, their links to the parts they drive will be broken.  The next time you open the Equation 
Editor dialog, this warning will appear. 

 

To reestablish the links between spreadsheets and parts, use the link button in the Equation Editor 
dialog. 

 To reestablish the link between a part and a spreadsheet 

1. With the affected part open, click the Equation Editor  tool.  

- OR - 

From the Tools menu, select Equation Editor.  The Missing External Reference dialog 
appears. 

2. Click OK.  The Equation Editor dialog appears.  
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3. The affected parameters are displayed in red. 

 

4. Click an affected parameter and click Link.  The Link Parameter dialog appears. 
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5. Click Windows Folders; then Browse if the associated spreadsheet is in a Windows folder.  
Click Repository; then Browse if the associated spreadsheet is in a repository.  The Browse 
for Spreadsheet File dialog opens. 

6. In Look In, browse to the location of the spreadsheet. 

7. Click the spreadsheet's file name to select it. 

8. Click Open.  The new file path to the spreadsheet appears in the browse field. 

9. Click Apply to all such parameters to apply the changes to all parameters driven by the same 
spreadsheet. 

10. Click OK. 

11. Repeat steps 4-10 if any affected parameters are driven by a separate spreadsheet. 

 
 

9.11    3D PDF Publishing 

Alibre Design supports publishing parts, assemblies, drawings, and BOMs to PDF file format.   Once 
published, these files can be viewed with the Adobe Reader.   

There are two levels of PDF publishing:   

• Model Only Publishing  

• Full Publisher Module   

 

Note:  Users with licenses for Alibre Design Xpress and Standard have access to Model Only 
Publishing.  Users with licenses for Alibre Design Professional and Expert have access to Full 
Publishing.  PDF Publishing is not supported for licenses of Alibre Design Basic.   

  

Model Only Publishing Features 

• Ability to publish PDF files with interactive 3D model, including rotate, pan, and zoom.    

• PDF file can be viewed with Adobe Reader 7.0.8 and above.  
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Full Publisher Module Features 

• Ability to publish PDF files with: 

• Interactive 3D model, including rotate, pan, and zoom 

• Assembly tree 

• Drawings 

• BOMs 

• Exploded view animation with ordered steps 

• Saved views    

• PDF file can be viewed with Adobe Reader 7.0.8 and above.  

 
 

9.11.1    Creating a PDF File 

 To create a PDF file of a part, sheet metal part, or assembly:  

1. From the File menu, select Publish to PDF, or select the Publish to Acrobat PDF tool  
from the PDF Publishing toolbar.   The PDF Publishing Wizard opens, and the 3D Model tab is 
active.   

2. Select a template to use.  (See PDF Publishing Templates (on page 273) for more information) 

3. Click Next. 

4. If you want to add a header, select the Title tab and enter a title.  Click the Font button 

 to change the font of the Title.  Please note:  The Title can be one line only, and 
the text will not wrap.   

5. If you want to add a footer, select the Footer tab and enter a footer.  Click the Font button 

 to change the font of the Footer.   Please note:  The Footer can be one line 
only, and the text will not wrap. 

6. If you selected a template that includes text, select the Body Text tab(s) and enter text as 

necessary.  Click the Font button  to change the font of the text.  To include a 
carriage return, press CTRL + Enter on your keyboard. 
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7. Click Next.  

8. Check the Views you want to include in your PDF, if any.  The default view (the state the model 
was in at the time you began the publishing process) is always included.   

9. Click Next.  

10. In the Page Layout section, select which page layout you wish to publish to.  

11. Check the Put my logo on the top right corner option to include an image in the PDF; then 
click Browse to find and select the image.   

12. In Save Location, browse to the location you want to save the PDF file to.  

Note: If you choose to save to an existing file, after clicking Publish, you will be prompted to 
choose if you want to overwrite the existing file or add the published page to the existing file at 
the end as an additional page.   

13. Choose Preview if you would like to view the PDF file before saving it.  This creates a 
temporary file that is deleted if you do not publish the file.   

14. Click Publish.  

The PDF file will be created and saved to the location you specified, and can be viewed with Adobe 
Reader 7.0.8 or higher.  

 

 To create a PDF file of a section view:  

1. You must be viewing the section view in the work area. 

2. From the File menu, select Publish to PDF.   The PDF Publishing Wizard opens, and the 3D 
Model tab is active. 

3. Continue following the steps listed above for creating a PDF file of a part, assembly, or sheet 
metal part. 

 

 To create a PDF file of an assembly in an exploded view:  

1. You must have a license for full publishing. 
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2. You must be viewing an assembly in the exploded state. 

3. From the File menu, select Publish to PDF, or select the Publish to Acrobat PDF tool  
from the PDF Publishing toolbar.   The PDF Publishing Wizard opens, and the 3D Model tab is 
active.  

4. Select a template to use.   (See PDF Publishing Templates (on page 273) for more information) 

5. Click Next.  

6. If you chose one of the templates that includes exploded view steps,  

a. In Publish State, choose to publish in Exploded or Unexploded State. This will determine 

which state the model is displayed in the PDF.   

b. Check the Include Explosion steps and descriptions box if you would like to include the 

steps in the PDF.  Click the Font button  if you would like to change the font of the 

exploded view steps in the PDF.  The text "PDF Publishing" will update to reflect the new 

font. 

c. Click Next.  

7. If you want to add a header, select the Title tab and enter a title.  Click the Font button 

 to change the font of the Title.  Please note:  The Title can be one line only, and 
the text will not wrap. 

8. If you want to add a footer, select the Footer tab and enter a footer.  Click the Font button 

 to change the font of the Footer.  Please note:  The Footer can be one line only, 
and the text will not wrap. 

9. Click Next.  

10. Check the Views you want to include in your PDF, if any.  The default view (the state the model 
was in at the time you began the publishing process) is always included. 

11. Click Next.  

12. In the Page Layout section, select which page layout you wish to publish to.  



Chapter 9 - Working with Parts 

 
 
 

 269 
 

13. Check the Put my logo on the top right corner option to include an image in the PDF; then 
click Browse to find and select the image.   

14. In Save Location, browse to the location you want to save the PDF file to.  

Note: If you choose to save to an existing file, after clicking Publish, you will be prompted to 
choose if you want to overwrite the existing file or add the published page to the existing file at 
the end as an additional page.   

15. Choose Preview if you would like to view the PDF file before saving it.  This creates a 
temporary file that is deleted if you do not publish the file.   

16. Click Publish. 

The PDF file will be created and saved to the location you specified. 

 

 To create a PDF file of images or text: 

1. From the File menu, select Publish to PDF, or select the Publish to Acrobat PDF tool  
from the PDF Publishing toolbar.  The PDF Publishing Wizard opens.   

2. Select the General tab.  

3. Select a template to use.   (See PDF Publishing Templates (on page 273) for more information) 

4. Click Next. 

5. If you selected a template that includes an image, click Browse to find and select the image 
you wish to publish.  

6. Depending on which template you selected, select the Title, Footer, and/or Body Text tabs and 
enter the text you wish to appear in each location.  Please note:  The Title and Footer can be 
one line only, and the text will not wrap. To include a carriage return in the Body Text section, 
press CTRL + Enter on your keyboard.  

7. Click Next.  

8. In the Page Layout section, select which page layout you wish to publish to.  
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9. If you chose the Image with Text template or the Text Only template, check the Put my logo 
on the top right corner to include an image in the PDF; then click Browse to find and select 
the image.  

10. In Save Location, browse to the location you want to save the PDF file to.  

Note: If you choose to save to an existing file, after clicking Publish, you will be prompted to 
choose if you want to overwrite the existing file or add the published page to the existing file at 
the end as an additional page.   

11. Choose Preview if you would like to view the PDF file before saving it.  This creates a 
temporary file that is deleted if you do not publish the file.   

12. Click Publish. 

The PDF file will be created and saved to the location you specified. 

 

 To create a PDF file of a 2D drawing: 

1. You must have installed PDFCreator during the installation of Alibre Design.  

Note: PDFCreator can not be installed on the Vista operating system. 

2. You must have Full Publishing capability.  

3. From the File menu, select Publish to PDF, or select the Publish to Acrobat PDF tool  
from the PDF Publishing toolbar.   The PDF Publishing Wizard opens, and the BOM/Drawing 
tab is active.  The Drawing Template option is selected. 

4. Click Next. 

5. If you want to add a header, select the Title tab and enter a title.  Click the Font button 

 to change the font of the Title.  Please note:  The Title can be one line only, and 
the text will not wrap.   

6. If you want to add a footer, select the Footer tab and enter a footer.  Click the Font button 

 to change the font of the Footer.   Please note:  The Footer can be one line 
only, and the text will not wrap. 

7. Click Next.   
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8. In the Page Layout section, select which page layout you wish to publish to.  

9. Check the Put my logo on the top right corner to include an image in the PDF; then click 
Browse to find and select the image.   

10. In Save Location, browse to the location you want to save the PDF file to.  

Note: If you choose to save to an existing file, after clicking Publish, you will be prompted to 
choose if you want to overwrite the existing file or add the published page to the existing file at 
the end as an additional page.   

11. Choose Preview if you would like to view the PDF file before saving it.  This creates a 
temporary file that is deleted if you do not publish the file.   

12. Click Publish.  

The PDF file will be created and saved to the location you specified, and can be viewed Adobe 
Reader 7.0.8 or higher. 

 

 To create a PDF file of a BOM: 

1. You must have installed PDFCreator during the installation of Alibre Design.  

Note: PDFCreator can not be installed on the Vista operating system. 

2. You must have Full Publishing capability. 

3. From the File menu, select Publish to PDF, or select the Publish to Acrobat PDF tool  
from the PDF Publishing toolbar.   The PDF Publishing Wizard opens, and the BOM/Drawing 
tab is active.  The BOM Template option is selected. 

4. Click Next. 

5. If you want to add a header, select the Title tab and enter a title.  Click the Font button 

 to change the font of the Title.  Please note:  The Title can be one line only, and 
the text will not wrap.   
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6. If you want to add a footer, select the Footer tab and enter a footer.  Click the Font button 

 to change the font of the Footer.   Please note:  The Footer can be one line 
only, and the text will not wrap. 

7. Click Next.   

8. In the Page Layout section, select which page layout you wish to publish to.  

9. Check the Put my logo on the top right corner to include an image in the PDF; then click 
Browse to find and select the image.   

10. In Save Location, browse to the location you want to save the PDF file to.  

Note: If you choose to save to an existing file, after clicking Publish, you will be prompted to 
choose if you want to overwrite the existing file or add the published page to the existing file at 
the end as an additional page.   

11. Choose Preview if you would like to view the PDF file before saving it.  This creates a 
temporary file that is deleted if you do not publish the file.   

12. Click Publish.  

The PDF file will be created and saved to the location you specified, and can be viewed Adobe 
Reader 7.0.8 or higher. 

 
 

9.11.2    Continuing with an Existing PDF 

If you have previously created a PDF file, you can continue adding data to that PDF at a later time.  

 To continue working on an existing PDF: 

1. Open the file containing the model, drawing, or BOM that you wish to include in the PDF.  

2. From the File menu, select Continue Previously Created PDF, or select the Continue 

Previously Created PDF tool  from the PDF Publishing toolbar.  The PDF Publishing 
Wizard dialog appears. 

3. Select the appropriate radio button to choose whether you want to Append to the last PDF 
you created, or Append to a different PDF.  

4. If you chose to append to a different PDF, click Browse to choose which PDF to append to.  
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5. Click Next.  

6. Continue in the PDF Publishing wizard as described in Creating a PDF File (on page 266).  

 
 

9.11.3    PDF Publishing Templates 

Templates available when creating a PDF from a Part, Sheet metal Part, or 
Assembly Workspace: 

 

Model Only, Full 
Page 

The published PDF file will have one page which 
shows the 3D model. 

 

Model Only, Half 
Page 

The published PDF file will have one page which 
shows the 3D model only in the upper half of the 
PDF page.  The rest of the PDF page will be blank. 

 

Model with text in 
lower half 

The published PDF file will have one page which 
shows the 3D model in the upper half of the PDF 
page.  The lower half of the PDF page will include 
your custom text. 

 

Templates available when creating a PDF from an Assembly Workspace 
while in an exploded view (only available if you have a license for full 
publishing): 

 

Exploded View, Full 
Page 

The published PDF file will have one page which 
shows the assembly in its exploded view and a title 
(if one is specified). 
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Exploded view, Half 
Page 

The published PDF file will have one page which 
shows the assembly in its exploded view and a title 
(if one is specified) only in the upper half of the 
PDF page.  The rest of the PDF page will be blank. 

 

Exploded view, Top, 
with Exploded View 
Step Information 

The published PDF file will show the assembly in 
the exploded view  in the upper half of the PDF 
page with all of the steps listed under it. 

 

Exploded view, Left, 
 with Exploded View 
Step Information 

The published PDF file will show the assembly in 
the exploded view  on the left side of the PDF page 
with all of the steps listed on the right. 

 

Templates available when creating a PDF of an image or of text only: 

 

Cover Page The published PDF file will have one page which 
shows the image in the top half, and your custom text 
in the bottom half. 

 

Image with Text The published PDF file will have one page which 
shows the image in the top half, and your custom text 
in the bottom half, along with any specified Title and 
Footer. 

 

Text Only The published PDF file will include your custom text. 
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Templates available when creating a PDF from a Drawing Workspace: 

 

Drawing The published PDF file will have one page which shows 
the sheet that was active when the publishing process 
was started. 

 

Templates available when creating a PDF from a BOM Workspace: 

 

Bill of Material The published PDF file will have one page which shows 
Bill of Material. 

 
 

9.11.4    Viewing Published PDF Files 

After you have published a PDF file, you can view the PDF using the Adobe Reader version 7.0.8 or 
higher.   

 To view a published PDF file: 

1. Ensure that you have installed Adobe Reader.  

2. Browse to the location you saved the file to.  

3. Double-click the file, and it will open in the Adobe Reader. 

 

 To view any additional views included in the file: 

Not all files will include additional views.  The views must have been selected during the publishing 
process.  

1. Ensure that you have installed Adobe Reader.  (Must be version 7.0.8 or higher) 

2. Browse to the location you saved the file to. 
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3. Double-click the file, and it will open in the Adobe Reader. 

4. Left-click once on the image of the model,  

OR,  

Right-click the image of the model and choose Enable 3D. 

5. From the Views drop down list, select the view you wish to view.   

Note: You can also select the Model Tree tab to see a list of all of the published views. 

 

 To view the explosion animation of an assembly 

Not all files will have the explode animation.  The file must have been published that way originally.  
This capability is available with the Full Publishing package.  

1. Ensure that you have installed Adobe Reader.  (Must be version 7.0.8 or higher) 

2. Browse to the location you saved the file to. 

3. Double-click the file, and it will open in the Adobe Reader. 

4. Left-click once on the image of the model,  

OR,  

Right-click the image of the model and choose Enable 3D. 

5. Click on any of the steps in the list to see the assembly explosion at that step.   

6. Click Reset, then Explode to view the animation of the entire explosion.   

7. To view the implosion, click Reset, and then Implode. 

Note:  You must click Reset each time you want to select either Explode or Implode for the 
animation to work correctly.  
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9.11.5    Improving the Quality of Published PDF Files 

Following these suggestions can improve the quality of your published PDF files.  Before beginning 
the publishing process:  

• Make sure your workspace window is maximized 

• Choose a white background for your work area 

• Center the model and make it fill as much of the work area as possible 

 
 

9.11.6    Publishing a Model to HTML 

You can send the image of a model directly to an HTML file if necessary.  

 To publish the model to an HTML file: 

1. Open the file containing the model you wish to publish.  

2. From the File menu, select Publish 3D PDF of model only in HTML, or select the Publish 3D 

Model in HTML tool  from the PDF Publishing toolbar.  The PDF Publishing Wizard dialog 
appears. 

3. In Save Location, type in the location where you want to save the file, or click the Browse 
button to specify the location.  

4. In File Names, enter a name for both the PDF file and the HTML file. 

You must provide a filename for both PDF and HTML.  The HTML file contains a link to the 
PDF, so both files are required for the HTML file to open correctly.    

5. Click Publish.  

  
 

9.12    Printing 3D Models 

You can print the images from your 3D workspace.  The print function will print all that is displayed, 
so you may want to hide planes, axes, and other items.  
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 To print: 

1. From the File menu, select Print. 

2. If you desire to print using a white background, check the option Use white background. 

3. Choose the printer and the number of copies, and click OK. 

 
 

9.13    Annotations 

You can insert 3D annotations in a part and assembly workspaces.  The following annotation types 
are supported in 3D workspaces: 

• Notes 

• Datums 

• Datum Targets 

• Feature Control Frames 

• Surface Finishes 

• Weld Symbols 

• The methods used to insert annotations for drawing and model workspaces are the same.  
Refer to section 11.7 for detailed information related to inserting annotations. 

 
 

9.14    Troubleshooting Failed Features 

A feature can fail to generate properly due to numerous reasons.  If a feature fails to generate 
correctly, a message is generated after the initial creation and a red X is displayed on the design 
icon in the Design Explorer, as illustrated below. 

 

Common causes of feature generation failure include: 

• The sketch used to define the feature profile contains open or overlapping figures (e.g. an 
extrude boss feature fails if the profile sketch contains any open ends) 
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• Improperly specifying the feature parameters (e.g. interchanging the path sketch and profile 
sketch involved in a sweep boss) 

• Modifying an upstream feature causes a downstream feature to fail 

 

 To troubleshoot a failed feature: 

• Right-click the feature and select Status from the pop-up menu.  A dialog appears 
containing information related to the cause of the feature failure. 

• Right-click the feature and select Edit.  The feature properties dialog appears. Modify the 
conditions if applicable. 

• If the failure is a result of an incorrect sketch, edit the sketch and correct accordingly. 

 
 

9.15    Viewing Constituents 

You can view the constituents of Alibre Design Parts, Sheet metal Parts, Assemblies, Drawings, and 
Bills of Material. 

 To view constituents in the Repository: 

1. In the Repository Explorer, browse to the location the item is stored in. 

2. Right-click the item and select Constituents from the pop-up menu; or highlight the item and 
select Constituents from the View menu.  The Constituents dialog appears, showing all items 
that are related to the selected item. 

 

 To view constituents in the Windows File System: 

1. In the Alibre Design Home Window, from the Tools menu, select Show Constituents.  The 
Show Constituents dialog appears. 

2. Browse to locate the item in the dialog. 

3. Click Open.  The Constituents dialog appears, showing all items that are related to the 
selected item. 

Or, 
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1. In the Windows File System, right-click an Alibre Design file and select Constituents.  The 
Constituents dialog appears, showing all items that are related to the selected item. 

 
 

9.16    Display Optimization 

9.16.1    Display Acceleration 

You can speed up the processing of large designs by entering Display Acceleration mode.  This is 
achieved by simplifying the design according to user-defined options.  This option can be used in 
designs (including parts, assemblies, sheet metal parts, exploded assemblies, and Design 
Booleans), but not in drawings or BOMs.  Some menu items will be unavailable while in Display 
Acceleration. 

 To set preferences for Display Acceleration: 

1. In a part or assembly workspace, from the File menu, select Properties.  

2. Select the Display tab.  

           

3. Check your desired options for Display Acceleration: 

• Coarse Display - Flat shading will be selected, no reflectivity will be used, visible 
and silhouette edges will not be shown.  If this option is checked, changing the 
display options (wireframe, shaded, etc.) will not change the display of the model.  

• Simplified Display Meshes - The complexity of meshes will be reduced, which will 
reduce the visual precision of the parts.  

• Remove Details on View Manipulation - During rotate, pan, and zoom operations, 
some faces and small parts will be left out of the display.  These will be returned to 
the display after the operation is completed. 

• No rollover until mouse pauses - If this option is checked, the you will not see any 
items highlight as you move the cursor until the mouse has paused for the 
designated amount of time. At that time, whatever item the cursor is paused over will 
highlight. 
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4. Choose Apply, then Close. 

 

 To enter Display Acceleration: 

1. From the View menu, select Display Acceleration. 

- OR- 

Select the Display Acceleration tool  from the View Toolbar. 

 

 To exit Display Acceleration: 

1. From the View menu, select Display Acceleration. 

- OR- 

Select the Display Acceleration tool  from the View Toolbar. 

 

Note:  If you save a model with Display Acceleration active, then it will remain in Display 
Acceleration when it is opened again.  
 

9.16.2    Curve Smoothness 

The Curve Smoothness setting affects how curves are displayed in a part or assembly.  There are 
two options available: automatic and manual.  The default setting for Curve Smoothness is manual. 

The Curve Smoothness setting does not affect the structure of the model, and is not reflected in the 
drawings created, when the standard precise views are used.  However, this setting does affect the 
views created using Fast View (see "Fast Views" on page 365) mode.  

 To set the curve smoothness: 

1. In a Part or Assembly workspace, from the File menu, choose Properties.  

2. Select the Display tab.  

3. In the Curve Smoothness section, choose one of the following:  
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a. Automatic - curves will be displayed using the number of segments necessary for a 

smooth representation.  When the view is zoomed in or out, the number of segments is 

recalculated. 

b. Manual - the number of segments is calculated once, according to the number indicated in 

the Minimal Circular Facets field. 

4. If Manual was selected, enter the Minimal Circular Facets. 

5. Click Apply, then Close.   
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C H A P T E R  1 0  

 Design Configurations 
Design configurations allow you to create multiple variations of a part, sheet metal part, or assembly 
and maintain them in a single workspace.  When a part with configurations is included in an 
assembly, you can specify which configuration you want to see in the assembly.  In addition, when 
you are creating a drawing, you can specify which configuration of a part or assembly will be 
inserted into a drawing view. 

The ability to create and edit Design Configurations is available in Alibre Design Professional and 
higher versions.  However, every part, sheet metal part, and assembly workspace will contain one 
configuration when it is opened.  This is true regardless of which version of Alibre Design you are 
using.  In versions that do not include the ability to create or edit configurations, this will be the only 
configuration. 

For example, if you open a design model in Alibre Design Basic that was originally modeled in 
Professional and has multiple configurations, you will see the configurations listed in the Design 
Explorer, but you will only be able to edit the configuration that was active when the model was last 
saved. 

In This Chapter 

Design Configurations Overview ............................................................................. 284 
Creating Part and Sheet Metal Part Configurations ................................................ 289 
Assembly Configurations......................................................................................... 293 
Using Configurations in Drawings ........................................................................... 307 
Using Configurations in a BOM ............................................................................... 308 
Using the Equation Editor with Configurations ........................................................ 310 
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10.1    Design Configurations Overview 

Below are illustrations for the use of Design Configurations in a part model named "Male Connector": 

 

Configuration of the Large Version of a Male Connector 

          

In the Design Explorer, the part model name has "- Large" appended to it, noting the active 
configuration. The configuration called "Large" has the active icon next to it (see Lock Properties 
Icon Descriptions for information about each icon).  The configuration called "Small" has the inactive, 
unlocked icon.  The model in the work area is displayed as shown. 
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Configuration of the Small Version of a Male Connector 

         

In the Design Explorer, the part model name now has "- Small" appended to it, noting the new active 
configuration. The configuration called "Large" has the inactive, locked icon next to it.  The 
configuration called "Small" has the active icon.  The model in the work area is displayed as shown. 

 
 

10.1.1    Lock properties represented in the Design Explorer 

Each configuration of a part, sheet metal part, or assembly listed in the Design Explorer has an icon 
that represents the lock properties of that configuration. The table below describes each icon.  

 

Icon Lock State Description 

 
Active All changes made apply to this active configuration.  Only 1 

configuration can be active at a time. 

 
Unlocked All of the changes made to the active configuration will be applied 

to unlocked configurations. 

 
Locked None of the changes made to the active configuration that are 

controlled by configuration lock properties will be applied to these 
locked configurations.   
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Partially Locked Some of the changes made to the active configuration will apply to 

these partially locked configurations, depending on the particular 
locks that are set for each one. 

 
Missing The configuration that was set for this assembly constituent is 

missing - generally because it has been deleted.  To resolve this, 
activate one of the other existing configurations by double-clicking 
it.  

   
 

10.1.2    Editing Properties of Configurations 

You can edit the lock properties of configurations in a design to control how each of the 
configurations update when you are making changes to the active configuration. 

 

 To edit the lock properties of a configuration: 

1. From the Edit menu, select Edit Config<2>. (The configuration that is available to edit from this 
menu will be the one you have highlighted in the Design Explorer) 

OR, 

Right-click the configuration in the Design Explorer and select Edit. 

The Configuration dialog appears.  This dialog is similar to the New Configuration dialog.  
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Figure 83: Edit Part Configuration Dialog 

 
Figure 84: Edit Assembly Configuration Dialog 

                          

2. Check the options you want to Lock for this configuration. 

3. Select OK to accept the selections. 

 

 To make a configuration active 

Double-click the configuration you want to activate; 

OR 

Right-click the configuration you want to activate and select Activate; 

OR 

Follow steps 1 and 2 above, and check the box next to the option Active, then Select OK. 
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10.1.3    Regeneration of Design Configurations 

When Alibre Design models are regenerated, each feature in the Design Explorer is calculated in the 
order it appears.  All features that appear above the blue "dog bone" are features that have been 
regenerated.  Features below the blue "dog bone" as well as suppressed features are not generated. 

 

 

When modeling with multiple configurations it is important to realize that as features are created in 
the active configuration, the features for inactive configurations are recorded but not executed.  This 
means that inactive configurations are not updated while you are editing the active configuration.  

Using the "Update Activated Configuration" option, you can choose if you want Alibre Design to 
automatically compute all newly added features when you switch a configuration from inactive to 
active.  

 

 To set the Update Activated Configuration option: 

In a Part Workspace, from the Features menu, choose Update Activated Configuration.  When this 
option is checked, it is on.  (This is the default setting)  When it is unchecked, it is off.   

If Update Activated Configuration is checked: When you activate a configuration, it will 
automatically be computed up to the dog bone position in the configuration you just edited.    

If Update Activated Configuration is unchecked: When you activate a configuration, no new 
features will be computed.  The dog bone is located below the last valid feature in the newly 
activated configuration.  This is useful if you want to modify data that does not require feature 
regeneration, such as Property Data.   

Note: When this option is off, the position of the dog bone can vary greatly between each 
configuration. 
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10.2    Creating Part and Sheet Metal Part Configurations 

When a new part or sheet metal part workspace is opened, the Configurations category will appear 
in the Design Explorer as the first category in the list. 

  

 Under the Configurations category, Config <1> is listed.  Every part contains at least one 
configuration. This is true for all versions of Alibre Design. 

 

 To create a new configuration: 

Note:  Not all versions of Alibre Design include the ability to create new configurations. 

1. From the Insert menu, select Configuration; OR right-click on Configurations in the Design 

Explorer and choose New Configuration;  OR select the Configuration tool  from the 
Inspection toolbar. The New Configuration dialog appears. 
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2. In the Name field, enter a name for the configuration. 

3. In the Copy From drop down menu, choose which configuration to use to start the new one.  
The Lock properties from the configuration you choose to copy from will populate in the Locks 
field.  You can modify these as needed. 

4. In the Locks field, set the lock requirements for the configuration. 

a. Lock All will check all of the properties 

b. Unlock All will uncheck all of the properties 
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The following table describes how each lock function will affect the model behavior: 

Individual 
Lock 

Locked Behavior 
(Checked) 

Unlocked Behavior 
(Unchecked) 

Feature 
suppression 

Any features added to the 
active configuration will be 
added as suppressed 
features in each locked 
configuration. 

Changes to suppression 
state 
(suppress/unsuppress) for 
already existing features in 
the active configuration will 
be ignored in locked 
configurations. 

Any features added to the 
active configuration will 
also be added to each 
unlocked configuration. 

Changes to suppression 
state of already existing 
features in the active 
configuration will also be 
applied to each unlocked 
configuration. 

Parameter 
values 

Any parameters added to 
the active configuration will 
also be applied with their 
initial values to all locked 
configurations. 

 However, any changes to 
parameter values will not 
be applied to locked 
configurations. 

Any parameters added to 
the active configuration will 
be applied with their initial 
values to all unlocked 
configurations.   

In addition, any changes to 
parameter values will also 
be applied to all unlocked 
configurations. 

Part Data 
(General 
Properties) 

Changes to the active 
configuration's Part Data 
property values will be 
ignored in all locked 
configurations.  

Note that the Name, 
Number, and Description 
fields in the Part Data will 
be the same for all 
configurations.  The locks 
apply to the property 
values. 

Changes to the active 
configuration's Part Data 
property values will be 
applied to all unlocked 
configurations. 

Color 
Properties 

Changes to the edge 
and/or face colors of the 
active configuration will be 
ignored in all locked 
configurations. 

Changes to the edge 
and/or face colors of the 
active configuration will 
also be applied to all 
unlocked configurations. 

Reference 
Geometry 
Hiding 

Hiding and unhiding of 
reference geometry in the 
active configuration is 
ignored in all locked 
configurations. 

Hiding and unhiding of 
reference geometry in the 
active configuration will be 
applied to all unlocked 
configurations.  
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Active Section 
View 

 

Choosing to activate or 
deactivate the view of a 3D 
section view in the active 
configuration is ignored in 
all locked configurations.  

Activating or deactivating 
the view of a 3D section 
view in the active 
configuration also changes 
the view state of all 
unlocked configurations.  

5. Check the Active checkbox to make the new configuration the active one. 

6. Select OK to create the new configuration.  The new configuration will appear in the Design 
Explorer.  In addition, once a second configuration has been created, the part name in the 
Design Explorer and in the workspace title bar will change to read "Part Name — Active 
Configuration Name".  

Note:   If you have only a single configuration, the part name in the Design Explorer and in the 
workspace title bar will read only "Part Name".  There will be no configuration name appended to the 
name. 

 
 

10.2.1    Helpful Notes on Design Configurations in Parts 

• Moving or resizing a sketch figure manually (such as by clicking and dragging) applies to all 
configurations.  Moving or resizing a sketch figure using dimensions does not necessarily 
(dimension values are parameters that can be different in each configuration). 

• All configurations have the same set of dimensions.  A dimension added to one 
configuration will be added to all configurations.  Values of dimensions are parameters that 
can differ between configurations.   

• All configurations have a common set of available features.  A feature deleted from one 
configuration is deleted from all configurations. (Features can be suppressed in individual 
configurations) 

• All configurations have a common feature order.  Features reordered in one configuration 
are reordered in all configurations. 

• In the design explorer, configurations are listed in the order they were created.  You can 
reorder them, if you are aware that relationships between features that are broken as a 
result of reordering will cause the affected features to fail. 

• You can not delete the active configuration.  If only one configuration exists, it is by default 
the active configuration, and the delete option will be disabled. 
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10.3    Assembly Configurations 

As with part workspaces, when a new assembly workspace is opened, the Configurations category 
will show up in the Design Explorer as the first category in the list. 

 

Under the Configurations category, Config <1> is listed.  Every assembly contains at least one 
configuration. This is true for all versions of Alibre Design.  

 

 To create a new configuration: 

Note:  Not all versions of Alibre Design include the ability to create new configurations. 

1. From the Insert menu, select Configuration; OR right-click on Configurations in the Design 

Explorer and choose New Configuration;  OR select the Configuration tool  from the 
Inspection toolbar. The New Configuration dialog appears. 
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2. In the Name field, enter a name for the configuration 

3. In the Copy From drop down menu, choose which configuration to use to start the new one. 
 The Lock properties from the configuration you choose to copy from will populate in the Locks 
field.  You can modify these as needed. 

4. In the Locks field, set the lock requirements for the configuration.  

a. Lock All will check all of the properties 

b. Unlock All will uncheck all of the properties 
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The following table describes how each lock function will affect the model behavior: 

Individual Lock Locked Behavior 
(Checked) 

Unlocked Behavior 
(Unchecked) 

General 

Parameter 
values 

Any parameters added 
to the active 
configuration will also be 
applied with their initial 
values to all locked 
configurations. 

 However, any changes 
to parameter values will 
not be applied to locked 
configurations. 

Any parameters added 
to the active 
configuration will be 
applied with their initial 
values to all unlocked 
configurations.   

In addition, any 
changes to parameter 
values will also be 
applied to all unlocked 
configurations. 

Part Data 
(General 
Properties) 

Changes to the active 
configuration's Part Data 
property values will be 
ignored in all locked 
configurations.  

Note that the Name, 
Number, and Description 
fields in the Part Data 
will be the same for all 
configurations.  The 
locks apply to the 
property values. 

Changes to the active 
configuration's Part 
Data property values 
will be applied to all 
unlocked 
configurations. 

Color Properties Changes to the edge 
and/or face colors of the 
active configuration will 
be ignored in all locked 
configurations. 

Changes to the edge 
and/or face colors of 
the active configuration 
will also be applied to 
all unlocked 
configurations. 

Reference 
Geometry Hiding 

Hiding and unhiding of 
reference geometry in 
the active configuration 
is ignored in all locked 
configurations. 

Hiding and unhiding of 
reference geometry in 
the active configuration 
will be applied to all 
unlocked 
configurations.  

Active Section 
View 

Choosing to activate or 
deactivate the view of a 
3D section view in the 
active configuration is 
ignored in all locked 
configurations. 

Activating or 
deactivating the view of 
a 3D section view in 
the active configuration 
also changes the view 
state of all unlocked 
configurations. 
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Assembly 

Part / 
Subassembly 
Configuration 

Changing the 
configuration of a 
component that is used 
in the active assembly 
configuration does not 
affect any locked 
assembly configurations. 

Changing the 
configuration of a 
component that is used 
in the active assembly 
configuration will also 
be changed in all 
unlocked assembly 
configurations. 

Part / 
Subassembly 
Suppression 

Components that are 
inserted in the active 
assembly configuration 
will be inserted as 
suppressed components 
in all locked assembly 
configurations. 

For already existing 
components, changing 
between suppressed 
and unsuppressed will 
not affect their 
suppression states in 
any locked assembly 
configurations. 

Components that are 
inserted in the active 
assembly configuration 
will also be inserted in 
all unlocked assembly 
configurations (in the 
same state). 

For already existing 
components, changing 
between suppressed 
and unsuppressed will 
change their 
suppression states in 
all unlocked assembly 
configurations. 

Part / 
Subassembly 
Hiding 

Hiding and unhiding of 
assembly components in 
the active assembly 
configuration is ignored 
in all locked assembly 
configurations. 

Hiding and unhiding of 
assembly components 
in the active assembly 
 configuration also 
applies to all unlocked 
configurations. 
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Constraint 
Suppression / 
Positions / Make 
Flexible 

Newly added constraints 
are suppressed. 
 Modifying the 
suppression state of an 
existing constraint has 
no effect. 

Changes to the make- 
flexible state are 
ignored. 

The position of 
unconstrained 
constituents is locked 

Newly added 
constraints are also 
applied to unlocked 
configurations. 
 Modifying the 
suppression state of an 
existing constraint is 
applied to unlocked 
configurations.  

Changes to the make- 
flexible state are 
applied to all unlocked 
assembly 
configurations. 

If the position of a 
component in the 
active configuration is 
modified, the position 
of that component in all 
unlocked assembly 
configurations will 
change to match. 

5. Check the Active checkbox to make the new configuration the active one. 

6. Select OK to create the new configuration.  The new configuration will appear in the Design 
Explorer.   In addition, once a second configuration has been created, the assembly name in 
the Design Explorer and in the workspace title bar will change to read "Assembly Name — 
Active Configuration Name". 

Note:   If you have only a single configuration, the assembly name in the Design Explorer and in the 
workspace title bar will read only "Assembly Name".  There will be no configuration name appended 
to the name. 

 
 

10.3.1    Inserting Configurations of Parts or Subassemblies 

When you insert a part or subassembly into a higher level assembly workspace, the active 
configuration of that model will automatically be inserted. After it has been inserted, you can change 
which configuration of a part or subassembly is used.  
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 To change which configuration is used in an assembly 

 
Figure 85: Design Explorer Showing a List of Parts in an Assembly 

 

1. Find the part or subassembly that you want to set a new configuration for, and expand it to see 
each of the categories for that component. 

 

 

     

2.  Expand the Configurations category.  In this example, the configuration called "Large" is 
currently active. 
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3. Double-click the configuration you want to make active in this assembly, or, right-click the 
configuration and select Activate. In this example, I double-clicked the configuration called 
"Small". 
 

 

 

The new configuration will become active in this assembly, and will be shown in the work area. This 
will not affect which configuration is active in any other assembly, or in the original model workspace. 

 

Note: Configuration information is only displayed for immediate children of the root assembly.  Parts 
nested within sub assemblies do not have a Configurations category node; however, the activate 
configuration name is appended to the part name.  You can see this illustrated below.   

Notice the root assembly is called "FourConnectors_w_Leads - Female Mixed Short". 
 (FourConnectors_w_Leads is the name of the assembly model file, and Female Mixed Short is the 
name of the active configuration) 
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There is a subassembly called "Four Connectors<1> - Male Large".  This means that Male Large is 
the active configuration of the model Four Connectors in this assembly.  You can see the 
Configurations category under this component, which lets you know you can change the active 
configuration from Male Large to something else if desired. 

The Four Connectors subassembly has several parts under it.  You will see one called "Male 
Connector<1> - Large".  This tells you that Large is the active configuration of the part called Male 
Connector.  Under that component there is no configuration category.  Since this component is 
nested in a subassembly of the root, you can not change the active configuration here. 

 

 

 

 To change which configuration is used for a component of a subassembly 

If you need to edit which configuration is active in a nested component that is not an immediate child 
of the root assembly, you must open the subassembly and change the active configuration there. 

You can open the subassembly separately, or you can edit it in the context of the root assembly. 
 (See "Editing parts and subassemblies in an assembly" for information on how to edit a component 
in the context of the root assembly) 
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If a part is edited in the context of an assembly, the part’s active configuration will automatically be 
set to match the configuration held by the assembly. 

 
 

10.3.2    Missing Design Configurations 

When using configurations, you must use care when deleting configurations that you have created, 
as they may be used by assembly components.  

When you open an assembly in which one of the components is missing its configuration, you will 
see a message similar to the following: 

 

 

You can select the OK button in the Message dialog, and the assembly will continue to open. You 
will see the following changes take place in the Design Explorer: 

• The component name appears dimmed, with a question mark over the icon. 

• The missing configuration name is present in the Configurations tree, with an X over the 
icon.   

• No configuration is marked as active (all configuration icons are in the inactive state).   

• No representation of the component with the missing configuration is shown in the work 
area. 
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Note: If a configuration is missing from a component in a subassembly of the root assembly, only 
the first indicator listed above will be seen for that component - the component name will appear 
dimmed, and will have a question mark over the icon. No Configurations tree will appear under the 
component. 

 
 

10.3.3    Using Configurations in Assembly Patterns 

Inserting a part or subassembly pattern of a model with multiple configurations 



Chapter 10 - Design Configurations 

 
 
 

 303 
 

When you insert a part/subassembly pattern in an assembly workspace, the configuration of all 
instances of the pattern will match the configuration of the seed (the original instance) at the time of 
creation. 

 
 

  
Figure 86: Pattern displayed in the work area - all instances are the same configuration 

 

Once the pattern has been created you can change any of the instances individually to a different 
configuration.  

 To change an instance in an assembly pattern: 

1. Click the plus symbol next to the instance that you want to change. This will expand the tree to 
show the configurations available.  

2. Double-click the configuration you want displayed for that instance to make it the active one.  
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The model will update in the work area to reflect the new configuration.  
 

 
 
 

 
 

 

 

Behavior of pattern instances in different configurations 

The number of instances in a pattern is a parameter. How the instances behave in different 
configurations depends on the lock properties of each configuration.  
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Example 1: 

The example assembly above has 1 configuration - Config 1.  Assembly Config 1 has a pattern of 4 
Female Connectors.   
 
Create another configuration of the assembly - Config 2. Lock all options except Parameter Values, 
which will be unlocked.   Assembly Config 2 is at this point is identical to Assembly Config 1.   
 
Next, activate Assembly Config 1, and edit the pattern so that it has 7 instances instead of 4.   
Then activate Assembly Config 2.  In the Design Explorer, the Female Connector pattern will show 
the new instances, but they will be suppressed.  This is because the option Part/Subassembly 
Suppression is locked, which means all new entities will be suppressed in Config 2.  However, 
Parameters is unlocked, which means the number of instances follows the changes made in the 
active configuration (Config 1 in this example).   
 
The result will be: 
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Example 2: 

Using the first example assembly again:  Assembly Config 1 has a pattern of 4 Female Connectors.   
 
Create another configuration of the assembly - Config 2. This time, lock all options.   Assembly 
Config 2 is at this point identical to Assembly Config 1.   
 
Next, activate Assembly Config 1, and edit the pattern so that it has 7 instances instead of 4.   
Then activate Assembly Config 2.  In the Design Explorer, the Female Connector pattern will NOT 
show the new instances at all.  This is because both Part/Subassembly Suppression and Parameter 
Values are locked.   
 
The result will be: 
 

   
 
 

 
 
 

10.3.4    Helpful Notes on Design Configurations in Assemblies 

• All configurations have the same set of constraints.  A constraint added to one 
configuration will be added to all configurations.  However, constraint values are 
parameters that can differ between configurations.   

• All configurations have a common set of available components.  A component deleted from 
one configuration is deleted from all configurations; however, you can suppress 
components in individual configurations. 

• In the design explorer, configurations are listed in the order they were created. 

• You can not delete the active configuration.  If only a single configuration exists, it is by 
default the active configuration, and the delete option will be disabled. 
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• If you change configurations in the assembly while editing an exploded view, that 
configuration will open in the exploded view the next time you go back to it. 

 
 

10.4    Using Configurations in Drawings 

When inserting new standard drawing views, you can choose which configuration you would like to 
see in the view. 

The Standard Views Creation dialog has a field called Configurations with a drop-down menu for you 
to select the configuration you wish to see in the views.  Since all models contain at least one 
configuration (Config<1> by default) the Configurations field will always be populated with a 
selection.  If your model contains more than one configuration, you can select the one you want from 
the menu. 

 

Notes:  

You can not create drawing views of assemblies with missing configurations. 
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If you have an assembly that includes BOTH design configurations AND inter-design constraints (on 
page 330) in the same assembly or subassembly, you will not be able to use Fast View mode when 
creating drawing views for the assembly.   

 
 

10.5    Using Configurations in a BOM 

When creating a BOM for a design, you can choose which configuration you would like to include. 

The Bill of Materials dialog has a field called Configurations with a drop-down menu for you to select 
the configuration. 

 

 

Two standard properties are added to the available options for inserting a column in a BOM.  They 
are: 

• Configuration Name - The name of the active configuration of a part used in an assembly.  
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• Part-Configuration Name - The name of the active configuration appended to the name of 
the design 

 

 

Below are two examples of BOMs that were created for an assembly that calls out a bolt that has 
three different configurations. The assembly uses at least one of each bolt configuration.  

Example 1: The BOM does not have the column Configuration Name included in it.  You can see 
that the part Small Bolt is listed three times, but the total quantity is listed by the first Small Bolt, and 
there is no indication given of which configuration is used.   
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Example 2:  The Configuration Name column has been added to the BOM.  Now you can see that 
again the Small Bolt part is listed three times, but the total quantity is split up correctly between the 
configurations used.   

 
 

10.6    Using the Equation Editor with Configurations 

Although all configurations of a design have a common set of dimensions, the values of those 
dimensions are parameters whose values can vary from configuration to configuration. 

 

For each dimension, the Name and Comment fields will be the same between configurations.  The 
Equation (which is either an equation or the specific value of the dimension) field can vary between 
configurations. 

You can edit the value of a dimension from the Equation Editor or by double-clicking the value in the 
sketch and typing in the new value. 

 

 



Chapter 11 - Assembly Design 

 
 
 

 311 
 

C H A P T E R  1 1  

 Assembly Design 
You can create multi-part assemblies of varying function and complexity. 
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11.1    Assembly Design Methodology 

You can use two distinct assembly design methods, or a combination of both.  The first method, 
often referred to as bottom-up design, involves creating each assembly part in an individual part 
workspace.  After the parts have all been individually modeled, you can then insert them into an 
assembly workspace, and subsequently position and mate them correctly by inserting assembly 
constraints. 

The second method, often referred to as top-down design, involves creating all the assembly parts 
in the assembly workspace.  Using this method enables you to design parts while referencing other 
assembly parts. 

Both methods have disadvantages and advantages.  The bottom-up design methodology is perhaps 
the simpler of the two and enables you to manage the design more efficiently.  The top-down design 
is somewhat more complex, but is valuable when the design of one part is heavily dependent on 
other parts. 

You can also use a combination of the bottom-up and top-down design methods.   
 

11.2    The Assembly Design Interface 

Assemblies are designed in assembly workspaces.  An assembly can be comprised of parts and 
other assemblies, referred to as subassemblies.  The parts and subassemblies that constitute an 
assembly are referred to as constituents. 

A typical assembly could have the following structure: 

Top-Level Assembly 

    Subassembly A 

• Part A1 

• Part A2 

• Part A3 

    Subassembly B 

• Part B1 

• Part B2 

    Part C 

    Part D 
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Assembly Workspace 

The assembly workspace looks similar to the part workspace.  However, the Sketching and Part 
Modeling toolbars are not displayed in the assembly workspace.  Instead, the Assembly Modeling 
toolbar is displayed by default on the right side of the workspace. 

 
Insert Part/Subassembly ... insert a part into the assembly 

 
Insert Pattern ... pattern a part in the assembly 

 
Insert Duplicate ... insert a copy of a part in the assembly 

 
Edit Part/Subassembly ... edit a part or subassembly 
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Insert Assembly Constraint ... manually insert an assembly constraint 

 
Auto Constrain ... place mate and align constraints automatically 

 
Move Part ... move an individual part or parts 

 
Rotate Part ... rotate an individual part or parts 

 
Precise Placement ... position a part precisely 

 
Minimum Motion ... use with Rotate or Move to localize motion to selected part 

 
Equation Editor 

 
Color Properties ... modify color properties of parts 

 
Regenerate ... update assembly constraints 

 
Manual Explode ... explode the parts manually 

 
Auto Explode ... allow the software to explode the parts automatically 

 
Expand Explosion ... increase the distance parts explode (auto mode) 

 
Contract Explosion ... decease the distance parts explode (auto mode) 

 
View Part Trails ... show/hide the trail lines 

 
Edit Exploded View Steps ... view/edit exploded view steps 

  

In assembly workspaces, the top-level assembly is listed first in the Design Explorer.  Parts and 
subassemblies are listed at the bottom in the order in which they are inserted or created.  The 

assembly  icon  signifies an assembly or subassembly item.  The part icon  signifies a part 
item. 
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The Design Explorer also lists the assembly reference geometry, assembly constraints, redline 
views, section views, as well as the faces and edges associated with each part. 

You can click the plus sign  next to an item to expand it and see its associated details.   For 
example, you will see a subassembly's constituents if you expand it. 

             

 

You can insert the same part or subassembly multiple times into an assembly.  When inserting 
duplicate parts or subassemblies, the item will be listed in the Design Explorer with its original name 
followed by a numeric label to indicate how many instances have been inserted, e.g. Part1<1>, 
Part1<2>, Part1<3>, etc. 

 
 

11.3    Assembly Basics 

You can create an assembly by inserting parts you have already designed, inserting imported parts, 
or designing new parts in the context of the assembly. 
 

11.3.1    Opening a New Assembly and Inserting Existing Parts 

1. Open a new assembly workspace.  The assembly workspace and the Insert 
Part/Subassembly dialog appear.  

2. In the Insert Part/Subassembly dialog, select the part to be inserted into the assembly.  

Repository Tab: 

This tab is only accessible if you have a version of Alibre Design that enables 
Repositories. 

Press the Ctrl key as you select multiple components. 

You can select multiple components only in the same repository and folder. 

You can select and insert parts from any repository you have access to. 
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File System Tab: 

Select the drive you wish to browse through from the Drives drop down list. 

Select the folder the component is located in.  The Directory field will update. 

If needed, you can use the Browse button to access non-mapped network locations. 

3. Select the components to insert into the assembly.  Press the Ctrl key as you select multiple 
components.  To select a series of items, hold the Shift key and select the first and last parts in 
the series. 

Note:  To start with a blank assembly workspace, click Cancel on the Insert 
Part/Subassembly dialog. 

4. Click OK to insert the part.  A preview of the part(s) appears in the assembly workspace.  The 
Inserting dialog also appears. 

5. Move the cursor to move the part(s) if necessary. 

6. Click once to place the part(s) in the workspace.  

7. If necessary, continue to click to insert duplicates. 

8. Press Esc or click Finish in the Inserting dialog to complete the insertion. 
 

11.3.2    Anchored Parts 

A part's position in an assembly can be fixed by anchoring the part in the work area.  An anchored 

part cannot be moved.  When a part is anchored, the Anchor  icon is displayed on the part in 
the Design Explorer.  You can anchor any part, as well as remove the anchor state from a part at 
any time. 

 To add or remove the anchor state: 

Right-click a part in the Design Explorer and select Anchor Part from the pop-up menu.  

 
 

11.3.3    Inserting an Existing Design Into an Open Assembly 

You can insert parts or sub-assemblies any time after an assembly has been opened. 
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 To insert an existing design into an assembly: 

1. From the Insert menu, select Part/Subassembly; or right-click in the work area and select 
Insert Part/Subassembly from the pop-up menu; or press Ctrl + Shift + I on the keyboard. 

The Insert Part/Subassembly dialog appears.  

2. In the Insert Part/Subassembly dialog, select a design to be inserted into the assembly.  You 
can also select multiple items to be inserted simultaneously.  Hold the Ctrl key when selecting 
multiple items. 

3. Click OK to insert the design.  A preview of the design(s) appears in the assembly workspace.  
The Inserting dialog also appears. 

 

4. To insert the design so that the design's origin is initially coincident with the assembly's origin, 
unselect the Show preview option. 

5. If the Show preview option is left on, you can move the cursor to position the design(s) at any 
location if necessary. 

6. Click once to place the design(s) in the workspace.  

7. If necessary, continue to click to insert duplicates. 

8. Press the Esc key on your keyboard or click Finish in the Inserting dialog to complete the 
insertion. 

 
 

11.3.4    Selecting Parts in the Assembly 

You can select individual parts in the assembly from the Design Explorer or the work area.  When 
you move your cursor over a part in the Design Explorer, the part is highlighted in the work area.  
When you select a part in the Design Explorer, the part is selected and highlighted in the work area, 
and vice versa. 
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 To select a part in the work area: 

1. Hold the Ctrl key and move the cursor over the part you want to select.  The part highlights and 

the cursor changes to .  

2. Click to select the part.  The part is highlighted in the work area as well as the Design Explorer. 

         

 
 

11.3.5    Part Display Options 

You can select from four different display modes to control how parts are displayed. 

The default display type is Shaded.  Other display options include Wireframe, Shaded & Visible 
Edges, and Shaded & All Edges. 

 To change the display: 

From the View menu, select Display and one of the four options: 

• Shaded:  displays parts in shaded mode, edges are not outlined. 

• Wireframe: displays parts in wireframe mode, only edges are outlined and displayed.  

Note:  When viewing the display in wireframe, you can turn the silhouette edges of the model 
on or off.  To do this, from the View menu, select Display.  Check the Silhouette Edges option 

to turn them on.  You can also use the   tool to toggle them on and off. 

• Shaded & Visible Edges: displays parts in shaded mode, only visible edges are outlined. 

• Shaded & All Edges: displays parts in shaded mode, visible as well as hidden edges are 
outlined. 

The display is updated. 
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Note: You can quickly change between shaded and wireframe display modes by selecting the 

Shaded  and Wireframe  tools from the Options drop down list on the Visibility toolbar. 

 
 

11.3.6    Inserting a Duplicate Design Into an Open Assembly 

You can insert copies of a part or subassembly that you have already inserted into an assembly. 

 To insert duplicates into an assembly: 

1. Select the design you want to insert a duplicate of.  You can select the design in the Design 
Explorer or work area. 

2. From the Insert menu select Duplicate.  A preview of the part appears in the assembly 
workspace.  The Duplicating dialog also appears.  

3. Move the cursor to move the design if necessary. 

4. Click once to place the design in the workspace.  

5. If necessary, continue to click to insert additional duplicates. 

6. Press Esc or click Finish in the Duplicating dialog to complete the insertion. 

7. The duplicate appears and is listed in the Design Explorer. 

 

 

 
 

11.3.7    Inserting a Pattern of Parts in an Assembly 

You can pattern a part or subassembly that you have already inserted into an assembly. 

Linear Pattern 

You can use a linear pattern to repeat a part in one, two, or three linear directions. 
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 To create a linear pattern of a part in an assembly: 

1. From the Insert menu select Part/Subassembly Pattern > Linear.  The Linear 
Part/Subassembly Pattern dialog appears. 

 

2. In Part/Subassembly to Pattern, select the part you wish to pattern. 

3. In Row Direction, select an edge, axis, or face that can be used to define an axis (as on a 
cone or cylinder) to set the direction for the row. 

4. In Column Direction, select an edge, axis, or face that can be used to define an axis (as on a 
cone or cylinder) to set the direction for the column. 

5. In Layer Direction, select an edge, axis, or face that can be used to define an axis (as on a 
cone or cylinder) to set the direction for the layer. 

6. Enter the number of copies you want in each direction, including the original.  A value of 1 will 
make no additional copies in that direction. 

7. Enter the distance you want between each copy in the spacing fields. 

8. In Label, enter a unique name for the pattern. 

9. Choose OK. 
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The linear pattern will appear in the Design Explorer, with the parts in the pattern listed under it in 
the tree.  These patterned parts cannot be edited or moved; however, any of the patterned parts can 
be deleted by right-clicking them in the Design Explorer and choosing Delete. 

 

Circular Pattern 

You can use a circular pattern to repeat a part in a radial direction around a centerline. 

 To create a circular pattern of a part in an assembly: 

1. From the Insert menu select Part/Subassembly Pattern > Circular.  The Circular 
Part/Subassembly Pattern dialog appears. 

 

2. In Part/Subassembly to Pattern, select the part you wish to pattern. 

3. In Center, select the axis you want the parts to be patterned around from the Design Explorer. 

4. In Copies, enter the number of copies you want, including the original. 

5. In Angle, set the angle value. 

6. In Layers, Enter the number of layers you want in the direction of your centerline.  The same 
number of copies will be created on each layer. 
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7. In Layer Spacing, set the distance between each layer. 

8. In Layer Twist, set an angle to rotate the layers with respect to each other, if desired. 

9. In Label, enter a unique name for the pattern. 

10. Click OK. 

The circular pattern will appear in the Design Explorer, with the parts in the pattern listed under it in 
the tree.  These patterned parts can not be edited or moved, however, any of the patterned parts 
can be deleted by right-clicking them in the Design Explorer and choosing Delete. 

 
 

11.3.8    Moving and Rotating Parts Freely 

You can move or rotate a part freely as long as it is not anchored or constrained in such a way that 
limits movement. 

 To move a part:  

1. Hold the Ctrl key, select a part in the work area, and drag the cursor.  The part moves as you 
drag the cursor.  You can release the Ctrl key after the part begins to move. 

Or 

 

1. Select the Move Part  tool from the Assembly Modeling toolbar; or from the Tools menu 
select Move Part.  

2. Move the cursor over the part you want to move. 

3. Click and drag the cursor to move the part.  

 

 To rotate a part: 

1. Move the cursor over the part to rotate. 
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2. Hold the Ctrl key, select a part in the work area holding both mouse buttons, and drag the 
cursor.  The part rotates as you drag the cursor.  You can release the Ctrl key after the part 
begins to rotate. 

Or 

 

1. Select the Rotate Part  tool from the Assembly Modeling toolbar; or from the Tools menu 
select Rotate Part. 

2. Move the cursor over the part you want to rotate. 

3. Click and drag the cursor to rotate the part. 

 
 

11.3.9    Moving and Rotating Parts Precisely 

You can move or rotate a part precisely if necessary as long as a part is not anchored or constrained 
in such a way that limits movement. 

 To move or rotate a part a precise distance or angle: 

1. Select the Precise Placement  tool from the Assembly Modeling toolbar; or from the 
Tools menu select Precise Placement.  The Precise Placement dialog appears. 

 

2. Select the part to move or rotate. 
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3. To move a part, in the Translation Entry area, specify the relative translation distance by 
entering values for DX, DY, and DZ. 

Or, 

To rotate a part, in the Rotation Entry area, select the rotation Axis and specify the relative 
rotation Angle in degrees.  The rotation axis can be an axis or linear edge on a part.   

4. Click Apply to move or rotate the part. 

5. Click Close to exit the dialog. 

 
 

11.3.10    Moving Parts to Simulate Assembly Physical Motion 

 To position a part or subassembly 

1. Hold the Ctrl key on the keyboard and click the part or subassembly.  The item is highlighted. 

2. While holding the Ctrl key and left-mouse button down, drag the part or subassembly to the 
new position.  You can release the Ctrl key after the part/subassembly begins to move. 

OR 

1. From the Tools menu, select Move Part. 

2. Click the Minimum Motion  tool on the Assembly Modeling toolbar 

3. Click and drag the part or subassembly.  The part or subassembly moves a minimum number 
of parts. 

 
 

11.3.11    Hiding a Part 

You can hide individual parts in an assembly.  A part that is hidden still fully participates in the 
regeneration of the model, as well as all physical property calculations.  It is simply not visible.  
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 To hide an individual part: 

Right-click a part in the Design Explorer and select Hide from the pop-up menu; or select a part in 
the work area (Ctrl + click) and right-click and select Hide from the pop-up menu.  The part is 
hidden in the work area and is listed in gray in the Design Explorer. 

 

 

 To unhide the part: 

Right-click the part in the Design Explorer and select Hide again. 

 
 

11.3.12    Suppressing a Part 

You can suppress individual parts in an assembly.  A part that is suppressed does not participate in 
the regeneration of the model, or any physical property calculations.    

 To suppress an individual part: 

Right-click a part in the Design Explorer and select Suppress from the pop-up menu; or select a part 
in the work area (Ctrl + click) and right-click and select Suppress from the pop-up menu.  The part 
is hidden in the work area and is listed in gray in the Design Explorer. 

 

 

 To unsuppress the part: 

Right-click the part in the Design Explorer and select Suppress again. 
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11.3.13    Changing a Part's Display 

You can control the display of an individual part. 

 To change a part's display: 

Right-click a part in the Design Explorer and select Wireframe, Shaded, Shaded & Visible Edges, 
or Shaded & All Edges from the pop-up menu.  The part display change is reflected in the work 
area. 

 
 

11.3.14    Applying Color Properties to a Part 

You can apply different color properties to each part in an assembly. 

 To apply color properties to a part: 

1. Select a part either in the Design Explorer or the work area. 

2. Select the Color Properties  tool from the Part Modeling toolbar; or right-click in the work 
area and select Color Properties from the pop-up menu; or from the Edit menu select Color 
<Part Name> Properties.  The Color Properties dialog appears. 

3. Select a color and set the Reflectivity and Opacity levels as necessary. 

4.  Click OK to apply the properties. 

Note:  You can apply the same color properties to the entire assembly.  Select the top-level 
assembly in the Design Explorer; or, from the Edit menu choose Select All.  Follow steps 1-4 above 
to apply the color properties. 

 
 

11.3.15    Checking Part Physical Properties 

You can check physical part properties on an individual part basis or the assembly basis. 

 To check part/assembly physical properties: 

1. Right-click a part or assembly in the Design Explorer and select Properties from the pop-up 
menu; or select a part in the Design Explorer or work area, right-click and select Properties 
from the pop-up menu. 
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The Measurement Tool dialog appears and lists the physical properties for the selection. 

2. Click Close on the dialog when finished viewing the properties. 

 
 

11.3.16    Viewing Part Reference Geometry 

You can view the reference geometry of a part while in an assembly.  These features can then be 
used to constrain the part to the assembly if desired. 

 To view part reference geometry: 

1. Right-click the part in the Design Explorer 

2. Choose Show Reference Geometry.  The part reference features will appear in the design 
explorer and in the model window. 

 

 To hide part reference geometry 

1. Right-click the part in the Design Explorer 

2. Choose Show Reference Geometry (This will be checked if reference geometry is shown. 
 Choosing it again will uncheck the option, hiding the reference geometry). 

 

11.4    Assembly Constraints 

You can insert assembly constraints to precisely position and mate parts with respect to each other 
in an assembly.  Assembly constraints also dictate how parts move or rotate with respect to other 
parts.  

A part is initially unconstrained and has six degrees of freedom when first inserted into an assembly.  
You can move or rotate an unconstrained part in any direction.  As you place assembly constraints 
on a part, the degrees of freedom are reduced and you begin to limit how a part can be moved or 
rotated.  A fully constrained part has zero degrees of freedom and its movement and/or rotation 
depend on the movement/rotation of the part or parts it is constrained to. 
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11.4.1    Assembly Constraint Types 

You can use five different types of assembly constraints:  mate, orient, angle, align, and tangent.  
Each constraint type is valid for specific combinations of items.  You can apply constraints to the 
following items: 

• Reference planes and axes 

• Linear edges 

• Planar faces 

• Cylindrical faces 

• Spherical, conical, and toroidal faces 

You will always select exactly two items when applying a constraint.  The following table summarizes 
which constraint types can be applied to various combinations of items. 

 

 Plane Cylinder Line Sphere 

Plane  
(planar face or reference 
plane) 

Mate 

Orient 

Angle 

Align 

   

Cylinder (cylindrical face) Tangent 

Align 

Align 

Tangent 

Orient 

  

Line (linear edge or axis) Align 

Orient 

Align 

Tangent 

Align 

Orient 

 

Sphere (spherical face) Tangent Align 

Tangent 

Align Align 

Tangent 
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11.4.2    Inserting Assembly Constraints 

 To insert assembly constraints: 

1. Click the Insert Assembly Constraint  tool from the Assembly Modeling toolbar; or right-
click in the work area and select Insert Assembly Constraint from the pop-up menu; or from 
the Insert menu select Assembly Constraint.  The Assembly Constraints dialog appears. 

 

2. Select the first edge, face, plane, or axis.  The selected item is highlighted in the work area and 
is listed in the Surfaces to constrain area. 

3. Select the second edge, face, plane, or axis.  The selected item is highlighted in the work area 
and is listed below the first selection in the Surfaces to constrain area. 

Note:  If you prefer, you can pre-select the two entities and then open the Assembly Constraint 
dialog.  The Surfaces to constrain field will be populated with the selections. 

4. Select the appropriate constraint type.  Only the constraint types that are valid for the selected 
items are available. 

5. If you are applying the Angle constraint, specify the angle in degrees. 

6. If you are applying the Tangent constraint, select Inside or Outside. 
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7. You can specify an Offset value if you are applying a Mate, Align, or Tangent constraint. 

8. Select the Preview option to check the result before applying it.  If the preview shows the parts 
in the incorrect position, modify the constraint properties accordingly. 

9. Click Apply to finalize the constraint. The second component in the list is constrained to the 
first component, and the constraint is listed in the Design Explorer under the Constraints node.  
The constraint label lists the constraint type.  Expand the node to view its constrained entities. 
The dialog remains open so you can create another constraint.  

10. Repeat the procedure to create another constraint, or click Close to exit the Assembly 
Constraints dialog. 

 
 

11.4.3    Inter-Design Constraints 

While in part edit mode, if you use a face on an existing part as a sketch plane or to create a new 
reference plane, an inter-design constraint will automatically be created.  This constraint will be 
displayed in the Design Explorer under the Constraints node when you switch back to assembly 
edit mode.  The inter-design constraint label by default lists the two related parts (the parent part and 
the associated part).  

 

After an inter-design constraint has been created, any change made to the parent part will 
automatically update the associated part.   To break the interdependency, delete the inter-design 
constraint in assembly edit mode.  If you do not want the new part to change as a result of other 
parts changing, it is good practice to immediately delete the inter-design constraints from the main 
assembly as soon as you are finished working on the newly created part.  
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11.4.4    Managing Assembly Constraints 

Each new assembly constraint that you insert will be listed under the Constraints node in the 
Design Explorer, and/or under the constituent that it references.  You can choose how you would like 
to display the constraints.   

 
Figure 87: Design Explorer Showing Constraints Listed Under Constraints Node and Individual Components 

If you move the cursor over a constraint or select a constraint in the Design Explorer,  the applicable 
entities will highlight in the work area. 
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 To change how constraints are viewed:  

1. From the View menu, select Assembly Constraints.  

2. Check As List to see the constraints listed in the Design Explorer under the Constraints node.  
This is a toggle on/off option. 

3. Check With Component to see the constraints listed under the parts they relate to.  This is a 
toggle on/off option. 

Both options can be checked at the same time, allowing the constraints to be shown in both 
locations in the design explorer. 

 

 To change a constraint's properties: 

You can change constraint properties such as offset distance or angle after a constraint has been 
applied. 

1. Right-click the constraint in the Design Explorer and select Edit from the pop-up menu.  The 
Assembly Constraints dialog appears. 

2. Modify the appropriate parameters. 

3. Click OK to apply the changes. 

 

 To rename a constraint: 

You can customize the constraint label in the Design Explorer. 

1. Right-click the constraint in the Design Explorer and select Rename from the pop-up menu; or 
double-click the constraint with a short pause between clicks.  The text cursor appears in the 
label. 

2. Type in a new label. 

3. Press Enter on the keyboard. 
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 To delete a constraint: 

Select the constraint and press Delete on the keyboard; or right-click the constraint in the Design 
Explorer and select Delete from the pop-up menu.  

The constraint is deleted. 
 

11.4.5    Using the Auto Constrain Mode Tool 

You can use the Auto Constrain Mode tool to quickly place mate and align constraints.  A mate 
constraint is applied if planar faces or linear edges are selected.  An align constraint is applied if 
cylindrical faces or edges are selected. 

 To use the Auto Constrain Mode tool: 

1. Select the Auto Constrain Mode  tool from the Assembly Modeling toolbar; or from the 
Tools menu select Auto Constrain; or press Ctrl + Shift + C on the keyboard. 

2. Select the first entity. 

3. Hold the Shift key on the keyboard and select the second entity. 

The constraint is applied and is listed in the Design Explorer.  

You will remain in auto constrain mode until you select a different tool. 

 
 

11.4.6    Failed Assembly Constraints 

A constraint may fail due to the following reasons:                                                                                

• Constraint was initially applied incorrectly, e.g. applying an align constraint to a planar face 
and a non-planar face. 

• The constraint creates an over-defined condition. 

• A condition changes after the constraint was applied, e.g. deleting a part from an assembly 
or the geometry in which the constraint applies is modified. 

A failed constraint is displayed in italics in the Design Explorer.  In the example below, the Align 
constraint has failed. 
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It is recommended you resolve a failed constraint as soon as the condition occurs. 

 To troubleshoot and resolve a failed constraint: 

• Right-click the constraint and select Status from the pop-up menu.  A dialog appears 
containing information related to the cause of the constraint failure. 

• Right-click the constraint and select Edit.  The Assembly Constraint dialog appears. Modify 
the constraint conditions if applicable. 

• In some cases, you may need to delete the constraint altogether and reapply the constraint. 
 

11.5    Flexible Subassemblies 

By default, subassemblies inserted into an assembly are rigid.  This means that a subassembly is 
treated as a rigid body for purposes of positioning and constraining it in the context of the parent 
assembly.  Consequently, if multiple instances of a subassembly are inserted into an assembly, the 
components in each instance will be in identical relative positions. 

You can easily convert a subassembly from rigid to flexible.  When a subassembly is made flexible, 
all of the parts in that subassembly can be positioned and constrained independently within the 
context of the top level assembly. 
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In the example shown here, two instances of a piston assembly are placed in the engine assembly.  
By default, these subassemblies are rigid.  Since each piston subassembly is treated as a rigid body, 
it is not possible to properly constrain them such that each piston is aligned with its respective 
cylinder and each connecting rod is aligned with the crankshaft.  This is because in order to 
completely satisfy the set of constraints, the piston in the second subassembly must move relative to 
its connecting rod.  You can easily accomplish this by making the second subassembly flexible. 

 To make a subassembly flexible: 

Right-click the desired subassembly in the Design Explorer and click the Make Flexible toggle on 
the pop-up menu. 

Each part in the subassembly can now be constrained independent of the other parts in the 
subassembly.  In the example above, it is now possible to properly locate each piston subassembly, 
as shown here: 

 

 

You can again make a subassembly rigid by turning off its Make Flexible toggle. 

Note: You can not use the Make Flexible command on any subassembly that contains a pattern. 
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11.6    Checking for Interferences 

You can check for interferences between selected assembly parts, selected groups of parts, or all 
assembly parts. 

 To check for interferences: 

1. Select the Check for Interferences  tool from the Inspection toolbar; or from the Tools 
menu select Check for Interferences.  The Interferences dialog appears. 

 

2. Select Global or User Specified Groups.  The Global option checks for interferences 
considering all parts of the assembly.  The User Specified Groups option checks only the 
parts you select. 

3. If you selected User Specified Groups, you must select at least one part in Group 1.  You can 
then choose to check for interferences between the selected Group 1 part(s) against: 

• Group 1: checks for interferences within the selected Group 1 parts (requires at 
least two selections) 

• Group 2: checks for interferences between Group 1 parts and parts selected in 
Group 2 

• All Other Items:  checks for interferences between Group 1 parts and all other parts 
in the assembly 
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4. Click the Check button.  The number of interferences detected is listed in the Interference 
found box.  Each interference will also be listed individually specifying which parts are 
interfering as well as the interfering volume. 

 

5. To further analyze interferences, select interference Display Options: 

• Show All Interfering Volumes: displays the detected interferences in red 

• Wireframe Non-Interfering Parts: displays the parts that are not interfering in 
wireframe display mode 
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• Hide Parts Not in Group 1 or Group 2: hides any parts that were not in the Group 1 
or Group 2 selections 

 
Figure 88: Assembly shown in work area with interfering volume highlighted 

6. To export the interference information to a .CSV file, click the Export button. 

 
 

11.7    Inserting an Exploded View 

You can insert exploded views of the assembly during the design process.  The exploded view 
allows you to display a configuration of the assembly with the parts separated.  You can use the auto 
explode mechanism, manually separate parts, or a combination of both.  You can create multiple 
exploded views in an assembly workspace.  The exploded views are saved with the design and can 
subsequently be used as views in drawings. 

The assembly parts must be constrained before the exploded view can be used.  The exploded view 
however, has no effect on the interpretation of assembly constraints. 
 

11.7.1    Inserting an Exploded View Using Auto Explode Mode 

You can create multiple exploded views in an assembly workspace.  You can auto explode an 
assembly to quickly create an exploded view of an assembly.  Mate and align assembly constraints 
must be applied before an exploded view can be created. 
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 To insert an exploded view using Auto Explode mode: 

1. From the Insert menu, select Exploded View.  The assembly changes to the exploded view.  
An Exploded View item is listed in blue under the Exploded View node in the Design Explorer.  
By default, exploded views will be labeled Exploded View(1), Exploded View(2), etc.  You can 
rename an exploded view if desired (right-click the view and select Rename from the pop-up 
menu). 

 

 

The majority of the assembly modeling tools become dimmed and the explode view tools 
become available on the Assembly Modeling toolbar. 

 
Manual Explode ... explode the parts manually 

 
Auto Explode ... allow the software to explode the parts automatically 

 
Expand Explosion ... increase the distance parts explode (auto mode) 

 
Contract Explosion ... decease the distance parts explode (auto 
mode) 

 
View Part Trails ... show/hide the trail lines 

 
Edit Exploded View Steps ... view/edit exploded view steps 

 

2. To automatically explode the assembly, click the Auto Explode Assembly  tool from the 
Assembly Modeling toolbar; or from the Tools menu, select Auto Explode Assembly.  The 
assembly is exploded.  The distances placed between assembly parts are automatically 
calculated based on part size and orientation.  
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By default, trail lines are displayed in the work area which provide a visual guide between 
a part and the part it is constrained to. 

 
Figure 89: Exploded View Displaying Trail Lines 

3. To hide the trail lines, unselect the View Part Trails   tool on the Assembly Modeling 
toolbar; or from the View menu, unselect Exploded View Trails. 

4. To increase or decrease the explode distance, click the Expand Explosion  tool (to 

increase) or the Contract Explosion  tool (to decrease) from the Assembly Modeling 
toolbar; or from the Tools menu, select Expand Explosion or Contract Explosion. 

5. Continue to expand or contract the exploded view until the desired view is achieved. 

6. To restore a part back to its original position, right-click the part and select Restore To Default 
Position from the pop-up menu. 

7. To exit the exploded assembly view and return to normal assembly mode, right-click the 
exploded view in the Design Explorer and select Exit Exploded View from the pop-up menu; 
or from the Edit menu, select Exit Exploded View; or right-click in the work area and select 
Exit Exploded View from the pop-up menu.  

The assembly is returned to its normal view.  
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11.7.2    Inserting an Exploded View Using Manual Explode 

You can create multiple exploded views in an assembly workspace.  You can use the manual 
explode mode to create a custom exploded view of an assembly.  Assembly constraints must be 
applied before an exploded view can be created.  You can use manual explode mode in conjunction 
with auto explode mode. 

 To insert an exploded view using Manual Explode mode: 

1. From the Insert menu, select Exploded View.  An Exploded View item is listed in blue under 
the Exploded View node in the Design Explorer.  By default, exploded views will be labeled 
Exploded View(1), Exploded View(2), etc.  You can rename an exploded view if desired 
(right-click the view and select Rename from the pop-up menu). 

2. To enter Manual Explode mode, select the Manual Explode Mode  tool from the 
Assembly Modeling toolbar; or right-click in the work area and select Manual Explode Mode 
from the pop-up menu; or from the Tools menu, select Manual Explode Mode. 

3. To specify the explode direction, select an axis, reference plane, model edge, model planar 
face, or model cylindrical face.  You can specify a different explode direction for each part you 
want to separate.  Reference arrows will subsequently be displayed near your selection. 

 
Figure 90: Manual Explode Mode - Displaying Reference Arrows 
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4. The reference arrows allow you to specify the direction in which you want to manually move a 
part.  The arrow that is currently selected is displayed in yellow and defines the direction the 
part will move in.  To select a different direction, select a different arrow.  To remove the 
reference arrows, click anywhere in any open space in the workspace.  

5. Select the part you want to move by left-clicking the part.  The part is highlighted.  To select 
multiple parts to move simultaneously, continue to click additional parts while holding the Shift 
key. 

 
Figure 91: Manual Explode Mode - Displaying Selected Part 

6. Left click again and drag the part(s) in the direction defined by the highlighted reference arrow.  
You can also move the part(s) in the direction opposite the arrow is pointing. 
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7. Release the mouse button to complete the separation. 

 
Figure 92: Manual Explode Mode - Displaying Final Part Location 

Tip: If you want to move an entire subassembly as one entity, select it in the Design Explorer 
so that all of the parts in the subassembly highlight.  Then left click in the work area and drag 
the mouse to move the part(s) to the desired location.  

8. By default, trail lines are displayed in the work area which provide a visual guide between a part 

and the part it is constrained to.  To hide the trail lines, unselect the View Part Trails  tool 
on the Assembly Modeling toolbar; or from the View menu, unselect Exploded View Trails. 

9. To exit Manual Explode Mode, unselect the Manual Explode Mode  tool from the 
Assembly Modeling toolbar; or from the Tools menu, unselect Manual Explode Mode. 

10. To automatically increase or decrease the explode distance after moving a part or parts, click 

the Expand Explosion  tool (to increase) or the Contract Explosion  tool (to 
decrease) from the Assembly Modeling toolbar; or from the Tools menu, select Expand 
Explosion or Contract Explosion. 

11. Continue to expand or contract the exploded view until the desired view is achieved. 

12. To restore a part back to its original position, right-click the part and select Restore To Default 
Position from the pop-up menu. 
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13. To exit the exploded assembly view and return to normal assembly mode, right-click the 
exploded view in the Design Explorer and select Exit Exploded View from the pop-up menu; 
or from the Edit menu, select Exit Exploded View; or right-click in the work area and select 
Exit Exploded View from the pop-up menu.  

14. The assembly is returned to its normal view.  

 
 

11.7.3    Viewing and/or Editing an Exploded View 

You can view and edit an exploded view at anytime. 

 To view and/or edit an exploded view: 

1. In the Design Explorer, right-click the Exploded view you want to edit and select Edit from the 
pop-up menu; or select the Exploded view and from the Edit menu, select Edit Exploded 
View.  

The Exploded view being edited is listed in blue text in the Design Explorer and is 
displayed in the work area. 

 

2. If necessary, make any necessary changes to the Exploded view. 

3. To return to the normal assembly view, right-click the Exploded view being edited and select 
Exit Exploded View from the pop-up menu. 

 

11.7.4    Exploded View Steps 

The Exploded View Step Editor allows you to create and manage steps for your exploded view.  
These steps will be similar to what an instruction manual describing the assembling information for 
the assembly would look like.  The steps can be used later when Publishing to PDF to animate the 
exploded view.  (This is available for users with Full Publishing capability only) 

The exploded view steps can be created in two ways:  

1. If you choose to auto-explode your assembly, the steps are automatically created as well.   

2. If you choose to manually explode your assembly, a new step is created each time you move a 
part.   However, only one step exists for each part in the assembly, so if you move a part a 
second time, then the step for it simply updates.  
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Characteristics of exploded view steps  

• Each step will only move a single part from its initial position to its exploded position or from 
its exploded position to its initial position. 

• A step can be moved to a different position in the sequence of steps. 

• You can give a name to each step as well as a description of what that step does. 

 

Editing exploded view steps 

You can access the Exploded View Step Editor in 4 different ways:  

• From the Edit menu, choose Edit Exploded View Steps 

• In the Design Explorer, right click on the Exploded View and choose Edit Exploded View 
Steps 

• Right-click in the work area, and choose Edit Exploded View Steps 

• From the Assembly Modeling toolbar, select the Open Exploded View Step Editor tool .  

You must be currently viewing an existing exploded view that has at least one part moved from its 
default location for any of the above options to be available.  

Once you have the Exploded View Step Editor open, you can click on each step, and the part 
associated with that step will be highlighted in the work area.  You can name a step, add a 
description, or change the sequence of the steps.  

 

 To modify a step:  

1. Click on the step you wish to edit.  

2. In the Name field, type a name that you want to use to refer to that step.  

3. In the Description field, enter a description of what that step does.  

4. Using the movement buttons on the right, move the step up or down in the sequence, or move 
it to the first or the last position in the sequence. 
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5. If you would like to combine 2 or more steps into one, press and hold the Control key as you 
select all of the steps that you wish to combine, and then click the Group Steps button.  (This 
action can only be reversed by using the Edit - Undo command while viewing the Exploded 
view, prior to exiting the model.)  This capability allows you to show movement of multiple parts 
simultaneously when the exploded view is published to PDF.  (Full Publishing licenses only) 

6. Choose Apply, then Close.  

 
 

11.7.5    Deleting an Exploded View 

 To delete an exploded view: 

1. Make sure you are not currently editing any Exploded views. 

2. In the Design Explorer, right-click the Exploded view you want to delete and select Delete from 
the pop-up menu; or select the Exploded view in the Design Explorer, and press Delete on the 
keyboard. 

 

11.7.6    Duplicating an Exploded View 

You can create a copy of an existing exploded view. 

 To duplicate an existing exploded view: 

1. Make sure you are not currently editing any Exploded views. 

2. In the Design Explorer, right-click the Exploded view you want to duplicate and select 
Duplicate from the pop-up menu; or select the Exploded view in the Design Explorer, and from 
the Insert menu, select Duplicate Exploded View.  

 A copy of the Exploded view is listed in the Design Explorer. 
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11.8    Saving and Opening an Assembly 

You can save an assembly and its constituents to the same local repository, to different local 
repositories, to remote repositories, or to the file system. 
 

11.8.1    Saving a New Assembly 

1. Select the Save  tool from the Standard toolbar; or from the File menu select Save.  The 
Save dialog appears.  

The top-level assembly is listed first in the item tree in the left-most column of the dialog. 

The following parts/subassemblies will be listed under the top-level assembly: 

• Any new parts that were created in the assembly. 

• Any existing parts or subassemblies that were inserted into the assembly and 
subsequently edited. 

The assembly icon  is displayed next to the top-level assembly. 

A blue part icon  and/or colored assembly icon  are displayed next to new parts 
and sub-assemblies, respectively, that have not been previously loaded from the 
Repository  (this includes new parts and imported parts/subassemblies). 

A gray part icon and/or gray assembly icon are displayed next to parts and sub-
assemblies, respectively, that have been previously saved to the Repository and have 
been edited in the context of the assembly. 

Existing items that were inserted into the assembly but were not edited will be saved with 
the top-level assembly but will not be listed in the Save dialog. 
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2. You can specify a name for the new assembly and each new part or sub-assembly that you 
created in the assembly.  Click each individual item in the item tree and then enter a name for 
the item in the Name field. 

 

 To save an assembly to the file system: 

1. Click the File System tab. 

2. Navigate to the file system folder in which you want to save the assembly. 
 
Note:  If you are saving an item as native Alibre STEP, you can specify a different save 
location for each item.  To do so, select the item in the item tree and then select the appropriate 
file system folder.  If you do not specify locations for each item, new assembly items will be 
saved to the location used for the top-level assembly. 

3. To create a new folder at the currently selected location, click New Folder. 

4. If desired, click Advanced to enter detailed comments about the assembly. 

5. In the Name field, type the assembly name. 

6. Click Save to save the assembly. 
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 To save an assembly to the repository: 

1. Click the Repository tab. 

2. Select a repository from the Repository Explorer and/or click the plus sign  next to a 
repository to expand it and display the folders within.  Select a folder as the save location if 
desired.  

Note:  If you are saving an item as a native Alibre STEP, you can specify a different save 
location for each item.  To do so, select the item in the item tree and then select the appropriate 
repository and/or folder.  If you do not specify locations for each item, new assembly items will 
be saved to the location used for the top-level assembly. 

3. If desired, click Advanced to enter detailed comments about the assembly. 

4. In the Name field, type the assembly name. 

5. Select the Save as type from the list.  The default type is the native Alibre format. 

6. By default, the Make new version for all option is on.  This option creates a new version of the 
design each time a save is completed.  If you prefer to maintain one version of a design, 
unselect the Make new version for all option. 

7. Click Save to save the assembly. 

 
 

11.8.2    Opening an Assembly 

You can open a previously saved assembly from the Home window, from the Repository or from an 
open workspace. 

 To open an assembly from the Home window or any workspace: 

1. Select the Open  tool from the Standard toolbar; or from the File menu select Open.  The 
Open dialog appears. 

2. Using the Document Browser embedded in the Open dialog, navigate through the repository 
or the file system to the location of the desired assembly. 

3. Select the assembly from the item list and click OK; or double-click the assembly in the item 
list. 

 



 Chapter 11 - Assembly Design 

 
 
 

350 

 To open an assembly from the repository: 

1. In the Repository Explorer, browse to the location the assembly is stored in.  If necessary, 
click the plus sign  next to a repository to expand it and display the folders within. 

2. To open the assembly, double-click the assembly in the item list; or right-click the assembly in 
the item list and select Open from the pop-up menu; or select the assembly in the item list and 

select the Open  tool from the Standard toolbar. 

 
 

11.8.3    Manually Updating Parts/Sub-assemblies 

By default, when you open an assembly, the latest versions of all the assembly's constituents are 
automatically opened.  However, if desired, you can choose to manually update parts/sub-
assemblies upon opening an assembly.  Consequently, if any parts/sub-assemblies have changed 
since the last time you opened the assembly, you will be prompted to manually update the modified 
constituents to the latest version. 

 To turn on the prompt for newer versions option: 

1. In any open workspace, from the Tools menu, select Options.  The Options dialog appears. 

2. Click the General tab if it is not already selected. 

3. In the Design area, click the Prompt for newer versions check box. 

4. Click OK. 

 

 To manually update an assembly constituent: 

1. Open the assembly.  If any constituents have changed since last opening the assembly and 
need to be updated, the Version Status dialog appears. 

A green node displayed next to a constituent indicates that the constituent's version is 
current.  A yellow indicates that a newer version of the constituent exists.  A red node 
indicates that the constituent cannot be found. 

2. To update an outdated constituent so that the most current version is used, select the 
constituent in the list and click Update. 

3. To update a sub-assembly and its constituents, select the sub-assembly in the list, click the 
Update branch check box, and then click Update. 
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4. To update a constituent that is used in multiple sub-assemblies, select the constituent in the 
list, click the Update all instances check box, and then click Update. 

5. To update a constituent that cannot be found, select the constituent in the list, and click Search 
to automatically search for the constituent in your repositories as well as any repositories that 
are currently shared to you.  If the constituent is found, the node will turn yellow and you will 
need to update it. 

6. To replace a constituent that cannot be found with a different constituent, select the constituent 
from the list, and click Replace.  The Insert Design dialog appears.  Select a constituent from 
the Repository Explorer and click OK. 

7. Click OK in the Version Status dialog to open the assembly. 

 
 

11.9    Editing and Designing Parts in the Assembly 

As previously mentioned in this chapter, you can edit existing parts as well as design new parts in 
the context of the assembly.  You can reference existing geometry while editing existing parts and 
designing new parts. 
 

11.9.1    Creating a New Part Within an Assembly 

 To create a new part in the assembly: 

1. From the Insert menu select New Part or New Sheet Metal Part; or press Ctrl + Shift + N (for 
new part) on the keyboard.  The work area changes from assembly edit mode to part edit 
mode.  The Sketching and Part Modeling toolbars are displayed on the right side instead of the 
Assembly Modeling toolbar.  All other parts in the assembly will be displayed semi-
transparently. 

Note:  New Sheet Metal Part is only available in Alibre Design Professional and Alibre Design 
Expert. 

Additionally, the new part is listed in blue in the Design Explorer to signify that it is 
currently being edited. 
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2. Construct the part features using the same techniques used to create a part in a part 
workspace.  

You can use edges and faces on other parts as the sketch plane in the new part.  You can 
also use edges and faces on other parts as references or targets as you model the new 
part.  You can also project entities from existing assembly parts onto a sketch plane in the 
new part to create sketch or reference figures. 

While in part edit mode, if you use a face on an existing part as a sketch plane or to create 
a new reference plane, an inter-design constraint (see "Inter-Design Constraints" on 
page 330) will automatically be created.   

3. You can switch back to assembly edit mode at any point.  To do so, right-click the part listed in 
blue in the Design Explorer and select Edit Root Assembly from the pop-up menu; or right-
click the top-level assembly in the Design Explorer and select Edit Part/Subassembly from the 
pop-up menu. 

 

11.9.2    Editing a Part in an Assembly 

You can edit a part without leaving the context of the assembly.  While editing a part in assembly 
mode, you can reference geometry on other parts while sketching or creating new features.  

You can also edit a part in an independent workspace as well.  After saving and closing the 
workspace, the changes made to the part will automatically be reflected in the assembly. 

 To edit a part in the context of the assembly: 

1. Right-click the part in the Design Explorer and select Edit Part/Subassembly from the pop-up 
menu; or select the part in the Design Explorer or work area and from the Edit menu select 
Edit <Part Name>.   

The work area changes from assembly edit mode to part edit mode.  The Sketching and Part 
Modeling toolbars are displayed on the right side of the work area instead of the Assembly 
Modeling toolbar.  All other parts in the assembly remain visible but are displayed semi-
transparently.  The part you are editing remains fully shaded. 
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Figure 93: Editing Part in Assembly - Displaying Part Shaded 

The part being edited is listed in blue in the Design Explorer and all the associated 
reference geometry, sketches, and features can be accessed. 

 

2. Edit the part sketches or features just like you would in a part workspace.  You can also add 
new features if required. 
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3. After making the necessary changes, return to assembly edit mode by right-clicking the part 
being edited in the Design Explorer and select Edit Root Assembly; or right-click the top-level 
assembly in the Design Explorer and select Edit Part/Subassembly. 

 

 To edit a part in an individual workspace: 

1. While holding the Shift key, right-click the part you want to edit in the Design Explorer and 
select Edit Part/Subassembly.  The part opens in a separate workspace. 

2. Make any necessary changes to the part.  The changes will be applied to the assembly 
automatically. 

3. When finished editing, close the part workspace.  In this case, you do not save the part from 
the part workspace.  You are returned to the assembly workspace and can continue working.  
When you save the assembly, any parts that you modified will also be saved. 

 
 

11.9.3    Improving Assembly Performance when Editing Parts 

When editing a part in the context of an assembly, you may notice that editing is a little slower than if 
you were editing it as a stand-alone part (outside the context of an assembly). 

The reason for this is that if your part has inter-part relationships, the assembly must re-evaluate 
these relationships each time you make an edit (the edits could be any modification, including 
adding dimensions to a sketch, creating a new sketch, creating a new feature, etc.)  The more inter-
part relationships you have, the more time is required to evaluate the model.  

Inter-part relationships are dependencies that one part has on other parts.  For example, if you 
project the edge of a feature (with Maintain Associativity checked on) into another part to use it to 
create a feature in the second part.  Another example would be if you created a sketch and created 
a dimension to a feature in another part.   

You can control whether or not Alibre Design evaluates all of these relationships on-the-fly, or all at 
once when you are ready for it to happen.  You do this using the Auto-Regenerate tool. 

If Auto-Regenerate is checked ON (this is the default behavior), all relationships will be evaluated 
on-the-fly.  If Auto-Regenerate is checked OFF, relationships will be evaluated at a specific time, as 
determined by one of the situations listed here: 

At any point during edit of the part, you turn ON Auto-Regenerate. The immediate effect of turning 
ON this switch is that all relationships are evaluated and all pending changes take effect and get 
displayed on the screen. From this point all new edits will result in on-the-fly evaluation. 
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If you do NOT explicitly turn on Auto-Regenerate, but you exit edit part mode, then at that time all 
the pending evaluations will be performed and the assembly will be brought up-to-date and its 
display updated. As a result, exiting edit mode could take a little longer to complete. Auto-
Regenerate will continue to remain turned OFF for subsequent editing operations.    

 

 To turn Auto-Regenerate On and Off: 

1. From the Tools menu, select Auto-Regenerate.  This is an on/off toggle.  If the option is check 
marked, it is on.  If it is not check marked, it is off.  

 
 

11.10    Importing Parts into an Assembly 

You can import parts and subassemblies into an assembly and subsequently use them in the 
design.  You can import STEP, SAT, and IGES files into an assembly.  To learn more about 
importing data refer to the chapter on importing and exporting data (on page 469). 

 To import a part into an assembly: 

1. Select the Import  tool from the Standard toolbar; or from the File menu select Import.  
The Import File dialog appears. 

2. Browse to the location of the file that you want to import. 

3. Select the file to import. 

4. Click Open.  The part/subassembly appears in the assembly workspace and is listed in the 
Design Explorer.  You can constrain the imported parts to existing parts and vice versa. 

 

11.11    Joining Parts & Removing Material in an Assembly 

You can use the Assembly Boolean command to either join multiple parts together into a new 
single part or to remove material from parts in an assembly.  The result is one or more new parts 
that can be added into the existing assembly or placed in a new workspace. 
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 To join parts in an assembly: 

          

1. From the assembly workspace, select the Assembly Boolean command from the Tools main 
menu.  The Assembly Boolean dialog appears. 

2. Select the parts to join from the Design Explorer or the 3D work area.  These will be listed in 
the Blanks field. 

3. Check the Join All Blanks option. 

4. If you want the resulting joined part to be placed in the original assembly, check the option 
Insert results into current assembly.  If you want the joined part in a separate workspace, 
uncheck this option. 

5. Keep the Tools field empty.  Click OK.  The selected parts are joined together.  The joined part 
is represented in the Design Explorer as a new part with an Imported SAT File feature. 

 



Chapter 11 - Assembly Design 

 
 
 

 357 
 

     

 

 To remove material in an assembly: 

You remove material from parts in the assembly by specifying one or more parts that will be used as 
tools for cutting away material. From the assembly workspace,  select the Assembly Boolean 
command from the Tools main menu.  The Assembly Boolean dialog appears. 

1. Select the parts from which you want to remove material from the Design Explorer or the 3D 
work area.  These will be listed in the Blanks field. 

2. Click in the Tools field and then select the parts you want to use for cutting. 

3. Use the Join All Blanks option if you want to unite all the blanks into a single part. 

4. If you want the resulting cut parts to be placed in the original assembly, check the option Insert 
results into current assembly.  If you want the cut parts in separate workspaces, uncheck 
this option. 

5. Click OK.  The selected blank parts are cut by the selected tool parts.  Each cut blank is 
represented in the Design Explorer as a new part with an Imported SAT File feature.  
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C H A P T E R  1 2  

 Drawings 
You can create 2D drawings of the parts and assemblies you create.  Standard 2D views can be 
created automatically from the part or assembly.  Custom views can be created based on the 
standard views already present in the drawing. 

In This Chapter 

Creating a New Drawing.......................................................................................... 360 
Saving and Opening a Drawing............................................................................... 367 
Working in a Drawing .............................................................................................. 369 
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Inserting Additional Views ....................................................................................... 400 
Custom Templates .................................................................................................. 415 
Annotations.............................................................................................................. 420 
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12.1    Creating a New Drawing 

12.1.1    Opening a New Drawing 

You can open a new drawing from the Home window, Repository, or any open workspace. 

 To open a new drawing from the Home window, repository, or any workspace: 

Select the New Drawing  tool from the Standard toolbar; or, from the File menu, select New > 
Drawing.  The New Sheet Properties dialog appears. 

 
 

12.1.2    Selecting a Drawing Template 

You can select from a number of standard drawing templates, your own custom templates, or a 
blank drawing of varying size.  ANSI, DIN, and ISO drawing templates are supported. 

 To select a drawing template: 

1. In the New Sheet Properties dialog, select Template or Blank Sheet. 

2. If you selected Template, also select a standard drawing template from the list.  To use a 
custom drawing template not listed, click Browse and select the template from the Custom 
Drawing Template dialog. 
 
OR, if you selected Blank Sheet, select a sheet size from the list. 
 
Note:  If you have previously browsed to another template folder, you can use the Default 
button to reset the template list back to the system template folder. 

3. If desired, enter a name for the sheet in the Sheet Name field. 

4. In the Default View Scale area, specify the scale to use in the drawing.  The scale can be 
changed later if necessary. 

5. To create a drawing with no models associated with it, check the Create An Empty Drawing 
box. 

6. Click OK.  If you selected a standard or custom template, the Fill In Text dialog may appear. 
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12.1.3    Specifying Standard Drawing Information 

When using standard or custom drawing templates, you can enter standard text information such as 
drawn by, drawn date, and drawing number. 

 To specify standard drawing information: 

1. In the Fill In Text dialog, select the DRAWN item from the Select Tag Field list and then type 
the appropriate information in the text box to the right.  

2. Repeat for DRAWN DATE and DWG NO. 

3. Click OK.  The drawing workspace and Insert Design dialog appear. 

Note:  To leave these fields blank, click OK without entering any information. 

 
 

12.1.4    Selecting the Model 

You can create 2D drawing views automatically using the views from a part or assembly. 

 To select the model: 

1. In the Insert Design dialog, use the Document Browser to select the part or assembly from 
which the 2D drawing views will be created. 

2. Click OK.  The Standard Views Creation dialog appears and the selected design populates 
the Design field. 
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12.1.5    Inserting Standard Views 

You can select which standard views you initially want to create in the drawing.  You can insert 
additional standard views later as necessary. 

 

 To insert the standard views: 

1. A preview of the selected part or assembly is shown in the Front View preview window.  To 
select a different part, click the Browse button to make a new selection. 

2. Select the view that you want to use as the Front View in the drawing.  You can use the arrow 
buttons to reorient the view in the preview window. 

     

You can also click the Workspace Orientation button to select from default and custom views 
created in the part or assembly workspace. 
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3. In the View Selections area select the views that you want to insert into the drawing.  The 
default views are Front, Top, and Right.  To add or remove a view, click the view's 
corresponding button. 

 

4. If multiple configurations of the design exist, select which one you want to use for these views 
from the Configurations list. 

5. In the case of assemblies, if any exploded views were created in the assembly workspace, you 
can also select an exploded view from the Exploded Views list. 

6. To see all of the options at the bottom of the dialog, if they are not visible, click the More 
Options button.  

7. In the View Creation Options section: 

a. Check the Fast Views box to use Fast View Mode (see "Fast Views" on page 365) on 

these views.  Fast View mode produces a less precise image (visually), but is substantially 

faster for large or very complex assemblies.  

b. Enter a value for the view scale into the Scale field; or, check the option Use Sheet scale, 

which will select the Sheet scale that was set in the New Sheet Properties dialog. 

c. Select the Project as Flat Pattern option if desired for sheet metal parts. 

8. In the View Detailing Options section: 

a. Check Select All to enable all of the available options. 

b. Check Hidden Lines to display the entities that would not be directly visible. 

c. Check Centermarks and/or Centerlines if you want to display them.  
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d. Check the Design Dimensions box if you want to display the driving dimensions from the 

model.  (These will be the original model dimensions.  If you have used any Push/Pull 

functions, the final model dimensions resulting from those will not be displayed.) 

e. Check Hole Callouts to display the full hole callout for holes created using the Hole 

feature. 

f. Check Cosmetic Threads to display a representation of the threads on a threaded hole.  

g. Check Tangent Edges to include the tangent edges in the view. 

h. Check Bend Centerlines to add center lines to bends in sheet metal parts. 

i. Check Part Trails to include the trail lines for exploded views of assemblies. 

9. Click OK to create the views.  Previews of the selected views are displayed in the work area.  
Note that the cursor is essentially tied to the front view.  As you move the cursor, the views will 
all move together.  

10. Move the cursor to dynamically re-position the front view to the correct location within the 
drawing sheet. 

11. Click to place the front view.  The corresponding views are also placed.  The dimensions that 
were used to create the part are displayed automatically in the corresponding view (if you 
checked the option to include design dimensions). 

The Drawing Explorer on the left side of the work area lists the sheets associated with 
the drawing as well as the views associated with each sheet.  The associated design is 
also listed under the view.  

 
Figure 94: Drawing Explorer showing parts listed under each view 

 

NOTE:  Alibre Design supports both First Angle and Third Angle projection methods.  You can set 
the projection method for a drawing in the Detailing tab of the Drawing Properties dialog.  Click 
Properties in the File main menu to bring up the Drawing Properties dialog. 
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12.1.6    Fast Views 

When you insert views into a drawing, you can choose one of two different modes to create the new 
views: Fast View or Precise View. Precise View mode is the standard mode and will always be used 
as the default.  Fast Views are useful for large or complex drawings, because they require less time 
to generate than views in the standard Precise mode.  There are some limitations when using Fast 
Views, so once you are no longer making a large number of changes to the model, you should 
convert your views to Precise Views.  You can include both Fast Views and Precise Views in the 
same drawing.  

Fast Views are noted by a specific icon in the Drawing Explorer , so you can easily tell whether 
or not a view is in Fast View mode.   

 
Figure 95: Drawing Explorer with icons denoting Fast Views and Precise Views 

 To use Fast View mode: 

1. Begin the process to insert standard views (see "Inserting Standard Views" on page 362). 

2. In the Standard Views Creation dialog, click the More Options button.  

3. Check the Fast Views option on.  

4. Continue selecting the desired options and then click OK to proceed with the view creation.  

 

Benefits of Fast Views 

Fast View mode is recommended for use with very large or very complex models.  The standard 
Precise View mode can take a long time to generate drawing views for these models.  Using Fast 
View mode, these views are generated 4-10 times faster, allowing you to get started detailing your 
drawing much sooner.  When you have finished working on your model, and have completed the 
detailing on the drawing, you can convert your views to Precise Views.  
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Note:  For small models, and models that are not complex, there is no perceptible difference 
between the two modes, so the standard Precise View mode should be used.  

 

Limitations of Fast Views 

The primary difference between Fast Views and Precise Views is that the image created using Fast 
Views is not as high quality as the image created using Precise View mode. In addition, Fast Views 
are visually affected by the circular faceting (see "Curve Smoothness" on page 281) value you are 
using in the 3D workspace. Fast Views should be considered to be "drafts" of the final 2D drawing. 
You can convert a Fast View to a Precise View at any time to improve the visual quality. 

You will want to convert your views to Precise Views before printing the 2D drawing, for a higher 
quality print.  

There are certain functions you will not be able to access within a view that was created using Fast 
Views: 

• If an assembly or subassembly contains BOTH inter-design constraints AND design 
configurations, Fast View mode will not be available when creating drawing views of the 
assembly. 

• You cannot refine edges. 

• You cannot set the layers of edges. 

• You do not have control over the appearance of hidden or visible lines. 

• Fast Views must be reprojected every time you open a drawing which uses them. If the 3D 
model data (for parts and assemblies) cannot be located, the views cannot be created and 
will be blank. 

• The ability to dimension segment data is not available in Fast Views. The majority of 
standard 2D drawing detailing practices do not involve using segment data so this will not 
likely be a problem for most users. 

Note:  All of these functions become available once the view is converted to a Precise View. 

 To convert Fast Views to Precise Views 

1. Right click on the view and select Create Precise View.  If this option is not available, then 
your view is already a Precise View. 

    Or, 

1. Right click on the view in the Drawing Explorer and select Create Precise View. If this option is 
not available, then your view is already a Precise View. 
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12.2    Saving and Opening a Drawing 

12.2.1    Saving a New Drawing 

 To save a drawing to the file system: 

1. Select the Save  tool from the Standard toolbar; or from the File menu select Save.  The 
Save dialog appears.  The drawing icon will be displayed next to the drawing name in the item 
list.  If you made changes to driving dimensions in the drawing, the associated part also will be 
displayed in the item list.  A gray part icon will be displayed next to the part. 

2. Click the File System tab. 

3. Navigate to the file system folder in which you want to save the drawing. 

4. To create a new folder at the currently selected location, click New Folder. 

5. If desired, click Advanced to enter detailed comments about the drawing. 

6. In the Name field, type the drawing name. 

7. Click Save to save the drawing. 

 

 To save a drawing to the repository: 

1. Select the Save  tool from the Standard toolbar; or from the File menu select Save.  The 
Save dialog appears.  The drawing icon will be displayed next to the drawing name in the item 
list.  If you made changes to driving dimensions in the drawing, the associated part also will be 
displayed in the item list.  A gray part icon will be displayed next to the part. 

2. Click the Repository tab. 

3. Navigate to the location in which you want to save the drawing. You can click the plus sign  
next to a repository to expand it and display its folders.  You can save the drawing directly 
under the selected repository or into any of the repository's folders 

4. To create a new folder at the currently selected location, click New Folder. 

5. If desired, click Advanced to enter detailed comments about the drawing. 
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6. In the Name field, type the drawing name. 

7. Select the Save as type from the list.  The default type is the native Alibre Design format. 

8. By default, the Make new version for all option is selected.  This option creates a new version 
of the drawing each time a save is completed.  If you prefer to maintain one version of a 
drawing, deselect the Make new version for all option. 

9. Click Save to save the drawing. 

 
 

12.2.2    Opening a Drawing 

Opening a drawing 

You can open a previously saved drawing from the Home Window, from the Repository or from an 
open workspace. 

 To open a drawing from the Home window or any workspace: 

1. Select the Open  tool from the Standard toolbar; or from the File menu select Open.  The 
Open dialog  appears. 

2. Using the Document Browser embedded in the Open dialog, navigate through the repository 
or the file system to the location of the desired part 

3. Select the drawing from the item list and click OK; or double-click the drawing in the item list. 

 

 To open a drawing from the repository: 

1. In the Repository Explorer, browse to the location the drawing is stored in.  If necessary, click 
the plus sign  next to a repository to expand it and display the folders within. 

2. To open the drawing, double-click the drawing in the item list; or right-click the drawing in the 
item list and select Open from the pop-up menu; or select the drawing in the item list and select 

the Open  tool from the Standard toolbar. 
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Immediately after opening a drawing, you have the ability to perform limited functions in the drawing, 
while the design(s) related to the drawing continue to load.  Large drawings containing numerous 
designs can take some time to fully load.  The following functions are available as soon as the 
drawing is visible: 

• Print and Print Preview 

• Zoom and Pan 

• View options such as Toggle Annotations and Toggle Redlines 

• Send snapshot by email 

• Selection Filter Commands 

 
 

12.3    Working in a Drawing 

12.3.1    Drawing Mark-Up Mode 

Drawing mark-up mode allows you to load a drawing without loading the underlying designs for the 
drawing.  You will enter mark-up mode if the designs are unavailable, or if you have modified any of 
the designs and choose not to update the drawing.  The features available in mark-up mode are all 
of the features that are accessible immediately after opening a drawing (on page 368) (while the 
parametric data continues loading), as well as Insert Annotations and Insert Redlines.  One benefit 
to Drawing Mark-up Mode is that you can send another user a drawing to review without sending the 
design files.  
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Opening from the repository: Drawings with designs saved with versions 

When you open a drawing from the repository that has outdated versions associated with it 
(meaning you have modified a design and saved it as a new version), you will see the Version 
Status dialog.  

 
Figure 96: Version Status dialog denoting outdated models 

The designs that have been modified and saved will be marked as Outdated.  You can choose to 
update the parts, and then select OK, or you can select OK without updating the parts.  If you 
update the designs, the drawing will open in normal edit mode.  If you choose not to update the 
designs, the drawing will open in mark-up mode and you will have use of limited features. 

 

 To update models: 

1. Select the model you wish to update.  You can check Update all instances to update each 
occurrence of the model in this drawing (for example, in the dialog above, the model named 
"Head" appears both as a standalone part and as a component in the "Cylinder Accessories" 
assembly). 

2. You can update all of the components in an assembly by checking the Update branch option, 
and then selecting the assembly (for example, in the dialog above, choosing to Update branch 
on the assembly called Cylinder Accessories will update three part models - Intake Manifold, 
Manifold Fitting, and Head). 

3. When you have the desired model chosen, click Update. 

4. Continue the process until all of the items are listed as Current, with a green dot next to them.  
(If you leave any items un-updated, the drawing will open in mark-up mode.) 
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5. Click OK to continue opening the drawing.  

 

Opening drawings from the repository without versions, or from the file 
system 

When you open a drawing from the file system that has an outdated design, or you open a drawing 
from the repository that has an outdated design that was saved without versions, the drawing file will 
open, and you will be prompted to Reproject the outdated designs. 

 

Choose one of the available options (see "Updating Drawing Views" on page 377), and then click 
OK to continue.    

 
 

12.3.2    Renaming Sheets & Views 

You can rename the sheet and corresponding views to convey relevant design information. 

 To rename a sheet or view: 

1. Right-click a sheet or view in the Drawing Explorer and select Rename from the pop-up menu. 

2. Type the new name. 

3. Press Enter.  The sheet or view name is updated. 
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12.3.3    Changing the Drawing Template 

You can change the drawing template after the initial drawing creation. 

 To change the drawing template: 

1. Right-click the sheet in the Drawing Explorer and select Change Template from the pop-up 
menu.  The New Sheet Properties dialog appears. 

2. Select the Template option and select a template from the list.  To use a custom drawing 
template not listed, click Browse and select the template from the Custom Drawing Template 
dialog.  Note:  If you have previously browsed to another template folder, you can use the 
Default button to reset the template list back to the system template folder. 

Or 

Select the Blank Sheet template option and select a sheet size from the drop down list. 

3. Change the Default View Scale if necessary. 

4. Click OK. 

5. If a Standard template was selected, the Fill In Text dialog appears.  Complete the applicable 
fields and click OK.  The sheet is updated and the new template is displayed in the work area. 

Note: If the new template has dimension styles or layer properties that conflict with the existing 
template, you will see the Conflicting Dimension Styles or Conflicting Entity Layers Dialog. 

 

Conflicting Dimension Styles 
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This dialog is telling you that two styles with the same name can not exist in a single drawing file.  If 
you are seeing this dialog, it is because you have tried to use a second template in a drawing file 
that contains styles with names that are identical to style names in the first template used in the 
drawing.  

Note: We recommend that you give all of your styles a unique name, even if they are in different 
templates.  This will prevent conflicts from arising if you choose to use more than one template in the 
same drawing file.  

You must choose one of the options:  

These options only apply to the styles that have the same name.  All other styles are unaffected.  In 
addition, these options do not modify the template itself, only the properties of the styles in this 
drawing file. The original templates remain unchanged.  

Keep Existing Styles - This option will keep the properties of the styles that are already in 
the drawing. 

Update Existing Styles - This option will keep the properties of the styles that are in the 
new template being added, so the existing style properties will be updated to match.     

Cancel - This option will cancel the action you just started, whether it was inserting a new sheet, 
or changing templates.  

If you change the template of any sheet in the drawing, the default style for the drawing will update 
to match the default style of the template you have changed to. 

Conflicting Entity Layers 

 

This dialog is telling you that two layers with the same name that have different specifications can 
not exist in a single drawing file.  If you are seeing this dialog, it is because you have tried to use a 
second template in a drawing file that contains one or more layers with names that are identical to 
layer names in the first template used in the drawing, but with different properties.  
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You must choose one of the options:  

These options only apply to the layers that conflict.  All other layers are unaffected.  In addition, 
these options do not modify the template itself, only the properties of the layers in this drawing file. 
The original templates remain unchanged.  

Keep Existing Layers - This option will keep the properties of the layers that are already 
in the drawing. 

Update Existing Styles - This option will overwrite the properties of the existing layers 
with the properties of the new template layers.      

Cancel - This option will cancel the action you just started, whether it was inserting a new sheet, 
or changing templates.  

 
 

12.3.4    Deleting Views 

You can delete views at any time. 

 To delete a view: 

Right-click the view in the Drawing Explorer and select Delete from the pop-up menu;  

or, select a view in the work area or Drawing Explorer and press Delete; 

or, select the Delete  tool from the Standard toolbar. 

Note:  Any views that were created from the deleted view, such as auxiliary views, will also be 
deleted. 

 
 

12.3.5    Hiding Views 

You can hide/unhide views at any time.  A hidden view is not displayed in the 2D work area.  It is 
displayed in the Drawing Explorer but is grayed out. 

 To hide a view: 

Right-click the view in the Drawing Explorer or the 2D work area and select Hide from the pop-up 
menu. 
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 To unhide a view: 

Right-click the view in the Drawing Explorer and select the Hide toggle (which should be marked 
with a check) from the pop-up menu. 

 
 

12.3.6    Drawing Selection Filters 

By default, you can select any item in a drawing.  When you move the cursor over an item in the 
work area, the item is highlighted.  You can select the following items individually in a drawing 
workspace: 

• Parts 

• Part edges and vertices 

• Dimensions 

• Sketches 

• Annotations 

• Redlines 

• Views 

As you work in a drawing workspace, you may find it advantageous to select a certain group or 
groups of items as opposed to all items.  In this case, you can apply selection filters and specify 
which item groups you want to select. 

 To use selection filters: 

On the Filters toolbar (see below), select the tools corresponding to the item groups you want to be 
able to select.  A filter is applied when the corresponding tool is in the pressed state. The following 
filters are available (in order as they appear below): 

Select Segments (drop down list includes Select Parts and Select Views) 

Select 2D Sketches 

Select Dimensions 

Select Annotations 

Select Vertices 
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Select Redlines 

 

Only items in the selected groups can be selected in the work area, so as you move your mouse 
pointer over a view, only applicable items will be highlighted.   

You can also apply filters by going to the Tools menu and choosing Selection Filters.  If a check 
mark is displayed next to a filter, the filter is currently being applied. 

 
 

12.3.7    Moving Views on the Sheet 

After initially placing the views, you can re-position views on the sheet as necessary.  Note that the 
standard views are initially aligned.  Moving the front view will cause related standard views to move.  
You can break the view alignment if necessary. 

 To move a view: 

1. Select the View selection filter if it is not already being applied. 

2. Click the Select  tool from the View toolbar if it is not already selected. 

3. Move the cursor over the view.  A red view boundary appears and the mouse pointer changes 
to resemble a hand. 

 
Figure 97: View outlined and mouse pointer changed to resemble a hand 

4. To reposition a view or the views, click and hold the mouse button, and move the cursor.  The 
selected view and all associated views move. 

5. Release the mouse button to place the views. 

Note:  You can break an individual view's dependence on other views by right-clicking the view and 
un-checking the Align toggle in the pop-up menu.  You can again establish the alignment by re-
checking the Align toggle. 
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12.3.8    Updating Drawing Views 

It is likely that you will need to make changes to your part and assembly models even after you have 
created 2D drawings of the models.  When you make a change to a part or assembly model and 
save the model, the 2D drawing becomes outdated, because it does not contain the most recent 
model information.  You can update the drawing to bring in the new model data.   

 To update drawing views: 

1. Select the Reproject Outdated Views tool  from the Detailing toolbar; or, from the Tools 
menu, select Reproject Outdated Views.  The Reproject dialog appears.  

2. Choose one of the following options: 

a. Fast Views - the outdated items will be projected in Fast View mode 

b. Precise Views - the outdated items will be projected in the standard mode 

c. Retain View Mode - the outdated views will be projected in whichever mode they are 

currently in 

3. Click OK to continue updating the drawing.  

Note: If you do not want to reproject your views, click Cancel. If you do not reproject your views, 
your 2D drawing will continue to be out of date, you will have limited editing options when working 
with your 2D Drawing until you reproject all outdated views. 

 
 

12.3.9    View and Sheet Boundaries 

A red view boundary is highlighted as you move the cursor over a view.  The view boundary is 
displayed both in and out of sketch mode.  The boundary size is calculated automatically based on 
the extents of the view.  Consequently, you cannot change the size of the view boundary. 
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You can only work on a view (e.g. add dimensions, sketch figures, etc.) when the view boundary is 
displayed around it.  The view boundary indicates the view is active.  Any items added to the view 
when it is active will be associated with the view.  If the view is moved, the inserted items will move 
with it. 

 
Figure 98: Drawing view displaying boundary outline 

A sheet boundary is also highlighted when a sheet is selected and you enter sketch mode.  The 
sheet boundary indicates the sheet is active.  Any items added to the sheet when it is active will be 
associated with the sheet.  The boundary size is based on the extents of the entire sheet. 

 
Figure 99: Drawing sheet displaying boundary outline 
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12.3.10    Changing the View Scale 

You can change the default view scale or the scale of individual views after they have been placed.  
A changed default view scale is applied to any views that are inserted subsequent to the scale 
change.  Views already in the sheet will not be effected.  Changing the scale of an individual view 
will subsequently change the scale of its dependent views. 

 To change the default view scale: 

1. In the Drawing Explorer, right-click the sheet you want to change the default view scale in and 
select Default View Scale from the pop-up menu.  The Scale dialog appears. 

2. Modify the scale as required. 

3. Click OK.  The default view scale is changed. 

 

 To change the scale of a view: 

1. Right-click the view and select Scale from the pop-up menu.  The Scale dialog appears. 

 

2. Specify the new scale. 

3. Click OK.  The view scale is updated. 

 
 

12.3.11    Line Display in Views 

You can control how individual views are displayed.  You can show or hide hidden lines and 
tangent edges.   By default, tangent edges are shown, and hidden lines are not displayed. 

 To show or hide hidden or tangent edge lines in a view: 

Right-click a view in the Drawing Explorer, or right-click a view in the work area and select one or 
both of the following:  Show Hidden Lines, or Show Tangent Edges.  A check mark displayed next 
to the option indicates the item is currently being displayed. 



 Chapter 12 - Drawings 

 
 
 

380 

Note:  You can also choose to show hidden lines during the view creation process.  In the Standard 
Views (see "Inserting Standard Views" on page 362) Creation dialog, click the More Options button 
to see the View Creation Options.  Check the Hidden Lines option to display them in the view.  

 
 

12.3.12    Centerlines and Centermarks 

The following apply to centermarks and centerlines in 2D drawings: 

• Can be modified globally or on an individual basis. 

• Dimensions can be placed between centermarks/centerlines and any other applicable item 
in a view. 

• Can be individually deleted, edited, or placed on a different layer. 

• Can be inserted on a per view basis. 

• Can be inserted individually for projected circular or cylindrical geometry. 

 

 To toggle automatic centermark and centerline display on and off: 

1. From the File menu, select Properties.  The Drawing Properties dialog appears.  

2. Click the Detailing tab. 

3. Under View Creation Options, uncheck Auto Create Centerlines and/or Auto Create 
Centermarks to turn them off;  check them to turn them on.  

4. Click Apply, and then Close. 

 

 To modify global centermark and centerline properties: 

1. From the File menu, select Properties.  The Drawing Properties dialog appears.  

2. Click the Detailing tab. 

3. Under Centerlines, modify the Centermark Style, Short Dash, Extension, and Gap as 
needed. 

4. Click Apply and Close. 
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 To modify individual centermark and centerline properties: 

1. Select the Select tool from the Viewing toolbar. 

2. Move the cursor over the centermark or centerline to be modified. 

3. Right-click the centermark or centerline and select Edit from the pop up menu.  The Centerline 
Properties dialog appears. 

4. Modify the Centermark Style, Short Dash, Extension, and Gap. 

5. If a centermark is being edited, you can rotate it by specifying a Direction angle. 

6. Click OK to accept the changes. 

 

 To delete a centermark or centerline: 

1. Select the Select tool from the Viewing toolbar. 

2. Move the cursor over the centermark or centerline to be deleted. 

3. Right-click the centermark or centerline and select Delete from the pop up menu.  
 
OR 

Right-click the figure and select Remove Center from the pop up menu. 

 

 To insert a centermark or centerline on a per view basis: 

1. Select the Select tool from the Viewing toolbar. 

2. Move the cursor over the view in which centermarks and centerlines are to be added.  

3. Right-click the view and select Insert Centers. 

Note: To insert the centerlines for individual holes, select the hole; then right-click and choose Insert 
Center. 
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 To insert a centerline on projected circular or cylindrical geometry: 

1. Select the Select tool from the Viewing toolbar. 

2. Move the cursor over the figure to insert a centerline on.  

3. Right-click the figure and select Insert Center from the pop up menu.  The centerline is 
displayed on the figure. 

 

Note:  You can also choose to show centermarks and/or centerlines during the view creation 
process.  In the Standard Views (see "Inserting Standard Views" on page 362) Creation dialog, click 
the More Options button to see the View Creation Options.  Check the option(s) you wish to display 
in the view.  

 
 

12.3.13    Optimizing the Drawing Display 

Optimizing your drawing display allows Alibre Design to choose how many segments to break non-
linear edges into when projecting them on the display.  Smaller edges will be broken down into less 
segments.  This optimization applies to all views in the drawing, and is valid for only projected 
edges, not for sketches created in the drawing itself.  

Turning on the Optimize option reduces the memory used by the drawing and also the time required 
to render it on the display. 

 

 To optimize your drawing display 

1. From the File menu, choose Properties.  

2. Select the Display tab.  

3. In the Curve Smoothness section, check the Optimize option to optimize drawing performance. 

 

Optimized edges may appear a little more coarse, because of the smaller number of segments used 
to display the edge.  If you have the optimize option turned on, you can refine individual non-linear 
edges so that they appear finer.   
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 To refine individual edges 

1. Right-click on the edge you wish to refine and select Refine Edge.   

This option will be disabled if the edge has already been refined, or if it is a linear edge.   

 
 

12.3.14    Layers 

In drawings, model views are displayed and detailed using a variety of layers.  The use of different 
layers is often dependant on the drafting and detailing standards defined by your organization.  In 
Alibre Design, there are six predefined layers that can be modified to meet your standards.  
Additional layers can be added to your pallet as needed.   

The layer settings are accessible from the Layers tab in the Drawing Properties dialog (File > 

Properties > Layers tab), or by selecting the Layers tool  . 
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The layer attributes are described as follows: 

• Current [checkbox]: Layer to be used for new drawing items.  Only one layer can be 
designated as current. 

• Name: The layer name. 

• Visible [checkbox]: When checked, all drawing items assigned to that layer are visible.  
Clear the checkbox to hide items in a particular layer. 

• Locked [checkbox]: When checked, the corresponding layer is locked and changes cannot 
be made to layer attributes. 

• Pattern: A preview of the layer line style.  Click to access a menu of additional styles.  

• Color: The layer color in the drawing. Double-click the colored box to access the Color 
dialog and select a different color. 

• Scale: Maximum length of line segments in dashed lines. 

• Comment: Insert a comment to indicate the layer purpose. 

Any items that are inserted or created in a drawing workspace (e.g., sketch figures, annotations, 
dimensions, etc.), are displayed using the current layer's attributes.  Only one layer can be current at 
a time.  If you change the pattern, visibility, color, or scale of a layer used in the drawing, all existing 
drawing items will be updated with the new settings. 

 To select a different layer as the current layer: 

1. Click the Current check box corresponding with the layer you want to make current. 

2. Click Apply. 

3. Click Close. 

 

 To change the pattern 

1. Double-click the appropriate Pattern entry.  An arrow appears in the cell. 
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You can scroll through the list, or type the first letter of the desired pattern name. For example, 
type the letter "i" to jump to the first ISO style. Continue pressing the "i" key to page through all 
of the ISO styles. 

 

2. Select the pattern you want from the list. 

3. Check Current to use this layer for new items. 

4. Click Apply to implement the new settings. 

Note:  For advanced users who want to customize the available line patterns in Alibre Design:  You 
can modify the predefined line patterns that ship with Alibre Design by editing the text file, 
alibre_unicode.lin.  You can use Notepad to edit this file.  A definition of the file format is embedded 
within the file.  This file is located in the folder C:\Documents and Settings\All Users\Application 
Data\Alibre Design\System Files. 

 

 To change the color: 

1. Double-click the appropriate Color cell.  The Color dialog appears. 

2. Select a preset color or click Define Custom Colors to create a specific color. 

3. Click OK to close the Color dialog. 

4. Click Apply to implement the new settings. 

 

 To change the layer name, scale, weight, or comment: 

1. Click the cell containing the text or value you want to change.  A gray box borders the cell. 

2. Click again.  A blinking cursor appears.  You can now edit the contents of the cell. 

3. Click Apply to implement the new settings. 
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 To add a layer: 

1. Click Add.  A new row appears at the bottom of the table, temporarily named New Line Style. 

 

2. Modify the layer attributes as necessary, including the layer Name. 

3. Click the Current check box to use this style for new items. 

4. Click Apply to implement the changes. 

5. Click Close when finished. 

 

 To delete a layer: 

1. Select the layer you want to delete from the list. 

2. Click Delete. 

 

 To change the layer of an existing figure, dimension, or annotation: 

1. Right-click the item you want to reformat and select Set Layer from the pop-up menu.  The 
Layers dialog appears. 

2. In the Current column, select the layer you want to move the selected item to. 

3. Click OK to apply the change. 
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When the layer for an annotation or dimension is changed, the entire dimension/annotation including 
figures and text will be rendered in the layer's color.   All figures and leaders will be rendered with 
the line pattern of the layer (continuous, dashed, etc.). 

The only exception to this rule is the Text Note annotation, for which the text is always displayed 
using the font color specified in the Text Note dialog.  The leader will still be rendered in the color 
and line pattern associated with the layer. 

 

You can change the properties of any figure on a layer without changing the layer that the figure 
resides on.  You do this by overriding the current layer style:  

1. Right-click the figure you wish to change the properties of.  

2. Select Set Layer.  The Layers dialog appears. 

 

 

3. Check the Override Layer Style box; then select the Pattern, Color, Scale, and Weight for the 
figure.  

4. Click OK to apply the changes.  The properties of the figure will be changed, but the figure will 
still reside on the original layer. 
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12.3.15    Adding Sheets 

You can add additional sheets to the drawing as needed. 

 To add a sheet to the drawing: 

1. Select the Insert New Sheet  tool from the Detailing toolbar; or from the Insert menu 
select New Sheet.  The New Sheet Properties dialog appears. 

2. Follow the steps outlined in the sections Selecting a Drawing Template (on page 360) and 
Specifying Standard Drawing Information (on page 361) to specify the information included in 
the new sheet.  After inserting a new sheet into the drawing, the sheet will be listed in the 
Drawing Explorer under the Sheets node. 

3. The new sheet will initially be blank.  Refer to the section on Inserting Additional Views (on 
page 400) for information on adding new views. 

4. To switch between sheets, select a sheet in the Drawing Explorer to view it. 

5. To delete a sheet, right-click the sheet in the Drawing Explorer and select Delete from the pop-
up menu. 

 
 

12.3.16    Reordering Sheets 

You can quickly change the order of the sheets in the drawing file. 

 To reorder the sheets: 

1. Select the Reorder Sheets tool   from the Detailing toolbar; or, from the Edit menu, select 
Reorder Sheets.  The Reorder Sheets dialog appears. 

2. Click the sheet you want to move.   

3. Choose the appropriate button on the right to move the sheet to the desired position. 

4. Click OK to accept the new sheet order and exit the dialog. 
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12.3.17    Moving a View to Another Sheet 

You can move a view to another sheet in a drawing. 

 To move a view to another sheet: 

1. Right-click the view in the work area or Drawing Explorer and select Move from the pop-up 
menu.  The Select Target Sheet dialog appears listing the drawing sheets you can move the 
view to. 

2. Select the sheet you want to move the view to. 

3. Click OK.  The view is moved to the specified sheet and is listed under the target sheet in the 
Drawing Explorer. 

 
 

12.3.18    Hiding Parts in a View (Assemblies Only) 

In a drawing of an assembly, you can hide parts in a view. 

 To hide a part in a view: 

1. Right-click the part in the work area view and select Hide Part from the pop-up menu. 

 

OR, 

1. In the Drawing Explorer, click the plus sign  next to the applicable view. 

2. Click the plus sign  next to the assembly name to expand the list of associated parts. 

3. Right-click the part and select Hide from the pop-up menu.  

4. The part is hidden in the view and is dimmed in the Drawing Explorer.  To unhide the part, right-
click the hidden part in the Drawing Explorer and unselect Hide.  
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12.3.19    Inserting Images in a Drawing 

You can insert images, such as logos, into drawings.  Several popular file types are supported:  
JPG, GIF, TIF, BMP, RLE, DIB, RLE, EMF, WMF, PNG, JPE, JPEG, JFIF, and TIFF.  Alibre Design 
does not support JPEG 2000 or lossless JPEGs, as well as some types of TIFF files. 

When you save the drawing, the images are compressed and stored with the drawing.  Opening the 
drawing opens all the images inside it. 

When you export a drawing in the Alibre Design STEP format, the images are compressed and 
saved with it.  When the STEP file is opened, the images are decompressed and loaded into the file. 

When you save a drawing as a template after inserting an image, the image will remain part of the 
template when it is used again in another drawing.   

 To insert an image in a drawing: 

1. From the Insert menu, select Image.  The Select Image dialog appears. 

2. Click Look In to browse to the saved location of the image you want to insert. 

3. Click the image's file name. 

4. Click Open.  The image appears in the drawing workspace and the cursor changes to a dotted 
crosshairs icon. 

5. Click the crosshairs icon on the drawing sheet to place the upper-left-hand corner of the image.  
The image is placed in the selected location. 

6. To resize the image, right-click it and select Scale from the pop-up menu.  The Scale dialog 
appears. 

7. To make the image smaller, decrease the value on the left.  To make the image larger, 
decrease the value on the right.  

8. Click and drag the image to place it as necessary. 

Note: You may also move images into Alibre Design by importing them to a repository or by 
dragging them from a Windows folder onto the Home window.  A blank drawing sheet opens with the 
image placed on it. 
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12.3.20    Printing a Drawing 

You can print one, all, or a specified list of sheets in a drawing.  You can also print just a portion of 
the current sheet. 

 To print: 

1. From the File menu, select Print. 

2. Use the Sheet range to specify what you want to print: 

• All sheets in the drawing. 

• The currently displayed portion of the current sheet. 

• The entire current sheet. 

• Only the sheets checked in the print dialog. 

3. Specify the number of copies you want to print. 

4. If you want the printed drawing to be fit to the size of the paper, check the Scale to fit option. 

5. If you want to print using only black and white, check the Print black and white option. 

6. Click OK. 

 

 To see a print preview of the current sheet: 

1. From the File menu, select Print Preview.  The Print Preview window appears with a preview 
of the drawing. 

 

 To optimize the quality of your print: 

1. If your drawing contains Fast Views (on page 365), you should convert them to Precise Views 
before printing for better print quality.   
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12.4    Dimensioning 

Typically, as you create features in part mode you place driving dimensions that define the 
associated sketch profiles.  Additionally, dimensions that define a feature's size, such as extrusion 
depth, are also considered driving dimensions.  

When you create a drawing based on the part, you can choose to display the driving dimensions 
from the part automatically during view creation (see "Inserting Standard Views" on page 362) on the 
applicable view in a drawing.  If you do not choose to display driving dimensions upon creating the 
drawing you can always do so later. 

 
Figure 100: Drawing view displaying dimensions on the model 

You can also manually insert additional dimensions on a drawing view.  These user-added 
dimensions are referred to as Reference dimensions.  Reference dimensions are displayed the 
same as driving dimensions.  However, you can display a reference dimension in parentheses to 
distinguish it from driving dimensions. Right-click the reference dimension and select Properties 
from the pop-up menu.  Select the Units and Tolerance tab, select the Display As Reference 
Dimension option, and click OK. 

If a driving dimension is changed in part mode, the associated dimension in the drawing will 
automatically get updated.  You can also edit driving dimensions in the drawing.  If you change a 
driving dimension in the drawing, the part is automatically updated. 

Reference dimensions cannot be edited or changed.  However, reference dimensions will update 
upon the modification of driving dimensions.  You can insert additional reference dimensions in 
drawings to further clarify the design intent.    
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12.4.1    Placing Additional Dimensions on a View 

You can use the same methods to add dimensions to a drawing as you use to dimension sketches in 
part mode (refer to Chapter 4). 

 To place dimensions in a drawing: 

1. Select the Dimension  tool from the Sketching toolbar. 

2. Select the figure to dimension.  A dimension preview appears, press Esc if the wrong figure 
was dimensioned. 

3. When the preview displays the correct dimension location, click to place the dimension.  The 
newly placed dimension is a reference dimension. 

 
 

12.4.2    Dimensioning Slots and Holes 

You can easily control how dimensions related to slots and holes are created and displayed. 

 To insert a dimension related to a slot or hole: 

1. Select the Dimension  tool from the Sketching toolbar. 

2. Select the first circular/radial figure or line to be dimensioned from.  A dimension appears but 
do not click to place it. 
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3. Select a second circular/radial figure or line to be dimensioned to.  The Slot Dimension 
Options dialog appears. 

 

 

4. From the Circular to Circular or Linear to Circular list, select a dimension type from the drop 
down list.  The numbers in the list correspond to the graphical key in the dialog. 

5. Click OK.  The dimension is previewed in the work area. 

6. Move the cursor to correctly position the dimension. 

7. Click to place the dimension. 

 
 

12.4.3    Placing Ordinate Dimensions on a View 

 To place ordinate dimensions: 

1. Right-click in the work area and select Ordinate Dimension from the pop-up menu; or from the 
Sketch menu select Ordinate Dimension. 

2. Select the Baseline figure. 

3. Select the Origin on the baseline figure. 

4. Drag the origin's dimension line away from the model and click to place it. 
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5. Select the entities (edges or points) you want to dimension using the same ordinate.  As you 
select each entity, the dimension is placed in the view aligned to the origin. 

 

Note:  You can insert additional ordinate dimensions to a chain after initial placement.  Select the 
Dimension tool, pick the baseline dimension, and then select the new dimension location to add the 
new dimension to the chain. 

 
 

12.4.4    Modifying Driving Dimension Values 

As previously described, you can change the values of driving dimensions in drawings.  A change to 
a driving dimension in a drawing will be reflected in the part automatically. 

 To modify a driving dimension: 

1. Make sure the Dimension selection filter (see "Drawing Selection Filters" on page 375) is on. 

2. Select the Select  tool from the View toolbar if it is not already selected. 

3. Move the cursor over the dimension.  The dimension turns red. 
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4. Double-click the dimension.  The dimension control box appears. 

 

5. Enter a new value in the box and press Enter. 

 

Changes made to driving dimensions in the drawing will be reflected in the part after the drawing has 
been saved and the part is opened. 

 
 

12.4.5    Dimension Properties 

Dimension properties are determined by the style that you assign to each dimension. 

When a dimension is created, it is automatically assigned to the dimension style that you have set as 
your default dimension style.   

You can change dimension properties either as a group or on an individual basis. 

 

 To change the default dimension style 

1. From the File menu, select Properties.  

2. Select the Dimensions and Annotations tab.  

3. In the Dimensions section, select your desired default style from the drop-down list.  This style 
will be applied to all newly-created dimensions.  

4. Click Apply, then Close. 

 

 To change the properties of a single dimension 

1. Right-click the dimension and select Properties.  The Dimension Properties dialog appears.  

2. To change which style is used for that dimension, select a new style from the Dimension Style 
drop-down list.   
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3. To set the properties for this dimension independent of any style, uncheck the Use 
Style checkbox.  You can then set the properties as desired for each tab.   

4. Click OK. 

 

 To change the properties of multiple dimensions 

1. Click the first dimension to select it, then hold the Shift key down as you select each 
subsequent dimension.   

2. Right-click on any of the selected dimensions and choose Properties.  The Dimension 
Properties dialog appears. The values for the FIRST dimension selected will be shown in the 
dialog.  All values that are common between the selected dimensions will be shown with a 
white background.  If any values differ between the selected dimensions, that field will be 
shown with a slightly gray background.   

3. To change which style is used for these dimension, select a new style from the Dimension 
Style drop-down list.   

4. To set the properties for this dimension independent of any style, uncheck the Use 
Style checkbox.  You can then set the properties as desired for each tab.   

5. Click OK. 

 
 

12.4.6    Dimension Styles 

Dimension styles are used to set the dimension properties in a 2D detailed drawing.   When a 
dimension is created, it is automatically assigned to the dimension style that you have set as your 
default dimension style.  

You can create multiple dimension styles in a drawing.  The styles are saved with the drawing file, 
not with your system profile, so you will not see the styles you have created in another drawing.   

If you anticipate that you will use the same styles again and again, you can save them in your 
drawing template.  Then, each time you use the template, the styles you created will be available.   
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Setting Your Default Style 

All newly inserted dimensions will automatically be assigned to the default style (you can change 
which style is used for an individual dimension after it has been created).  You can change the 
default style used in your drawing by going to File > Properties, and choosing the Dimensions and 
Annotations tab.  In Default Style, choose the style you wish to use from the drop-down list.  

 

 To Edit an Existing Dimension Style:  

1. From the Tools menu, select Dimension Styles.  The Dimension Styles dialog appears. 

2. Choose the dimension you wish to modify from the Dimension Style drop-down list. 

3. Make any necessary modifications on each of the tabs.  

4. Click OK to accept the changes and exit the dialog, OR choose another style to modify from the 
drop-down list, OR choose to create a new style.  

 

 To Create a New Dimension Style: 

1. From the Tools menu, select Dimension Styles.  The Dimension Styles dialog appears. 

2. Click the New Dimension Style button. 

3. In Name, enter the name for the new style.   

4. In Copy From, select which existing style you would like to use for the initial values. 

5. Click OK.  

6. Make any necessary modifications on each of the tabs.  

7. Click OK to accept the changes and exit the dialog, or choose another style to modify from the 
drop-down list, or choose to create a new style.  

 

Using Dimension Styles in Templates 

Saving your dimension styles to your template allows you to reuse the same styles without having to 
create them again each time you start a new drawing.   
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Note: We recommend that you give all of your styles a unique name, even if they are in different 
templates.  This will prevent conflicts from arising if you choose to use more than one template in the 
same drawing file.  

 

If you do use the same style names for styles in different templates, you may see the following 
dialog when you attempt to use both templates in the same drawing: 

 

This dialog is telling you that two styles with the same name cannot exist in a single drawing file.  
The dialog in the above example has found three different styles in the second template brought in 
to a drawing that have the same name as styles in the first template used in the drawing.   

You must choose one of the options:  

These options only apply to the styles that have the same name.  All other styles are unaffected.  In 
addition, these options do not modify the template itself, only the properties of the styles in this 
drawing file. The original templates remain unchanged.   

Keep Existing Styles - This option will keep the properties of the styles that are already in the 
drawing. 

Update Existing Styles - This option will keep the properties of the styles that are in the new 
template being added, so the existing style properties will be updated to match.     
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Cancel - This option will cancel the action you just started, whether it was inserting a new sheet, or 
changing templates.  

 

If you change the template of any sheet in the drawing, the default style for the drawing will update 
to match the default style of the template you have changed to. 

 
 

12.5    Inserting Additional Views 

In addition to the standard views, you can insert additional custom views to further clarify design 
intent.  You can insert auxiliary, detail, section, and exploded views.   

You can also insert flat pattern views of sheet metal parts in Alibre Design Professional. 

Note: When you insert additional views that are dependent views (such as the detail view), the new 
view will be created with the same projection method as the parent view (Fast View or Precise 
View).  Once the new view has been placed, you can control the projection type independently.  

 
 

12.5.1    Standard View 

You can insert an additional standard view as needed. 

 To insert a standard view: 

1. Select the Standard View  tool from the Detailing toolbar; or from the Insert menu select 
Standard View.  The Insert Design dialog appears. 

2. Select the model (see "Selecting the Model" on page 361) and choose which views you wish to 
insert (see "Inserting Standard Views" on page 362). 

 
 

12.5.2    Auxiliary View 

An auxiliary view is created by projecting an orthogonal view normal to a linear edge or sketch line in 
an existing view. 
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 To create an auxiliary view: 

1. Select the Auxiliary View  tool from the Detailing toolbar; or from the Insert menu select 
Auxiliary View. 

2. Select a linear edge or straight sketch line on an existing view.  The edge selected from the 
parent view must reside on a face that is perpendicular to the plane of the screen.  

 

Note:  To use a sketch line as the projection line, the sketch line must reside on the view.  To 
do this, first select the view you wish to use to create the auxiliary view.  Then select the 
Activate 2D Sketch tool from the sketching toolbar and sketch a line.  The line can intersect 
the view boundaries.   Exit Sketch Mode, then follow steps 1 and 2 above to create the new 
view.  (After the auxiliary view is created, the sketch line can be deleted.) 

3. A preview of the auxiliary view is displayed. 

4. Move the cursor to position the auxiliary view to the correct location. 
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5. Click to place the auxiliary view.  The auxiliary view is placed on the sheet, aligned to the edge 
from which it was created.  You can only move the auxiliary view in the direction normal to the 
edge from which it was created. 

 

Note:  To break the alignment between the auxiliary view and the parent view, right-click the 
view that is currently aligned, and select Align.  Selecting Align will uncheck that option, and 
you can then drag the view unconstrained. 

 

 
 

12.5.3    Detail View 

A detail view is a view that shows a portion of an existing view at an enlarged scale. 

 To create a detail view: 

1. Select the Activate 2D Sketch  tool from the Sketching toolbar.  
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2. Sketch any closed figure enclosing the area that you want to detail. 

 
Figure 101: Drawing view with closed shape outlining detail area 

3. Select the Detail View  tool from the Detailing toolbar; or from the Insert menu, select 
Detail View. 

4. Select the sketch figure.  A preview of the detail view appears. 

5. Move the mouse to position the detail view appropriately.  The detail view can be placed 
anywhere on the sheet.  Click to locate the view.  The default scale for the detail view is the 
same as the sheet scale.  To enlarge the detail view, right-click it and select Scale from the 
pop-up menu. 

 
Figure 102: Completed detail view 
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You can place dimensions on the detail view.  You can also change both the detail circle label and 
the detail note.  To change either, double-click the text or right-click the text and select Edit from the 
pop-up menu.  The Note dialog appears containing the original text.  Enter the new text and click 
OK. 

Also, in the Detailing tab of the Drawing Properties dialog, you can pre-define the border style and 
font used for detail circles and detail view labels. 

When using a sketched circle for the detail view, the leader line and annotation positions are 
determined by the last location of the mouse before finalizing the circle you sketched as the 
reference.  

 

 To change the detail location: 

1. Choose the Select  tool from the View toolbar if it is not already selected. 

2. Move the cursor over the detail circle annotation.  The annotation is highlighted and the cursor 
changes. 

3. Click and drag the detail circle annotation to the new location. 

4. Release the mouse button to reposition the circle.  You will see a dialog letting you know that 
moving the annotation will update the dependent views. 

5. Choose Yes to continue, or No to cancel the operation. If you choose Yes, the detail view is 
updated automatically to reflect the detail circle position change.  (You can turn the prompt off if 
desired - from the Tools menu, select Options.  On the General tab, uncheck Prompt when 
detail, section, or partial view annotation moved.) 

 

 To change the location of detail labels: 

You can move both the label for the detail view, as well as the label for the detail area. 

1. Click the Select  tool from the View toolbar if it is not already selected. 

2. Move the mouse pointer over the detail annotation.  The annotation is highlighted and the 
mouse pointer changes. 

3. Click and drag the annotation to the desired location.  
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 To change the detail area size: 

1. Click the Select  tool from the View toolbar if it is not already selected. 

2. Move the cursor over the detail circle annotation.  The annotation is highlighted and the cursor 
changes. 

3. Double-click the annotation.  The Detail View Annotation dialog appears and the circle center 
node is displayed. 

4. Move the cursor over the circle. 

5. Click and drag to resize. 

6. Release the mouse button when the circle is resized appropriately.  

7. Click OK in the Detail View Annotation dialog.  The detail view is updated automatically to 
reflect the change in size of the detail area. 

 
 

12.5.4    Section View 

A section view represents a 2D cross-section of a model.  Section views are created from other 
views and are dependent on them.  You can create a normal section view or a stepped section view. 

 To create a normal section view: 

1. Sketch a straight line across the view to define the section location.  Make sure you are 
sketching in the view by selecting the view in the Design Explorer before entering Sketch Mode. 
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2. Select the Section View  tool from the Detailing toolbar; or from the Insert menu select 
Section View. 

3. Select the line that you sketched in step 1.  A preview of the section view appears in the 
drawing. 

4. Drag the section view preview to the appropriate location on the sheet.  You will only be able to 
move the view in a direction normal to the section line. 

5. Click to place the view. 

 

 

Note:  In the Detailing tab of the Drawing Properties dialog, you can pre-define the display style for 
the section line, the font for the section line label, and the default hatch pattern style. 

 

Note:  For advanced users who want to customize the available hatch patterns in Alibre Design:  
You can modify the predefined hatch patterns that ship with Alibre Design by editing the text file, 
alibre_unicode.pat.  You can use Notepad to edit this file.  A definition of the file format is embedded 
within the file.  This file is located in the folder C:\Documents and Settings\All Users\Application 
Data\Alibre Design\System Files. 

 

 To modify a section view: 

• To edit the letter label on the section line or the note on the section view, double-click the 
item, or right-click and select Edit from the pop-up menu.  The Note dialog appears 
containing the original text.  Enter the new text and click OK. 

• To change the cut direction, right-click the section view and select Reverse Section View 
from the pop-up menu. 
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• The section view crosshatch pattern is set in the Detailing tab on the Design Properties 
dialog (File > Properties).  You can modify the crosshatch pattern for an individual section 
view.  Right-click the section view and select Change Cross Hatch from the pop-up menu.  
The Hatch Properties dialog appears.  Select a new crosshatch pattern from the list or 
modify the Scale or Angle.  Click OK to apply the changes. 

 

 To create a stepped section view: 

1. Sketch a series of line segments across the view to define the section location. 

 
Figure 103: Drawing view showing stepped outline for section view 

2. Select the Section View  tool from the Detailing toolbar; or from the Insert menu, select 
Section View. 

3. Select any of the line segments that you sketched in step 1.  A preview of the section view 
appears in the drawing. 

4. Drag the section view preview to the appropriate location on the sheet.  You will only be able to 
move the view in a direction normal to the section line. 
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5. Click to place the view. 

 
Figure 104: Drawing showing completed section view from stepped outline 

 

 To redefine the section location (either normal or stepped): 

1. Select the Select  tool from the View toolbar if it is not already selected. 

2. Move the cursor over the section line annotation.  The annotation is highlighted and the cursor 
changes.  

3. Click and drag the line to the desired location. 

4. Release the mouse button to place the line.  You will see a dialog letting you know that moving 
the annotation will update the dependent views. 

5. Choose Yes to continue, or No to cancel the operation. If you choose Yes, the section view is 
updated automatically to reflect the section line position change.  (You can turn the prompt off if 
desired - from the Tools menu, select Options.  On the General tab, uncheck Prompt when 
detail, section, or partial view annotation moved.) 

 

 To change the location of section view labels: 

You can move the label for the section view, as well as the labels for the section line. 

1. Click the Select  tool from the View toolbar if it is not already selected. 

2. Move the mouse pointer over the annotation.  The annotation is highlighted and the mouse 
pointer changes.  
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3. Click and drag the annotation to the desired location. 

 

 To change the direction of the section view: 

1. Right-click the section view in the work area and select Reverse Section View from the pop-up 
menu. 

 Or 

Right-click the section view in the Drawing Explorer and select Reverse Section View from the 
pop-up menu. 

2. The section line is flipped and the section view is displayed from the opposite direction. 

 

 To change the hatch pattern for all parts in the section view: 

1. Right-click the section view in the work area and select Change Cross Hatch from the pop-up 
menu; or right-click the section view in the Drawing Explorer and select Change Cross Hatch 
from the pop-up menu.  The Hatch Properties dialog appears. 

2. Select a new cross hatch pattern from the Pattern pull down menu. 

3. Specify the cross hatch Scale. 

4. Specify the cross hatch Angle. 

5. If desired, you can also modify the color, line weight, and offset distance for the hatch 
pattern. 

6. Click OK to apply the new cross hatch pattern. 

Note:  You can also access the cross hatch settings from the Drawing Properties dialog.  From 
the File menu, select Properties and then select the Detailing tab in the dialog. 

 

 To change the hatch pattern for individual parts in a section view: 

1. In the Drawing Explorer, expand the assembly under the section view to reveal the individual 
parts displayed in the section. 
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2. Right-click the desired part and choose Change Cross Hatch from the pop-up menu.  The 
Hatch Properties dialog appears. 

3. Modify the hatch pattern properties as desired. 

4. Click OK to apply the new cross hatch pattern to the selected part. 

 
 

12.5.5    Broken View 

You can create a broken view in a drawing of a long part that has a uniform cross-section.  Creating 
a broken view is useful when you want to display a part with a larger scale on a smaller size drawing 
sheet. 

 To insert a broken view:  

1. Select the Select  tool from the View toolbar if it is not already selected. 

2. Right-click the view you want to break in the Drawing Explorer or the work area and select 
Create Broken View from the pop-up menu; or select the view and then from the Insert menu, 

select Broken View; or select the view and then select the Broken View  tool from the 
Detailing toolbar. 

3. Two break lines appear in the view and the Broken View dialog appears. 

 

4. Select a break line Style.  You can use Straight, Zig, or Curve break lines. 

5. Drag the break lines to the appropriate break locations in the view. 

6. Specify the break Width. 
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7. Specify a break line Angle if desired. 

8. Click OK.  The part is displayed with a break in the geometry. 

 

Reference dimensions and part dimensions associated with the broken area reflect the actual value. 

 

 To modify the broken view: 

1. Click the Select  tool from the View toolbar if it is not already selected. 

2. Move the cursor over one of the break lines. 

3. Right-click the break line and select Edit from the pop-up menu.  The Broken View dialog 
appears. 

4. Change the Style, Width, or Angle as necessary. 

5. Drag the break lines to redefine the break position. 

6. Click OK when finished. 

 

 To restore the broken view to it original state: 

1. Select the Select  tool from the View toolbar if it is not already selected. 

2. Move the cursor over one of the break lines. 

3. Right-click the break line and select Delete from the pop-up menu.  The break lines are deleted 
and the view is restored to its unbroken state. 
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12.5.6    Partial View 

You can modify an existing view to create a partial view.  A partial view allows you to only show a 
portion of an existing view.  

 To insert a partial view:  

1. Click the Select  tool from the View toolbar if it is not already selected. 

2. Select the view that you wish you transform into a partial view, then select the Sketch Mode 
tool from the Sketching toolbar.  Partial views can be created from any other view, including 
primary and dependent views. 

3. Sketch any closed figure enclosing the area that you wish to keep in the partial view.  

    

4. Select the Partial View  tool from the Detailing toolbar; or from the Insert menu select 
Partial View. 

5. Select the sketched closed figure.  The view will transform into a partial view. 
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 To change the partial view area size: 

1. Choose the Select  tool from the View toolbar if it is not already selected. 

2. Move the mouse pointer over the partial view area dashed outline. 

3. Right-click the dashed outline and select Edit.  The Partial View Annotation dialog appears. 

          

4. Make any necessary changes to the partial view outline.  You can only modify the exiting 
sketch lines; you cannot sketch new ones. 

5. In the Partial View Annotation dialog, select Cancel to discard the changes, or OK to update 
the partial view. 

 

 To move the partial view area: 

1. Click the Select  tool from the View toolbar if it is not already selected. 

2. Move the mouse pointer over the partial view area dashed outline. 

3. Click and drag the outline to a new position in the view.  You will see a dialog letting you know 
that moving the annotation will update the dependent views.   
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4. Choose Yes to continue, or No to cancel the operation. If you choose Yes, the partial view is 
updated automatically to reflect the view outline's position change.  (You can turn the prompt off 
if desired - from the Tools menu, select Options.  On the General tab, uncheck Prompt when 
detail, section, or partial view annotation moved.) 

 

 To transform the partial view back to its original state: 

1. Choose the Select  tool from the View toolbar if it is not already selected. 

2. Move the mouse pointer over the partial view area dashed outline. 

3. Right-click the dashed outline and select delete.  

 
 

12.5.7    Exploded View 

You can insert a 2D exploded view representation of any exploded view you created in the assembly 
workspace. 

 To create an exploded view of an assembly: 

1. Select the Standard Views  tool from the Detailing toolbar; or from the Insert menu, select 
Standard Views.  The Standard Views Creation dialog appears. 

2. In the Design area, select the assembly item from the drop down list that you want to insert an 
exploded view of; or click Browse to select the assembly from the Document Browser.  Any 
exploded views that were saved with the assembly are subsequently listed in the Exploded 
Views drop down list. 

3. Select the appropriate exploded view to insert. 

 

4. Use the arrow buttons in the Front View area as well as the View Selection buttons to select 
the appropriate exploded view orientation(s). 



Chapter 12 - Drawings 

 
 
 

 415 
 

5. Click OK.  A preview of the exploded view appears in the work area. 

6. Move the cursor to position the view. 

7. Click to place the exploded view on the sheet. 

Note:  You can toggle on and off the trail lines of an exploded view by right clicking on the view and 
selecting Show Part Trails. 

 
 

12.5.8    Flat Pattern View of a Sheet Metal Part 

You can insert a flat pattern representation of any sheet metal part you created.  Bend lines will be 
shown in a flat pattern view, and they can be used to create dimensions. 

 To create a flat pattern view of a sheet metal part: 

1. Select the Standard Views  tool from the Detailing toolbar; or from the Insert menu, select 
Standard Views.  The Standard Views Creation dialog appears. 

2. Follow steps 1-4 for creating standard views (see "Inserting Standard Views" on page 362), and 
then click the More Options button to see all of the View Creation Options.   

3. Check the Project as Flat Pattern box.                   

4. Click OK.  A preview of the flat pattern view appears in the work area. 

5. Move the cursor to position the view. 

6. Click once to place the view on the sheet. 

 
 

12.6    Custom Templates 

You can create a custom drawing template that meets your design process requirements.  A custom 
template can be created in two different ways:  as a symbol that you insert into a drawing, or saved 
as a drawing that you select from the New Sheet Properties dialog. 
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12.6.1    Creating a Custom Template 

 To create a custom template: 

1. Open a new drawing workspace.  The New Sheet Properties dialog appears. 

2. Select Blank Sheet. 

3. Select a sheet size from the pull-down list. 

4. Click the Create An Empty Drawing check box. 

5. Click OK.  An empty drawing workspace appears. 

6. In the work area, sketch the border and title block using the sketch tools. 

 

7. Create text labels or standard information such as your company's name and address.  From 
the Sketch menu select  Text > Label.  Text labels can be used for making title block labels 
such as Scale, DRW, PART NO., etc. 

8. Set up fields that collect data from the user for variable information such as Drawn by, Date, 
Designed For, Drawing Number, Scale, etc.  From the Sketch menu select Text > Field.   Text 
fields can be used for making title block fields to receive data that corresponds with SCALE, 
DRW, PART NO., etc. 
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9. Save the custom template as a drawing (see "Saving and Using a Custom Template as a 
Drawing" on page 418) or as a symbol (see "Saving and Using a Custom Template as a 
Symbol" on page 419). 

 
 

12.6.2    Customizing an Existing Template 

 To customize an existing template: 

1. Open a new drawing workspace.  The New Sheet Properties dialog appears. 

2. Select the Template option and select a template from the list.  To open a custom template not 
listed, click Browse and select the template from the Custom Drawing Template dialog.  
Note:  If you have previously browsed to another template folder, you can use the Default 
button to reset the template list back to the system template folder. 

3. Click OK in the Sheet Properties dialog. 

4. If the Fill In Text dialog appears, complete any applicable fields. 

5. Click OK when finished with the Fill In Text dialog. The Insert Design dialog appears. 

6. Click Cancel. 

7. Right-click the sheet in the Drawing Explorer and select Activate Sketch on Sheet from the 
pop-up menu. 

8. Move the mouse pointer over the drawing border.  The border is highlighted. 

9. Right-click and select Explode Symbol from the pop-up menu.  The template is exploded into 
individual segments. 

10. Make the necessary changes to the template. 

11. From the Sketch menu, select Activate Sketch to leave the sketch mode. 

12. Save the custom template as a drawing (see "Saving and Using a Custom Template as a 
Drawing" on page 418) or as a symbol (see "Saving and Using a Custom Template as a 
Symbol" on page 419). 
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Note:  When you use the template, all of the entities will be placed on the continuous layer.  You can 
right-click on an entity and choose Explode Symbol to explode the format and all entities will revert 
to their original layer.  Most of the time you will not need to do this.  It is only necessary if you need 
to see the different line styles for the entities in the template.  

 
 

12.6.3    Saving and Using a Custom Template as a Drawing 

 To save a custom template as a drawing: 

1. From the File menu, select Save As.  The Save As dialog appears. 

2. Navigate to the desired location in either a repository or the file system. 

3. Specify a name for the drawing template. 

4. Click Save. 

 

 To use a custom template drawing: 

1. Start a new drawing. 

2. In the New Sheet Properties dialog, choose Template, and 
select the Browse button. 

3. In the Custom Drawing Template dialog, browse through your repository or file system to find 
the desired template, which you have already saved, and click it. 

4. Click OK in the Custom Drawing Template dialog (The OK button is slow to activate here). 

5. Click OK. 

6. You will be prompted to fill in any default and user added text if you put any text fields in your 
template.  Enter the desired information; then click OK.  
Your drawing format will appear, with the prompt to select a model. 
 

Note:  The next time the New Sheet Properties dialog is invoked, the Template list will be 
populated with all the custom templates located in the folder you last browsed to in step 2 
above.  You can use the Default button to reset this list to the default template folder. 
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12.6.4    Saving and Using a Custom Template as a Symbol 

 To save a custom template as a symbol: 

1. Select the Activate Sketch  tool from the Sketching toolbar. 

2. From the Sketch menu select Create Custom Symbol.  The Create Custom Symbol dialog 
appears. 

3. In the workspace, drag a selection box around the figures, fields, and labels that you want to 
include in the template. These elements appear in the Figures to include list. 

4. In the dialog, move your cursor to Anchor Point and click in the X or Y boxes.  

5. Click in the work area where you want the bottom left corner of the template to appear in a new 
Drawing workspace. The coordinates appear in the Anchor Point area and are relative to the 
origin.  Maintaining a (0,0) anchor point is acceptable. 

6. Click OK.  The Save Custom Symbol dialog appears. 

7. In the Repository Explorer, browse to the appropriate save location and select a repository 
and/or folder. 

8. Specify a name for the drawing template 

9. Click Save. 

 

 To use a custom template symbol: 

1. Open a new drawing workspace.  The New Sheet Properties dialog appears. 

2. Select Blank Sheet, and the corresponding sheet size. 

3. Click the Create An Empty Drawing check box. 

4. Specify the drawing Scale. 

5. Click OK.  A blank drawing workspace appears. 
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6. From the Sketch menu select Activate Sketch. 

7. From the Sketch menu select Insert Custom Symbol.  The Select Custom Symbol dialog 
appears. 

8. Browse the Repository Explorer and select the custom symbol you created to use as a 
template. 

9. Click OK. 

10. In the work area, select a location corresponding to the anchor point defined in the custom 
template. If your anchor point was defined at (0, 0), pick the sketch node representing the origin 
of the sheet.  The custom template appears in the work area. 

11. If any fields were created with the custom template, a dialog appears containing the field 
properties.  Enter the text associated with the fields. 

12. Click OK. 

 
 

12.7    Annotations 

You can insert various annotation types into a part, assembly, or drawing workspace to describe and 
clarify design and manufacturing information.  You can insert notes, datums and datum targets, 
feature control frames, surface finishes, weld symbols, and balloon callouts. 

To insert annotations in any workspace, from the Insert menu select Annotations and then select 
from the available annotation types. 

In a drawing workspace, the annotation tools are also displayed on the Detailing toolbar. 

 

 
Note Insert a note annotation 

 
Datum Insert a datum annotation 

 
Datum Target Insert a datum target annotation 

 
Feature Control Frame Insert a feature control frame notation 
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Surface Finish Insert a surface finish annotation 

 
Weld Insert a weld symbol annotation 

 
Callout Insert a balloon callout annotation 

You can pre-define certain display characteristics for annotations, including arrow types and sizes, 
text font, and the shape of balloon callouts, in the Annotations tab of the Drawing Properties 
dialog. 

 
 

12.7.1    Note 

You can create a free-floating note or a note with a leader pointing to an edge or face.  The note can 
contain both text and symbols.  In a part or assembly, you can attach annotations to solids.  In a 
drawing, you can attach annotations to any view, or to the projected edge of a model. 

 To insert a note: 

1. In any workspace, from the Insert menu select Annotation > Note; or in a drawing workspace, 

select the Note  tool from the Detailing toolbar.  The Note dialog appears. 

 

2. In the Note area, type the annotation text.  You may align the text vertically and horizontally by 
clicking the text alignment icons above the Note field. 
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3. Click Font to specify the font, font style, size, color, and effects. 

4. To insert a symbol, click the Symbols  button.  The Insert Alibre Design 
Symbols dialog appears.  Click a symbol to insert it.  Click Close to close the symbols box. 

5. Specify a Rotation Angle if required. 

6. If you want to include a leader, click the Show option in the Leader area.  

7. Select the Bent option if you want the leader line to have a short horizontal segment near the 
annotation.  

8. From the Arrow pull-down menu, select the arrow type you want to use. 

9. From the Position pull-down menu, select the position in which the text will be placed in 
relation to the leader. 

10. Select Smart Anchor if desired.  The smart anchor option will automatically adjust the position 
of the text if the leader is re-positioned.  The smart anchor option overrides the position 
selection in step 9. 

11. Move the mouse in the work area.  A preview of the annotation appears attached to the mouse 
pointer.  Left click once to place the leader line.  Left click again to place the annotation.  The 
text appears in light blue.   

12. Click Apply to accept the annotation placement (or you can double-click).  The dialog remains 
open so you can continue to place additional annotations. 

Before choosing Apply, you can reposition the annotation while it is light blue in color.  To do 
this, left click on the leader line or the text, whichever you wish to move, and release the mouse 
button.  Move the mouse to reposition.  Left click again to place it.  

13. Click Close to exit the dialog. 

Note: You can copy and paste note annotations on the same sheet or paste them on another sheet 
in the same drawing file.  

To copy the annotation: click on it to select it (press and hold the Shift key to select multiple 
annotations).  Then, either right click and choose Copy; or, from the Edit menu, select Copy.   

To paste the annotation: you can choose Paste from the Edit menu, or you can move your mouse 
to the location you want to paste the annotation and press CTRL + V on your keyboard. 
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12.7.2    Displaying Hole Callouts and Threads in Views 

Threaded hole information, if applied in the 3D design, can be called out upon creation of views in 
the 2D drawing.  Cosmetic threads, represented graphically by dashed lines, can also be called out 
on the drawing.  

 

The default callout includes the number of identical holes, the type of thread, and the thread depth. 

 

Setting hole callout and thread default options 

You can control whether hole callouts and cosmetic threads are automatically created with all new 
views.   

 To set default view creation options: 

1. from the File menu, select Properties.   

2. On the Detailing tab, in the View Creation Options section, check on all of the options that you 
want to include by default in all newly created views.  

 

 

Setting hole callout and thread options during view creation 

You can also choose to include the hole callouts and cosmetic threads during the creation of the 
view in the Standard Views Creation dialog.   
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1. From the Insert menu, select Standard Views.  

2. Fill out the information in the Standard Views Creation dialog as necessary.  

3. Click the More Options button to see the View Creation options.  

4. Check the Hole Callouts and/or Cosmetic Threads options as desired to include them 
automatically.  

5. Click OK to continue with the view creation.  

 

Manually adding, editing, or deleting hole callouts and cosmetic threads 

 To manually apply a hole callout: 

1. Move the cursor over the hole.  The hole is highlighted. 

2. Right-click and select Insert Hole Callout from the pop-up menu.  The hole callout is 
displayed. 

Or, 

1. Select the hole. 

2. From the Insert menu, select Hole Callout for Hole. 

Note: You can show the callouts for an entire view by right-clicking a view in the Drawing Explorer, 
or right-click a view in the work area and select Insert Hole Callouts. 

 

 To edit the hole callout: 

1. Move the cursor over the hole callout.  The cursor changes and displays the annotation symbol. 

2. Right-click the hole callout and select Edit from the pop up menu.  The Hole Callout dialog 
appears. 

3. Modify the Callout Note as necessary. 

4. Modify the Leader parameters as necessary. 
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5. Click OK when finished. 

 

 To manually apply cosmetic threads: 

1. Move the cursor over hole.  The hole is highlighted. 

2. Right-click and select Insert Cosmetic Threads from the pop-up menu.  The cosmetic threads 
are displayed for the selected hole. 

Or, 

1. Select the hole.  

2. From the Insert menu, select Cosmetic Thread for Hole.  

Notes:  

You can show the cosmetic threads for an entire view by right-clicking a view in the Drawing 
Explorer, or right-click a view in the work area and select Insert Cosmetic Threads.  

You can show the cosmetic threads as a ¾ circular figure by checking the Three Quarter Circle box 
in the View Creation Option section of the Detailing tab in the Drawing Properties dialog. 

 

 To delete a cosmetic thread: 

1. Move the cursor over the cosmetic thread symbol.  The cursor changes and displays the 
annotation symbol. 

2. Right-click the cosmetic thread and select Delete from the pop up menu. 

 
 

12.7.3    Datums 

In a part or assembly, you can attach annotations to solids.  In a drawing, you can attach 
annotations to any view, or to the projected edge of a model. 
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 To insert a datum annotation: 

1. In any type of workspace, from the Insert menu select Annotation > Datum.  In a drawing 

workspace, select the Datum  tool from the Detailing toolbar.  The Datum Annotation 
dialog appears. 

 

2. In the Datum Label box, specify the letter you wish to start the datum series with. 

3. Select the Show option if want to use a leader with the datum.  Select the Bent option if you 
want the leader line to have a short horizontal segment near the annotation. 

4. From the Position pull-down menu, select the position in which the text will be placed in 
relation to the leader. 

5. Select Smart Anchor if desired.  The smart anchor option will automatically adjust the position 
of the text if the leader is re-positioned.  The smart anchor option overrides the position 
selection in step 4. 

6. From the Arrow pull-down menu, select the type of arrow to use with the leader. 

7. Move the mouse in the work area.  A preview of the annotation appears attached to the mouse 
pointer.  Left click once to place the leader line.  Left click again to place the annotation.  The 
text appears in light blue.   

8. Click Apply to accept the annotation placement (or you can double-click).  The dialog remains 
open so you can continue to place additional annotations. 

Before choosing Apply, you can reposition the annotation while it is light blue in color.  To do 
this, left click on the leader line or the text, whichever you wish to move, and release the mouse 
button.  Move the mouse to reposition.  Left click again to place it.  
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9. Click Close to exit the dialog. 

 

Datums can be resized and repositioned by clicking the text and dragging.  This will change the 
length of the leader, as well as reposition the datum box. Datums can also be moved to another 
location by clicking the arrow, as opposed to the text. 

 
 

12.7.4    Datum Targets 

In a part or assembly, you can attach annotations to solids.  In a drawing, you can attach 
annotations to any view, or to the projected edge of a model. 
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 To insert a datum target: 

1. In any type of workspace, from the Insert menu select Annotation > Datum Target.  In a 

drawing workspace, select the Datum Target  tool from the Detailing toolbar.  The Datum 
Target Annotation dialog appears. 

 

The top area of the Datum Target dialog previews the annotation as you build it. 

2. Select the target type: Point, Circular, or Rectangular. 

3. In the Area fields, specify the target size. 

4. Select the Show option to show or hide the datum target. 

5. Select the Show size outside symbol option if desired. 

6. In the Target notation fields, specify the datum reference label(s). 

7. Select the Bent Leader option if necessary.  

8. Move the mouse in the work area.  A preview of the annotation appears attached to the mouse 
pointer.  Left click once to place the leader line.  Left click again to place the annotation.  The 
text appears in light blue.   

9. Click Apply to accept the annotation placement (or you can double-click).  The dialog remains 
open so you can continue to place additional annotations. 

Before choosing Apply, you can reposition the annotation while it is light blue in color.  To do 
this, left click on the leader line or the text, whichever you wish to move, and release the mouse 
button.  Move the mouse to reposition.  Left click again to place it.  
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10. Click Close to exit the dialog. 

Note: You can copy and paste datum target annotations on the same sheet or paste them on 
another sheet in the same drawing file.  

To copy the annotation: click on it to select it (press and hold the Shift key to select multiple 
annotations).  Then, either right click and choose Copy; or, from the Edit menu, select Copy.   

To paste the annotation: you can choose Paste from the Edit menu, or you can move your mouse 
to the location you want to paste the annotation and press CTRL + V on your keyboard. 

 

 

 

The datum target symbol can be repositioned by clicking the text and dragging. This will change the 
length of the leader, as well as reposition the datum target symbol. Datum targets can also be 
moved to another location by clicking the arrow, as opposed to the text. 

 
 

12.7.5    Feature Control Frames 

The geometric tolerance annotations let you specify a reference frame that contains all the 
geometric tolerance information for a selected surface or feature. The annotations support both the 
ANSI Y14.5 M-1982 and the 1994 standards. 
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Example 

 

 

You also include datum references if the geometric tolerance is related to a datum. 

You reference primary, secondary, and tertiary datum reference frames with the following material 
conditions for each geometric tolerance: 

(M) MMC-maximum material condition 

(L) LMC-least material condition 

(S) RFS-regardless of feature size 

(F) Free State-not limited by state position. 
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 To create a feature control frame: 

1. In any type of workspace, from the Insert menu select Annotation > Feature Control Frame.  

In a drawing workspace, select the Feature Control Frame  tool from the Detailing 
toolbar.  The Feature Control Frame dialog appears. 

 

2. If the geometric tolerance is related to a datum, specify as many as three datum references that 
form the Datum Reference Frame. For the primary, secondary, and tertiary datums: 

• Click the Datum reference letter. (The reference letters were created when you 
inserted the Datum annotations.) 

• Click the MC arrow for the datum, and select the material condition for that datum. 

3. Click the Symbol arrow, and select one or more of the displayed tolerance symbols. 

The geometric tolerance symbols indicate controls for form, profile, orientation, location, 
and runout. 

 

Symbol Control Type 

 Orientation Angularity 

 Form Circle 

 Location Concentricity 

 Form Cylindricity 

 Form Flatness 
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 Orientation Parallelism 

 Orientation Perpendicularity 

 Location Position 

 Profile Line Edge 

 Profile Surface 

 Runout Simple 

 Form Straightness 

 Locations Symmetry 

 Runout Total 

4. Specify the allowed Tolerance values. 

5. Select the Diametrical Tolerance  symbol if the tolerance is associated with a diameter 
zone. 

6. Select a material condition from the MC pull-down menu for each tolerance value. 

7. Repeat steps 2-6 on the Feature Relative tab if you want to specify a stacked feature control 
frame.  This allows you to see a different symbol for each row.  If you want a composite 
tolerance instead (one symbol shared across rows), check the Composite Tolerance 
checkbox. 

8. Select the Projected Tolerance option if required and specify the Height of the projected 
tolerance zone. 

9. Select the Standard that you want to use for the tolerance symbol.  Alibre Design supports 
ANSI Y14.5 M-1982 and 1994.  The preview shows the symbol for the selected standard. 

10. Select the Between Points option to call out a tolerance between two points.  Enter labels for 
the two points. 

11. Select the Show option to include a leader, the Bent option if desired, and select an Arrow 
type. 

12. Select Smart Anchor if necessary. 

13. Move the mouse in the work area.  A preview of the annotation appears attached to the mouse 
pointer.  Left click once to place the leader line.  Left click again to place the annotation.  The 
text appears in light blue.   
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14. Click Apply to accept the annotation placement (or you can double-click).  The dialog remains 
open so you can continue to place additional annotations. 

Before choosing Apply, you can reposition the annotation while it is light blue in color.  To do 
this, left click on the leader line or the text, whichever you wish to move, and release the mouse 
button.  Move the mouse to reposition.  Left click again to place it.  

15. Click Close to exit the dialog. 

Note: You can copy and paste feature control frame annotations on the same sheet or paste them 
on another sheet in the same drawing file.  

To copy the annotation: click on it to select it (press and hold the Shift key to select multiple 
annotations).  Then, either right click and choose Copy; or, from the Edit menu, select Copy.   

To paste the annotation: you can choose Paste from the Edit menu, or you can move your mouse 
to the location you want to paste the annotation and press CTRL + V on your keyboard. 

 
 

12.7.6    Surface Finish Symbol 

In drawing, part, or assembly workspaces you can specify the surface texture of a face by using a 
Surface Finish Symbol. In a part or assembly, you can attach annotations to solids.  In a drawing, 
you can attach annotations to any view, or to the projected edge of a model. 

 To create a surface finish symbol: 

1. In any type of workspace, from the Insert menu select Annotation > Surface Finish.  In a 

drawing workspace, select the Surface Finish  tool from the Detailing toolbar.  The 
Surface Finish dialog appears. 

2. From the Symbol pull-down menu, select the machining method for the surface finish. 

3. From the Lay Direction pull-down menu, select the direction of the surface pattern. 

4. In the Roughness area: 

• Specify a value for the Maximum allowable height deviation from the surface mean plane. 

• Specify a value for the Minimum allowable height deviation. 

• Specify a value for the average Spacing of roughness peaks. 

• Specify a value for the roughness Sampling length. 
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5. Select the symbol Standard that you want to use.  Alibre Design supports ANSI Y14.16, ISO 
1302, and JIS Symbols. 

6. In Material Removal, specify the value for the amount of stock to be removed by the 
machining method that you selected. 

7. In the Waviness area: 

• Type a value for the Waviness (peak-to-valley height) of the waves. 

• Type a value for the Spacing between adjacent peaks. 

8. If you want to specify the Production Method to be used for the surface finish, type it in the 
box provided. 

9. If you want to include a leader: 

• Select Show. 

• Select Bent if you want the line to have a short horizontal segment near the annotation. 

• Click the Arrow down arrow, and select a style. 

10. Move the mouse in the work area.  A preview of the annotation appears attached to the mouse 
pointer.  Left click once to place the leader line.  Left click again to place the annotation.  The 
text appears in light blue.  

11. Use the Rotation Angle to change the angle at which the symbol is displayed. 

12. Check the Flip Text box if you desire to flip the text 180°. 

Note: The Flip Text box will automatically become checked if the rotation angle goes above 
90°.  However, you can uncheck the box if you do not want the text flipped. 

13. Click Apply to accept the annotation placement (or you can double-click).  The dialog remains 
open so you can continue to place additional annotations. 

Before choosing Apply, you can reposition the annotation while it is light blue in color.  To do 
this, left click on the leader line or the text, whichever you wish to move, and release the mouse 
button.  Move the mouse to reposition.  Left click again to place it.  

14. Click Close to exit the dialog. 

Note: You can copy and paste surface finish annotations on the same sheet or paste them on 
another sheet in the same drawing file.  
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To copy the annotation: click on it to select it (press and hold the Shift key to select multiple 
annotations).  Then, either right click and choose Copy; or, from the Edit menu, select Copy.   

To paste the annotation: you can choose Paste from the Edit menu, or you can move your mouse 
to the location you want to paste the annotation and press CTRL + V on your keyboard. 

 
 

12.7.7    Weld Symbol 

 To create a weld symbol: 

1. In any type of workspace, from the Insert menu select Annotation > Weld.  In a drawing 

workspace, select the Weld  tool from the Detailing toolbar.  The Weld dialog appears. 

2. Click the Far or Near tab, depending on where you want the annotation placed in relation to the 
design. 

3. From the Finishing method pull-down menu, select the method that you want to specify. 

4. From the Contour pull-down menu, select the shape that you want for the weld surface. 

5. Specify a Groove angle value in degrees. 

6. Specify a Root opening value. 

7. In the Weld symbol area, select the weld symbol from the pull-down menu. You can also type 
text into the boxes on both sides of the weld symbol. 

8. In the Joint with spacer area, select the spacer type from the pull-down menu. 

9. Select the applicable weld placement options: 

• All around 

• Field or site weld 

• Display pointing down (enabled if you select Field or site weld) 

• Stagger weld (enabled if you select a fillet for both the Near and Far tabs) 

10. In the Specification process area, type any additional instructions to be included with the weld 
symbol. 
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11. If you are specifying both a Near and a Far weld, click the other tab, and repeat the steps for 
the other weld. 

12. If you want to include a leader: 

• Select Show. 

• Select Bent if you want the line to have a short horizontal segment near the annotation. 

13. In Arrow, select an arrow style. 

14. Move the mouse in the work area.  A preview of the annotation appears attached to the mouse 
pointer.  Left click once to place the leader line.  Left click again to place the annotation.  The 
text appears in light blue.   

15. Click Apply to accept the annotation placement (or you can double-click).  The dialog remains 
open so you can continue to place additional annotations. 

Before choosing Apply, you can reposition the annotation while it is light blue in color.  To do 
this, left click on the leader line or the text, whichever you wish to move, and release the mouse 
button.  Move the mouse to reposition.  Left click again to place it.  

16. Click Close to exit the dialog. 

Note: You can copy and paste weld annotations on the same sheet or paste them on another sheet 
in the same drawing file.  

To copy the annotation: click on it to select it (press and hold the Shift key to select multiple 
annotations).  Then, either right click and choose Copy; or, from the Edit menu, select Copy.   

To paste the annotation: you can choose Paste from the Edit menu, or you can move your mouse 
to the location you want to paste the annotation and press CTRL + V on your keyboard. 

 
 

12.7.8    Editing and Deleting Annotations 

You can edit or delete an annotation anytime after it has been created and placed. 

 To edit or delete an annotation: 

1. Select the Select  tool from the View toolbar. 

2. Move the cursor over the annotation.  The annotation is highlighted and the cursor includes the 
symbol icon when it is over the annotation that can be edited or deleted. 
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3. Right-click the annotation and select Edit or Delete from the pop-up menu.  In the Edit case, 
the Annotation dialog appears. 

4. Make the necessary changes to the annotation properties. 

 

 To move an annotation: 

1. In the workspace, click an annotation, then without releasing the button, drag the annotation.  
You can align an annotation with other annotations when you drag it.  To turn this option on and 
off, from the Tools menu, select Options.  On the General tab, check (to turn on) or uncheck 
(to turn off) Align annotations when dragging.  When this option is checked on, you can 
press and hold the CTRL key to override it. 

Or, 

1. Right-click the annotation you would like to change and select Edit. The original dialog 
appears. 

2. In the workspace, click where you want to move the annotation. 
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C H A P T E R  1 3  

 Bills of Material 
You can create a bill of material (BOM) for an assembly, as well as a part if necessary.  You can 
create a custom BOM, or create a new BOM from a template. 

The bill of material is fully associative to the assembly and/or drawing.  A change made in the 
assembly (e.g. adding or removing parts and subassemblies) is automatically applied to the BOM.  

You can launch the BOM workspace directly from the drawing.  Changes made in the BOM 
workspace will be updated automatically in the drawing.  Manual changes to the BOM are not 
reflected in the associated assembly (or part).  

In This Chapter 

Specifying BOM Data .............................................................................................. 440 
Creating Bills of Material.......................................................................................... 441 
Working With a BOM in a Drawing .......................................................................... 444 
Working in a BOM Workspace ................................................................................ 454 
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13.1    Specifying BOM Data 

You can specify BOM related properties for a part or for an assembly that you want to treat as a part 
for BOM purposes.  Consequently, these properties can be displayed in a BOM of any assembly that 
contains the part or assembly. 

 To save BOM data with a part: 

1. From the File menu, select Properties.  The Design Properties dialog appears. 

2. Select the General tab. 

3. Scroll through the Property list to find the applicable BOM property.  

4. To enter BOM property data, click in the corresponding value field.  The cursor appears. 

5. Type in the appropriate text. 

6. Continue specifying value fields as required. 

7. Click Apply. 

8. Click Close. 

9. Save the part. 

When you add the part to an assembly, and subsequently create a BOM, the BOM data will 
automatically be displayed. 

 

 To save BOM data with an assembly: 

1. Follow the procedure above for a part but also check the option Treat as part in BOM, which is 
found in the General tab of the Design Properties dialog. 
 
Now, this assembly will be treated as a part whenever it is encountered in a BOM.  It will 
appear as a single item in the BOM.  Also, the BOM properties assigned to it will be reported in 
the BOM.  The parts contained in this assembly will not appear as separate items in the BOM. 
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13.2    Creating Bills of Material 

You can create a new Bill of Materials for an assembly, and a part if necessary.  You must first 
create the design and save it before a BOM can be created.  

 
 

13.2.1    Creating a New BOM 

 To create a new Bill of Materials: 

1. In the Home window, Repository, or any workspace, from the File menu, select New > Bill of 

Materials; or, select the Bill of Materials  tool from the main toolbar.  

2. The Bill of Materials dialog appears. 

 

 

3. Select the New Bill of Materials option. 
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4. In the Choose Template area, select the Standard Template or Custom Template option. 

5. If you are using a Standard Template, select the appropriate template size as well. 

Note:  Alibre Design includes the BOM ANSI ABC and BOM ANSI D&E bill of materials 
templates ready for use.  The BOM ANSI ABC template is for use with drawing templates ANSI 
A Portrait, ANSI A Landscape, ANSI B, and ANSI C.  The BOM ANSI D&E template is for use 
with drawing templates ANSI D and ANSI E. 

6. If you are using a Custom Template, click Browse.  The Select Bill of Materials Template 
dialog appears.  Select the appropriate template and click OK. 

7. In the Bill of Materials dialog Design area, click Browse.  The Choose Design Part or 
Assembly dialog appears. 

8. Select the assembly or part for which you want a bill of materials. 

9. Click OK in the Choose Design Part or Assembly dialog. 

10. Click OK in the Bill of Materials dialog. 

11. The BOM workspace appears containing the BOM data.  When using a new BOM template, the 
first row will be blank by default.  The default headers are Item Number, Part Number, 
Quantity, and Part Name. 

12. Modify the BOM (see "Working in a BOM Workspace" on page 454) as required. 

13. From the File menu, select Save; or select the Save  tool from the main toolbar.  The 
Save dialog appears. 

14. In the Document Browser, select the location in which you want to save the BOM. 

15. Enter the BOM Name. 

16. Click Save.  The BOM can now be opened independently or inserted into a drawing (see 
"Inserting a BOM  View Into a Drawing" on page 444) if necessary. 

 
 

13.2.2    Creating a Custom BOM Template 

You can create a custom BOM template to meet your own design, purchasing, and production 
requirements and specifications. 
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 To create a custom BOM template: 

1. In the Home window, Repository, or any workspace, from the File menu, select New  > Bill of 

Materials; or select the New Bill of Materials   tool from the main toolbar.  The Bill of 
Materials dialog appears. 

2. Select the New Bill of Materials template radio button. 

3. Click OK.  A New Bill of Materials workspace appears.  The workspace contains one empty row 
by default.  The default column headers are Item Number, Part Number, Quantity, and Part 
Name.  

 

 

Note:  If you choose to leave a blank row in the custom template, the blank row will be listed 
first any time you use the custom template.  Delete the blank row if you do not want to include it 
in the custom template. 

4. Modify the table (see "Working in a BOM Workspace" on page 454) as necessary to meet your 
requirements.   

5. Select the Save  tool from the Standard toolbar; or from the File menu, select Save.  The 
Save dialog appears. 

6. In the Document Browser, select the location in which you want to save the custom template. 

7. Specify a Name for the custom template. 

8. Select Alibre as the Save as type. 

9. Click Save. 
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13.3    Working With a BOM in a Drawing 

13.3.1    Inserting a BOM View Into a Drawing 

You can insert a new BOM view or existing BOM view into a drawing.   

Note: You can only insert one BOM view per drawing.  However, you can insert the BOM view into 
any drawing sheet.   

When you insert a BOM view into a drawing, you are automatically linking the BOM to the drawing.   
Linking a BOM to a drawing creates an association between the BOM data and the drawing itself.  
You can link a BOM to a drawing (see "Linking a BOM to a Drawing" on page 446) without actually 
inserting the view into a sheet.   

 To insert an existing BOM view into a drawing: 

1. Select the Insert Bill of Materials  tool from the Detailing toolbar; or from the Insert menu, 
select Bill of Materials View. 

2. The Bill of Materials dialog appears. 
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3. Click the Existing Bill of Materials radio button. 

4. Click Browse.  The Choose Design Part or Assembly dialog appears.  In the Document 
Browser, navigate to the location containing the BOM.  

5. Select the BOM item and click OK.  

6. Click OK in the Bill of Materials dialog.  A preview of the BOM view appears in the work area 
and is listed in the Drawing Explorer with the other views. 

 

7. Move the cursor to position the BOM view on the sheet and click to place the view.  

8. You can move a BOM view just like any other drawing view. 

 

 To insert a new BOM view into a drawing: 

1. Select the Insert Bill of Materials  tool from the Detailing toolbar; or, from the Insert 
menu, select Bill of Materials View.  The Bill of Materials dialog appears. 

2. Click the New Bill of Materials radio button. 

3. Select a Standard Template. 

Or, 

Select a Custom Template.  Click Browse to select the custom template. 

4. In the Design area, click Browse.  The Choose Design Part or Assembly dialog appears.  

5. In the Document Browser, navigate to the location containing the design. 

6. Select the design and click OK. 
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7. Click OK in the Bill of Materials dialog.  A preview of the BOM view appears in the work area 
and is listed in the Drawing Explorer in the sheet view list. 

8. Move the cursor to position the BOM view on the sheet and click to place the view. 

 
 

13.3.2    Linking a BOM to a Drawing 

Linking a BOM to a drawing creates an association between the BOM data and the drawing itself.  
You can link a BOM to a drawing without actually inserting the BOM view into a sheet.  This is useful 
if you want to display item callouts in a drawing but do not want to display the BOM data in the 
sheet.   

Before you can insert callout balloons, you must either link a BOM to a drawing or insert a BOM view 
into the drawing.  Inserting a BOM view into a drawing automatically links the BOM to the drawing. 

 To link a BOM to a drawing: 

1. From the Tools menu, select Bill of Materials > Link; or in the Drawing Explorer, right-click 
the drawing name and select Link Bill of Materials from the pop-up menu.  The Bill of 
Materials dialog appears. 

2. To link a new BOM, select the New Bill of Materials option.  Specify the Standard Template 
or Custom Template option, and select a size or template accordingly.  Click Browse to select 
the applicable design.  

3. To link an existing BOM, select the Existing Bill of Materials option. 

4. Click Browse.  The Choose Design Part or Assembly dialog appears. 

5. In the Document Browser, navigate to the location of the BOM. 

6. Select the applicable BOM in the item list. 

7. Click OK.  The BOM name appears in the Bill of Materials dialog. 

8. Click OK.  The BOM item appears in the Drawing Explorer under the drawing name. 

You can insert callout balloons after the BOM has been linked to the drawing.  
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13.3.3    Unlinking a BOM from a Drawing 

Unlinking a BOM from a drawing removes all association between the BOM and drawing.   If the 
BOM view has been inserted into the sheet, unlinking a BOM will delete the BOM view from the 
sheet automatically. 

 To unlink a BOM from a drawing: 

1. In the Drawing Explorer, right-click the BOM item beneath the drawing name and select Unlink 
from the pop-up menu; or from the Tools menu, select Bill of Materials > Unlink.  If a BOM 
view exists in the drawing, the Unlinking Bill of Materials dialog appears. 

2. In the Unlinking Bill of Materials dialog, click Yes.  If applicable, the BOM view is deleted 
from the drawing sheet, and the association between the BOM and the drawing is broken. 

 
 

13.3.4    Editing a BOM 

You can open the BOM workspace directly from the drawing and subsequently edit the BOM 
attributes. 

 To edit the BOM from the drawing: 

1. Select the Select  tool from the View toolbar. 

2. Move the cursor over the BOM view in the work area and double-click; or in the Drawing 
Explorer, right-click the BOM item and select Edit Bill of Materials from the pop-up menu; or in 
the Drawing Explorer, double-click the BOM item.  The BOM workspace appears. 

3. In the BOM workspace, edit the BOM as necessary (refer to section 11.4 for information related 
to working in a BOM workspace).  The BOM view in the drawing will update automatically. 

4. Close the BOM workspace when finished.  You do not need to save the changes before you 
close the BOM workspace.  Any changes made to the BOM will be saved when you save the 
drawing. 

 
 

13.3.5    Moving the BOM View on the Sheet 

You can move a BOM view after it has been inserted into a sheet. 



 Chapter 13 - Bills of Material 

 
 
 

448 

 To move a BOM view on a sheet: 

1. From the Tools menu, select Selection Filters > Views, if it is not already selected. 

2. Select the Select  tool from the View toolbar. 

3. Move the cursor over the view in the work area.  The view is highlighted and the cursor 
changes. 

 

4. Click and drag the view to the desired location on the sheet. 

5. Release the mouse button to place the view. 

 
 

13.3.6    Hiding the BOM View 

You can hide the BOM view in a sheet. 

 To hide a BOM view: 

1. In the Drawing Explorer, right-click the BOM item listed under the sheet and select Hide from 
the pop-up menu. 

Or, 

1. Click the Select  tool from the View toolbar. 

2. Move the cursor over the BOM view in the work area, right-click, and select Hide from the pop-
up menu. 
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The view is hidden in the work area and the associated text is dimmed in the Drawing Explorer. 

 

 

 To show the BOM view:  

Right-click the dimmed BOM item in the Drawing Explorer and unselect Hide from the pop-up menu. 

 
 

13.3.7    Deleting the BOM View 

You can delete a BOM view from a sheet at anytime. 

 To delete a BOM view: 

1. In the Drawing Explorer, right-click the BOM item listed under the sheet and select Delete from 
the pop-up menu. 

Or, 

1. Click the Select  tool from the View toolbar. 

2. Move the cursor over the table in the work area, right-click, and select Delete from the pop-up 
menu. 

 

The table is deleted from the work area and Drawing Explorer. 

Note:  The BOM is still associated with a drawing after you delete a table from a sheet.   You must 
unlink the BOM from the drawing to remove all association between the BOM and drawing.  Refer to 
section 11.3.3 for information related to unlinking a BOM from a drawing. 
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13.3.8    Moving a BOM View to Another Sheet 

You can move the BOM view from one sheet to another sheet in the drawing if necessary. 

 To move the BOM view from one sheet to another: 

1. Click the Select  tool from the View toolbar. 

2. Right-click the BOM view in the work area or the Drawing Explorer and select Move from the 
pop-up menu.  The Move item is enabled only when the drawing contains at least two sheets. 

The Select Target Sheet dialog appears. 

3. From the Target Sheet list, select the sheet you want to move the BOM view to. 

4. Click OK.  The BOM view is listed under the target sheet in the Drawing Explorer and appears 
in the target sheet work area. 

 
 

13.3.9    Splitting a BOM View 

You can split a BOM view into multiple smaller views if necessary.  This is useful if a view is too long 
to fit onto a sheet. 

 To split a view: 

1. From the Tools menu, select Bill of Materials > Split View; or right-click the BOM view in the 
work area or Drawing Explorer and select Split View from the pop-up menu.  

2. The Split Bill of Materials View dialog appears. 
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3. The Minimum and Maximum values are specific to the table being split.  The Minimum value 
represents the combined width of the header row and the widest row in the table.  The 
Maximum value represents the combined width of the header row and all the rows in the table 
except for the last row. 

4. In the Split At field, specify a split value.  This value must fall between the Minimum and 
Maximum view height values. 

5. Click OK.  The view is split into multiple views.  

 

You can move the views independently on the sheet.  You can also move individual views onto a 
different sheet if necessary.  However, if you delete or hide one view, the rest of the views will be 
deleted or hidden as well.  If you add a row to the BOM after is has been split, the row will be added 
to the last BOM view. 

To restore the view back to its original configuration, enter a Split At value outside the Minimum - 
Maximum range. 

 
 

13.3.10    Adding Callout Balloons 

After you have linked a BOM with a drawing or inserted a BOM view into a drawing, you can add 
callout balloons to drawing views. 

 To add callout balloons: 

1. Select the Callout  tool from the Detailing toolbar; or from the Insert menu, select 
Annotation > Callout. 

2. The Callout Annotation dialog appears. 
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3. Select Regular or Split from the Style pull-down menu. The Regular style will by default 
display only the item number in the callout balloon.  The Split style will divide the callout 
balloon into halves.  The upper half displays the item number by default, and the lower half 
displays custom information. 

                    

   Regular Callout            Split Callout 

 

4. If necessary, select the Override option to manually enter an item number. 

5. If the Split type was selected, enter custom text in Lower (Custom) text box area. 

6. In the Leader area, select: 

7. Show if you want to display a leader with the callout balloon. 

8. Bent if you want to display a bent leader with the callout balloon. 

9. An Arrow type from the pull down menu. 

10. Move the cursor over a part in the drawing view.  The part is highlighted. 

 

 

11. Click once to create the callout balloon.  The callout balloon appears. 

12. Drag the balloon to the appropriate position and click to place. 

13. Click Apply in the Callout Annotation dialog.  The balloon is placed. 
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14. Continue to select parts and click Apply to add additional balloons. 

15. Click Close when finished. 

 

Notes:   

The Callout Annotation dialog appears by default when you insert a callout.  If desired, you can 
specify the callout settings you want to use in the dialog, and then unselect the Show dialog when 
inserting callouts option.  You will then be able to insert callouts quickly without using the dialog.  
After selecting the Callout tool, simply click a part in a view to create the callout balloon and click to 
place it.  To turn the dialog option back on, from the Tools menu, select Options.  In the General 
tab, select the Show dialog when inserting callouts option. 

You cannot copy and paste BOM callouts. 
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13.4    Working in a BOM Workspace 

All work related to creating or editing a BOM is performed in a BOM workspace.  The BOM 
workspace displays the bill of material data in tabular format similar to a spreadsheet.  

 

In a BOM workspace you can: 

• Add/delete rows & columns 

• Resize rows & columns 

• Hide rows 

• Change data and header font properties 

• Automatically re-sequence data 

• Override design values 

• Set column header and data alignment 

• Print BOM data 

• Export BOM data to a .CSV file 

• Append (add) rows 

• Organize data by dragging and dropping columns and rows 
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• Change the table display orientation 

• Sort data in ascending or descending order 

• Control how a BOM will be displayed in a drawing 

 
 

13.4.1    Adding and Deleting Columns in a BOM 

You can add standard or custom columns to a BOM as well as delete columns as needed. 

 To add a column to a BOM: 

1. From the Edit menu, select Insert Column; or right-click in the table area and select Column > 
Insert from the pop up menu.  The Insert Column dialog appears. 

 

Note:  In the Insert Column dialog, you can edit the fields under the Display As column.  You 
cannot edit the Property or Data Type fields when using standard headers. 

2. In the Standard Properties area select a column header from the options listed. 

3. Click the Add button to move the standard header to the column list. 
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4. To create a column with a custom header, click the Custom button.  The custom column is 
automatically added to the column list. 

 

5. Edit the Display As field for the custom header as necessary. 

6. In the Data Type column, select the column data format: Text, Date, Number, or Parameter. 

7. Columns will be displayed in the BOM in the order in which they are listed in the Insert Column 
dialog.  To move a column up or down in the list, select a row, and then click either the up 
arrow or down arrow. 

 

8. Click OK. 
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 To delete a column from a BOM: 

1. Click the table header of the column you want to delete.  The entire column is highlighted. 

 

2. Right-click in the table area and select Column > Delete from the pop up menu; or from the 
Edit menu, select Delete. 

 
 

13.4.2    Adding and Deleting a Row in a BOM 

You can add rows in a BOM as needed.  You can also delete a row at any time that has been 
manually inserted.  However, in order to delete a row that was generated automatically from a 
design (i.e., a part in the assembly), you must first delete the associated part in the assembly.  The 
Quantity value must then be updated to zero before the row can be deleted. 

 To add a row: 

From the Edit menu, select Append Row; or right-click in the table area and select Row > Append 
from the pop up menu.  A row is added to the end of the table. 

 

 To delete a row: 

1. Click the table row number you want to delete.  The entire row is highlighted. 
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2. Right-click in the table area and select Row > Delete from the pop up menu; or from the Edit 
menu, select Delete. 

 

13.4.3    Hiding a Row 

You can hide rows in a BOM.  Hidden rows are not displayed in the BOM view in the drawing. 

 To hide a row: 

1. Click the table row number you want to hide.  The entire row is highlighted. 

2. Right-click in the table area and select Row > Hide from the pop up menu; or from the Format 
menu, select Row > Hide.  The row becomes hidden.  

Note: A distinct line is displayed between the rows that border above and below the row that has 
been hidden.  In the illustration below, row 2 has been hidden. 

 

 

 To display hidden rows: 

From the View menu, select Hidden Rows.  The hidden row is displayed and the corresponding 
table row number field is orange. 

 

 

 To unhide a row: 

1. If hidden rows are displayed, select the table row number of the hidden row.  The entire row is 
highlighted. 

Or 
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If hidden rows are not displayed, select table row number above the hidden row, and then 
hold the Shift key and select the table row number below the hidden row.  Both selected 
rows become highlighted. 

2. Right-click in the table area and select Row > Unhide from the pop up menu; or from the 
Format menu, select Row > Unhide. 

 
 

13.4.4    Resizing Rows and Columns 

You can resize rows and columns to customize the look of the table. 

 To resize a row or column by dragging: 

1. In the row number or column header area, move the cursor near the edge of the row or column 
you want to resize.  The cursor changes appearance. 

 

 

2. Click and drag the row or column border to change the respective width or height. 

3. Release the mouse button when finished resizing. 

 

 To resize a row by specifying a row height value: 

1. Click the row number you want to resize.  The entire row is highlighted. 

2. Right-click in the table area and select Row > Height from the pop up menu; or from the 
Format menu, select Row > Height.  The Row Height dialog appears. 
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3. Specify the Row height value. 

4. Check the Apply to all rows option if desired. 

5. Click OK. 

 

 To automatically adjust a column's width: 

1. In the main column header area, move the cursor over the right edge of the column you want to 
automatically resize. 

2. Double-click the right edge.  The column width automatically adjusts to the widest field in the 
column. 

 

Or 

 

1. Click the table Header of the column you want to automatically resize.  The entire column is 
highlighted. 

2. Right-click in the table area and select Column > AutoFit from the pop up menu; or from the 
Format menu, select AutoFit Column.  The column width automatically adjusts to the widest 
field in the column.  

 
 

13.4.5    Adjusting Column Header and Data Alignment 

You can adjust the alignment of column headers and column data independently or together. 

 To adjust column header alignment: 

1. Select any field in the column in which you want to change the header alignment. 

2. Right-click in the table area and select Header Alignment > Left or Center or Right. 

Or, from the Format menu, select Header Alignment > Left or Center or Right.  

Or, select the Align Left , Center , or Align Right  tool from the View toolbar. 
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The column header alignment changes. 

 

 To adjust column data alignment: 

1. Select any field in the column in which you want to change the data alignment. 

2. Right-click in the table area and select Data Alignment > Left or Center or Right. 

Or from the Format menu, select Data Alignment > Left or Center or Right.  

Or select the Align Left , Center , or Align Right  tool from the View toolbar. 

 

The column data alignment changes. 

 

 To adjust column header and data alignment together: 

1. Click the table header of the column you want align.  The entire column is highlighted. 

2. Right-click in the table area and select Data Alignment > Left or Center or Right. 

Or from the Format menu, select Data Alignment > Left or Center or Right.  

Or select the Align Left , Center , or Align Right  tool from the View toolbar. 

 

The column header and data alignment changes. 

 
 

13.4.6    Moving Rows and Columns in a Table 

You can drag and drop rows and columns to reposition data within the table. 
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 To move a row or column: 

1. Move the cursor over a table column header or row number. 

 

2. Click the column header cell or row number cell and drag to the new table position. 

3. Release the mouse button to complete the move. 

 
 

13.4.7    Sorting Data in Ascending or Descending Order 

You can sort column data in ascending or descending order. 

 To sort data in ascending or descending order: 

1. Click the table header of the column you want to sort.  The entire column is highlighted. 

2. To sort the column data in ascending order, select the Sort Ascending  tool from the main 
toolbar; or from the Data menu, select Sort > Ascending. 

Or 

To sort the column data in descending order, select the Sort Descending  tool from 
the main toolbar; or from the Data menu, select Sort > Descending. 

 

The data is sorted accordingly. 

 
 

13.4.8    Changing the Header Display Orientation 

You can change the table display so that the header is located at the bottom of the table and the row 
numbers increase going up the table.  By default, the header is located at the top of the BOM table 
and the row numbers increase going down the table. 
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 To change the header display orientation: 

1. Select the Bottom Up Display  tool from the View toolbar; or From the View menu, select 
Bottom Up Display.  The column headers are positioned at the bottom of the table and the 
row numbers increase going up the table. 

2. To return to the default orientation, repeat step 1. 

 
 

13.4.9    Customizing Header and Data Font Properties 

You can change the font properties associated with column headers and tabular data. You cannot 
change font properties for individual items in the table. 

 To customize header font properties: 

1. Right-click in the table area and select Header Font from the pop-up menu; or from the Format 
menu, select Header Font.  The Font dialog box appears. 

2. Modify the Font, Font Style, Size, Effects, Color, and Script as desired. 

3. Click OK. 

 

 To customize data font properties: 

1. Right-click in the table area and select Header Font from the pop-up menu; or from the Format 
menu, select Header Font.  The Font dialog box appears. 

2. Modify the Font, Font Style, Size, Effects, Color, and Script as desired. 

3. Click OK. 

 
 

13.4.10    Overriding Design Values 

When you create a BOM, the table contains information based on the design, e.g. part number, part 
name, quantity, etc.  These items are referred to as design values since they are dictated by the 
design.  You can manually override design values in a BOM workspace.  Overriding a design value 
in the BOM workspace will not have an effect on the actual design. 
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 To override a design value: 

1. Select the field containing the design value that you want to override. 

2. Change the value as necessary and press Enter on the keyboard.  The cell containing the 
overridden value becomes blue. 

 

 

 To restore a value to its design value: 

1. Select the cell containing the overridden value. 

2. Right-click the cell and select Use Design Value from the pop-up menu; or, from the Edit 
menu, select Use Design Value.  The cells value is restored to the value specified by the 
design. 

 
 

13.4.11    Modifying the BOM View Style 

You can control how the BOM view is displayed in the drawing.  You can choose to show or hide row 
and column lines, only column lines, only row lines, or no lines.   The table style setting only applies 
to the BOM view in the drawing.  Table lines are always visible in the BOM workspace regardless of 
which table style setting is used.  By default, row and column lines are visible. 

 To modify the table style: 

Click the Options arrow on the View toolbar to display the Table Style drop down toolbar. 

 

From the toolbar, select: 

• No Lines: the BOM table will be displayed without lines. 
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• Row Lines: the BOM table will be displayed with row lines only. 

• Column Lines: the BOM table will be displayed with column lines only. 

• Row, Column Lines: the BOM table will be displayed with column and row lines. 

 

Or, 

 

From the Format menu, select Table Style > No Lines or Row Lines or Column Lines or Row, 
Column Lines. 

 
 

13.4.12    Resequencing Data 

You can resequence (reorder) data in a table after you delete or move rows.  Resequencing a BOM 
will reset the Item Numbers so that they are sequentially numbered correctly in the order listed. 

 To resequence a BOM: 

From the Data menu, select Resequence.  The Item Numbers are reordered. 

 

 

Before Resequencing 
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After Resequencing 

 
 

13.4.13    Updating the Table 

You can have the assembly workspace open and the BOM workspace open simultaneously.  
Consequently, you can update a BOM table after making changes to an assembly.  Before you can 
update the BOM, you first must save any changes made to the design.  The design does not need to 
be open in order to update the table.  You cannot update the BOM when it is being edited within the 
context of the drawing. 

 To update the table: 

From the Data menu, select Update Table. 

Or 

Select the Update Table  tool from the Edit toolbar. 

The table is updated to reflect any recent changes made in the design. 

 
 

13.4.14    Exporting a BOM 

You can export a BOM table as a .csv file.  You can open .csv files in any spreadsheet application or 
text editor. 
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 To export a BOM: 

1. Select the Export File  tool from the Standard toolbar; or from the File menu, select 
Export.  The Export File dialog box appears. 

2. Select the Save in location. 

3. Specify a File name. 

4. Select a Save as type. 

5. Click Save. 
 

13.4.15    Printing a BOM 

You can print a BOM table by itself directly from the BOM workspace. 

 To print a BOM table: 

1. From the File menu, select Print.  The Print dialog box appears. 

2. Select the appropriate printer. 

3. Specify the print layout. 

 





Chapter 14 - Importing and Exporting Data 

 
 
 

 469 
 

C H A P T E R  1 4  

 Importing and Exporting Data 
Alibre Design's import and export functionality enables interaction with data from other CAD 
systems.  Furthermore, machine tools and rapid prototyping can be driven from exported data 
created in Alibre Design.  The STEP format is an ISO standard that is driven by industry.  Alibre 
Design's native format is STEP AP 203 and AP 214, two protocols in the STEP standard.  Alibre's 
STEP schema allows for the creation of parametric features along with geometry.  This powerful 
capability and platform choice allows the data created in Alibre Design to be available for use 
beyond Alibre Design itself. 

In This Chapter 

Importing Data ......................................................................................................... 470 
Import Settings and Import Advisor ......................................................................... 473 
Exporting Data......................................................................................................... 475 
Special Options for IGES and STL Files ................................................................. 478 
 



 Chapter 14 - Importing and Exporting Data 

 
 
 

470 

 
 

14.1    Importing Data 

14.1.1    Supported File Types 

A variety of file formats are supported for interoperating with data from other CAD systems.  The 
import data types available are: 

• STEP AP 203/214 (*.stp, *.step, *.ste) 

STEP (Standard for the Exchange of Product model data).  An ASCII format set and 
driven by industry that all major CAD tools have adopted. 

• Alibre STEP (*.stp) 

Feature-based STEP data inherent from Alibre's STEP schema 

• SAT (*.sat) 

ACIS file format 

• IGES (*.igs) 

Initial Graphics Exchange Specification. An ANSI-standard format. 

• DWG (*.dwg) 

Standard file format for saving vector graphics from within AutoCAD. 

• DXF (*.dxf) 

For drawing interchange format. An ASCII or binary file format of an AutoCAD drawing file 
for exporting AutoCAD drawings to other applications or for importing drawings from other 
applications. 

• 3DM (*.3dm) 

Rhino Program file format 

 
 

14.1.2    Importing a File 

You can import 3D parts and assemblies in STEP, IGES, or SAT formats.  You can import 2D 
drawings in the DXF or DWG formats. 
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 To import a model file: 

1. Select the Import  tool from the Standard toolbar; or, from the File menu select Import.  
The Import File dialog appears. 

 

 

2. Browse to the location on the disc where the file is located and select the file. 

3. Click Open.  The File Import Options dialog appears if you are importing STEP (non-native 
Alibre), IGES, and SAT files (see section 12.2 for more information about import options). 

4. Select the applicable import options. 

5. Click OK.  The data appears in the workspace: 
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6. Note that the part is displayed in the Design Explorer with the label indicating the file type, e.g. 
Imported STEP file or Imported SAT file.  Any feature created on the imported model will 
appear after this entry in the feature history tree. 

 

 To import a DXF or DWG file: 

1. Select the Import  tool from the Standard toolbar; or from the File menu select Import.  
The Import File dialog appears. 

2. Browse to the location on the disk where the file is located and select the file. 

3. Click Open.  The Import DXF/DWG File dialog appears. 

 

 

4. Select the Units for the imported file. 

5. Check Maintain Projection to maintain the projection plane of the imported model in Alibre 
Design.  If this option is unchecked, the model will be projected onto the XY-Plane in Alibre 
Design. 

6. Check Import Only Visible Layers to bring in only the visible layers from the original file.  Any 
"frozen" or "off" layers will not be imported.  If this option is not checked all layers will be 
imported.  This can clutter the drawing and slow performance.  

7. Click OK.  The file opens in a drawing workspace. 
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14.2    Import Settings and Import Advisor 

Alibre Design's import settings provide various options to apply when importing data.  The Import 
Options dialog will appear by default as you import data.  You can also set default import options 
from any workspace. 

 To set default import options from a workspace: 

1. From the Tools menu select Options.  The Design Options dialog appears. 

2. Select the Interoperability tab. 

 

The Interoperability tab contains different selections that can be applied for imported data.  The 
selections for import are as follows: 

• Heal.  Recalculates inaccurate geometry in order to make the part more accurate upon 
import. 

• Make Tolerant.  Tags inaccurate geometry for more intelligent subsequent operations. 
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• Discard Non-Solid Faces.  Discards faces that are not part of a solid.  These faces may 
have been created for reference. 

• Unstitch To Standalone Faces.  Converts a solid part to a set of faces.  This can improve 
the visual representation of the part.  This option is not recommended if changes will be 
made to the solid. 

• Stitch To Solid.  Converts a surface model to a solid part. 

• Override Units.  Converts the units to those specified. 

• Note:  All import options can operate simultaneously, with the exception of Convert To 
Surface Model and Convert To Solid Model. 

3. Select Import Advisor to generate an import summary after the file has been imported.  With 
this option selected, a dialog appears after import displaying errors, suggestions and options 
that can be changed for the specific import issue. 

 

4. Select the Check Part option to obtain information about the integrity of the file. 

5. If Import Advisor or Check Part is checked, select an Accuracy level for the report: 

• Low: Fast error checks. 

• Medium: Slower error checks plus D-cubed curve and surface checks. 

• High: Slower warning and error checks plus D-cubed and surface checks. 

• Very High: Warning and error checks plus edge convexity change point and face/face 
intersection checks. 

6. Select Healing Analysis if Heal is checked under Import Options.  This produces a report on 
any data corrected as a result of the Heal command. 

7. Select Conversion Log to view a report about import. 

8. Check Do Not Show Options When Importing to bypass this dialog in the future.  Options set 
in the Design Options dialog will be used automatically. 
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9. Check Set As Default Import Options to use these settings for future imports.  Settings in the 
Design Options dialog will be updated. 

10. If any Analysis and Reporting options are selected, the Import File Analysis and Reporting 
dialog appears. 

 

To save report data, highlight the text and press Ctrl-C to copy. The text can be pasted into another 
application for viewing or printing. 

The tools that are available through the import options will provide a high degree of success in 
working with data from other CAD systems.  For issues that are elusive, the Alibre Assistant should 
be contacted. 

Options set in the Design Options dialog apply to all imports unless changes are made in the Import 
File Options dialog. 

All import options can operate simultaneously, with the exception of Convert To Surface Model and 
Convert To Solid Model. 

 
 

14.3    Exporting Data 

You can export Alibre Design native data using a number of formats. 

 
 

14.3.1    Supported File Types 

The table below summarizes the file types you can use to export data from Alibre Design. 
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Drawing Alibre Design file (*.stp) 

AutoCAD DWG file (*.dwg) 

AutoCAD DXF file (*.dxf) 

JPEG Image file (*.jpg) 

Bitmap file (*.bmp) 

Enhanced Metafile file (*.emf) 

 

Image Files: 

JPEG Image file (*.jpg) 

Bitmap file (*.bmp) 

PNG file (*.png) 

TIFF file (*.tiff) 

GIF file (*.gif) 

Assembly Alibre Design file (*.stp) 

AP 203 file (*.stp) 

AP 214 file (*.stp) 

ACIS 3.0-R10 files (*.sat) 

STL file (*.stl) 

 

Image Files: 

JPEG Image file (*.jpg) 

Bitmap file (*.bmp) 

PNG file (*.png) 

TIFF file (*.tiff) 

GIF file (*.gif) 

 

Part Alibre Design file (*.stp) 

AP 203 file (*.stp) 

AP 214 file (*.stp) 

ACIS 3.0-R10 files (*.sat) 

IGES file (*.igs) 

STL file (*.stl) 

Image Files: 

JPEG Image file (*.jpg) 

Bitmap file (*.bmp) 

PNG file (*.png) 

TIFF file (*.tiff) 

GIF file (*.gif) 

BOM CSV file (*.csv) 
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14.3.2    Exporting a File 

 To export a file: 

1. Select the Export  tool from the Standard toolbar; or, from the File menu select Export.  
The Export File dialog appears. 

 

 

2. Browse to the location you want to export the file to. 

3. Specify the File name. 

4. From the Save as type menu, select the appropriate file format to use. 

5. Click Save. 
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14.4    Special Options for IGES and STL Files 

Alibre Design has special option settings for exporting IGES and STL files and importing IGES 
files.  These special settings are found in the File Types tab of the Options dialog.  You can access 
the Options dialog by selecting Options from the Tools main menu in any 3D workspace. 
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C H A P T E R  1 5  

 The Repository 
The Repository is personal data vault and versioning system that lets you store and control access 
to project-related data.  The Repository is available in certain versions of Alibre Design. 

In This Chapter 
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15.1    Repository Overview 

By default, if you have a license for Repositories, your first repository is initialized on your local hard 
drive during installation.  You may create additional local repositories as needed.  Current 
subscribers may also purchase a repository on the Alibre Design server for centralized storage of 
team data.  

Anything stored in a repository, including parts, symbols, subassemblies, assemblies, drawings or 
other files, are referred to as items.  

Repositories are used to: 

• Store, retrieve and share designs and drawings created with Alibre Design. 

• Store, retrieve and share other project-related files. 

• Access and manage items in a familiar directory structure. 

• Track changes to items through built-in version history. 

• Copy and Paste or Move items between repositories and folders. 

• Manage access privileges for other Alibre Design users. 

You may give other teams and users specific access rights to a repository and its contents.  You can 
also decide who gets an automatic notification when items in the repository are changed.  To 
activate access privileges, you must also share the repository with these teams and users.  A shared 
local repository is only available to others when you are signed into Alibre Design on that computer.  
However, once shared, a server repository is available to other users even when you are not signed 
in. 

It is important to back up your repository regularly.  To do this, you create a Repository Snapshot 
(see "Repository Snapshots" on page 509). 

 
 

15.2    Local Repositories 

By default, upon installation, every Alibre Design user with repository capability is set up with one 
repository on the local hard drive.  Additional local repositories may be created as needed.  Local 
repositories exist on the computer where they were created. 

You may give other users specific access rights to content in your repositories.   
Your local repository is only available to others when you are signed into Alibre Design on the 
computer where the repository resides. 

You can move and delete local repositories as well. 
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15.2.1    Creating a Local Repository 

 To create a local repository: 

1. Select the New Repository  tool from the Standard toolbar; or from the File menu select 
New Repository; or right-click in the Repository Explorer and choose Create Repository.  The 
Choose Directory dialog appears. 

 
Figure 105: Choose Directory Dialog in Repository Workspace 

2. Enter a name for the new repository in the Repository field.   

Important Note: The name cannot contain any of the following characters: \ / : * ? " < > | & or 
the tab character.  Using one of these characters can cause the repository to not display in the 
repository workspace. 

3. From the Drives drop down menu, select the drive you want to store the repository on.  You 
can select a network drive if necessary.  Use the Browse button to search through non-
mapped network drives. 

4. Browse to select a location for the repository on the selected hard drive.  The selected location 
will be shown in the Location field. 
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5. Click New Folder if necessary. 

6. When finished, click OK.  The new repository will appear in the Repository Explorer. 

 
 

15.2.2    Moving a Local Repository 

You may change the storage location of a local repository.  This may be necessary if disk space 
becomes a limiting issue. 

 To move a local repository: 

1. In the Repository Explorer, select the repository you want to move. 

2. Select the Move  tool from the Standard toolbar; or right-click in the Explorer area and 
select Move from the pop-up menu; or from the Edit menu select Move.  The Choose Director 
dialog appears. 

3. Browse to select a new location.  You may also create a new directory using the New Folder 
button. 

4. When finished, click OK.  The repository is now stored in the indicated directory. 

 
 

15.2.3    Deleting a Local Repository 

You may delete all local repositories, but you cannot delete repositories that have been shared to 
you.  The contents of a deleted repository cannot be recovered. 

 To delete a local repository: 

1. In the Repository Explorer, select the repository you want to delete. 

2. Select the Delete  tool from the Standard toolbar; or right-click in the Explorer area and 
select Delete from the pop-up menu; or from the Edit menu select Delete.  The Confirm 
Repository Delete dialog appears. 

3. Click Yes. 

4. A second Confirm Repository Delete dialog appears.  If absolutely certain, type OK in the text 
box.  
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5. Click OK.  The repository and all its contents are permanently deleted.  They cannot be 
recovered. 

 
 

15.2.4    Renaming a Repository 

You may rename a local repository. 

 To rename a repository: 

1. In the Repository Explorer, right-click the repository and select Rename from the pop-up menu; 

or, select the Rename tool  from the Standard toolbar.  The Rename Repository dialog 
appears. 

2. Enter a new repository name.  

Important Note: The name cannot contain any of the following characters: \ / : * ? " < > | & or 
the tab character.  Using one of these characters can cause the repository to not display in the 
repository workspace. 

3. When finished, click OK.  The repository is renamed. 

 
 

15.3    About Repository Items 

Anything stored in a repository, including parts, symbols, subassemblies, assemblies, drawings, bills 
of material, or other files, is referred to as an item.  An item may contain notes, version history and 
comments. 
 

15.3.1    Item Types 

The following icons distinguish item types: 

 

Folders 
 

 

Parts 
 

Parts created in Alibre Design 
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Sheet Metal Parts 
 

Sheet Metal Parts created in Alibre Design 

Assemblies 
 

Assemblies created in Alibre Design 

Drawings 
 

Drawings created in Alibre Design 

Custom symbols 
 

Custom symbols can only be opened when in a 
drawing workspace.  They can be renamed, copied 
and deleted in the repository.  See Chapter 9 for more 
about custom symbols. 

Unknowns 
 

Other items are represented by the icon associated 
with the originating application, if known; otherwise a 
question mark is used.  

BOM 
  

Bill of Material created in Alibre Design 

Items of different types can have the same name.  You can give the same name to items of the 
same type only if they are in different folders.  

 

 
Figure 106: Repository Explorer Showing Various File Types 

 
 

15.3.2    Item Properties 

When you save a part, assembly or drawing for the first time, you are prompted for certain 
properties.  

• Item Name:  Equivalent to a file name.  Items can be renamed. 

• Version Number:  A number that you assign to the version you are saving. Displayed in 
the item's version history, described below. 
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• Description:  A text description.  Displayed in the property area of the Repository when the 
item is selected. 

• Notes:  Text notes attached to an item, indicated by a symbol on the icon . An item can 
have multiple notes. Access the notes by right-clicking the item and selecting Add/View 
Notes. 

Other properties include: 

• Checked Out status:  Indicates whether you, or another user, have the item checked out.  
You cannot edit an item that is checked out by another user. 

• Version History:  Lists the version number, user name, date saved, and any comment 
entered when the version was saved.  Displayed when you select the item and select 
Show Selected Item's Version History option. 

• Security/Notifications:  You assign access and notification policies for other users. 

 
 

15.3.3    Selecting Items 

To select one item or folder, click the item or folder. 

To select multiple items, press the Ctrl key as you select each item. 

To select all items in a folder, click the top item; then press Shift and click the last item. 

Note: You can select multiple items, but you cannot select multiple folders. 

 
 

15.4    Depositing and Withdrawing Other Files 

Files created outside Alibre Design may be stored in the Repository (e.g., Word documents, Excel 
documents, files from other CAD systems, etc.).  These files are referred to as Other items in the 
Repository environment.  The items can be launched in their associated program via the Repository, 
checked in/out, changed and saved.  Item properties such as notes and version history are also 
available.  
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15.4.1    Depositing Other Items 

You can deposit Other type items from your operating system file structure into the Repository.  You 
can deposit Alibre Design files into the repository, but this is not recommended.  The deposit 
functionality is intended for files that are created in other programs, that you would like to keep 
together with your Alibre Design files. Depositing Alibre Design files in the Repository results in 
limitations in some functions (see "Limitations of Deposited Alibre Design Files" on page 486).  

 To deposit an item: 

1. In the Repository Explorer, select the repository and folder where you want to deposit the file. 

2. Right-click in the Explorer and select Deposit from the pop-up menu; or from the File menu 
select Deposit.  The Deposit to Current Folder dialog appears. 

3. Browse to the location the file is stored in. 

4. Select the file. 

5. Click Open.  The file is stored in the selected repository location. 

Check Out the item if you do not want users with access to the folder to make changes to the file.  
Use Check In to make the item available again. 

 
 

15.4.2    Limitations of Deposited Alibre Design Files 

You can save your Alibre Design files in your Windows file system, or you can save the files in the 
Repository (if your version supports the Repository).  If you save the files in the file system, and then 
deposit them into the Repository, the files will be missing some of the attributes of files that are 
saved directly to the Repository.  Because of this, the Search capabilities of these files will be 
limited.  For example, a Where Used search will not located deposited items.   

To fully enable all of the search capabilities, you should save the file(s) directly to the Repository.  If 
you have already saved your file(s) to the file system or you have deposited them in the Repository, 
you can go through the following steps to save them directly to the Repository:  

 To save the file directly to the Repository: 

1. If the file(s) have already been saved to the file system, open the Alibre Design file from the 
file system (if there are multiple files, you can open the top-level assembly).  

2. From the File menu, choose Save As.   
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3. Save the file in a Repository. 

4. You can then delete the file that was saved in the file system. 

Or 

1. If the file(s) have already been deposited in the Repository, open the Repository workspace 
and locate the file(s).  

2. Double-click the file to open it (if there are multiple files, you can open the top-level assembly). 

3. From the File menu, select Save As.  

4. Save to a new location in the Repository.  You now have two copies of the file(s) - the 
deposited files and the newly saved files.   

5. Delete the deposited files.  

 

You will now have full search capabilities for the file(s).    

 
 

15.4.3    Withdrawing an Item 

You can withdraw Other type items from the Repository into your operating system file structure. 

 To withdraw an item: 

1. Select the item you wish to withdraw.  (To retrieve an earlier version of the file, show the 
version history and select the version you want to retrieve.) 

2. Right-click and select Withdraw from the pop-up menu; or from the File menu select 
Withdraw.  The Withdraw Selected Item dialog appears. 

3. Select the location where you want to withdraw the item to. 

4. Click Save.  A copy of the item is saved to the new location. 

Note:  While a copy of the item is saved to the new location, the item also remains in the repository. 
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15.5    Opening a Repository Item 

You can open the items created in Alibre Design, as well as items you have deposited in the 
Repository.  
 

15.5.1    To Open an Item 

1. Select the part, assembly, drawing or other item that you want to open. 

2. Double-click the item; or from the File menu select Open; or select the Open  tool on the 
Standard toolbar and click the Repository tab in the Open dialog. 

3. An Alibre Design part, sheet metal part, assembly, BOM, or drawing opens in a workspace. 

4. An Other item will open in the originating application.  For example, if you open a Word 
document, the item will be opened in Microsoft Word. 

 
 

15.5.2    Opening a Folder 

1. In the Repository Explorer, click the plus sign  to expand a repository and/or any top-level 
folders, if necessary. 

2. Select the folder you want to open.  The items within the folder appear on the right in the items 
list. 

 
 

15.5.3    Opening an Item That is Checked Out 

You can view an item that someone else has checked out by opening a read-only copy of it.  You 
cannot make changes to the read-only copy; all the editing commands and toolbar buttons in the 
workspace are disabled. 

 To view a read-only copy of an item: 

1. In the Repository Explorer, browse to the repository or folder that contains the item. 

2. Click the item to select it. 
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3. Right-click the item and select Open Read-only; or, select the Open Read Only tool  from 
the Standard toolbar; or,  from the File menu select Open Read-only. 

 
 

15.6    Searching for a Repository Item 

You can search Repositories to locate a particular item.  You can perform quick searches by 
filename, or you can perform an advanced search with properties such as file size, Alibre Design 
usernames, or your own custom properties.  

Note:  If you have deposited an Alibre Design file in the Repository, rather than saving it directly to 
the Repository, the search capabilities regarding that file will be limited (see "Limitations of 
Deposited Alibre Design Files" on page 486).   

 To perform a quick search: 

1. Type in all or part of a filename in the Quick Search field.  You can use a wildcard (*) if 
necessary at the beginning or end of the entry.  

 

2. Check the Search all repositories? option if you would like to search all of the available 
repositories to find the file.  If you leave this option unchecked, it will search in the Repository 
that you have selected.  The selected Repository is shown highlighted in the Design Explorer.  

3. Press the Enter key or click the Quick Search tool  to begin the search.  
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4. If there are no files matching the search requirements, you will receive a No Results Found 
message.  If files are found, the Search Results dialog will appear, with a list of all files meeting 
the requirements.   

 
Figure 107: Repository Search Results Dialog 

5. You can right-click on any of the items in the dialog and choose the desired option (see "Using 
the Search Results Dialog" on page 490). 

6. When you are finished with the Search Results, click OK to exit the dialog.  

The results of the last successful search are stored for future use. To access these results, from the 

Search menu, select Show Last Results; or, select the Show Last Results tool . 

 
 

15.6.1    Using the Search Results Dialog 

After you perform a search, if files are found, the Search Results dialog appears, with a list of all files 
meeting the requirements.  You can right-click on any of the items in the dialog and make one of the 
following selections:   

a. Open Read-only - open the file as a read-only file 

b. Show in Repository - the repository workspace will show the location of the item 

c. Where Used - perform another search to determine where the item is used (see "Where 

Used Search Options" on page 491) 

d. Show Constituents - a dialog appears listing all of the components of the selected item 

e. Item Notes - see any repository notes that have been created for the selected item 
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f. Version Properties - view the properties of the current version of the selected item 

If you need to open a model for editing after performing a search, the best method to do this is to 
right-click on it in the Search Results dialog, and choose the option Show in Repository.  This will 
highlight the item in the Repository.  You can then double-click the item to open it.  You can not open 
a file for editing from the Search Results dialog - you can only open a file as a read-only file.   

If you need to open multiple files after performing a search, the best method to do this is to use the 

Show Last Results option from the Search menu (or the tool ).  This allows you to return to 
your results without performing the same search over again.  

 
 

15.6.2    Where Used Search Options 

You can perform a where used search to locate all files where the selected item is used, including 
assemblies, drawings, and BOMs.  

 To perform a where used search: 

1. Select an item in the Repository, or in the Search Results dialog.   

2. If you are selecting an item in the Search Results dialog, right click the item and select Where 
Used, and then choose one of the following options (if you are selecting an item from the 
Repository, you can use the appropriate tool for each selection from the Search toolbar): 

a.  Top level Assemblies - lists only top level assemblies that contain the specified item 

somewhere in their constituents 

b.  Primary Parent Assemblies - lists the assemblies that explicitly contain the selected 

item 

c.  Drawings - lists all drawings that contain the selected item 

d.  BOMs  - lists all BOMs that contain the selected item 

3. The Advanced Search dialog appears.  Select which repositories you would like to search to 
find results.  

4. Click OK to begin the search.  
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15.6.3    Performing an Advanced Repository Search 

The Advanced Search tool allows you to query any available repositories for files based on wide 
variety of criteria.  

 To perform an advanced search: 

1. In the Repository workspace, select the Advanced Search tool ; or, from the Search menu, 
select Advanced Search.  The Advanced Search dialog appears.  Enter search criteria into 
any of the desired fields.  You do not have to enter data in all of the fields - only the ones you 
wish to search by.  

 

Basic Properties Section 

2. In Name Contains, enter all or part of a file name.  You can use a wildcard (*) at the beginning 
and/or end if necessary.  

3. In File Size Is, choose an option from the drop-down menu.  Choose Between to search for a 
file size between two values, or search for a file larger or smaller than the specified value.  

Advanced Properties Section 

4. In Notes, Descriptions, click the Set button to enter data in this field.  This will search through 
the Notes, Description, Comments, and Part Numbers that you have saved in your file.  You 
can use the wildcard (*) only in the Number field in this dialog.  

5. In Dates and Users, click the Set button to enter data in this field.  You can enter criteria for 
files that were created, modified, accessed, or checked out by users, and include a date range.   
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6. In Custom Properties, click the Set button to enter data in this field.  You can select from a list 
of properties that you have previously defined (see "Defining Custom Properties" on page 493).  
You can not use the wildcard symbol in the Custom Properties fields.  You can enter criteria for 
as many categories as you would like.  Click OK when you have finished entering criteria.  

7. Check the Search All Versions option if you want to look at every existing version of the files.  
Any versions that match the criteria will be displayed in the results dialog.  If this option is not 
checked, the search will include only the most recent saved version of the files.  

8. In the Search In section, check which repositories you would like to search.   

9. Click the Search button to begin the search.  

10. Click Close to exit the Advanced Search dialog.  

The results of the last successful search are stored for future use. To access these results, from the 

Search menu, select Show Last Results; or, select the Show Last Results tool . 

 
 

15.6.4    Defining Custom Properties 

You can create custom properties for individual items in the repository.  This allows you to track 
customized data such as preferred manufacturers for specific parts, or how to package parts.  Once 
these properties have been assigned, you can then use them to perform a search for all items with 
these same properties in the repository. Custom properties can be applied to any file in the 
repository, including files not created in Alibre Design.  

To use Custom Properties, you must first add the properties you want to the global property list.  
Once they are in the global list, you can add any or all of them to individual files, then assign values 
as necessary.  

 To add custom properties to the global list: 

1. In the Repository workspace, from the Tools menu, select Define Custom Properties.  The 
Add Custom Properties dialog appears.  

2. In the Add section, enter the name of the new property in the Enter New Property field.  

3. Click the Add button or press the Enter key to add the new property to the list of Current 
Properties. 

4. Select OK when you have finished adding new properties.  
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 To remove custom properties from the global list: 

1. In the Repository workspace, from the Tools menu, select Define Custom Properties.  The 
Add Custom Properties dialog appears. 

2. Check the box next to each property that you would like to remove; or, click Select All to check 
all of the properties.  

3. Select the Remove Selected Properties button to remove the properties.  

4. Click OK when you have finished.  

 

 To add custom properties to a repository item: 

1. In the Repository workspace, select the item that you would like to define the properties for.  

2. Right click the item and choose Properties; or, from the File menu, select Properties.  The 
Item Properties dialog appears.  

3. Select the Custom Properties tab.  

4. Click the Add Custom Property button.  The Add Custom Properties dialog appears.  

5. Check the box next to each property that you would like to define for this item.  

6. Click OK when you have finished.  The properties are added to the Custom Properties list.  

7. Click in the Value field for one of the properties and enter the necessary data.  Press the Enter 
key to accept the value.  

8. Continue entering data in the remaining properties.   

9. Click OK to exit the dialog.  Any properties that do not have values associated with them will be 
automatically removed from the property list for this item.   

 

Once you have set up your custom properties, you can perform an advanced search (see 
"Performing an Advanced Repository Search" on page 492) to locate file items in the Repository 
based on your customized information.  
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15.7    Previewing a Repository Item 

You may view a thumbnail preview of items in your repository.  Previews are not available for non-
native items. 

 To preview a repository item: 

1. In the Repository Explorer, browse to the folder containing the item that you want to preview.  
The list of available items appears. 

2. Select the item that you want to preview.  The thumbnail preview appears in the Item 
Properties area.  The thumbnail preview represents the item's display orientation during the 
last save operation. 

 
Figure 108: Repository Workspace - Item Properties section 

 

Note:  You must save items individually in a workspace before a preview is displayed in the 
Repository.  For example if you create parts in the context of an assembly, only the top-level 
assembly will previewed in the repository.  You must open and save each part in the assembly in 
order to generate a preview image in the repository. 

 
 

15.8    Renaming a Repository Item 

You can rename items or folders in a repository. When renamed, references to the item or folder are 
automatically adjusted.  To rename an item or folder, you must have Write privileges.  Its name may 
be the same as another item in the repository folder (or even the folder name), as long as the items 
are different types (for example, part or assembly).  You cannot rename an item that is checked out. 
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 To rename an item: 

1. Select the item that you want to rename. 

2. Right-click the item and select Rename from the pop-up menu; or, select the Rename tool  
from the Standard toolbar; or,  from the Edit menu select Rename.  The Rename Item (or 
Rename Folder) dialog appears. 

3. Type the new name.  The name must meet the naming requirements (see below). 

4. Click OK. 

 

Naming requirements for repository items: 

• The name cannot exceed 80 characters. 

• The name cannot contain any of the following characters: \ / : * ? " < > | & or the tab 
character. 

• The name cannot begin with a period. 

• The path name cannot exceed 255 characters. 

 
 

15.9    Viewing an Item's Version History 

 To view an item's version history: 

1. Select the item to view the version history of. 
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2. Check the Show Selected Item's Version History box at the bottom of the Item section.   The 
item's version history information appears. 

 
Figure 109: Repository Workspace Showing Version History of a Part 

 
 

15.10    Rolling Back to a Previous Version 

You can roll back to a previous version of an item.  This action removes all versions that are more 
recent than the version marked for rollback.  This action cannot be reversed or undone.  An item 
cannot be rolled back while it is checked out. 

 To rollback an item: 

1. Select the item you want to roll back. 

2. Check the Show Selected Item's Version History box at the bottom of the Item section. 

3. Click to select the version that you want to roll back to. 

4. From the Tools menu click Rollback; or select the Rollback  tool from the Repository 
Tool toolbar.  A confirmation message appears. 

5. Click Yes to proceed.  All versions later than the selected version are permanently deleted. 
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15.11    Purging Previous Versions of an Item 

Purging permanently removes all but the most recent version of a repository item.  It is a good idea 
to purge version periodically to prevent the file size of the item from getting too large.   

 To purge an item: 

1. Select the repository item that you want to purge. 

2. From the Tools menu select Purge; or select the Purge  tool from the Repository Tools 
toolbar.  A confirmation message appears. 

3. Click Yes to permanently remove all versions of the item except the most recent version.  You 
cannot restore the older versions after removing them. 

 
 

15.12    Adding/Viewing Notes for a Repository Item 

You can add notes to a repository item.  Unlike version comments, which are associated with a 
specific version of the item, notes belong to the item itself. You can add multiple notes, and you can 
remove notes. 

Note: You cannot rename or edit a note, but you can remove it and replace it with a new note. 

 
 

15.12.1    Adding a Repository Note 

 To create a repository note: 

1. Select the item to which you want to add a note. 

2. Right-click the item and select Add/View Notes from the pop-up menu; or select the Add/View 

Notes  tool from the Repository Tools toolbar; or from the Tools menu, select Add/View 
Notes.  The Note History dialog appears. 

3. Click Add.  The Add New Note dialog appears. 

4. Type a Subject for the note, and type the text of the note. 
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5. Click OK.  A listing for the note appears in the item's Note History. 

6. Click OK to close the Note History dialog. The icon for the item now includes a small image of a 

note  to indicate that at least one note has been attached. 

 
 

15.12.2    Viewing a Repository Note 

If a repository item has notes, a small note image is displayed at the bottom right of its icon .  

 

 To view a note: 

1. Select the item with a note. 

2. Right-click the item and select Add/View Notes from the pop-up menu; or select the Add/View 

Notes  tool from the Repository Tools toolbar; or from the Tools menu select Add/View 
Notes.  The Note History dialog appears. 

3. Select the note that you want to view. The box at the bottom of the dialog displays the text of 
the selected note. 

4. Click OK. 

 
 

15.12.3    Removing a Repository Note 

 

 To remove a repository note: 

1. Select the item from which you want to remove a note. 

2. Right-click the item and select Add/View Notes from the pop-up menu; or select the Add/View 

Notes  tool from the Repository Tools toolbar; or from the Tools menu select Add/View 
Notes.  The Note History dialog appears. 

3. Select the note that you want to remove. 
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4. Click Delete. 

5. Click OK. 

 
 

15.13    Undoing a Check Out 

Undoing a check out voids any temporary changes made while you had the item checked out. It 
does not cancel changes that you have saved to the item's version history. 

 To undo a check out: 

1. Select the item for which you want to undo the check out.  A checked out item is indicated by a 
checkmark to the left of the item name. 

 

2. Right-click the item and select Undo Check Out from the pop-up menu; or from the Tools 

menu select Undo Check Out; or select the Undo Check Out  tool from the Repository 
Tools toolbar. 

 
 

15.14    Copying and Moving Repository Items 

Copying an item creates a duplicate of the item in the specified location. You can copy folders, parts, 
assemblies, drawings, and external items.  When you copy a folder, both the folder and its contents 
are duplicated.  It is not necessary to have write privileges to copy an item to your repository. 

Moving an item changes the location that the item is stored in and accessed from.  You can move 
folders, parts, assemblies, drawings, bills of material, custom symbols and external items.  

However, if you want to share an item with a colleague or team, the best method is to share the 
repository (see "Sharing and Unsharing Repositories" on page 504).   
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15.14.1    Copying an Item 

 To copy a single item: 

1. Select the item that you want to copy. 

2. Click, drag, and drop to the target location. 

Or 

Right-click the item and select Copy from the pop-up menu; or from the Edit menu select 

Copy; or select the Copy Items  from the Repository Tools toolbar.  The Copy Item dialog 
appears. 

Select the repository or folder into which you want to copy the item. 

3. Type a name if you want to give the copy of the item a new name. The name must meet the 
naming requirements (see "Renaming a Repository Item" on page 495). 

4. Click OK. 

Copied assemblies 

If you copy an assembly in a repository, the location information for the assembly and its 
constituents changes to the new location, regardless of whether you moved it from another server or 
locally. 

Since the copied assembly's constituents do not rely on whether the original location is online, they 
can be opened and changed at any time, provided the appropriate rights have been assigned and it 
is available to be checked out. 

 
 

15.14.2    Moving an Item 

You must have Delete permission on the item being moved and Write permission to the folder or 
repository where the item is being moved to. 

• Moving an assembly or drawing does not move the associated constituents with it. 

• Moving a folder includes the folder's contents. 
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 To move an item: 

1. Select the item that you want to move. 

2. Hold the Shift key and drag the item to the target location. 

Or 

1. Right-click the item and select Move from the pop-up menu; or select the item and from the 
Edit menu, select Move.  The Move Item dialog appears. 

2. Select the target location. 

3. Click OK.  

 

The item is moved to the specified location. 

 
 

15.15    Deleting a Repository Item 

You can delete folders and items in your repository.  You can also delete an entire local repository if 
you own it.  

Deleting an item not only deletes all versions of the item.  To delete an item, you must have Delete 
privileges.  You cannot delete an item that is checked out. 

 To delete a repository item: 

1. Click the item that you want to delete. 

2. Press Delete on the keyboard; or right-click the item and select Delete from the pop-up menu; 
or from the Edit menu select Delete. 

Note: If you have been assigned policies since opening Alibre Design, you may need to 
perform a Refresh operation in the Repository for those policies to be active.  Until you 
Refresh, you may not be able to perform any saving, moving, copying, etc. of secure folders. 

 To restore a deleted item: 

1. Expand the repository in which the item was deleted. 
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2. Click the Recycle Bin. 

3. Right-click the deleted item in the item list and select Restore in the pop-up menu. 

4. The item is restored back to its original location. 

 
 

15.16    Repository Folders 

Folders in the repository are similar to other folders on your computer.  They are used to organize 
your data.  You can determine the total size and number of contents in a folder or repository through 
the Folder Properties. 

You can create, rename, copy and delete folders in your repository.   Copying a folder creates a 
duplicate of the folder and its contents in a location that you specify.  When you copy a folder that 
contains assemblies or drawings, all parts and subassemblies referenced in those items are 
duplicated in the new folder.  Deleting a folder removes both the folder and all of its contents. 

 
 

15.16.1    Creating a Folder 

 To create a folder: 

1. Right-click the folder or repository that will hold the new folder and select Create New Folder.  
Or, select a repository or folder then select New Folder from the File menu.  The New Folder 
dialog appears. 

2. Enter a name for the folder.  Review the naming requirements (see "Renaming a Repository 
Item" on page 495) if necessary. 

3. Click OK. 

 
 

15.16.2    Copying a Folder 

 To copy a folder: 

1. Select a folder and drag it to a new repository or folder.  A progress meter will appear while the 
copy takes place.  It will display an estimate of the remaining time needed to complete the 
copy. 
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OR 

2. Right-click the folder and select Copy.  Or, select the folder and choose Copy from the Edit 
menu.  The Copy Folder dialog appears. 

3. Select the repository and/or folder where you want to copy the folder. 

4. Click OK.  A progress meter will appear while the copy takes place.  It will display an estimate 
of the remaining time needed to complete the copy. 

 
 

15.16.3    Deleting a Folder 

To delete a folder, you must have Delete privileges. 

 To delete a folder: 

1. Select the folder and choose the Delete  tool; or, right-click the folder and select Delete.  
The Send to Recycle Bin dialog appears. 

2. Click Yes.  The contents of the folder are moved to the Recycle Bin in that repository. 

 
 

15.17    Sharing and Unsharing Repositories 

You can select which teams and individual users may view and access data in your repositories.  
You must be the owner of the repository to share it. 

Sharing a repository allows others only to see the repository.  Assigning permissions to repository 
items will allow others subsequently to see and access data in the shared repository. 

 To share a repository to a listed team or user: 

1. Select the repository that you want to share. 
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2. Right-click the repository and select Sharing/Security from the pop-up menu; or select the 
Sharing/Security tool from the Repository Tools toolbar; or from the Tools menu select 
Sharing/Security.  The Sharing/Security dialog appears and the Sharing tab is active. 

 
Figure 110: Repository Sharing/Security Dialog 

3. Click the Add/Remove button to bring up the Add/Remove Principles dialog.  Use this dialog 
to select users (or teams, on the Teams tab) from the Listed users section, or enter an Alibre 
Design username in the Unlisted User field.  Click Add to add the users or teams to the Publish 
to these users section.  To select multiple entries, press and hold the Ctrl key as you select. 

 
Figure 111: Repository Sharing - Add/Remove Principals Dialog 
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4. Click OK to close the Add/Remove Principles dialog. 

5. Click Apply and Close. 

 

 To unshare a repository to a team or user: 

You can unshare a repository by following the same procedure as above, except use the Remove 
button in the Add/Remove Principles dialog. 

 
 

15.18    Setting Permission Policies for Repository Items 

You can grant other users secure access to items and folders in your repositories by setting 
Permission Policies in the Sharing/Security dialog.  Permission options include: Administrate, 
Delete, Read and Write.  Users granted Administrate rights may grant access rights to other users.  
You must be working online to modify the permission policies of your data and you must have 
already shared the repository to the users you are granting data access. 

To simplify the assignment of permission policies, grant rights to a team role instead of individual 
users.  Then add and remove users from that team role.  To assign permissions for a team, you 
must have administrative privileges for the team.  See Chapter 16 for more information about teams 
and roles.  

 To modify the permission policies: 

1. Select the folder or item for which you want to assign permissions. 
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2. Right-click the folder or item and select Sharing/Security from the pop-up menu; or select the 

Sharing/Security  tool from the Repository Tools toolbar; or from the Tools menu select 
Sharing/Security.  The Sharing/Security dialog appears and the Security tab is active. 
 

 

3. Click the Add/Remove button to bring up the Add/Remove Principals dialog.  Use this dialog 
to select and Add or Remove individual users and teams.  To select multiple entries, press and 
hold the Ctrl key as you select. 

4. Click the Permissions radio button to display the four access rights:  Administrate, Delete, 
Read and Write.  Check the desired options. 

5. Click Apply and Close. 

Note:  If you select a folder or repository, you can choose to apply the folder's (or repository's) 
permission policies as the default settings for any new items created in the folder.  Alternatively, 
you can click the Advanced button and explicitly define the default permission policies to be 
used for newly created items.  Finally, on the Apply Options tab in the Advanced dialog, you 
can choose to apply these default policies to existing items or to apply them recursively to 
subfolders.  You can also choose to Replace/Combine any existing policies by/with the new 
policies. 
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15.19    Assigning Notification Policies for Repository Items 

Notification policies determine when a user is notified, via an automatic system message, of a 
specific activity associated with an item.  You can specify that a user or team receive notification of 
the following events: 

• Administrate 

• Check in (not available for folders and repositories) 

• Check out (not available for folders and repositories) 

• Delete 

• Write 

Note: To assign notification policies to a team role, you must have administrative privileges for 
that team. 

 To assign notifications: 

1. Select the folder or item for which you want to assign notifications. 

2. Right-click the folder or item and select Sharing/Security from the pop-up menu; or select the 

Sharing/Security  tool from the Repository Tools toolbar; or from the Tools menu select 
Sharing/Security.  The Sharing/Security dialog appears and the Security tab is active. 

3. Click the Add/Remove button to bring up the Add/Remove Principals dialog.  Use this dialog 
to select and add or remove individual users and teams.  To select multiple entries, press and 
hold the Ctrl key as you select. 

4. Click the Notifications radio button to display the five types of notifications (three for  folders 
and repositories).  Check the desired options. 

5. Click Apply and Close. 

Note:  If you select a folder or repository, you can choose to apply the folder's (or repository's) 
notification policies as the default settings for any new items created in the folder.  Alternatively, 
you can click the Advanced button and explicitly define the default notification policies to be 
used for newly created items.  Finally, on the Apply Options tab in the Advanced dialog, you 
can choose to apply these default policies to existing items or to apply them recursively to 
subfolders.  You can also choose to Replace/Combine any existing policies by/with the new 
policies. 
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15.20    Repository Snapshots 

You can create a snapshot copy of a local repository by saving it as a single file on the Windows file 
system.  Then you can copy the snapshot to another computer with Alibre Design installed and 
insert the repository into the Alibre Design environment. 

 To create a snapshot of a repository: 

1. In the repository browser, right-click the repository for which you want a snapshot and select 
Save Snapshot of Repository from the right mouse pop-up.  Or, click the desired repository 
and select Save Snapshot of Repository from the Tools main menu. 
 
The Save Snapshot of Repository dialog appears. 

2. Specify a name and file system folder for the snapshot file. 

3. Click OK. 

 

 To create a repository from a snapshot file: 

1. In the repository browser, right-click the repository list and select Create Repository from 
Snapshot from the right mouse pop-up.  Or, select Create Repository from Snapshot from 
the Tools main menu. 
 
The Create Repository from Snapshot dialog appears. 

2. Specify the snapshot file. 

3. Specify a file system folder to be used for the newly inserted repository. 

4. If desired, specify a different name for the new repository. 

5. Click OK.  The repository and the items in it are now available for use in Alibre Design. 

Note:  If you get prompted that continuing will write over or delete a repository, you may want to 
restore the repository to a different location.  Writing over or deleting a repository is a permanent 
action.   
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15.21    Caching 

To avoid delays in loading model data before a Team Design session you may cache items in 
advance.  Caching an item stores a copy of the item in the temporary system memory and reduces 
the model load time.  

You can cache parts, assemblies and drawings.  If an assembly has constituents, the constituents 
are also cached.  You can cache individual items, or you can cache multiple items by selecting a 
folder. 

Note: The repository with the item must have been shared to you.  You must have at least read 
permissions for the repository, folder and item. 

When an item is cached, the icon for that item changes based on the status of the caching process - 

the icon will display with colored arrows . 

• Red arrows: Caching has been requested, but the item is not yet cached. 

• Green arrows: The item and all of its dependencies (if any) are cached. 

• Blue arrows: The item is cached, but one or more of its dependencies (version history or 
constituents) are not yet cached. 

 
 

15.21.1    Caching Options for Items 

You can set options for caching in the Item Cache Setting dialog.   

 To set Item Cache options: 

1. In the Repository workspace, select the item you wish to set options for.  

2. From the Tools menu, select Caching.  

3. Choose from the following options:  

a. Cache most recent versions only 

b. Cache the entire version history 

c. Cache constituents (only used with assemblies) 

d. The cache priority order when caching more than one item. 
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15.21.2    Caching Options for Folders 

The folder cache settings may be applied to all item types or just one. 
 

15.22    Caching Repository Items 

Caching is useful for items residing in a shared repository that you want to be able to open quickly.  
Caching is also beneficial for users who plan to participate in a Team Design session. 

Caching an item stores a copy of the selected item in your temporary system memory.  A cached 
item is physically stored in your local repository but it will not be listed in your repository.  You must 
continue to access the item from the repository from where you cached it. 

 
 

15.22.1    Caching a Repository Folder 

 To cache a repository folder: 

1. Select the folder to be cached. 

2. Right-click the folder and select Caching from the pop-up menu; or select the Caching  
tool from the Repository Tools toolbar; or from the Tools menu select Caching.  The Folder 
Cache Settings dialog appears. 
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3. Select the item type to cache in the Object Type area. 

4. In the Settings area, select Enable Caching. 

5. Select either the Cache most recent versions only option or the Cache entire version 
history option. 

6. If assemblies are involved, select Cache constituents if you want to cache the constituents as 
well. 

Select the High Priority option if you want an item type to be cached before other items. 
 
Note:  Using the High Priority option for an item requires that item to be cached before other 
items selected are cached.  Use High Priority for parts or assemblies that are needed first. 

7. Click Apply these settings to all Object Types if you want all object types selected in the 
Object Type area of this dialog to have the same settings. 

8. Click OK. 
 

15.22.2    Caching a Repository Item 

 To cache an item: 

1. Select the item to be cached. 

2. Right-click the item and select Caching from the pop-up  menu; or select the Caching  
tool from the Repository Tools toolbar; or from the Tools menu select Caching.  The Item 
Cache Settings dialog appears. 
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3. In the Settings section, check Enable Caching. 

4. Select either the Cache most recent versions only option or the Cache entire version 
history option. 

5. If you are caching an assembly, select the Cache constituents option if you want to cache the 
constituents as well. 

Note: The Current Item Status area provides information on the item you are caching such as 
whether the item is currently cached and whether the version history was cached with the item 
or not. 

6. Click OK. 

 
 

15.22.3    Disabling Caching Repository Items 

If you no longer want a repository item cached, disable the caching of the item. 

 To disable items cached in a repository folder: 

1. Select the folder in which you want to disable the caching of items. 

2. Right-click the folder and select Caching from the pop-up menu; or select the Caching  
tool from the Repository Tools toolbar; or from the Tools menu select Caching.  The Folder 
Cache Settings dialog appears. 

3. In the Settings section, uncheck Enable Caching. 

4. Click OK. 

 

 To disable caching of a repository item: 

1. Select the item that you want to disable the caching of. 

2. Right-click the item and select Caching from the pop-up menu; or select the Caching  tool 
from the Repository Tools toolbar; or from the Tools menu select Caching.  The Folder Cache 
Settings dialog appears. 
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3. In the Settings section, uncheck Enable Caching. 

4. Click OK. 

NOTE: When caching is disabled for an item, its icon no longer displays its cached status. 
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C H A P T E R  1 6  

 Alibre Motion 
Alibre Motion™ is a motion simulation solution for analyzing the behavior of mechanical assemblies 
with moving parts. Using Alibre Motion, engineers and designers can create simulations and 
animations of systems that move, such as linkages, engines, automotive suspensions, conveyors 
and other mechanisms. It can be used to study and analyze how various components interact and 
behave according to engineering principles and physical laws. 

With Alibre Motion you can build virtual prototypes to help analyze and optimize designs without 
having to build and test expensive and time-consuming physical prototypes. Alibre Motion enables 
multi-body dynamic analysis on an assembly created in Alibre Design enabling one to realistically 
predict and visualize the assembly's motion. 

Note:  Alibre Motion is available in the Alibre Design Expert version.  For more information on 
getting a license for Alibre Motion, please contact Alibre Sales. 

Use Alibre Motion to: 

• Create Virtual Prototypes with Automatic Constraint Mapping 

• Quickly create animations that can be saved as AVI files 

• Generate motion with prescribed rotations and translations 

• Generate motions due to gravity and prescribed forces and torques 

• Create accurate simulation models with a variety of physical elements 

• Get simulation feedback from traces and X-Y result plots 

• Detect interferences of overlapping bodies 

Once installed and enabled, Alibre Motion is accessed from the main menu of the Assembly 
Workspace. The Motion Explorer, similar to the Design Explorer, allows you to view and interact with 
all of the Parts, Constraints, Physical Elements (Motors, Springs, Dampers and Motions) and 
Settings that make up a simulation. 
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16.1    An Overview of Simulation 

Newton’s laws of motion provide an accurate description of how bodies move under the influence of 
forces. However, except in the simplest of situations, applying those laws can be complex. The 
motion of a body can rarely be described by a single equation predicting its position and acceleration 
at any time in the future. Real designs usually involve multiple bodies and multiple forces or motions, 
all interacting with each other in ways that are too complex to solve without the aid of computer 
simulation. The field of physics and mathematics involved in these calculations is known as Rigid 
Multi-Body Dynamics. 

What does a Simulator do? 

In reality, time moves smoothly. A simulator, in contrast, needs to break time into a series of 
calculation time-steps, or intervals, much as a movie or animation is broken down into a series of 
frames. Starting from a set of initial conditions at the beginning of a time-step, the new positions and 
accelerations of each body in the system are calculated using Newton’s laws from the forces and 
torques acting on them, and what is known about their physical characteristics. 

What Makes up a Simulation? 

• The type of simulation to perform and its driving parameters 

• The physical characteristics of the bodies that make up the system 

• The constraints that dictate the way the bodies influence each other 

• The forces and torques acting on or within the system 

• Any prescribed motions to be forced upon the system 
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16.2    Installing and Enabling Alibre Motion 

Installing Alibre Motion 

Before beginning to use Alibre Motion, you must first install the Alibre Motion Add-On.  

Note:  You must have a license for Alibre Motion to install and enable it.  Alibre Motion is available 
for the Alibre Design Expert version. 

 

Enabling Motion 

Once you have installed the Alibre Motion Add-On, you can enable Motion from the Home window or 
an Assembly Workspace.   

 To enable Alibre Motion: 

1. From the Tools menu, select Add-On Manager.  

2. Find Alibre Motion in the list of available Add-Ons and check the box beside it.  

3. Alibre Motion loads immediately. You will notice that there is now a Motion main menu item in 
the Assembly Workspace. 

 

 
 

16.3    The Alibre Motion User Interface 

Once installed and enabled, Alibre Motion is accessed from the main menu in an Assembly 
Workspace. The three main components of Alibre Motion are:  
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• The Motion main menu:  allows you to enter Alibre Motion when you are in an assembly 
workspace 

• The Motion Explorer:  similar to the Design Explorer, allows you to view and interact with all 
the Parts, Constraints, Physical Elements (Motors, Springs, Dampers and Motions) and 
Settings that make up a Simulation 

• The Playback Deck:  allows you to start the generation of a simulation and control playback 
of the animation 

 

 
 

16.3.1    The Main Alibre Motion Menu 

The Motion main menu can be accessed in an Assembly workspace when Motion is installed and 
enabled.  

    

 

Motion Explorer 

This activates Alibre Motion for the Assembly you are working on. When this is selected, the Motion 
Explorer is shown, where you can add and change any physical elements that you wish to use in 
your simulation. 
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Enable Simulation Mode 

When you have added all of the desired elements, this puts the Assembly workspace into Simulation 
/ Playback mode. In this state, all the constraints in the Assembly are suppressed, and any 
Anchored bodies are freed. The Simulator takes control of the placement of all moving parts and 
sub-assemblies, in order to animate them as Simulation frames are generated. 

Regenerate Simulation 

When you have made changes to your Assembly, use this to update the Simulator. You may be 
prompted to do this occasionally if you have made a change that renders the Simulator unable to 
animate the model. 

Clear Simulation 

This completely resets the Assembly design to create a blank simulation. 

Note: All changes you have made to the Simulation set-up, physical elements added, and feedback 
elements you have defined, will be lost. 

Show Status Window 

The Status window shows any Warnings and Simulator messages generated when checking the 
simulation model, or generating a simulation. If you have closed the window, it can be re-opened by 
selecting this item. 

Settings 

This item takes you to the Settings dialog, where you can specify the parameters that determine how 
the Simulation should be generated and played back. From here you can also specify how Traces 
appear, and other options. 

 
 

16.3.2    Alibre Motion Explorer 

Much like the Design Explorer, the Motion Explorer shows all the items which make-up a Simulation 
set-up. From here, using the right-click menu on headings and individual items, you can create new 
Simulations, insert Physical Elements, specify measurements that should be taken, and Traces to be 
shown. 

 To launch the Motion Explorer 

1. In an assembly workspace, from the Motion main menu, select Motion Explorer. 
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2. The Motion Explorer opens, and either loads existing Simulation Setup Data if the open 
Assembly file contains it, or automatically generates a new Simulation, reading in all the 
physical data and characteristics of the parts, and constraints that make up the assembly. 

 
Figure 112: Motion Explorer 

 

Automatic Simulation Creation 

The first four group headings (Configuration, Fixed Parts, Moving Parts, and Constraints) contain all 
of the Simulation elements that Alibre Motion creates automatically for you by analyzing your 
Assembly design, using Automatic Body Mapping (see "Moving And Fixed Parts" on page 548) and 
Automatic Constraint Mapping (see "Automatic Constraint Mapping (ACM) in Alibre Motion" on page 
547). 

Additional Simulation Elements 

The remaining group headings contain those elements you may choose to add to create your 
Simulations, and to define any feedback and results you may require. 
 

Motion Explorer Groups 

Configuration and Simulations 

The currently active Assembly Configuration is shown with all existing simulations based on it. In the 
Motion Explorer image in the previous section, the default configuration, “Config<1>” is active, and 
there is only one Simulation, “Simulation<1>”, which is active. 
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Fixed Parts 

Those parts that Alibre Motion has determined cannot move during the simulation are shown under 
this heading. These are anchored Parts and those anchored Sub-Assemblies that are not “Flexible”. 
These do not affect the dynamics of the simulation, but may hold the points to which constrained 
Moving Parts attach. Under each Fixed Part is a Constraints sub-heading listing all attached 
constraints. This duplicates a portion of the Constraints list. 

Moving Parts 

These are the dynamic Parts that have the potential to move during the simulation. Each Moving 
Part is shown with a Part icon or a Sub-Assembly icon depending on which it represents. Under 
each Moving Part is a Constraints sub-heading listing all attached constraints. This duplicates a 
portion of the Constraints list. 

Note: This list of Moving Parts will not necessarily be the same as the Parts and Sub-Assemblies in 
the top level of the Design Explorer. For instance, if a Sub-Assembly is made "Flexible", then there 
will be Moving Parts that come from that Sub-Assembly. 

Constraints 

This contains a list of all the constraints that the Automatic Constraint Mapping has determined 
should take part in the Dynamic Simulation. If a constraint is suppressed at the time when the 
Simulation is Created or Regenerated, then it is not used by the simulator. 

Note: The Automatic Constraint Manager creates a Motion Equivalent Constraint for almost all 
permissible Alibre Constraints. If a constraint cannot be used by Alibre Motion, then the icon is 
shown with a question mark, and is excluded from Simulations. If the constraint is important to the 
Assembly, you need to try to constrain it differently in your assembly, then regenerate the 
Simulation. 

 
 

16.3.3    Motion Settings 

Settings for Alibre Motion can be specified by choosing Settings from the Motion main menu.   
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Playback Tab 

Settings on the Playback tab are stored in the assembly.  You can specify different settings for each 
Simulation in the assembly.  

 

 To set Playback options: 

1. In Target playback speed, specify the maximum speed at which Motion should animate the 
simulated frames.  

Note that the actual playback speed that can be achieved is dependent on many factors, 
particularly the speed of your system and its graphics capabilities, and the complexity of 
the model being simulated. See Optimizing Playback Performance for more information. 

2. Check the Loop playback checkbox if you wish to loop between the loop-start and loop-end 

points. This is also achieved by pressing the Loop button  on the Playback Deck. 

3. In Loop from, choose either: 

a. start of simulation to loop to the first simulation frame when playback reaches the loop-

end point 

b. frame to loop to the specified frame number when playback reaches the loop-end point 
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4. In Loop to, choose either:  

a. end of simulation to continue the playback all the way to the final simulation frame 

available 

b. frame to loop to the loop-start when it reaches the specified frame number 

Note:  If you change the Playback settings after a simulation has been started, and the current frame 
of the simulation is already past the frame you set as your Loop to frame, the playback will continue 
on without looping. 

 

Simulation Tab 

Settings on the Simulation tab are stored in the assembly.  You can specify different settings for 
each Simulation in the assembly. 
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 To set Simulation Options: 

1. In Start simulation at time ( t ) =, specify the time ( t ) at which the Simulation should start. 
The variable “t” is used internally by the Simulator in many of the equations that define the 
Physical Elements used in simulation, including Harmonic (sinusoidally varying) functions. 

2. Choose one of the following options:  

a. Simulate indefinitely while playing:  When selected, the Simulator will continue 

generating frames as long as you are in Play mode. When the current frame being shown 

reaches the last available simulation frame, the Simulator is restarted, and each frame is 

shown as it is generated. 

Note: The maximum number of frames that Alibre Motion can generate for a single simulation is 
32,767. 

b. End at specified time:  Specify the maximum amount of time in seconds that should be 

simulated. When the Simulator reaches this point, it is stopped. 

3. In Simulation frame interval, specify the output time-step or simulation frame interval. The 
Simulator produces an output frame after each interval. If the Target Playback Speed matches 
this interval, and your model and system allow playback at that speed, you can produce a 
Simulation playback in real-time. 

Note: The Simulator internally determines the time-step required to produce an accurate 
simulation, and this may well vary throughout the simulation. However, it only produces an 
output frame for animation at intervals as specified by this parameter. 

4. In Error Tolerance, specify the error tolerance allowed internally by the Simulator during 
calculation. The allowable range of values varies depending on the type of simulation specified 
in “Simulation Type”. Under some circumstances, lower values may impact Simulation 
performance, and the highest value is selected by default. 

5. In Simulation type, specify the type of Simulation to be performed. Choose the desired type 
from the drop-down list. See Simulation Types and Parameters (see "Simulation Types and 
Parameters:" on page 544) for more information. 

 

Traces Tab 

Note: This dialog is available on the Settings dialog, or by selecting Trace Options from the right-
click menu of any Trace listed in the Motion Explorer. 
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This form is used to specify the type, length and default colors of Traces shown during playback to 
visualize the paths of Parts and Sub-Assemblies, and to get feedback concerning their Velocities 
and Accelerations.  

 

 To set Trace options: 

1. Check Enable traces to show traces during playback.  No traces of any kind will be shown 
during playback unless this box is checked. 

2. Check Show trails to see indications from previous animation frames.  These trails can be 
extremely useful for visualizing the paths taken by Parts. If no Individual Trace Types have the 
Show Trail option selected, or no Traces are currently being generated, then no trails will be 
shown. 

Note: Trails are always shown stretching backwards in time from the current frame, even during 
Reverse playback. 

3. Check Show Position trails as lines to show the Position indicator for previous frames as a 
series of straight lines joining each previous Position. If this box is NOT checked, previous 
Positions are shown as a series of discreet Position indicators. 

4. In Trail length, specify the maximum number of previous frames for which to show trails. Note 
that during the first frames of animation, when the current frame number is less than this figure, 
trails will be shorter than this number. Specifying extremely long trails may degrade playback 
performance. 
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5. In Settings for individual trace types, you may specify how individual trace-types are 
displayed. Select in the list-box the trace-type you wish to change, and for that type you may 
specify: 

a. Check Show trace to see visual indicators at the current frame during animation playback. 

b. Check Show trail to see visual indicators for previous frames during animation playback. 

c. Check Fade trail color to see visual indicators for previous frames fading to black over 

the length of the trail. 

d. In Color, set the color of the visual indicator for the selected trace type. To select a 

different color, press the Browse button . 

 

General Tab 

 

 To set General options: 

1. Check Show all warning, information and confirmation dialogs to see pop-up dialogs with 
messages and warnings while working in Alibre Motion.  
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2. Check Show Simulation Messages to see messages concerning the actions and status of the 
Simulator in the Motion Status Window. 

3. Check Save Simulation Data in Assembly File if you want to save your simulation data with the 
assembly.  If you do NOT want your simulation information saved, un-check the box.  

Note: If this box is not checked, any Simulation setup data, actuators, springs, dampers and 
feedback elements will not be saved, and will be lost when you close the Assembly workspace. 

 

When you have finished setting your options on all of the tabs in the Motion Options dialog: 

1. Check Make these the default settings to save these settings as the default for all new 
Simulations generated from that point on.  (This option does not apply to the General Tab, so it 
will be grayed out if you have that tab selected.  Select any other tab and then check the option 
on.) 

2. Click OK to apply your changes and exit the dialog, or click Cancel to abandon your changes 
and exit the dialog.  

 
 

16.3.4    Playback Deck 

This section of the Motion Explorer is used to control the starting and playback of Simulations. From 
here you also control the X-Y Plots dialog, the Interferences dialog, the Video Generation (AVI) 
dialog, and the Settings / Options dialog. 

Note: The Playback deck is only enabled when you are in Simulation Mode. Select Simulation Mode 
from the Motion main menu. 
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Frames Slider 

 

Gives a graphic indication of the number of simulated frames available for playback, and the current 
frame. To jump to another frame, either drag the slider, or click on the background either side of it. 
Whenever the slider is positioned at the far right during playback, the Simulator will be running, 
generating more Simulation frames. 

Current-Frame / Total Frames 

 

Shows the current frame, and the total number of simulated frames. 

Current-Time / Total Time 

 

Shows the time (t) of the current frame, and the total simulated time available. 

Note: Control the simulation frame interval (step size) in the Simulations Settings Tab of the Settings 
form. 

 

Button Name What it does 

 

Play Starts the simulation and animation 
process. 

 

Step Forward Steps forward by one frame. 

 During playback  

  When paused 

Pause / Stop During playback, stops the animation at 
the current frame. When paused, resets to 
the first simulation frame. 
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Step Back Steps backward by one frame. 

 

Play Backwards Plays the simulation backwards from the 
current position. 

 

Video Generation 
(AVI) 

Opens the Video Generation (AVI) dialog 
to enable you to generate movies of your 
simulations. See Generating Video with 
Alibre Motion (on page 558) for more 
information. 

 

Loop Playback Loops the playback between specified 
start and end points. 

 

X-Y Plot Opens / Closes the X-Y Plot. 

 

Interferences / 
Collisions 

Opens / Closes the Interferences dialog. 

 

Settings / Options Opens the Settings dialog, from where you 
can specify Simulation, Playback, Trace 
and other settings and options. 

 
 

16.4    Overview of Simulating and Playing 

Once you have Alibre Motion installed and enabled, there are simple steps to follow to create and 
animate a Simulation from your Assembly design. 

The Basic Steps 

1. Activate the Motion Explorer:  Select Motion Explorer from the Motion main menu. 

2. Add Physical Elements:  Right-click on constraints and other headings in the Motion Explorer, 
enable gravity, and add any motors, actuators, springs, and dampers required. 

3. Enter Simulation Mode: Select Enable Simulation Mode from the Motion main menu. 

4. Press Play:  Press the Play button on the Playback deck. 
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  In addition you may wish to… 

1. Show a Trace of the position of a moving part: Right-click a Moving Part and select Trace, then 
select a quantity to trace.  

2. Create a Video of the animation: Press the Video button on the Playback deck.  

3. Show an X-Y Plot of the position, velocity or another dynamic measurement of a moving part:   
Right-Click a moving Part and select Dynamic Measurement.  Ensure Show In XY Plot is 
checked, and after specifying the measurement, press the X-Y Plot button on the Playback 
deck.  

4. Make changes to your design and regenerate the Simulation:   Right-click the Simulation item 
on the Motion Explorer, and select Regenerate, or select Regenerate from the Motion main 
menu.  

5. Detect Interferences: Press the Interferences button on the Playback deck.  

6. Export dynamic measurements for analysis: Right-Click a Part and select Dynamic 
Measurement.  After specifying the measurement, right-click that Measurement item in the 
Motion Explorer then select Export. 

 
 

16.5    Forces and Torques In Simulations 

Within any but the simplest of mechanical systems there are numerous forces and torques acting on 
each body within the system. Some are specified by the person who created the simulation model, 
and usually many more are a result of the interactions of the constrained bodies according to 
Newton's third law. Newton's third law states that for every action there is an equal and opposite 
reaction, and is encapsulated in physics terms by the laws of Conservation of Momentum, and 
Conservation of Angular Momentum. 

Forces External to the System 

The law of Conservation of Momentum states that in the absence of any external forces, the total 
momentum of a system is conserved. For simulation purposes, the only ways to add external forces 
or torques to a system are: 

• Enabling Gravity:  When it is enabled, gravity acts on the entire system, and a constant 
magnitude and direction is used throughout (you can specify the components of gravity, or 
choose the default value of 9.81 m/s2 in the direction of the negative Y-Axis). 

• Constraining a Part to a “Fixed” or “Anchored” Part, or a Geometry Feature (Planes, Axes) 
within the main Assembly. 



Chapter 16 - Alibre Motion 

 
 
 

 531 
 

Forces Internal to the System 

Internal forces can change the configuration of your assembled designs, but on their own they 
cannot influence the total momentum, either linear or angular, of the system. 

• Constraints between “Moving Parts” can be considered as entirely internal to the system. 

Note: You don’t need to explicitly distinguish between these in any way - Alibre Motion will 
simulate the Assembly as you have designed it. 

 

Physical Elements: Motors and Actuators, Springs and Dampers 

One step in the process of producing a simulation is specifying any physical elements that transmit, 
produce, or modify forces and torques. The Assembly constraints within your designs specify where 
physical elements can be placed, and there may be times that you add constraints to your design 
solely for the purpose of adding a physical element such as a spring. An enormous number of real-
world interactions can be accurately modeled by using combinations of these. Depending on the 
type of constraint and the details of its geometry, you may be able to add some or all of the 
following: 

• Motor (or Rotary Actuator):  Produces a torque or rotational motion. For instance, a car 
engine, a winch, or a DVD player motor. 

• Rotary Spring:  Produces a torque opposing rotational displacement. Real-world 
equivalents include a door hinge-spring and a coiled watch-spring. 

• Rotary Damper:  Produces a torque opposing rotational motion, for instance a car clutch, or 
an electric generator. They can also be used to model “wet” friction. 

• Linear Actuator:  Produces a force or motion in a particular direction, for instance an 
hydraulic ram, or an electric car-window lifter. 

• Linear Spring:  Produces a force which acts to oppose displacement in a straight line, such 
as an elastic band, or a car suspension spring. 

• Linear Damper:  Produces a force which acts to oppose motion in a straight line, such as a 
shock-absorber. Can also model “wet” or sliding friction. 

You can expect nothing to happen unless at least one physical element has been added. In some 
circumstances, enabling gravity may be all that you require, but more often, you will need to add the 
motors, springs and dampers found in the mechanism you are designing. 
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16.5.1    Adding Physical Elements (Motors and Actuators, Springs 
and Dampers) 

 To Add a Physical Element 

1. Right-click on a Constraint in the Motion Explorer. 

2. Choose Insert from the pop-up menu. 

3. Select from the enabled options: 

 

 

Note: If you have already added a Physical Element of a particular type to that constraint, the option 
will be shown disabled. 

A dialog opens to allow you to specify the setting for the element you are adding. 

Linear or Rotary 

All moving parts in your simulations are free to move in any way, except where specifically 
constrained. When simulated, they act under the influence of constraints, gravity, and forces, 
torques, and motions specified by you, using physical elements. The types of physical element 
available in Alibre Motion are divided into two broad categories. 

• Rotary - concerns torques and motion around a central axis 

• Linear - concerns forces and motion in straight lines 

Constraints Define Types of Physical Elements Available 

The Assembly Constraints and their geometries and settings defined in your designs dictate the type 
of any physical elements you can add to create simulations. The types of motions allowed by the 
constraint in Alibre Design can give you a good idea of which sorts of physical elements are 
available for that constraint, and shown in the “Insert” sub-menu. 

For instance, an “Align” constraint between two straight edges, allows rotation of each part around 
the lines, as well as linear motion along the lines. When mapped into Alibre Motion, you are able to 
add both Rotary elements and Linear Elements to this type of constraint. 
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Constraints Define Attachment Points of Physical Elements 

Any physical element produces, transmits or modifies a force or torque between two “Attachment 
Points”, or points of action. These points are taken directly from the features used to create the 
Constraint in your Assembly. 

 
 

16.5.2    Actuators (Motors and Linear Actuators) 

When you add a Motor or Actuator to your Simulation, they may be specified in either one of two 
ways: 

For Motors (Rotary Actuators) 

• Torque type 

• Prescribed Motion (Rotation) type 

For Linear Actuators 

• Force type 

• Prescribed Motion (Translation) type 

 

 

 

Each type has its own characteristics and uses: 

• Force-Torque Actuators - These actuator types are used to specify the force (linear) or 
torque (rotary) acting on the connected parts. Depending on the physical characteristics of 
the parts, and any other parts and physical elements connected to them, these actuators 
may or may not produce any resultant motion, in the same way that pushing on a door 
does not necessarily open it. 

• Prescribed Motion Actuators - These actuator types are used to specify the actual motion of 
the connected parts, disregarding the force or torque that that motion would require. 

 

 To Add an Actuator: 

1. In the Motion Explorer, right-click on a constraint. 
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2. Select Insert, then select either Linear or Rotary Actuator.   The Actuator Settings dialog 
opens.  

Note: Depending on the constraint, you may be able to add one, both, or neither type of 
Actuator. 

3. In Type, choose either a Force motor or a Linear Motion motor. (For Rotary Actuators (motors), 
you may choose between a Torque motor, and a Rotation motor.) 

4. Choose either Constant or Harmonic function. 

 

 To Edit an Actuator: 

1. Right-click the Actuator in the Motion Explorer, and select Edit. 

OR 

 Double-click the Actuator item. 

 

 To Re-Name, Delete, or Suppress an Actuator: 

1. Right-click the Actuator in the Motion Explorer, and select the required option. Suppressed 
Actuators are shown grayed out. 

 
 

Force- and Torque- Type Actuators 

In many circumstances, simulations using these types can be the more realistic choice. Actuators of 
these types may be opposed by springs, dampers, and the inertias of any driven parts in a realistic 
way. 

Forces and Torques can be defined in the following ways: 

• Constant Force or Torque 

• Harmonic (or Sinusoidally varying) Force or Torque 
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Prescribed Motions and Rotations 

Actuators of the Prescribed-Motion type produce the specified motion of the connected parts, no 
matter what magnitude of force or torque would be required to do so in the real world. They are very 
useful for answering sizing questions like: “Assuming this part is to rotate at 5rpm, what torque would 
be required?”, and are often used for modeling sub-sections of larger systems where the required 
output of the system is specified in advance, and for examining the ranges of motion of parts. 

Prescribed Motions can be defined in the following ways: 

• Constant Motion 

• Harmonic Motion (or Sinusoidal Motion) 

 

Some characteristics of Prescribed Motions and Rotations 

• Prescribed Motion Actuators are Incompatible With Springs and Dampers 

Since Springs and Dampers produce force or torque effects, any Prescribed Motions 
acting on the same constraints will completely override them. In this situation, any Springs 
or Dampers will be automatically excluded from the simulation (Springs and Dampers on 
other constraints remain unaffected, and their effects will be calculated normally). 

• Prescribed Motion Actuators Can Produce Locking 

If you prescribe a Motion that cannot continue past a certain point due to other constraints, 
then you have created a situation where an “irresistible force meets an immovable object”, 
as the Simulator does not decide which constraint or motion should be ignored at that 
point. Metaphysical considerations aside, this produces a simulation condition for which 
there is no viable solution, so the simulation stops at that point, and a warning message is 
displayed.  

• Quasi-Kinematic Simulations Always Use Prescribed Motion Types 

The inputs to Quasi-Kinematic simulations that you create are always prescribed motions, as forces, 
torques and inertias are effectively ignored in this type of simulation. See Simulation Types and 
Parameters for more on Quasi-Kinematic simulations. You can use prescribed motions in Dynamic 
Simulations, as well. 

 

Specifying Harmonic Functions 

Various quantities in Alibre Motion, including prescribed motions, forces, and torques, may be 
specified as Harmonic or Sinusoidally varying functions of time. This enables you to create back-
and-forth motions, for instance.  
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To completely specify a Sinusoidal function, three things must be known:  

• Period - The Period is the time taken for one complete cycle. You can enter the Period in 
seconds, which is the time taken for one complete cycle, or the Frequency in Hertz, which 
is the number of cycles per second. Entering one automatically calculates the other. 

• Amplitude - The Amplitude of a Sinusoidal function is defined as the difference between the 
mid-point and one extreme or the other. In most applications, we know the range of motion 
or force required, so Alibre Motion allows you to specify the Amplitude by entering the 
Upper and Lower limits. 

• Phase - The Phase is most easily thought of as the position within a cycle. In Math and 
Engineering, Phase is usually specified in Radians or Degrees, but since this may often not 
easily translate to the problem at hand, Alibre Motion specifies the Phase as a combination 
of the Initial value and whether the value is initially increasing or decreasing. For instance, if 
the Initial Value is half way between the Upper and Lower limits and increasing, this would 
represent a Phase of 0. If it is initially decreasing, the Phase would be 180 degrees, or Pi 
Radians. 

 

When you first start a Simulation, the positions of the parts, either Linear or Angular, are taken from 
your Assembly Design. If you are specifying a Harmonic Prescribed Motion, you will see that the 
Initial Value box is disabled. In this case, if you want to specify different initial conditions, ensure that 
you are not in Simulation Mode, change the position of the Part, and regenerate the Simulation. 
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Often you will know the range of motion or force relative to the initial value, rather than as absolutes. 
Alibre Motion allows you to specify the Limits in either absolute or relative terms. To specify that the 
values you enter should be interpreted as relative to the Initial Value, check the "Limits are relative" 
check-box. 
 

Actuator Settings 

General Tab 

Note: Applying changes to the values in this dialog will reset the current simulation. 

 

1. Check Enable motor (or Enable actuator) to enable this actuator, or uncheck to disable it. 

2. In Name, specify the name of the actuator as it should be shown on the Motion Explorer, and in 
any Dynamic Measurements. 

3. In Type, choose either:  

a. Specify motor torque (or Specify actuation force) for a motor that produces a force or a 

torque. 

b. Specify rotation (or Specify motion) for a motor that produces a prescribed motion. 
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Actuator Force Tab 

Note: Applying changes to the values in this dialog will reset the current simulation. 

 

Select either Constant force (or Constant Torque) or Harmonic force (or Harmonic Torque) 

• Constant torque / force - specifies that the Torque or Force produced does not vary over 
time. 

a. In Force (Torque), enter the force to be produced by the actuator.  Note the units 

displayed.  

b. Check Reverse to reverse the sign of the force (torque). 

• Harmonic force / Harmonic torque - specifies that the force or torque produced by the 
actuator varies sinusoidally over time.  
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Prescribed Motion Tab 

Note: Applying changes to the values in this dialog will reset the current simulation. 

 

Select either Constant velocity motion (or Constant rotation) or Oscillating motion (or Rotary 
Oscillation).   

If you select Constant velocity motion, the motion produced does not vary over time.  

a. Specify the velocity or angular velocity to be produced by this actuator, then select the 

units from the drop-down list. 

b. Check Reverse to reverse the direction of the motion.  

If you select Oscillating motion, the displacement produced by the actuator varies sinusoidally over 
time.  

When you have finished making changes on each of the tabs, choose OK to save and apply the 
changes you made and close the dialog; or choose Cancel to abandon changes and close the 
dialog.  
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16.5.3    Springs 

Springs in Alibre Motion are assumed to perfectly obey Hooke’s law at all times, and have no non-
linear behavior. 

 

 To add a spring: 

1. In the Motion Explorer, right-click on a constraint. 

2. Select Insert, then select either Linear or Rotary spring. The Spring Settings dialog appears.  
To define a spring, you must specify the Spring constant, which is the force or torque produced 
per unit of linear or angular displacement from the unstretched position. The force produced by 
a spring always opposes the displacement. 

Note: Depending on the constraint, you may be able to add one, both, or neither type of Spring. 

 

Note: Applying changes to the values in this form will reset the current simulation. 

3. Check Enable spring to enable this spring, or uncheck to disable it. 

4. In Spring constant, enter the Spring Coefficient, or Spring Constant. Note the units shown to 
the right of the text-box. 

5. Select Initially un-stretched if you want the spring assumed to be initially unstretched in the 
design at the start of simulation. Any subsequent deflection will cause the spring to produce a 
force or torque acting towards this initial point. 
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6. Select Unstretched Length / Unstretched Angle if you want the spring assumed to be already 
stretched in the original design, at the start of animation. You can specify the natural length or 
angle of the spring in the text-box to the right. 

7. Select OK to save and apply the changes you made; or click Cancel to abandon your changes. 

 

 To edit a spring: 

1. Right-click the Spring in the Motion Explorer, and select Edit, or simply double-click on the 
spring item. 

 

 To re-name, delete, or suppress springs: 

1. Right-click the Spring in the Motion Explorer, and select the required option. Suppressed 
springs are shown grayed out. 

 
 

16.5.4    Dampers 

Dampers in Alibre Motion have no non-linear behavior, and produce a force or torque that is 
perfectly proportional to the linear or angular velocity. The force or torque produced by a damper 
always opposes the motion. 

 

 To Add a Damper: 

1. In the Motion Explorer, right-click on a constraint, and select Insert. 

2. Choose either Linear or Rotary damper. The Damper dialog opens.  
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Note: Depending on the constraint, you may be able to add one, both, or neither type of 
Damper. 

 

3. Check Enable damper to enable this damper, or uncheck to disable it. 

4. In Damping coefficient, enter the coefficient of damping to be applied at the constraint. Note 
the units shown to the right of the textbox. 

5. Click OK to save and apply changes; or click Cancel to abandon changes. 

 

 To Edit a Damper: 

1. Right-click the Damper in the Motion Explorer, and select Edit  

OR  

Double-click the Damper item. 

 

 Re-Naming, Deleting, and Suppressing Dampers: 

1. Right-click the Damper in the Motion Explorer, and select the required option. Suppressed 
Dampers are shown grayed out. 
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16.5.5    Gravity 

By default, the acceleration due to gravity (often approximated as 9.81 m/s2, or 32.185 ft/s2 at the 
Earth’s surface) is NOT enabled in Alibre Motion. You can enable gravity and change the values and 
direction used by the Alibre Motion simulator from the Motion Explorer. 

 To Enable Gravity: 

The Gravity Node is shown grayed when gravity is not enabled.  

 

1. Right-click on Gravity, and select Enable Gravity 

 

     Or 

1. Right-click on Gravity, and select Edit.  The Gravity dialog appears. 

2. Check Enable gravity in the dialog. 

 

3. Click OK.  
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 To Change Gravity Settings 

1. Right-click on Gravity, and select Edit.  The Gravity dialog appears. 

2. Check Enable gravity in the dialog. 

 

3. Specify the components of gravity along each major axis of the Assembly. Enter values in each 
of the X, Y, and Z — Axis text boxes. 

4. If you wish to go back to the default values for gravity, press the Default button.  The default 
values are -9.81 m/s2 or -32.185 ft/s2 along the Y-Axis, and zero along the X- and Z-axes. 

5. Click OK. 

 
 

16.6    Simulation Types and Parameters: 

To specify the Simulation Type and Parameters used for a Simulation, from the Motion main menu, 
select Settings.  Choose the Simulation Settings Tab. 

There are various methods used to produce simulations of systems and mechanisms, each with 
their own characteristics. Choosing the type of Simulator to use, and the parameters that specify it, 
can be very important to producing useful results: 

• Dynamic Simulation 
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• Kinematic Simulation 

• Quasi-Kinematic Simulation 

The default settings provided by Alibre Motion will produce effective simulations in a very wide 
variety of situations. You should find them useful when simulating most mechanisms on everyday 
scales. If you are working with mechanisms that move or rotate very fast, or very slowly, are 
extremely large or small, you may get better results by adjusting these parameters: 

• Time-Step (or Simulation Frame Interval) 

• Error Tolerance 

 
 

16.6.1    Simulation Types 

Dynamic Simulation: 

This is the most accurate and therefore realistic type of simulation. Each body in the system is 
analyzed to determine the physical characteristics that influence its motions and accelerations. The 
effects of any forces or torques applied to or within the system are calculated and applied precisely, 
and the movements and accelerations of each body are derived as accurately as possible within the 
specified simulation parameters. The correct solutions for a particular time-step are found using an 
iterative process, which can involve thousands and often millions of calculations for each simulation 
time-step or frame. By default, Alibre Motion uses this type of simulation. 

Kinematic Simulation: 

Kinematics is a branch of physics which is concerned with the motions of objects and particles 
without regard to the forces or torques which create those motions. The familiar laws of motion (such 
as v = u + a x t) are examples of the application of kinematics. So a Kinematic Simulation is driven 
solely by any motions prescribed for the system, and does not take account of the weights or 
moments of inertia of the Parts involved. There are situations in which this may produce a useful 
simulation, for instance if the reason for simulating is to detect the range of motion of a part, possible 
interferences, or for generating demonstration movies. Manually moving constrained Parts in 
Assemblies using the mouse can sometimes produce results similar to a Kinematic Simulation. 

Though purely Kinematic Simulation may sometimes be acceptable, there are some cases in which 
it will produce a very different result from a Dynamic one. For instance, a piston and arm moving up 
and down will normally produce a smooth rotation in the crank to which they are connected. 
However, a purely Kinematic Simulation may show the crank rotating back and forth 180 degrees, 
never completing a full circle. Normally the angular momentum of the crank and arm would carry the 
motion through the “top-dead-center” position, but angular momenta are ignored in Kinematics. For 
this reason, Alibre Motion does not use this type of simulation. 
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Quasi-Kinematic Simulation: 

The other type of simulation used by Alibre Motion is a new development of Kinematic Simulation. 
Rather than ignoring the mass, inertia and momentum of a Part, Alibre Motion substitutes values 
such as 1 wherever possible, which means that solutions to large and complex problems can often 
be found much more efficiently. This type of simulation may be best for very large or complex 
assemblies, when generating demonstration animations, detecting possible interferences, and where 
only the ranges of motion are the outputs of interest.  

 
 

16.6.2    Producing Efficient and Useful Simulations 

There are a few simple general principles that when followed will help produce accurate and efficient 
simulations. Some are good general CAD practice, while others are specific to simulating with Alibre 
Motion: 

Build Full-Size 

This is good general CAD practice, but is crucial to accurate simulation. Specifying a large force to 
act on a body may produce misleading results if the body is ten times shorter, and a thousand times 
lighter, than its real-world counterpart. 

Specify The Material (or at Least the Density) 

Alibre Motion needs to know the mass and the moments of inertia of a part in order to simulate it. 
These are calculated by Alibre Motion from the density of the Part, and the volume and shape of its 
design. Be sure to verify the correct material density has been specified for each part, whether you 
are designing new parts, or importing existing ones. 

Group Non-Independent Parts into Sub-Assemblies 

The efficiency of a simulator is always dependent on the number of moving parts it has to analyze 
and compute. In designs with Parts that are locked together and cannot move independently of one 
another, simulation will be more efficient if they are grouped into sub-assemblies that the simulator 
can treat as one object. No loss of simulation accuracy is to be expected in these cases, as the 
physical characteristics of a sub-assembly are calculated from its constituent parts. However in 
many cases, especially where there are numerous constraints and parts, the benefits in performance 
and efficiency can be significant. 

Include Nuts and Bolts In Sub-Assemblies 

An extension of the last point with regard to small items, whose dynamics are rarely of interest, is 
that it is usually best to include them in a subassembly with one of the parts they secure. For 
instance, you might want to “attach” bolts to one part, the nuts to the other, and then constrain those 
two sub-assemblies together as another sub-assembly. Alibre Motion will then only need to solve the 
dynamics of one part, rather than many. 
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Ensure The Constraints are Correct 

Alibre Motion uses Automatic Constraint Mapping (ACM) to define the ways that Parts and Sub-
Assemblies can interact. Ensuring that the Assembly moves as required before activating Motion 
goes a long way towards ensuring the expected behavior from Simulations. Also, be careful not to 
over-constrain the Assembly, as this may cause locking. 

Build Realistic Parts 

Not just the mass, but also the shape and size of a part determines its moments of inertia, which 
influence the way it moves when acted on by a force or torque. For instance, a basketball has larger 
moments of inertia than an identical-weight soccer-ball has, and because of this, accelerates more 
slowly when rolling downhill. (Of course, if you drop them straight down, neglecting air-resistance, 
they would accelerate identically). Similarly the center-of-mass must be in the right place to produce 
realistic behavior. 

Use Realistic Constraints 

Most constraints in Alibre Design represent a real-world physical behavior. For instance in the real-
world, a rod passing through a sleeve is constrained by the contact between the outer surface of the 
rod and the inner surface of the sleeve. The Alibre equivalent of this relationship would be an Align 
constraint between the two surfaces. However, some useful constraints provided by Alibre Design 
do not have a real-world counterpart, such as those which include a Reference Geometry feature, an 
Axis or a Plane. Even though Alibre Motion may simulate the constraint such that the parts move 
exactly as expected, the Reference Geometry could lie outside the Part, and forces and torques may 
act through that point, which in reality could not happen. Avoid constraining against Reference 
Geometry in Assemblies you plan to simulate.  

 
 

16.6.3    Automatic Constraint Mapping (ACM) in Alibre Motion 

In the past, one of the most time-consuming processes when creating models for simulation was 
adding constraints. Often a CAD design had constraints that needed to be recreated from scratch in 
the simulation program. Alibre Motion automatically creates simulation constraints from the Design 
Constraints already present in the Assembly, using a process called Automatic Constraint Mapping, 
or ACM. 

ACM is completed automatically when the Motion Explorer is activated from the Motion Menu, and 
whenever a new simulation is created or Regenerated. 

Tip: Before activating Motion ensure all constraints are correct and that the Parts and Sub-
Assemblies move as required. 
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16.6.4    Moving And Fixed Parts 

Automatic Body Mapping (ABM) 

Alibre Motion uses Automatic Body Mapping to analyze your Assembly designs, and determine 
which Parts and Sub-Assemblies should become Moving Parts for the purposes of simulation. If a 
Sub-Assembly is Made Flexible, then the Parts and Sub-Assemblies in it will all produce moving 
parts. Automatic Constraint Mapping will also create simulation constraints for each of its contained 
constraints. If the Sub- Assembly is not “Flexible” then the entire Sub-Assembly will become a 
Moving Part. 

Because of this it is common for the Motion Explorer to show that the simulation has more moving 
parts than the Design Explorer shows. 

Fixed Parts 

“Anchored” Parts and Sub-Assemblies will always become Fixed Parts. The dynamics of Fixed Parts 
is not calculated, and they are used by Alibre Motion only when they are constrained to Moving 
Parts, and for determining any Interferences or Collisions. 

Physical Characteristics of Parts And Sub-Assemblies 

The physical characteristics of the moving parts in the simulation decide how they react to forces 
and torques applied to them. Alibre Motion calculates these characteristics directly from your existing 
Part and Sub-Assembly designs: 

• Location 

• Orientation 

• Mass - calculated from the Material specified 

• Location of the center of mass (also known as center of gravity, or CG) 

• Moments of inertia 

• The position of each point at which another body or force can act 

All of these are computed automatically by Alibre Motion from the Assembly, whenever a Simulation 
is generated. They come from the design of each part, and the constraints in the Assembly. 

Tip: Ensuring that these characteristics are correct when designing your parts and assemblies is a 
crucial step in the process of producing accurate and useful simulations. 
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16.6.5    Creating Simulations 

 To create a new simulation: 

1. In the Motion Explorer, right-click on the name of the assembly, and select New Simulation.  
The New Simulation dialog appears.   

 

2. In Name, type a name for the new simulation.  

3. In Copy From, select from the drop-down list which existing simulation you want to use as the 
start point for the new one, or choose None.  

4. Check the Active checkbox if you want to make the new simulation the active one.  

5. Click OK to create the new simulation. 

 
 

16.6.6    Renaming Simulations 

Alibre Motion supplies a default name for each new Simulation you create. To help you keep track of 
them, it is often a good idea to give them more meaningful names, as you might with Design 
Configurations. For instance, you might name one “Motions Only”, and another “Forces Active”. 

 To Rename a Simulation: 

1. In the Motion Explorer, right-click the Simulation you wish to rename, and select Rename.  

 

 

 

 

 

2. Type the new name for the Simulation.   
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3. Press Enter to save, or Escape to cancel the renaming.  Simulations will be listed in 
alphabetical order in the Motion Explorer.   

 
 

16.6.7    Running Simulations 

After you have all of the necessary simulation options set, you can begin the simulation.  To do this, 
make sure you have Enable Simulation Mode checked from the Motion main menu.   Click the Play 
tool   to begin the simulation.   Choose the Pause   tool, then Stop   to end the simulation.  

 

Optimizing Playback Performance 

While the Alibre Motion Simulator is generating the simulation, playback will normally be slowed. 
These data are only calculated once for any given simulation, and playing the simulation back for the 
second time will be faster. A good visual indication is the Frame Slider Indicator on the Playback 
Deck: if the pointer is at the far right of the Slider, then the Simulator is running, and performance 
should be expected to be slowed. If the pointer is running over an already blue section, then the 
Simulator is not running. 

• Set the Target Playback Rate - Make sure that the Target Playback rate is set to a 
reasonable value, using the Target playback frame rate check-box in the Playback Settings 
tab of the Settings dialog. Note: This target rate will not be achievable in all cases. 

• Stop Other Programs - If you have other calculation intensive programs running in the 
background, they may some effect. Usually, programs that are not doing anything at the 
time will have a negligible effect, but often starting other programs will completely 
monopolize the CPU, slowing simulator performance. 

• Hide Reference Geometry - Hiding Planes and Axes improves playback performance, as 
Alibre Design will not have to resize the features at each frame as the various parts of your 
assembly move.  (Press CTRL + SHIFT + P on your keyboard to hide all the reference 
geometry in your model.) 

• Optimize Your Graphics Card performance - The Graphics Card in your machine will 
have a great influence on the speed at which graphic images can be displayed. The 
manufacturer of the card or your computer may well have information on the best settings 
for your situation.  

• Suppress Irrelevant Parts - Excluding parts which have no influence on the simulation 
may improve playback performance, especially if they are complex or irregularly curved 
shapes. 

• Close Information Windows - Generating the XY-Plots of dynamic measurements, and 
generating Interferences demands a great deal from your computer, and you will usually 
find that hiding these, as well as the Motion Status Window, will give the best performance. 

• AVI Generation - Generating AVI's will slow playback performance, and the amount to 
which they do so will vary greatly depending on the Video Handler or CODEC, that you 
use. 
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16.6.8    Simulation Warnings 

While reading your Assembly design, and also before and during simulation, there may be times 
when Alibre Motion detects a condition which may affect the accuracy or some other aspect of the 
Simulation you wish to perform.  

For instance, you will be warned when any Moving Parts in your assembly have extremely high or 
low densities, as this may be an indication that the results you get will not be realistic. In all of these 
cases, the Motion Status window opens automatically if it is not already showing, and the warnings 
are displayed. If you are satisfied that the situation described is as you intended, you can close the 
window, and ignore the messages, if you so choose. 

 

Simulator Messages 

Just before and during Simulation, the Alibre Motion Simulator displays various messages showing 
its status, and the progress of the simulation calculations. These are displayed in the bottom half of 
the Motion Status Window (unless you have turned them off by unchecking Show Simulation 
Messages on the General Tab of the Settings dialog). In some situations, such as when you specify 
a prescribed motion that cannot continue, the Simulator will stop, and display various messages 
here. If the Simulator stops for no apparent reason, make sure that the Simulator messages are 
visible, as they often provide useful feedback about what has happened, and what may be done to 
correct the situation. 

 

 To turn on and off the Motion Status window: 

1. From the Motion main menu, check the option Show Status Window to turn it on, and 
uncheck the option to turn it off.  

 
 

16.6.9    Maintaining Multiple Simulations 

Multiple Simulations 

Alibre Motion allows you to maintain multiple Simulation Setups for each Configuration in your 
Assembly design. Each Simulation may have completely different Motors and Motions, as well as 
with different Traces, Measurements and Simulation and Playback settings specified. Using this 
feature you can try out multiple scenarios on an assembly with, for instance, different strength 
motors, and compare the results from each. 
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Simulations with Design Configurations 

When Motion is enabled in the workspace of a new Assembly, a default simulation is created using 
Automatic Body Mapping and Automatic Constraint Mapping. The Part and Constraint data is taken 
from the Configuration currently active at that time, and the Simulation generated applies to that 
specific Configuration. 

Note: Only Simulations for the Currently Active Configuration are displayed in the Motion Explorer 

Alibre Motion detects when you change the Active Configuration, and if it already has Simulation 
Setup data for that Configuration, the Motion Explorer will switch to that Simulation. If not, a new 
default Simulation Setup will be generated for the newly activated Configuration. 

 
 

16.6.10    Deleting Simulations 

If you have more than one simulation for a particular assembly, you can delete all of them except 
one.  One simulation will always remain in the Motion Explorer.  

  

 To delete a simulation: 

1. In the Motion Explorer, right-click the simulation you wish to delete, and select Delete. 

    
 

16.6.11    Activating a Different Simulation 

If you have more than one Simulation Setup for the currently active Configuration, they are displayed 
under the Configuration name at the top of the Motion Explorer. Currently inactive Simulations are 
shown grayed out. 

 To Switch Between Simulations: 

1. In the Motion Explorer, right-click the Simulation you wish to switch to. 

 

2. Select Activate.  The Simulation is activated and checked, and any relevant Simulation 
Warnings will be shown at this time. 
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16.7    Results and Feedback from Alibre Motion Simulations 

There are several different ways to obtain and view the results of simulations in Alibre Motion, each 
one of which may be most useful in any given circumstance. Any combination of these may be used 
at the same time: 

• Traces 

• Video Generation 

• X-Y Plots 

• Dynamic Measurements 

• Exporting Data 

 
 

16.7.1    Traces - Visualizing Paths and Vectors 

Traces can be an extremely useful and efficient way of visually examining simulation data. They 
enable you to see at a glance how a Part moves during the simulation, and to see how its velocity 
and acceleration changes. Traces may also add greatly to the visual impact of Videos generated 
from simulations of your designs, and Alibre Motion gives you several parameters that you can use 
to customize the way that Traces are displayed. 

 

Traces are persistent 3D objects 

Traces are shown as lines and shapes on the main canvas, but they are 3D reference geometry that 
dynamically change, enabling you to easily visualize 3D paths as you pan, zoom and tilt during 
playback. 
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Trace Options are stored with the Simulation setup data in your Assembly file 

Unless you have chosen not to (by un-checking the “Save Simulation Setup Data in Assembly file” 
Settings option), then all information concerning your simulation, including your customized Trace 
options, are stored in the Assembly file. This means you can share not just an Assembly and 
Simulations, but also how they are displayed, perhaps for maximum effect. 

Display Vector Data Using Traces 

The Velocity and Acceleration of individual Parts can be displayed using traces. The direction of 
these vector quantities is shown as a line connected to the center of gravity (CG) of a part, or the 
Point of Action of a constraint. The length of the displayed line represents the magnitude of the 
Vector Quantity. Velocity vector lines are scaled logarithmically such that Zero velocity is a line 5 
pixels long, and the maximum possible velocity (C, the speed of light in a vacuum) is half the length 
of the diagonal extents of the assembly. To derive quantitative velocity and acceleration data, use X-
Y Plots, or the “Current Value…” option. 

 
 

Examples Of Various Trace Options 

Here are some examples of the sorts of traces that can be produced using the options in the Trace 
Options dialog: 

            

  8 Frame Trail-length, Position, Velocity and Acceleration Traces Shown, Position Trails Shown 
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As above, with “Position - Fade Trails” selected 

    

As above, with “Trail Length” of 30 frames 
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 Acceleration trails shown 
 

Creating Traces 

 To create a Trace: 

1. In the Motion Explorer, right-click on a Moving Part or a Constraint, and select the type of Trace 
you wish to display from the Trace menu.  A new Trace item is shown below the Traces item in 
the Motion Explorer: 

        

Note: Traces are shown on the main canvas during playback. 

 

 To Change Trace Options: 

1. Right-click the trace you wish to modify, and select or deselect the desired items. To change 
the way Traces of particular types are shown, select “Trace Options…” from the right-click 
menu of any Trace, or the “Traces” item in the Motion Explorer: 

            

2. Change the desired options in the Trace Options dialog.  
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Current Values 

 To see the current values of a Trace: 

1. You must have created a trace for a moving part or constraint, and have traces enabled.  

2. In the Motion Explorer, expand the Traces category.   You will see listed there each of the 
moving parts or constraints that you created a trace for.  

3. Right-click on one of the parts or constraints and select Current Values.  The Data dialog 
appears.  

 

 

This dialog shows the current values of any measurable quantity at the current frame. You cannot 
change any values here, and no selections you make will reset the current simulation.    

Position data is shown relative to the Assembly origin. 

The position, velocity and acceleration data shown for a Part is the data for its Center of Mass (CG) 

• Frame - Shows the current playback frame at which the measurements are taken. 

• In Data type - select the type of data you are interested in. The selections in this dropdown 
will vary depending on the item for which data is being shown. When you make a different 
selection, the relevant data is shown immediately. 

• X, Y, Z - The data is shown as components parallel to the major axes of the Assembly 
design in the X, Y, Z boxes. 

• Magnitude - The total magnitude is shown in the Magnitude box.  
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16.7.2    Generating Video with Alibre Motion 

Generating Video (AVI) files can be a useful way of easily sharing the results of simulating your 
designs with colleagues and others, as generated files may be distributed via email, internet 
download and many other means, and may be played on a wide variety of systems. 

Important Note: By no means will all Codecs installed on your system be able to generate video. 
Though many are available as free downloads from Microsoft® and other manufacturers, some may 
only be capable of playing back video, and not generating it. See Generating Video for more 
information. To protect your system, always be extremely careful when downloading programs and 
other files from the internet, and only ever do so only from trustworthy sources. 

 

How videos are created 

Clicking the Video option button  opens the Generate Video (AVI) Form, giving you the 
opportunity to specify the name of the file to be created, and various other settings that affect the 
video generation process. Then during playback, the main canvas is saved as a bitmap. Each 
bitmap is combined together and packaged into an AVI file. Whenever Videos are generated on your 
system, the software which does this is called a CODEC (short for COder / DECoder), or Video 
Handler. These are generally small programs that need to be installed and registered, and it is likely 
that there are several of these already on your system. Alibre Motion is able to utilize those Codecs 
which handle a color-depth of 24-bits. The list of Codecs currently installed on your machine is 
shown in the drop-down box in the Advanced Tab of the Generate Video (AVI) Form. 

The Codec used to play a video must be compatible with the Codec used to generate the video, so 
each AVI file holds information concerning how it was generated. A video player program examines 
the file, determines whether a suitable Codec is already installed, and some video players may 
optionally download and install them automatically if one is not. 

It is worth noting that the speed of generation, the quality of the generated video, and the number of 
systems on which it may be easily played, are all heavily dependent on the choice of Codec used to 
generate it. A great deal of information concerning Codec’s and video generation is available online. 

Note: During Video generation, some Codecs may show an options form or other display to allow 
you to monitor progress or change features. Playback may also be considerably slowed while videos 
are being generated. It is also possible that some Codecs may cause your system to slow or hang, 
though this is rare. 
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Not all Codecs can generate Video 

Since Codec’s are often written by 3rd parties, your operating system generally cannot distinguish 
between those that may be used to both generate and playback videos, and those that cannot, and 
are only useful for playback. Since it may also be hard to predict the effect of the Quality and Key- 
Frame parameters, it is worth experimenting to find settings that work best for you. 
 

Generate Video Settings 

General Tab 

 

1. In Output file to create, specify the name and path of the video file to be generated. Click the 

Browse button  to select a file and path from the standard File dialog. 

2. In Movie display name, enter the name of the movie as it should be shown in a video playback 
program. 
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Note: Not all video players display this name, or may do so only as an option. 

3. In Video frames per second, enter the number of frames per second at which video playback 
programs should display the generated video. 

Note: The maximum speed at which video may be played back depends on the system and the 
video playback program. 

4. Click OK to apply changes and close the dialog, or Cancel to abandon changes and close the 
dialog.  

 

Advanced Tab 

 

1. In Video handler, select the Codec you wish to use to generate the video (AVI) file.  This drop-
down list shows all the video handlers, or Codecs, that are installed and registered on your 
particular system. This list will vary from system to system, and some systems may not have 
any Codecs installed.  
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2. The Handler description field shows the internal description of the Codec as provided by the 
Codec itself. 

3. The Quality parameter is used by some Codecs to determine the quality of the Video to 
generate. Generally, the higher the quality, the larger the file size. 

4. The Key-frame every field is used by some Codecs to determine how often the entire image 
should be stored within the generated video file. Some Codecs use a process whereby an initial 
frame (a key-frame) is stored, then each subsequent frame is stored only as the difference 
between that frame and the last. The purpose of this process is to minimize file-size. 

5. Click OK to close the form.  If a suitable Codec, file, and parameters have been chosen, a 
video will be generated while the simulation is next played.  If you do not wish to create a video, 
or save your changes, click Cancel.  

 
 

16.7.3    Generating X-Y Plots from Simulation Data 

You can generate X-Y Plots if you have selected Dynamic Measurements for at least one of your 
moving parts or constraints.   

 To select a Dynamic Measurement: 

1. In the Motion Explorer, right-click on one of the moving parts or constraints, and select 
Dynamic Measurement.  The Dynamic Measurement dialog appears.  

2. In Name, enter a name for the measurement.  

3. In Measurement, select which type of measurement you want to take for this part or constraint.   

4. In Component, choose which component to measure - X, Y, Z, or total magnitude.  

5. In Display Color, choose which color you want this measurement represented in when plotted.  

6. Check the Show in X-Y plot option if you want this measurement to appear on the graph when 
you have X-Y plot turned on.  

Once you have created your Dynamic Measurements, they will appear in the Motion Explorer under 
the Measurements category.  Any measurements that you have selected to show in the X-Y plot will 
appear on the graph when you have the Show/Hide X-Y Plots button selected.    

You can turn on the plot option before or after the simulation has been run.  
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       Results shown in X-Y Plot 

 

 To Copy and Paste Chart Data:  

1. You can copy and paste the chart data from Alibre Design into another application for use in 
reports and presentations.  

2. Right-click in the graph area and select Copy. You will see the following dialog: 

 

This tells you that if you go into another application and choose Paste, you will be pasting only 
the values of the data in text.  If you choose Paste Special, or a similar option, you will given 
the choice to paste the text or an image.  If you want to paste both text and the image, you will 
need to do it twice.   Click OK to close the dialog.  
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3. Open the application you want to paste the data into, and choose the appropriate Paste option.  

 

 To Export Chart Data:  

You can export the chart data out of Alibre Design for use in reports and presentations. 

1. Right-click in the graph area and select Export chart data.  The Export Data dialog appears.  

 

2. In Data separator, select which method you want to use to separate the data points. 

3. In Export, select all of the options you want exported out.   

4. In Export File, click the browse button to browse to a location to save the file, and choose if 
you want it saved as a text file or a .csv file.  

5. Choose Export to export the data to the file you specified.  The Export option exports only the 
chart data, not the plot image.  
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16.8    Detecting Interferences 

While generating or playing back Simulations, Alibre Motion allows you to check for Interferences 

between parts at each frame. To enable this, depress the Interferences tool   on the Playback 
deck, while in Simulation Mode. The Interferences dialog opens, which enables you to set options 
and view the details of any Interferences found.  

Note:  Interferences checks for clashes with each part against every other part in your assembly, 
and therefore can be a calculation-intensive operation. It is usually best to simulate first, and then 
check Interferences only during playback, because during simulation the Simulator may be using a 
large part of the capacity of the CPU in your computer. 

 
 

16.8.1    The Interferences Dialog 

Note: Depending on the complexity of your model and the speed of your system, checking for 
Interferences can slow playback performance. 

 

• Check Stop playback when found to automatically stop playback whenever any 
Interferences are found. This allows you to find the configuration where two parts first 
collide, for instance. 

• Check Show interference extents to draw a red box around any interferences found at the 
current frame, enabling you to quickly identify which parts are interfering, and where. 

• In Interferences found, Alibre Motion displays the number of interferences found in the 
assembly. 

• The Interferences List displays the details of each interference. For each Interference the 
names of the two parts are shown, as well as the volume of interference, which is the 
amount the two parts overlap. 

 
 

16.9    Frequently Asked Questions (FAQ) 

• What is Dynamic Simulation? 

Please see the overview of simulation (see "An Overview of Simulation" on page 516) for 
details on this question. 

• What is the difference between Simulation and Animation? 
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Simulation is the process of calculating the positions of the bodies at a given moment, 
animation is displaying the bodies at the new positions in sequence. 

• Does Dynamic Simulation involve stresses and strains within the bodies? 

No, generally Dynamic Simulation is concerned with what is termed Rigid-Body Dynamics, 
which assumes each body is infinitely strong, and infinitely stiff. 

• How do I generate Video of my Simulations? 

Please see the section on generating videos (see "Generating Video with Alibre Motion" 
on page 558) for information on how to do this. 

 





Chapter 17 - Collaboration Capabilities 

 
 
 

 567 
 

C H A P T E R  1 7  

 Collaboration Capabilities 
In addition to its powerful modeling capabilities, Alibre Design contains a unique collaboration engine 
that allows engineering teams to work together simultaneously over the Internet to create, visualize, 
review and modify their designs and drawings.  Alibre Design also allows users to directly share and 
manage all types of files with other users, using the Internet as a work platform. 

This chapter includes a brief overview of working online and the functionality available.  The 
subsequent chapters provide detailed information on each collaboration tool.  

 

In This Chapter 

Working Online ........................................................................................................ 568 
The Contacts List and Alibre Assistant.................................................................... 569 
Message Center ...................................................................................................... 570 
Team Manager ........................................................................................................ 571 
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17.1    Working Online 

To use the unique communication and collaboration tools in Alibre Design, you must be signed into 
the Alibre Design server.   Users who have purchased Alibre Design Basic, Standard, Professional, 
or Expert who have an active maintenance agreement can sign into the Alibre Design server.   
Working while connected to the Alibre Design server is referred to as online mode.  Alibre Design 
operates in offline mode by default.   In offline mode, all communication and collaboration tools are 
disabled.   

 To work online: 

In the Home Window, click the link Click here to work online, found in the Contacts section. You 
will be prompted for your username and password to work online.  

 

 To switch between working online and offline: 

When Alibre Design is running in online mode, the Alibre Design icon in the Windows system tray 
has an orange appearance.  When offline, the icon has a gray appearance.  To switch between 
offline and online modes, right-click the Alibre Design icon in the Windows system tray and select 
Work Online or Work Offline. 
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Note:  When Alibre Design is in online mode, users may choose to be alerted when certain events 
occur.  The alerts can be turned on and off by clicking Display Alerts in the right-click menu.  Alerts 
occur when an associate signs into Alibre Design, a message or team session invitation is received, 
and an associate has shared a repository.  

 

 
 

17.2    The Contacts List and Alibre Assistant 

The Contacts List is a customizable listing of your personal contacts of Alibre Design users, support 
personnel and consultants. 

The Alibre Assistant: 

After signing into the Alibre Design server, you may see a contact called Alibre Assistant in the 
Contacts list.  The Alibre Assistant corresponds to a support engineer at Alibre headquarters who 
can offer real-time technical help through Alibre Design.  An Alibre support engineer is online and 
available for assistance whenever Alibre Assistant is visible in the contacts list.  

 To add an associate to your contacts list:  

1. While working online, select Add/Remove Contacts from the Actions main menu.  Or, click 
the Add/Remove Contacts icon on the Home window. 

2. Select the desired name from the Listed Users area and click Add.  Alternatively, if you know 
the user name of your associate, type it into the Unlisted User area and click Add. 

3. Click OK.  The added users will appear in your contact lists. 
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17.3    Message Center 

In addition to this overview, you can reference the detailed chapter on using the Message Center 
(see "The Message Center" on page 573).  

Messages can be sent to other Alibre Design users while working online.  Messages are sent, 
viewed and managed in the Message Center.  To access the Message Center, from the Window 
menu, select Message Center.  Or, click the Message Center tool on the Home window toolbar.  

The Message Center is organized similar to most email applications. 

 
Figure 113: Message Center Window 

Incoming messages are stored in the Inbox, and outbound messages are logged in Sent Items.  To 
create a new message, from the File menu, select New Message.  Create new folders to organize 
messages, just right-click a folder and select New Folder.  Most Message Center features are only 
available when working online. 

Note:  Messages can also be sent from the Home window.  From the Actions menu, select Send 
Message.  Or, right-click a contact in the Contact list and select Send Message. 



Chapter 17 - Collaboration Capabilities 

 
 
 

 571 
 

To set options for receiving messages, from the Tools menu, select Options. 

 

You may opt to be alerted of new messages by pop-up boxes and/or a system sound. 

Even if the notification and alert options are turned off, a message icon in the lower right corner of 
the Home window indicates that a new message has arrived. 

 

You may also forward messages to an email account.  Three options are available: never forward 
messages, forward messages only when offline, and always forward messages. 

 
 

17.4    Team Manager 

In addition to this overview, you can reference the detailed chapter on using the Team Manager (see 
"The Team Manager" on page 581).  

Alibre Design enables you to efficiently manage people and data by defining roles and teams for 
your contacts.  Defined teams of users are ideal for projects involving multiple people.  
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Team administration is handled in the Team Manager window, which is only accessible when 
working online.  To open the Team Manager from the Home window, from the Window menu, select 
Team Manager.  Or, click the Team Manager tool on the Home window toolbar.  

 
Figure 114: Team Manager Window 

By default, a Home Team is listed in the Team Explorer on the left side of the window.  To create a 
new team, from the Action menu, select Add Team.  To add members to a team, click a team name 
in the Team Explorer to select it; then, from the Actions menu, select Add Team Member.  Team 
roles may also be added and assigned to team members.  From the Actions menu, select Add 
Team Role.  

Roles are typically used to control data access.  For example, some team members may need 
permission to modify data while others only need permission to view data.  An “Engineer” role could 
be set with more advanced permissions and a “Reviewer” role could be set with more limited access 
to the data.  Permissions are set in the Repository, applied to individual files and folders.  After you 
create a team and its associated roles, data can easily be shared with the entire team through the 
repository. More details on setting access permissions on repository data can be found in the 
chapter on The Repository (on page 479). 

Teams can also be invited to a Team Design session, eliminating the need to send an invitation to 
multiple people.  If a user is removed from a team, he or she is also removed from the team session.  
More details on Team Design sessions can be found in the chapter on Team Design (see "Team 
Design Sessions" on page 587). 
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 The Message Center 
The Message Center is used to manage, send and retrieve voice and text messages.  There are two 
types of messages stored in the Message Center: messages sent by other users, and messages 
that report activity associated with repository item notifications.  New messages are sent to the Inbox 
in the Message Center.  Additionally, you may have new messages forwarded to an email account. 

Messages can be organized using folders, similar to email applications.  Messages contain the 
following information: user name of sender, date and time the message arrived, subject of the 
message, and a recording or text.  In addition, team session invitations include an attachment 
containing the session details. 

In This Chapter 

Opening the Message Center.................................................................................. 574 
Retrieving Messages ............................................................................................... 574 
Sending Messages .................................................................................................. 575 
Replying to Messages ............................................................................................. 577 
Deleting Messages .................................................................................................. 578 
Using Folders in the Message Center ..................................................................... 578 
Setting Message Options ........................................................................................ 579 
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18.1    Opening the Message Center 

 To open the Message Center from the Home window: 

Select the Message Center  tool from the Standard toolbar; or, from the Window menu select 
Message Center.  The Message Center window appears. 

 

 To open the Message Center from any other area: 

From the Window menu, select Message Center.  The Message Center window appears. 

 
 

18.2    Retrieving Messages 

You can retrieve messages when working online.  For recorded messages, you will need speakers 
or headphones. 
 

18.2.1    Reading a Text Message 

 To read a text message: 

1. Select the Inbox from the Folder List. 
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2. Select a message.  The text of the message appears at the bottom of the window. 

 
 

18.2.2    To Play a Recorded Message 

 To play a message: 

1. Click the green arrow to start the message.  

2. Click the black square to stop or pause the message.  

 
 

18.3    Sending Messages 

Messages can be sent from the Message Center, the Home window and any open workspace.  
Messages can be sent any time you are working online.  Recipients working online will be notified of 
new messages immediately.  Otherwise, the message will be delivered to their Inbox in the Message 
Center upon their next sign-in. 

 
 

18.3.1    Creating a New Message From the Home Window 

 To send a message from the Home window: 

1. From the Actions menu, select Send Message; or, select the Send Message  tool. 

2. Click the To: button to add recipients to the message.  

3. Select users from the Listed Users section, or enter an Alibre Design username in the Unlisted 
User field.  

4. Click Add to add users to the Recipients section.  

5. Click OK when you have finished adding recipients.  

You can also right-click a contact and select Send Message.  The To field will be populated 
automatically, and more recipients can be added 
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18.3.2    Creating a New Message from the Message Center 

 To create a new message: 

1. From the File menu, select New > Message. 

Or, from the Actions menu, select New Message. 

Or, right-click in the message list section and select New Message.  

2. The New Message dialog appears. 

 

3. Follow the instructions for working with the new message dialog (see "Recording a Voice 
Message" on page 577) and/or recording a voice message (on page 577) if desired.  

  
 

18.3.3    Working With the New Message Dialog 

1. Click the To: button.  The Recipients dialog appears. 

2. Select the teams and users to whom the message will be sent.  Click the Teams tab to select 
teams.  Click the Members tab to select members. Ctrl + click to select multiple users or 
teams. 
 
To write to an unlisted team or user, type the team or user name in the Unlisted field. 
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3. Click Add.  Selected users or teams appear in the recipients list. 

4. Click OK. The selected users and teams appear in the To field. 

5. Enter a Subject (optional). 

6. Type or record a message to activate the Send button. 

7. Click Send. 

 
 

18.3.4    Recording a Voice Message 

1. Click the Record  button to begin recording your message.  Voice messages may last as 
long as 60 seconds. 

2. Click the Stop  button when finished recording. The number of seconds recorded appears 
and the Send button becomes active. 

 
 

18.4    Replying to Messages 

 To reply to messages: 

1. Right-click a message. 

2. Select Reply or Reply to All. 

3. Enter a Subject (optional). 

4. Type or record a message. 

5. Click Send. 

Note: You may only reply to a message from the Message Center.  You cannot reply to 
notifications. 
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18.5    Deleting Messages 

Deleting a message moves it to the Deleted Items folder. Deleting a message from the Deleted 
Items folder permanently removes the message. 

 To delete a message: 

1. Expand the folder that contains the message. 

2. Select the message and press Delete on the keyboard; or right-click the message and select 
Delete Message from the pop-up menu; or from the Edit menu select Delete.  The message 
moves to the Deleted Items folder. 

To empty the Deleted Items folder, click the folder and select Empty Deleted Items from the Tools 
menu. 
 

18.6    Using Folders in the Message Center 

18.6.1    Creating a New Folder 

 To create a new folder: 

1. Select the location for the new folder. 

2. Right-click and select New Folder from the pop-up menu; or from the File menu select New 
Folder.  A folder appears with the temporary name “New Folder” highlighted. 

3. Type a Name for the folder 

4. Press Enter. 

 
 

18.6.2    Deleting a Folder 

 To delete a folder: 

1. Select a folder. 

2. Press Delete on the keyboard; or right-click a folder and select Delete Folder from the pop-up 
menu; or from the Edit menu select Delete.  The folder is moved to the Deleted Items folder. 
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18.6.3    Moving a Folder into Another Folder 

 To move a folder into another folder: 

Select and drag the folder over another folder. 

 
 

18.6.4    Renaming a Folder 

 To rename a folder: 

1. Select a folder to highlight it. 

2. Click again to make the folder name editable. 

3. Type a new name for the folder. 

4. Press Enter. 

 
 

18.7    Setting Message Options 

Message options affect how you are notified of messages.  When working in Alibre Design, you may 
choose to be alerted to new messages through a pop-up window or sound.  

In addition, you may choose that messages be forwarded to an email account, all the time, only 
when you are offline, or never.  You can forward copies of your messages to an email account to be 
notified of changes to designs, even when you are signed out of Alibre Design. 
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 To set message options:  

1. From the Tools menu, select Options. The Message options dialog appears. 

 

2. Select the Popup option to receive an alert via a pop-up window. 

3. Select the Beep option for an audible alert. 

4. To forward Alibre Design messages to your email account, select Never, Only when offline, or 
Always. 

Note:  With Never selected, messages are not forwarded.  The Only when offline option only 
forwards them when you are signed out of Alibre Design.  Selecting Always forwards all 
messages to email account you specify. 

5. Additionally, if you selected the Only when offline or Always option, type an email address. 
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 The Team Manager 
Alibre Design enables you to efficiently manage people and data by defining roles and teams for 
your contacts.  Teams are ideal for projects involving multiple people.  Team administration is 
handled in the Team Manager window, which is only accessible when working online.   

The Team Manager is where teams and roles are created, members are added to teams and roles 
are assigned to members.  

Teams published to you also appear in the Team Manager.  All members and roles are displayed, 
but may only be modified by members granted administrative privileges.  

 

In This Chapter 

Opening the Team Manager.................................................................................... 582 
Creating and Deleting Teams.................................................................................. 582 
Creating and Deleting Team Roles ......................................................................... 584 
Publishing a Team................................................................................................... 586 
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19.1    Opening the Team Manager 

 To open the Team Manager from the Home window: 

Select the Team Manager  tool from the Standard toolbar; or, from the Window menu select 
Team Manager.  The Team Manager window appears. 

 

 To open the Team Manager from any other area: 

From the Window menu, select Team Manager.  The Team Manager window appears. 

 

 
 

19.2    Creating and Deleting Teams 

In the Team Manager, one team by default, your Home team, is displayed in the Teams Explorer 
with Roles and Members.  You are the default member of your Home team. 
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 To add a team: 

Right-click Teams and select Add Team from the pop-up menu; or, from the Actions menu, select 
Add Team. 

 

 To delete a team: 

1. Right-click the team and select Remove Team. 

Or, 

1. In the Team Explorer, select a team. 

2. Select Remove Team from the Actions menu. 

 

 To add a member to a team: 

1. Expand the team so that Roles and Members are visible. 

2. Right-click Members and select Add Team Member from the pop-up menu; or from the 
Actions menu select Add Team Member.   The Add Member dialog appears. 

3. Select a user from the Listed users or Contacts list,  or type a user name in Unlisted user box. 

4. Click Add.  The user name is added to the Members list. 

5. Click OK. The new member appears in the Team Explorer. 

Note: To add members to a team, you must be the creator of the team or have administrative 
rights for it. 
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 To remove a team member: 

1. Right-click the member and select Remove Team Member from the pop-up menu. 

Or, 

1. In the Team Explorer, select the member. 

2. From the Actions menu, select Remove Team Member. 

 
 

19.3    Creating and Deleting Team Roles 

Roles are typically used to control data access.  For example, some team members may need 
permission to modify data while others only need permission to view data.   
An “Engineer” role could be set with more advanced permissions and a “Reviewer” role could be set 
with more limited access to the data.  Permissions are set in the Repository (see "The Repository" 
on page 479).  

Team roles provide a way to group team members for the purposes of sharing data and establishing 
access permissions to data.  Combinations of permissions and notifications can be established to 
limit whether other users may view or modify repository items. 

After you create a team and its associated roles, data can easily be shared with the entire team by 
sharing a repository to the team.  Teams can also be invited to a Team Design session, eliminating 
the need to send an invitation to multiple people.   
If a user is removed from a team, they are also removed from the team session. 

Roles may be set to determine whether other users may: 

• Check out and make changes to items. 

• Overwrite changes made by other users. 

• Delete. 

• Be notified of changes. 

• Be notified if users with administrative privileges are added. 

• View the changes as new versions are checked in. 

To create and delete team roles, you must be the creator of a team or have administrative privileges 
for it. 
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Members with administrative privileges may: 

• Add and remove team members. 

• Add and delete roles. 

• Modify which roles are assigned to members. 

• Grant access privileges for repository items to teams and roles, through the Repository. 

 

 To add a role to a team: 

1. Expand the team so that Roles and Members are visible. 

2. Right-click Roles and select Add Team Role from the pop-up menu; or  
from the Actions menu select Add Team Role.  The Add Team Role dialog appears. 
 

Note:  If the command is dimmed, you do not have administrative privileges and may not add 
or remove roles. 

3. Enter a name for the role. 

4. Click OK. 

 

 To remove a team role: 

1. Right-click the role and select Remove Team Role from the pop-up menu.  The role is deleted. 

Or, 

1. In the Team Explorer, select the role. 

2. Select Remove Team Role from the Actions menu.  The role is deleted. 

 

 To assign roles to a team member: 

1. Expand the team so that Roles and Members are visible. 

2. Expand Members so that the members are visible. 
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3. Select a team member.  All roles in that team appear under Role Membership in the Team 
Manager. 

4. Click to check or un-check a role.  Checked roles are applied to the selected member. 

 
 

19.4    Publishing a Team 

You can publish one of your teams to a user or another team, which causes the team to appear in 
their Team Manager, and in the Teams list in dialogs, for publishing their own teams and team 
sessions and for sharing repositories. 

Note: You must have administrative privileges for a team to publish it. 

 To publish a team: 

1. Select a team. 

2. From the Actions menu select Publishing.  The Publishing dialog appears. 

3. Select a team from the Teams tab or a user from the Users tab. Ctrl-click to select multiple 
teams or users.  If the team is not listed, type the name of the unlisted team. 

4. Click Add. 

5. Click OK. 

 

 To remove a published team:  

1. Select the team's name in the Publish to these Teams area. 

2. Click Remove. The selected name returns to the Listed Teams area. 

3. Click OK. 

Tip: If you double-click a name, it moves to the opposite area. 
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 Team Design Sessions 
Team Design sessions let you work online with other Alibre Design users to view, edit and provide 
feedback on designs.  By reviewing designs and proposed changes together in real time, you can 
discuss issues and reach agreement faster, and eliminate delays inherent in traditional design-
approval-redesign cycles. 

Team Design sessions occur in a secure environment-only invited users can participate.  The person 
who initiates the session, the leader, has full control over who attends and each user's level of 
participation.  As the leader, you invite and admit users and assign each attendee viewer or editor 
status.  During the session, all participants can see design changes in real time and insert 
comments, but only those with editor status will be able to make design changes.  Additionally, you 
can lead or join any number of concurrent team sessions. 

Team Design sessions help you work quickly and efficiently with your associates and other users.  
Alibre Design provides a number of tools to facilitate communication during a session including text 
chat, voice chat, private messages, reference arrows, redline and markup, and view manipulation 
and reorientation. 

In This Chapter 

Leading a Team Session......................................................................................... 588 
Joining and Leaving a Team Design Session ......................................................... 597 
Scheduled Team Sessions...................................................................................... 599 
Working in a Team Design Session ........................................................................ 602 
Setting Alert Options................................................................................................ 614 
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20.1    Leading a Team Session 

When you start a team session, you are the session leader.  In the Team Design explorer, you are 

distinguished as the leader by the crown icon . 

The leader is responsible for: 

• Inviting participants. 

• Accepting or rejecting applicants. 

• Designating participants as editors or viewers. 

• Issuing free passes. 

• Adding parts, assemblies and drawings to the session. 

• Saving changes made to the design during the session. 

• Ending the session. 

If you want to lead a new team session while already participating in one, launch the new session 
from another workspace or the Home window. 

 
 

20.1.1    Leading a Session from the Home Window 

You can initiate a team design session directly from the Home window. 

 To lead a session from the Home window: 

1. From the Actions menu, select Lead Session; or right-click in the Contacts area and select 
Lead Session. 

Note:  To quickly start a chat session, right-click a user in the Contact list and select Lead 
Session > No Data.  The Chat Window immediately opens and an invitation is sent to that 
contact. 

Or, click the Lead Session  button. 

2. Choose the type of data that will be used to start the session.  Additional data can be added 
after the session begins. 

• No Data: the session will start without data, in the Chat Window.  
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• New Part/Assembly/Drawing: the session will start in an empty workspace of the selected 
type. 

• Repository Item: the session will start with the design selected through the Select Item 
dialog.  The Publishing dialog appears. 

 
 

3. In the Listed teams area or Listed users area, select the teams or users to invite.  Ctrl-click to 
select multiple teams/users.  If a specific team or user does not appear in the list, type it in the 
Unlisted team or Unlisted user field. 

4. Click Add.  The name appears in the Publish to these teams or Publish to these users area. 

5. Select Use as default publishing to use the same group of teams and users for subsequent 
team sessions. 

6. Click OK.  If Repository Item was selected in step 2, the Select Item dialog appears, 
otherwise the team session starts and invitations are sent. 

7. If the Select Item dialog appears, browse and select a design. 

8. Click OK.  The Team Design session starts with the selected design and invitations are sent. 
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20.1.2    Leading a Session from a Workspace 

 To lead a session from a workspace: 

1. Open the design with which you want to start the session.  You may also choose to start with a 
new part, assembly or drawing. 

2. From the Team Design menu, select Lead Session; or, select the Lead Team Design 

Session  tool from the Team Design toolbar.  The Publishing dialog appears. 

3. Select the teams and users to invite to the session. 

4. Click OK.  The Team Design session starts and invitations are sent. 

 
 

20.1.3    Accepting or Rejecting a Session Applicant 

Once a Team Design session has been published, invited users can apply to join the session.  The 
leader must then admit each applicant and assign editor or viewer status.  Alternatively, the session 
leader can issue free passes, which allow invited users to bypass the request process.  The leader 
may also change each participant's status during the session.  

 To accept a session applicant: 

1. When a user applies to join your session, the Leader Controls dialog will appear.  Users who 
are ready to join the Team Design session are listed under the Applicants tab. 

 

           

 

 

Note:  You can also access the Leader Controls dialog from the Team Design menu by 
selecting Leader Controls. 

2. Select each user name and choose from the following: 
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• Accept as Editor: The user is admitted to the session and can hold the baton to edit the 
design. 

• Accept as Viewer: The user is admitted to the session as a viewer.  The participant cannot 
edit the design, but can observe the session, enter comments in the Chat Window and join 
in the conversation. 

• Reject: The user is not admitted to the session, but the invitation to join is still open.  The 
user can apply to join again.  If the user's participation is not desired, it is best to remove 
the invitation. 

3. Click Close. 

You may also bypass the Leader Controls dialog.  Just right-click the user name under Applicants 
in the Team Design explorer and select the appropriate status.  The result is the same. 

 

 
 

20.1.4    Leader Controls: Toggling the Status of a Participant 

The leader of a Team Design session may change the status of a participant at any time.  This may 
be done with the Leader Controls dialog box or through the Team Design explorer. 

 To toggle a participant's status: 

1. In the Team Design explorer, right-click the user name under the Participants list and select 

Toggle Status from the pop-up menu.  The status icon changes from a cap  to a hard 

hat or vice versa. 

Or, 
                               

1. From the Team Design menu select Leader Controls.  The Leader Controls dialog box 
appears. 
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2. Click Participants. 

3. Select the participant whose status you want to change. Ctrl-click to select multiple user 
names. 

4. Click Toggle Status.  The status icon changes from a cap to a hard hat or vice 
versa. 

 
 

20.1.5    Leader Controls: Removing a Participant 

The leader of a Team Design session may remove a participant from the session at any time.  This 
may be done with the Leader Controls dialog or through the Team Design explorer.  The participant 
can reapply to the session unless you remove that participant from the Publishing list. 

 To remove a participant: 

1. Right-click the user name under Participants list in the Team Design explorer and select 
Remove from the pop-up menu.  If the participant has the baton, it is returned to you.  A 
message in the Chat Window notes that the participant has left the session. 

Or, 

1. From the Team Design menu select Leader Controls.  The Leader Controls dialog appears.  

2. Select the Participants tab. 

3. Click the name of the participant you want to remove. 

4. Click Remove.  If the participant has the baton, it is returned to you.  A message in the Chat 
Window notes that the participant has left the session. 

 
 

20.1.6    Leader Controls: Free Passes 

The leader of a Team Design session can issue free passes to specific users, which allow them to 
bypass the admittance process.  Users who have been issued a free pass are immediately accepted 
into the session when they join. 
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The session leader can 

• Assign a free pass. 

• Change the editor/viewer status of a user's free pass. 

• Remove a free pass. 

 

 To assign a free pass: 

1. From the Team Design menu select Leader Controls.  The Leader Controls dialog appears 
with the Free Pass Holders tab displayed. 

2. Click Issue Passes.  The Issue Free Passes dialog appears with a list of users to whom you 
have published the session. 

 

3. Select the users to whom you want to issue a free pass.  Ctrl-click to select multiple users. 

4. Select Add as Viewer or Add as Editor.  The dialog closes and the user appears in the Free 
Pass Holders list in the Leader Controls dialog with the appropriate status icon. 

 

 To change the status of a user's free pass: 

1. From the Team Design menu select Leader Controls.  The Leader Controls dialog appears 
with the Free Pass Holders tab displayed. 

2. Click the member whose status you want to change. 

3. Click Toggle Status. 
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 To remove a free pass: 

1. From the Team Design menu select Leader Controls.  The Leader Controls dialog appears 
with the Free Pass Holders tab displayed. 

2. Click the member you want to remove. 

3. Click Remove. The member may still apply to join the session, but as leader you must approve 
or reject the application. 

 
 

20.1.7    Publishing a Session in Progress to Additional Users 

Once a session is in progress, the leader may invite additional users and teams through the 
Publishing dialog.  At the same time, the leader can also effectively un-invite users or teams. 

 To publish a session in progress to additional teams or users: 

1. When leading a team session, from the Team Design menu select Publishing.  The 
Publishing dialog appears with the current teams and users listed. 

2. Click the Teams tab or the Users tab, as needed. 

3. In the Listed area, select the team or user you want to add to the team session. 

4. In the Unlisted area, type the name of any unlisted team or user you want to add to the team 
session. 

5. Click Add.  The names appear in the Recipients box. 

6. Click OK.  Your team session will be visible to invited users in the Sessions tab in the Home 
window or in the Join Session dialog box. 

 

 To remove teams or users from a session: 

1. When leading a team session, from the Team Design menu, select Publishing.  The 
Publishing dialog box appears with the current teams and users listed. 

2. Click the Teams tab or the Users tab, as needed. 

3. In the Recipients box, select the team or user you want to remove from the team session. 
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4. Click Remove. 

5. Click OK.  The team session is no longer available to those users. 

 
 

20.1.8    Adding a Design to a Team Session 

The leader of a team session can add and remove parts, assemblies and drawings at any time.  
Workspaces that are part of a specific team session are listed in the Team Design explorer and 
menu as channels.  The active workspace/channel is marked with a check.  Each workspace is also 
listed in the Windows menu. 

 To add a design to an active session: 

1. From the Team Design menu select Open in Session. 

2. Select New Part/Assembly/Drawing to open an empty workspace of the selected type; or 
select Repository Item to open an existing design through the Select Item dialog. 
The added workspace appears in the Team Design explorer under Channels. 

 

 

 To add an open design to an active session 

1. Open a part, assembly or drawing.  The design opens in an appropriate workspace. 

2. In that same workspace, from the Team Design menu, select Add to Session. 
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3. If you are currently leading more than one team session, the Add to Session dialog appears 
so that you can choose a session.  Otherwise, the item immediately becomes a part of the 
active session and is available to participants. 

 
 

20.1.9    Removing a Design from an Active Session 

 To remove a design from an active session: 

1. From the Team Design menu select Remove from Session.  The End Session dialog box 
appears with the message: Are you sure you want to remove this item from your Team 
Design session?. 

2. Click Yes.  The item is removed from the session, but remains open. 

Or, 

1. From the File menu, select Close.  The workspace closes and is removed from the session. 

 

Note:  If you select Remove from Session when only one part is active in a Team Design session, 
the session will end.  You will be prompted with the End Session dialog.  

 
 

20.1.10    Ending a Team Design Session 

The leader of a Team Design session is the only participant who can end the session.  The leader 
can end the session at any time by closing or removing the last item from the session, or by 
selecting End Session from the Team Design menu or toolbar. 

 To end a session and continue to work with the design: 

1. From the Team Design menu, select End Session; or select the End Session  tool from 
the Team Design toolbar.  The End Session dialog appears with the message, Are you sure 
you want to end this team session? 

2. Click Yes.  Participants are notified and their workspace closes.  As the leader, the Team 
Design tools disappear, but the workspace remains open. 

3. To close the workspace, select Close from the File menu. 
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 To end a session and exit the design: 

1. From the File menu, select Close until all items associated with the Team Design session are 
closed.  On the last item, the End Session dialog appears with the message: Are you sure 
you want to end this team session? 

2. Click Yes.  The file closes and the session ends.  Participants are notified that the session has 
ended. 

 
 

20.2    Joining and Leaving a Team Design Session 

20.2.1    Joining a Team Design Session 

When you are invited to a Team Design session, you must join the session to participate.  If you 
have been invited to a Team Design session, it will be listed in the Sessions Explorer in the Home 
window Sessions tab.  

        

Sessions to which you have been invited are also listed in the Join Session dialog, which is 
accessible from the Team Design menu in any other workspace, including the Repository, Team 
Manager and Message Center. 

 To join a Team Design session: 

1. From the Home window click the Sessions tab;  

2. Right-click the session in the Sessions Explorer and select Join Session from the pop-up 
menu; or double-click the session in the Sessions Explorer.  The Join Session dialog opens.  
All current Team Design sessions that have been published to you appear in the list. 

3. Select the session that you want to join. 
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4. In the Local Session Replication area, select Replicate from source or Replicate from 
copy. 

• Replicate from source: When the session starts, a copy of the session leader's data is 
transferred to your computer.  

• Replicate from copy: To choose this option, you must have already copied the session 
leader's data to one of your repositories. 

 

 

5. Click Join.  The Joining Team Design Session dialog appears with the message: Waiting for 
confirmation.  This box will remain open until the leader accepts you as an editor or viewer, or 
your application is rejected.  If you are accepted, the session will load.  If you are rejected, you 
will receive a notification. 

Note: You can also access the Join Session dialog by selecting Join Session from the Team 
Design menu in the Repository, Team Manager, Message Center or any workspace.  Or, in a 

workspace you can select the Join Team Design Session tool from the Team Design toolbar. 

 
 

20.2.2    Leaving a Team Design Session 

As a participant, you can leave a Team Design session at any time.  You are not responsible for 
saving changes to the model or drawing.  When you leave, the session will continue until the leader 
ends it. 

 To leave a Team Design session: 

From the Team Design menu select Leave Session;  or, select the Leave Team Design Session 

tool from the Team Design toolbar. 
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20.3    Scheduled Team Sessions 

Scheduling a team session allows the participants to plan time for the session and, when given 
permission, preview the data.  Additionally, participants can pre-cache the data for a faster start.  
Sessions can only be scheduled from the Home window. 

 
 

20.3.1    Scheduling a Team Session 

 To schedule a team session: 

1. In the Home Window, do one of the following:  

a. Select the Sessions tab, and then click the Schedule Session button. 

b. From the Actions menu, select Schedule Session. 

c. Select the Sessions tab, and then right-click the Scheduled Sessions entry, then select 

Schedule Session from the pop-up menu. 

d. Right-click in the Contacts section and select Schedule Session from the pop-up menu.  

(You can also right-click a contact to pre-populate the To field with that user.)   
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The Schedule Session dialog appears. 

 

2. Click the To button to invite users.  The Recipients dialog appears.  Add users or teams and 
select OK. 

3. Specify the Start time.  

4. Specify the End time. 

5. From the Data menu, select from the following choices: 

• No Data: the session will start without data, in the Chat Window.  Data can be added later. 

• New Part/Assembly/Drawing: the session will start in an empty workspace of the selected 
type. 

• Repository Item: the session will start with the design selected through the Browse button. 

1. If Repository Item is selected, check Allow participants to preview data to give 

Read Only access to invitees to whom you have not previously shared the data. 

2. If Repository Item is selected, click Browse to select the design.  The Select Item 

dialog appears.  Browse to and select the design and click OK. 

6. Set the session Reminder if desired. 
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7. Enter information about the session in the text box. 

8. Click Send.  The invitation is sent to invitees. 

 
 

20.3.2    Accepting and Declining a Scheduled Session 

When you are invited to a scheduled session, the session appears in the Sessions Explorer and is 
embedded in a message sent to your Message Center.  

 To accept an invitation: 

1. From the Actions menu, select Scheduled Session > Accept. 

Or right-click the session entry in the Session explorer and select Accept.  Accepted 
appears next to your user name under the Participants node. 

Or, 

1. To review a scheduled session before accepting, right-click the entry in the Session explorer 
and select Open. 

2. Click Accept.  Accepted appears next to your user name under Participants. 

 

 To decline an invitation: 

1. From the Actions menu, select Scheduled Session > Decline. 

Or right-click the session entry in the Session explorer and select Decline. 

 
Or to review a scheduled session before accepting, right-click the entry in the Session 
explorer and select Decline. 

2. The Decline Session Invitation dialog box appears. 

3. To also delete the session from the Session explorer, select Decline and delete the session 
invitation.  The session will be removed from the Session explorer. 

Or select Decline the invitation for now to keep the invitation in the Session explorer.  You 
can choose to accept the session at another time. 

4. Click OK.  A notification is sent to the organizer.  If the scheduled session has not been 
deleted, Declined appears next to your user name under the Participants node. 
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20.4    Working in a Team Design Session 

Participants in Team Design sessions are granted viewer or editor status by the session leader when 
they are admitted to the session.  To avoid conflict, a participant must be an editor and hold the 
baton to edit a design.  Since the baton holder has the ability to edit the model, the baton cannot be 
passed to a participant with View status-the command is unavailable. If a participant with View 
status should need to edit the model, the leader can change a participant's status at anytime. 

Leader 
 

Crown Starts the session, invites and admits participants, assigns 
status and saves work completed.  Also, can edit the 
design while in possession of the baton. 

Viewer 
 

Cap Cannot edit the design, but has other capabilities.   
See Participant capabilities below. 

Editor 
 

Hard Hat Can edit the design when in possession of the baton.   
Can also save work. 

 
 

Baton Identifies who has the baton. Only the participant holding 
the baton can edit the model or drawing. 

 

Participant capabilities 

Editors holding the baton have complete control over the design. 

Participants who are not holding the baton, regardless of viewer/editor status, can perform the 
following functions: 

• Use the Team Design Explorer to reorient your view of the workspace to that of another 
participant, follow a participant's view and send a message to a participant. 

• Use the commands available in the Team Design menu and toolbar including Follow Baton 
Holder and Reorient to Baton Holder. 

• Independently modify your view of the design with the Rotate and Zoom tools.  Zoom tools 
include: Zoom to Selection, Zoom to Window, and Zoom to Fit. 

• Pan your workspace horizontally, vertically, or diagonally across the screen. 

• Explode a constrained assembly. (Available only with assemblies.) 

• Show/hide the Design Explorer. 

• Insert redlines. 

• Place and rotate arrows on the model. 

• Use the Chat Window and show/hide the Chat Window. 
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20.4.1    The Team Design Explorer 

During a Team Design session, participants are listed in the Team Design Explorer located below 
the Design Explorer.  Icons indicate the leader, the baton holder and a participant's viewer/editor 
status.  When you are leading a session, an Applicants list and Invitees list are also displayed. 

 

 

Using the Team Design explorer 

Right-click Menu 
Command 

Description 
    

Pass Baton Pass the baton to the selected 
participant. 

 X X X 

Send Message Send a message to the selected 
participant during a Team Design 
session.  The message will not be 
recorded in the Chat Window. 

X X X  

Toggle Status A Leader Control: toggle the status 
of a participant between viewer and 
editor.  When that participant has 
the baton, it is returned to the 
leader. 

   X  

Remove A Leader Control: remove the 
participant from the Team Design 
session. 

   X  
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Take Baton A Leader Control: take immediate 
control of the baton. 

   X  

Reorient to Participant Your view changes to match that of 
the selected participant at that 
moment. 

X X X  

Follow Participant Your view updates continually so 
that it is the same as the view seen 
by the selected participant. 

X X X  

 
 

20.4.2    The Baton 

To facilitate Team Design, Alibre Design has implemented the concept of the baton.  The baton 
holder can pass the baton to any editor or the leader at any time. 

• Only one participant can hold the baton at a time. 

• Only participants with editor status are eligible to hold the baton. 

• At any time, the session leader may take the baton without the permission of the baton 
holder. 

 

Requesting the baton 

A baton request alerts the current holder that another participant would like to edit the design.  
Editors can request the baton at any time.  The option to request the baton is not available to 
viewers. 

 To request the baton:  

Select Request Baton from the Team Design menu; or click the Request Baton button in the Chat 

Window; or select the Request Baton  tool on the Team Design toolbar.  The baton holder is 
notified of the request by the Baton Request dialog.  The request is also recorded in the Chat 
Window. 
 
The holder can then choose whether to pass the baton. 

 

Passing the baton 

The baton holder may pass the baton to any participant with editor status at any time. 
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 To pass the baton: 

1. In the Team Design Explorer, right-click the participant to whom you want to pass the baton. 

2. Select Pass Baton.  The baton is passed immediately.  The participant is notified by the Baton 
Received dialog, and the event is recorded in the  
Chat Window. 
 
You may also select the participant in the Team Design Explorer; then click the Pass Baton 

 tool on the Team Design toolbar. 

Note: If you have received a formal Baton Request, you may pass that participant the baton by 
selecting Pass Baton to <username>@<servername>.com from the Team Design menu. 

 

Taking the Baton 

The leader of a Team Design session can take the baton from any participant at any time.  It may be 
necessary to take the baton if the current holder is disconnected from the session, or has been 
called away and forgot to give it to someone else. The Take Baton command is only available to the 
session leader. 

 

 To take the baton: 

1. From the Team Design menu, select Leader Controls.  The Leader Controls dialog appears.  
 

        

2. Click the Participants tab. 

3. Click Take Baton.  The baton is passed to you immediately and the event is recorded in the 
Chat Window. 
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Note:  You may also right-click the baton holder in the Team Design explorer and select Take 
Baton. 

 
 

20.4.3    Reorienting to Another Participant's View 

When working in a Team Design session, it is useful to view the design from the same orientation as 
another participant.  Participants can choose to view the design from the same orientation as a 
specific participant or the baton holder.  And, when you have the baton you may reorient all the other 
participants to your view.  

While participating in a Team Design session you may choose to view the design from the same 
orientation as the baton holder.  You can either Reorient to Baton Holder or Follow Baton Holder, 
or Reorient to Participant or Follow Participant.  

When you Reorient to Baton Holder, or Reorient to Participant, your view of the workspace 
changes to match what is seen by the baton holder, or the selected participant, at that moment.  
When the baton holder or participant modifies the view, your view will remain the same.  To maintain 
a synchronized view, you must either use the Reorient to Baton Holder command repeatedly (or 
Reorient to Participant) or choose the Follow Baton Holder command (or Follow Participant 
command). 

 

 To reorient to the baton holder: 

From the Team Design menu, select Reorient > To Baton Holder.  Your view changes to match 
that of the baton holder. 
 

Or  

Select the Reorient to Baton  tool on the Team Design toolbar. 

 

 To follow the baton holder: 

From the Team Design menu, select Reorient > Follow Baton Holder.   

Or select the Follow Baton Holder  tool on the Team Design toolbar. 
 
A green arrow overlaid on top of the baton icon in the Team Design explorer indicates the participant 
to whom your view is synchronized.  Each time the baton holder modifies the view, your orientation 
changes to match.  Once the baton is passed, your view will continue to be synchronized to 
whomever is holding the baton. 
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Note: When Follow the Baton Holder is active, a checkmark appears in the right-click menu.  
Clear the checkmark to stop following the baton holder. 

 

 To reorient to a participant: 

In the Team Design Explorer, right-click the participant to whom you want to reorient and select 
Reorient To Participant from the pop-up menu.  Your view changes to match that of the selected 
participant. 

 

 To follow a participant: 

In the Team Design Explorer, right-click the participant you want to follow and select Follow 
participant from the pop-up menu.  As the participant's orientation changes, your orientation 
changes to match it.  
 
A green arrow overlaid on top of the baton icon in the Team Design explorer indicates the participant 
to whom your view is synchronized. 
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 To reorient all others: 

From the Team Design menu, select Reorient > All Others.   
 

Or, select the Reorient All tool   on the Team Design toolbar. 

All participants' views change to match your current orientation.  To lead participants through a 
series of views, you must reorient them each time you alter the view. 

 
 

20.4.4    The Chat Window 

Chat sessions are available when you work online.  Each Team Design session includes a Chat 
Window, which records both system messages and participant messages.  System messages are 
automatic and record baton events, participant administration events and note each change made to 
the design.  

When working with multiple designs in a Team Design session, participant messages are visible in 
all channels, while system messages only appear in the channel in which they are invoked.  

   

To show or hide the Chat Window in a Team Design session, select Chat Window from the Team 
Design menu to toggle the display.  A checkmark indicates that the Chat Window is visible. 

Additionally, you can 

• Take periodic snapshots of ongoing work for documentation purposes.  

• Save the chat session as a text file or HTML file. Store the file in a repository with other 
design documentation or email the chat to associates who may want a record of the 
session. 

• Resize the Chat Window. 

• Send a voice message. 

• Request the baton, if you are an editor. 
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Note: Participant messages are color-coded.  As participants join, each is assigned a unique 
message color. 

 

Saving a Chat Session 

You can save the chat history of a team session as a text file or HTML file to review at a later date 
and/or forward to the other participants.  The file can be stored in the repository with other design 
documentation. 

 

 To save a chat session: 

1. Select the format for the file from the drop down menu next to the Save Chat button. 

2. Click Save Chat. 

3. Choose a location, and enter a file name. 

4. Click Save. 

 

 To send a private message: 

When working in a team session, you may send a private message to another participant. 

1. Right-click a participant in the Team Design explorer and select Send Message. 
 

Or select Send Message from the Team Design menu; or click the Send Message  tool 
on the Team Design toolbar.  The New Message dialog appears.  The message is already 
addressed to the selected participant.  You may add additional recipients. 

2. Type or record a message. 

3. Click Send.  Messages sent to participants will be delivered to their Message Center. 
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20.4.5    Voice Chat 

When suitably equipped with speakers and microphones, users can speak to each other through the 
Chat Window.  The meter on the right of the Chat Window shows the volume of the microphone and 
the speakers. 

The meter labeled with a microphone represents the volume of your voice when speaking into the 
microphone.  The meter labeled with a speaker represents the volume of incoming communication. 

 

Green color bars indicate an acceptable level.  
  
Yellow indicates an inadequate volume.  
  
Red indicates a volume that has reached an unacceptable level and is distorting.  

 To voice chat with team members: 

1. Click and hold the Speak button or press the F12 key. 

2. Speak into the microphone. All session participants will hear. 

3. When you are finished speaking, release the Speak button. 

Note: When the Chat Window is hidden, you can still use voice chat by pressing F12. 

 
 

20.4.6    Redlines 

Redlines let you point out or draw attention to specific aspects of a design.  Redlines can also be 
used to document suggested design changes; saving a design as a new version will capture any 
redlines and can subsequently be reviewed later if necessary.  

Redlines are associated with orientations and are only visible when the associated orientation is 
displayed.  Redlines cannot be moved or edited.  Any participant can insert redlines, but redlines can 
only be deleted by the baton holder. 
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Use redlines to: 

• Draw a shape (circle, rectangle or freehand) around a specific area of the design. 

• Insert a note or comment. 

 To insert a redline: 

1. From the Insert menu, select Redline > Freehand, Ellipse, or Rectangle; or select the 

Freehand, Ellipse, or Rectangle  tool from the Redline toolbar. 

2. Drag a shape around the area you want to discuss or highlight. 
Or for a note, enter text in the Note dialog.  Click in the work area to set the leader; then drag to 
place the note. 

 

 

 To hide or show redlines: 

From the View menu, select Redlines.  If checked, redlines are visible. 

Note: To see a specific redline, make sure redlines are not hidden; then double-click the entry in 
the Design Explorer. This will reorient the view so that the redline is visible. 

 

 To display the redline author and date created: 

Drag the pointer over the redline. The author's name and date created appears. 
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 To pick a different color for subsequent redlines: 

1. From the Insert menu, select Redline > Color; or select the Redline Color  tool from the 
Redline toolbar.  The Color dialog appears. 

2. Select a new color. 

3. Click OK. 

 

 To set the redline width: 

1. From the Insert menu, select Redline > Width; or select the Redline Width  tool from the 
Redline toolbar.  The Width dialog appears. 

2. The default width is 9.  Enter a new width (1 is the lowest allowable setting). 

3. Click OK. 

 

 To delete a redline: 

In the Design Explorer, right-click the redline and select Delete from the pop-up menu; or right-click 
the redline in the work area and select Delete from the pop-up menu. 

 
 

20.4.7    Reference Arrows 

Each participant in a Team Design session can use one 3D reference arrow in the workspace as a 
visual aid for communication.  You can place, move or rotate your arrow anytime 
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• You can show and hide arrows. 

• You can attach a reference arrow to any part of a model or drawing. 

• You can move your own arrow; you cannot move other participants' arrows. 

• The arrow is only visible during the session; it does not become part of the design. 

• The color of your arrow is assigned by Alibre Design to ensure that each participant's arrow 
is unique. 

 

Two types of pointers are displayed when you are placing and moving reference arrows: 

 Appears when your pointer is over a location where you can place the arrow.  Click 
anywhere on the model or drawing to place the arrow. Or you can drag the arrow to reposition it on 
the model or drawing. 

  

 Appears when your pointer is over a location where you cannot place an arrow. 

 

Note:  3D arrows cannot be placed on sketches. 
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 To place your reference arrow: 

1. From the Team Design menu, select Place Arrow; or, select the Place Reference Arrow 

 tool from the Team Design toolbar. 

2. Click the model where you want to place the arrow.  The arrow appears. 

 

 To show or hide reference arrows: 

From the Team Design menu select Show Arrows.  When checked, arrows are visible. 

Or, select the Show Reference Arrows  tool on the Team Design menu. 

 

 To move your reference arrow: 

1. From the Team Design menu, select Place Arrow; or select the Place Reference Arrow  
tool from the Team Design toolbar. 

2. Drag the arrow to where you want to attach it.  Or click the model or drawing where you want to 
attach the arrow.  The arrow moves. 

 

 To remove reference arrows: 

From the Team Design menu, select Remove Arrow; or, select the Remove Reference Arrow 

 tool from the Team Design toolbar. 

 

You can only remove your own reference arrow. 

 
 

20.5    Setting Alert Options 

You can choose to receive alerts about events occurring during Team Design sessions.  You can 
also select how to receive them. 
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1. In the Home window, from the Tools menu select Options.  The Options dialog appears. 

2. Click the Team Design tab. 

      

3. In the Alert me by area, select how you want to receive alerts. 

• Popup dialog 

• Beep 

4. In the Alert me when area, select which baton events trigger an alert. 

5. Click OK. 

Note: Regardless of your alert settings, you will receive chat messages about baton events 
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